ΘΕΜΑ Α. 1. Στην εντολή εκχώρησης Χ ΨΕΥΔΗΣ η μεταβλητή Χ είναι τύπου χαρακτήρες.

Save this PDF as:
 WORD  PNG  TXT  JPG

Μέγεθος: px
Εμφάνιση ξεκινά από τη σελίδα:

Download "ΘΕΜΑ Α. 1. Στην εντολή εκχώρησης Χ ΨΕΥΔΗΣ η μεταβλητή Χ είναι τύπου χαρακτήρες."

Transcript

1 ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΤΕΤΑΡΤΗ 08/04/2015- ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΕΞΙ (6) ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιο σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και, δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή ή τη λέξη ΛΑΘΟΣ, αν η πρόταση είναι λανθασμένη. 1. Στην εντολή εκχώρησης Χ ΨΕΥΔΗΣ η μεταβλητή Χ είναι τύπου χαρακτήρες. 2. Ο έλεγχος ορθότητας των δεδομένων θα μπορούσε να αποδοθεί και με την δομή επανάληψης ΓΙΑ..ΑΠΟ..ΜΕΧΡΙ..ΜΕ_ΒΗΜΑ 3. Το αποτέλεσμα της έκφρασης x mod 5, όπου x ένας θετικός ακέραιος αριθμός, μπορεί πάντα να αποτελέσει την τιμή δείκτη στοιχείου ενός μονοδιάστατου πίνακα 4. Κατά την ταξινόμηση σε αύξουσα σειρά ενός μονοδιάστατου πίνακα μεγέθους 5 θα γίνουν συνολικά πέντε (5) περάσματα. 5. Η λογική έκφραση ΜΙΚΡΟΣ > ΜΕΓΑΛΟΣ έχει τιμή ΑΛΗΘΗΣ. Α2. Δίνεται το παρακάτω τμήμα αλγορίθμου στο οποίο έχουμε αριθμήσει τις εντολές του: 1. Διάβασε Χ 2. Υ Χ mod 5 = 0 3. Εμφάνισε Το ότι είναι πολλαπλάσιος του 5 ο, Χ, είναι, Υ ΤΕΛΟΣ 1ΗΣ ΑΠΟ 6 ΣΕΛΙΔΕΣ (Μονάδες 10) Να ξαναγράψετε στο τετράδιο σας το παραπάνω τμήμα αντικαθιστώντας την εντολή 2 με μια δομή σύνθετης επιλογής, ώστε να παράγει το ίδιο αποτέλεσμα. (Μονάδες 10) Α3. Να γράψετε στο τετράδιο σας τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β που αντιστοιχεί σωστά Στήλη Α Στήλη Β 1. Ιεραρχική σχεδίαση α. Αντικείμενο πρόγραμμα 2. Δομημένος β. Οι εντολές της είναι μια ακολουθία δυαδικών

2 ΑΡΧΗ 2ΗΣ ΣΕΛΙΔΑΣ Προγραμματισμός ψηφίων 3. Υποπρόγραμμα γ. Περιορισμός των λαθών κατά την ανάπτυξη του προγράμματος 4. Μεταγλωττιστής δ. Διάσπαση του προβλήματος σε μια σειρά από απλούστερα προβλήματα. 5. Τεχνητή νοημοσύνη ε. Έχει μόνο μια είσοδο και μια έξοδο. 6. Γλώσσα μηχανής στ. LISP Α4. α. Τι καθορίζει η λίστα των πραγματικών παραμέτρων; (Μονάδες 1) β. Τι καθορίζει η λίστα των τυπικών παραμέτρων; (Μονάδες 1) (Μονάδες 6) γ. Ποιους κανόνες πρέπει να ακολουθούν οι λίστες των πραγματικών και των τυπικών παραμέτρων; (Μονάδες 3) (Μονάδες 5) Α5. Να γράψετε στο τετράδιο σας τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β που αντιστοιχεί σωστά. Σημειώνεται ότι από τη Στήλη Β περισσεύει μια επιλογή. Στήλη Α Τμήματα αλγορίθμου 1. Για κ από 2 μέχρι 19 με_βήμα 3 Για λ από κ μέχρι 20 με_βήμα 2 Εμφάνισε ΑΕΠΠ Τέλος_επανάληψης Τέλος_επανάληψης 2. Για κ από 1 μέχρι 7 Εμφάνισε ΑΕΠΠ Για λ από 0 μέχρι 4 Εμφάνισε ΑΕΠΠ Τέλος_επανάληψης Τέλος_επανάληψης 3. Για κ από 0 μέχρι 17 Εμφάνισε ΑΕΠΠ Τέλος_επανάληψης Για λ από κ μέχρι 37 Εμφάνισε ΑΕΠΠ Τέλος_επανάληψης Στήλη Β Πλήθος εμφανίσεων λεκτικού ΑΕΠΠ α. 38 β. 40 γ. 42 δ. 36 (Μονάδες 9) ΤΕΛΟΣ 2ΗΣ ΑΠΟ 6 ΣΕΛΙΔΕΣ

3 ΑΡΧΗ 3ΗΣ ΣΕΛΙΔΑΣ ΘΕΜΑ Β Β1. Δίνεται το παρακάτω ημιτελές (έχει κενά) πρόγραμμα το οποίο περιέχει και υποπρόγραμμα ΠΡΟΓΡΑΜΜΑ Β1 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Κ ΑΡΧΗ ΔΙΑΒΑΣΕ Α, Β Κ FEEL_LUCKY(A, B) ΓΡΑΨΕ Το τυχερό αποτέλεσμα των αριθμών, Α, και, Β, είναι:, Κ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΣΥΝΑΡΤΗΣΗ (ΜΙ, Μ2): ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: ΑΡΧΗ ΑΘΡ 0 ΟΣΟ Μ1 > 0 ΕΠΑΝΑΛΑΒΕ ΑΝ Μ1 MOD 2 = 1 ΤΟΤΕ ΑΘΡ ΑΘΡ + Μ2 ΤΕΛΟΣ_ΑΝ Μ1 Μ1 DIV 2 M2 M2 * 2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ α Να ξαναγράψετε το παραπάνω πρόγραμμα με συμπληρωμένα τα κενά του. έτσι ώστε να θεωρείται ολοκληρωμένη η συνάρτηση που συνοδεύει το πρόγραμμα. (μονάδες 5) β. Να ξαναγράψετε το παραπάνω πρόγραμμα ισοδύναμα, χωρίς τη χρήση του υποπρογράμματος. (μονάδες 5) γ. Να γράψετε στο τετράδιο σας τι θα εμφανίσει το αρχικό πρόγραμμα αν δοθεί σαν είσοδος οι τιμές 54 και 13 στις μεταβλητές Α και Β αντίστοιχα.(μονάδες 2) Β2. Δίνεται το παρακάτω τμήμα αλγορίθμου γραμμένο σε «ψευδογλώσσα»: Κ 4 Όσο Κ > = 1 επανάλαβε Α 1 Αν Κ < > 2 τότε Για Λ από 1 μέχρι Κ Α Α * 2 ΤΕΛΟΣ 3ΗΣ ΑΠΟ 6 ΣΕΛΙΔΕΣ (Μονάδες 12)

4 ΑΡΧΗ 4ΗΣ ΣΕΛΙΔΑΣ Εμφάνισε Λ, Α Τέλος_επανάληψης Τέλος_αν Κ Κ / 2 Τέλος_επανάληψης Εμφάνισε Κ Να γράψετε στο τετράδιο σας το ισοδύναμο διάγραμμα ροής. (Μονάδες 8) ΘΕΜΑ Γ Η πανελλήνια ένωση «Μαθητής ΝΑΙ ρομπότ ΟΧΙ» ξεκίνησε ένα πρόγραμμα σεμιναρίων με αντικείμενο τη διαχείριση χρόνου διαβάσματος το οποίο θα διεξαχθεί κατά περιόδους σε όλη την Ελλάδα με εισηγητές Πανεπιστημιακούς καθηγητές και παιδοψυχολόγους από Ευρωπαϊκά πανεπιστήμια. Προτού ξεκινήσει η διεξαγωγή του, γίνεται έρευνα για να καταγραφούν συμμετοχές για κάθε σχολείο έτσι ώστε να ορίσουν το ΠΟΥ θα πραγματοποιηθούν τα σεμινάρια. Να αναπτυχθεί αλγόριθμος σε «ψευδογλώσσα» ο οποίος: Γ1. Θα διαβάζει το όνομα του σχολείου. Η εισαγωγή στοιχείων θα γίνεται μέχρι να δοθεί ως όνομα σχολείου η λέξη «ΤΕΛΟΣ». ΤΕΛΟΣ 4ΗΣ ΑΠΟ 6 ΣΕΛΙΔΕΣ (Μονάδες 2) Γ2. Για κάθε σχολείο, θα διαβάζει το όνομα του τμήματος που θα εξετάσει μέχρι να δοθεί ως όνομα τμήματος ο χαρακτήρας Ω. (Μονάδες 2) Γ3. Θεωρώντας ότι κάθε τμήμα από αυτά που εξετάζονται έχει 25 μαθητές, θα ζητά από κάθε μαθητή του τμήματος το φύλο του εξασφαλίζοντας ότι θα δοθούν μόνο οι χαρακτήρες Α ή Κ (για αγόρι ή κορίτσι αντίστοιχα) καθώς και αν θα συμμετάσχει στο σεμινάριο θεωρώντας ότι η τιμή που θα δοθεί σαν απάντηση είναι έγκυρη και είναι μια από τις τιμές «ΝΑΙ» ή «ΟΧΙ». Γ4. Ο αλγόριθμος στο τέλος να εμφανίζει : (Μονάδες 3) α. Πόσα παιδιά εξετάστηκαν συνολικά ως προς το αν θα συμμετέχουν στα σεμινάρια. β. Πόσα από αυτά ήταν αγόρια και πόσα κορίτσια. (Μονάδες 3) (Μονάδες 2)

5 ΑΡΧΗ 5ΗΣ ΣΕΛΙΔΑΣ γ. Το ποσοστό (%) των κοριτσιών που θα συμμετάσχει στο σεμινάριο (στο σύνολο των κοριτσιών). (Μονάδες 4) δ. Το όνομα του σχολείου με το μεγαλύτερο ποσοστό συμμετοχής. (να θεωρήσετε ότι υπάρχει ένα μόνο τέτοιο σχολείο) Παρατηρήσεις: (Μονάδες 4) 1. Να θεωρήσετε ότι ο αλγόριθμος επεξεργάζεται τουλάχιστον ένα σχολείο, και ότι δεν υπάρχει σχολείο χωρίς τμήματα. Επίσης ότι είναι ενδεχόμενο να υπάρχει σχολείο μόνο με αγόρια μαθητές. 2. Τόσο κατά την είσοδο των δεδομένων όσο και κατά την έξοδο των αποτελεσμάτων δεν είναι απαραίτητο να υπάρχουν κατάλληλα διαμορφωμένα μηνύματα. ΘΕΜΑ Δ Σε έναν μεγάλο Φροντιστηριακό Όμιλο στην χρονιά που μας πέρασε παρακολούθησαν τα 6 μαθήματα της Τεχνολογικής Κατεύθυνσης ως μαθητές της Γ Λυκείου, συνολικά 80 άτομα. Στον όμιλο κατά την διάρκεια του περασμένου σχολικού έτους πραγματοποιήθηκαν 4 κύκλοι διαγωνισμάτων προσομοίωσης. Να αναπτύξετε πρόγραμμα γραμμένο σε «ΓΛΩΣΣΑ» το οποίο: : Δ1. Περιέχει τμήμα δηλώσεων ΤΕΛΟΣ 5ΗΣ ΑΠΟ 6 ΣΕΛΙΔΕΣ (Μονάδες 2) Δ2. Για κάθε μαθητή να διαβάζει το ονοματεπώνυμο του και να το καταχωρίζει στον πίνακα ΟΝΕΠ[80]. Επίσης να δημιουργεί τον πίνακα ΒΑΘ[80, 24] ο οποίος περιέχει τους βαθμούς του μαθητή σε κάθε διαγώνισμα που πήρε μέρος εξασφαλίζοντας ότι η βαθμολογία βρίσκεται στο διάστημα Σε περίπτωση που ο μαθητής δεν προσήλθε στο διαγώνισμα σαν τιμή του αντίστοιχου στοιχείου να καταχωρίζεται το -1. Για λόγους φιλικότητας προς το χρήστη το πρόγραμμα θα ρωτά αν ο μαθητής πήρε μέρος στο συγκεκριμένο διαγώνισμα μέσω του μηνύματος «ΠΗΡΕ ΜΕΡΟΣ ΣΤΟ ΔΙΑΓΩΝΙΣΜΑ; ΝΑΙ/ΟΧΙ» και ανάλογα με την απάντηση γίνεται και η κατάλληλη καταχώριση. Να θεωρήσετε ότι δίνεται σαν απάντηση μια έγκυρη αλφαριθμητική τιμή. (Μονάδες 3) Δ3. Ο όμιλος για να ενημερώσει σχετικά τους γονείς των μαθητών που απουσιάζουν συχνά από τα διαγωνίσματα θέλει από το πρόγραμμα, να εμφανίζει ταξινομημένα κατά αλφαβητική σειρά τα στοιχεία του πίνακα ΚΟΠΑΝΑΤΖΗΔΕΣ, ο οποίος θα περιέχει τα ονοματεπώνυμα εκείνων των μαθητών που απουσίαζαν από τα διαγωνίσματα σε ποσοστό μεγαλύτερο του

6 ΑΡΧΗ 6ΗΣ ΣΕΛΙΔΑΣ 60% επί του συνόλου των διαγωνισμάτων (να θεωρήσετε ότι υπάρχουν τουλάχιστον δύο (2) τέτοιοι μαθητές). Για τον υπολογισμό του πλήθους των απουσιών κάθε μαθητή να χρησιμοποιηθεί η συνάρτηση με όνομα ΑΠΟΥΣΙΕΣ που θα πρέπει να κατασκευάσετε. Η περιγραφή του υποπρογράμματος δίνεται στο ερώτημα Δ5. (Μονάδες 5) Δ4. Να δημιουργεί αρχικά τον πίνακα ΜΟ[80] του οποίου κάθε στοιχείο είναι ο στρογγυλοποιημένος στον πλησιέστερο ακέραιο μέσος όρος βαθμολογίας κάθε μαθητή στα διαγωνίσματα που πήρε μέρος (πχ. αν ο μέσος όρος βαθμολογίας ενός μαθητή είναι 15.6 τότε στον πίνακα ΜΟ στο αντίστοιχο στοιχείο θα καταχωρείται το 16, ενώ αντίθετα αν ο μέσος όρος είναι 15.3 θα καταχωρείται το 15). Στη συνέχεια το πρόγραμμα να δημιουργεί τον πίνακα ΣΥΧΝ[20] του οποίου κάθε στοιχείο είναι η συχνότητα εμφάνισης των στρογγυλοποιημένων μέσων όρων βαθμολογίας κάθε μαθητή στα διαγωνίσματα που πήρε μέρος. Ο πίνακας θα πρέπει να έχει μηδενιστεί πρώτα. Το πρόγραμμα τελικά να εμφανίζει δύο βαθμούς (1-20) που είχαν συχνότητας εμφάνισης στρογγυλοποιημένων μέσων όρων βαθμολογίας μεγαλύτερη του 30. Σε περίπτωση που δεν υπάρχουν τέτοιοι βαθμοί να εμφανίζεται το μήνυμα «Κανένας βαθμός δεν εμφανίστηκε περισσότερο από 30 φορές». (Μονάδες 6) Δ5. Η συνάρτηση ΑΠΟΥΣΙΕΣ να καλείται για κάθε μαθητή, με παραμέτρους τον πίνακα ΒΑΘ και έναν ακέραιο που αποτελεί τη σειρά του μαθητή. Η συνάρτηση θα υπολογίζει και θα επιστρέφει το πλήθος των μαθημάτων που ο μαθητής δεν πήρε μέρος (Μονάδες 4) Παρατήρηση: Τόσο κατά την είσοδο των δεδομένων όσο και κατά την έξοδο των αποτελεσμάτων δεν είναι απαραίτητο να υπάρχουν κατάλληλα διαμορφωμένα μηνύματα εκτός από εκείνες τις περιπτώσεις που υποδεικνύονται στην εκφώνηση του προγράμματος. ΟΔΗΓΙΕΣ (για τους εξεταζομένους) 1. Στο εξώφυλλο του τετραδίου να γράψετε το εξεταζόμενο μάθημα. Στο εσώφυλλο πάνωπάνω να συμπληρώσετε τα ατομικά στοιχεία μαθητή. Στην αρχή των απαντήσεών σας να γράψετε πάνω-πάνω την ημερομηνία και το εξεταζόμενο μάθημα. Να μην αντιγράψετε τα θέματα στο τετράδιο και να μην γράψετε πουθενά στις απαντήσεις σας το όνομά σας. 2. Να γράψετε το ονοματεπώνυμό σας στο πάνω μέρος των φωτοαντιγράφων αμέσως μόλις σας παραδοθούν. Τυχόν σημειώσεις σας πάνω στα θέματα δεν θα βαθμολογηθούν σε καμία περίπτωση. Κατά την αποχώρησή σας να παραδώσετε μαζί με το τετράδιο και τα φωτοαντίγραφα. 3. Να απαντήσετε στο τετράδιό σας σε όλα τα θέματα μόνο με μπλε ή μόνο με μαύρο στυλό με μελάνι που δεν σβήνει. Μολύβι επιτρέπεται, μόνο αν το ζητάει η εκφώνηση, και ΜΟΝΟ για πίνακες, διαγράμματα κλπ.. 4. Κάθε απάντηση επιστημονικά τεκμηριωμένη είναι αποδεκτή. 5. Διάρκεια εξέτασης: τρεις (3) ώρες μετά τη διανομή των φωτοαντιγράφων. 6. Χρόνος δυνατής αποχώρησης: 10:30 KΑΛΗ ΕΠΙΤΥΧΙΑ - ΤΕΛΟΣ ΜΗΝΥΜΑΤΟΣ ΤΕΛΟΣ 6ΗΣ ΑΠΟ 6 ΣΕΛΙΔΕΣ

7 ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΤΕΤΑΡΤΗ 08/04/ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΔΕΚΑ (10) ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1 ΣΩΣΤΟ 2 ΛΑΘΟΣ 3 ΛΑΘΟΣ 4 ΛΑΘΟΣ 5 - ΣΩΣΤΟ Α3. Α2. 1. Διάβασε Χ 2. Αν Χ mod 5 = 0 τότε 3. Υ Αληθής 4. Αλλιώς 5. Υ Ψευδής 6. Τέλος_αν 7. Εμφάνισε Το ότι είναι πολλαπλάσιος του 5 ο, Χ, είναι, Υ Α4. Α5. 1 δ 2 γ 3 ε 4 α 5 στ 6 β α. Η λίστα των πραγματικών παραμέτρων (actual parameter list) καθορίζει τις παραμέτρους στη κλήση του υποπρογράμματος. (παρ σχολικό βιβλίο). β. Η λίστα των τυπικών παραμέτρων (formal parameter list) καθορίζει τις παραμέτρους στη δήλωση του υποπρογράμματος. (παρ σχολικό βιβλίο) γ. Ο αριθμός των πραγματικών και των τυπικών παραμέτρων πρέπει να είναι ο ίδιος. Κάθε πραγματική παράμετρος αντιστοιχεί στην τυπική παράμετρο που βρίσκεται στην αντίστοιχη θέση. Για παράδειγμα η πρώτη της λίστας των τυπικών με τη πρώτη της λίστας των πραγματικών. Η τυπική παράμετρος και η αντίστοιχη της πραγματική πρέπει να είναι ίδιου τύπου. (παρ σχολικό βιβλίο) 1 δ 2 γ 3 α ΤΕΛΟΣ 1ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ

8 ΑΡΧΗ 2ΗΣ ΣΕΛΙΔΑΣ ΘΕΜΑ Β Β1. α. ΠΡΟΓΡΑΜΜΑ Β1 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Κ ΑΡΧΗ ΔΙΑΒΑΣΕ Α, Β Κ FEEL_ LUCKY(A, B) ΓΡΑΨΕ Το τυχερό αποτέλεσμα των αριθμών, Α, και, Β, είναι:, Κ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΣΥΝΑΡΤΗΣΗ FEEL_LUCKY (ΜΙ, Μ2):ΑΚΕΡΑΙΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: ΜΙ, Μ2, ΑΘΡ ΑΡΧΗ ΑΘΡ 0 ΟΣΟ Μ1 > 0 ΕΠΑΝΑΛΑΒΕ ΑΝ Μ1 MOD 2 = 1 ΤΟΤΕ ΑΘΡ ΑΘΡ + Μ2 ΤΕΛΟΣ_ΑΝ Μ1 Μ1 DIV 2 M2 M2 * 2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ FEEL_LUCKY ΑΘΡ ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ Σημείωση: Με κόκκινα γράμματα είναι τα κατάλληλα αλγοριθμικά στοιχεία με τα οποία έπρεπε να συμπληρωθούν τα κενά β. ΠΡΟΓΡΑΜΜΑ Χωρίς_Υποπρογράμματα ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Κ, ΜΙ, Μ2 ΑΡΧΗ ΔΙΑΒΑΣΕ Α, Β ΜΙ Α Μ2 Β Κ 0 ΟΣΟ Μ1 > 0 ΕΠΑΝΑΛΑΒΕ ΑΝ Μ1 MOD 2 = 1 ΤΟΤΕ Κ Κ + Μ2 ΤΕΛΟΣ_ΑΝ Μ1 Μ1 DIV 2 M2 M2 * 2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ Το τυχερό αποτέλεσμα των αριθμών, Α, και, Β, είναι:, Κ ΤΕΛΟΣ 2ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ

9 ΑΡΧΗ 3ΗΣ ΣΕΛΙΔΑΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ γ. Για την καλύτερη κατανόηση του εξαγόμενου αποτελέσματος παραθέτουμε τον παρακάτω ενδεικτικό πίνακα τιμών: Αριθμούμε όλες τις εντολές του κύριου προγράμματος και του υποπρογράμματος ως εξής : 1. ΠΡΟΓΡΑΜΜΑ Β1 2. ΜΕΤΑΒΛΗΤΕΣ 3. ΑΚΕΡΑΙΕΣ: Α, Β, Κ 4. ΑΡΧΗ 5. ΔΙΑΒΑΣΕ Α, Β 6. Κ FEEL LUCKY(A, B) 7. ΓΡΑΨΕ Το τυχερό αποτέλεσμα των αριθμών, Α, και, Β, είναι:, Κ 8. ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 9. ΣΥΝΑΡΤΗΣΗ FEEL LUCKY (ΜΙ, Μ2):ΑΚΕΡΑΙΑ 10. ΜΕΤΑΒΛΗΤΕΣ 11. ΑΚΕΡΑΙΕΣ: ΜΙ, Μ2, ΑΘΡ 12. ΑΡΧΗ 13. ΑΘΡ ΟΣΟ Μ1 > 0 ΕΠΑΝΑΛΑΒΕ 15. ΑΝ Μ1 MOD 2 = 1 ΤΟΤΕ 16. ΑΘΡ ΑΘΡ + Μ2 17. ΤΕΛΟΣ_ΑΝ 18. Μ1 Μ1 DIV M2 M2 * ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 21. FEEL LUCKY ΑΘΡ 22. ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ Για την παρακολούθηση της εκτέλεσης του προγράμματος με τιμές εισόδου Α=54 και Β=13 παραθέτουμε το παρακάτω υπόδειγμα πίνακα τιμών που έχει συμπληρωθεί ως εξής: Στη στήλη με τίτλο «αριθμός γραμμής» καταγράφεται ο αριθμός της εντολής που εκτελείται. Στη στήλη με τίτλο «έξοδος» καταγράφεται η τιμή εξόδου, εφόσον η εντολή εξόδου που εκτελείται είναι εντολή εξόδου. Στη στήλη με τίτλο «συνθήκη» καταγράφεται η λογική τιμή ΑΛΗΘΗΣ ή ΨΕΥΔΗΣ, εφόσον η εντολή που εκτελείται περιλαμβάνει συνθήκη. Στο σημείο που καλείται το υποπρόγραμμα και κατά την διάρκεια της εκτέλεσης του ο πίνακα ς τιμών επεκτείνεται σε μια στήλη για κάθε μεταβλητή του υποπρογράμματος. αριθμός έξοδος συνθήκη Α Β Κ γραμμής ΤΕΛΟΣ 3ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ FEEL_ LUCKY Μ1 Μ2 ΑΘΡ

10 ΑΡΧΗ 4ΗΣ ΣΕΛΙΔΑΣ ΑΛΗΘΗΣ 15 ΨΕΥΔΗΣ ΑΛΗΘΗΣ 15 ΑΛΗΘΗΣ ΑΛΗΘΗΣ 15 ΑΛΗΘΗΣ ΑΛΗΘΗΣ 15 ΨΕΥΔΗΣ ΑΛΗΘΗΣ 15 ΑΛΗΘΗΣ ΑΛΗΘΗΣ 15 ΑΛΗΘΗΣ ΨΕΥΔΗΣ Το τυχερό αποτέλεσμα των αριθμών, 54, και 13 είναι: 702 Το πρόγραμμα κατά την εκτέλεση του εμφανίζει: Το τυχερό αποτέλεσμα των αριθμών, 54, και 13 είναι: 702 ΤΕΛΟΣ 4ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ

11 ΑΡΧΗ 5ΗΣ ΣΕΛΙΔΑΣ B2. Κ 4 Κ >= 1 αληθής Α 1 Κ Κ / 2 ψευδής Εμφάνισε Κ ψευδής Κ < > 2 Λ 1 αληθής ψευδής Λ <= Κ αληθής Α 2 * Α Εμφάνισε Λ, Α Λ Λ +1 ΤΕΛΟΣ 5ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ

12 ΑΡΧΗ 6ΗΣ ΣΕΛΙΔΑΣ ΘΕΜΑ Γ (Ενδεικτική απάντηση) 1 Αλγόριθμος ΘΕΜΑ_Γ 2 Σχολεία 0! αριθμός σχολείων που επεξεργάζεται ο αλγόριθμος 3 Εξεταζόμενοι 0! σύνολο μαθητών που εξετάστηκαν για το αν θα συμμετάσχουν. 4 Σύνολο_ΑΓ 0! σύνολο αγοριών που εξετάστηκαν για το αν θα συμμετάσχουν. 5 Σύνολο_ΑΓ_ΣΥΜ 0! σύνολο αγοριών που τελικά θα συμμετάσχουν 6 Σύνολο_ΚΟΡ 0! σύνολο κοριτσιών που εξετάστηκαν για το αν θα συμμετάσχουν. 7 Σύνολο_ΚΟΡ_ΣΥΜ 0! σύνολο κοριτσιών που τελικά θα συμμετάσχουν 8 Εμφάνισε Δώστε όνομα σχολείου 9 Διάβασε ΟΝ_ΣΧ 10 Αρχή_επανάληψης 11 Τμήματα 0! αριθμός τμημάτων κάθε σχολείου 12 Σχολεία Σχολεία Εμφάνισε Δώστε όνομα τμήματος 14 Διάβασε ΟΝ_ΤΜΗΜ 15 ΑΓ_ΣΧ 0! Αριθμός αγοριών επεξεργαζόμενου σχολείου 16 ΚΟΡ_ΣΧ 0! Αριθμός κοριτσιών επεξεργαζόμενου σχολείου 17 ΑΓ_ΣΥΜ_ΣΧ 0! Αριθμός αγοριών που θα συμμετάσχουν από το σχολείο 18 ΚΟΡ_ΣΥΜ_ΣΧ 0! Αριθμός κοριτσιών που θα συμμετάσχουν από το σχολείο 19 Αρχή_επανάληψης 20 Τμήματα Τμήματα Για ΜΑΘ από 1 μέχρι Αρχή_επανάληψης 23 Εμφάνισε Δώστε το φύλο του, ΜΑΘ, -ου μαθητή/τριας 24 Διάβασε Φ 25 Μέχρις_ότου Φ = A ή Φ = Κ 26 Εμφάνισε Θα συμμετάσχει ο, ΜΑΘ, -ος μαθητής/τρια στο σεμινάριο; ΝΑΙ/ΟΧΙ; 27 Διάβασε ΑΠ 28 Αν Φ = Α τότε 29 ΑΓ_ΣΧ ΑΓ_ΣΧ Αν ΑΠ = ΝΑΙ τότε 31 ΑΓ_ΣΥΜ_ΣΧ ΑΓ_ΣΥΜ_ΣΧ Τέλος_αν 33 Αλλιώς 34 ΚΟΡ_ΣΧ ΚΟΡ_ΣΧ Αν ΑΠ = ΝΑΙ τότε 36 ΚΟΡ_ΣΥΜ_ΣΧ ΚΟΡ_ΣΥΜ_ΣΧ Τέλος_αν 38 Τέλος_αν 39 Τέλος_επανάληψης 40 Εμφάνισε Δώστε όνομα επόμενου τμήματος. Για τέλος δώστε Ω 41 Διάβασε ΟΝ_ΤΜΗΜ 42 Μέχρις_ότου ΟΝ_ΤΜΗΜ = Ω 43 Εξεταζόμενοι_ΣΧ Τμήματα * 25! εξεταζόμενοι μαθητές σχολείου 44 Σύνολο_ΑΓ Σύνολο_ΑΓ + ΑΓ_ΣΧ 45 Σύνολο_ΚΟΡ Σύνολο_ΚΟΡ + ΚΟΡ_ΣΧ ΤΕΛΟΣ 6ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ

13 ΑΡΧΗ 7ΗΣ ΣΕΛΙΔΑΣ 46 Εξεταζόμενοι Εξεταζόμενοι + Εξεταζόμενοι_ΣΧ 47 ΣΥΜ_ΣΧ ΑΓ_ΣΥΜ_ΣΧ + ΚΟΡ_ΣΥΜ_ΣΧ 48 Σύνολο_ΚΟΡ_ΣΥΜ Σύνολο_ΚΟΡ_ΣΥΜ + ΚΟΡ_ΣΥΜ_ΣΧ 49 ΠΟΣ_ΣΥΜ_ΣΧ (ΣΥΜ_ΣΧ / Εξεταζόμενοι_ΣΧ) * Αν Σχολεία = 1 τότε 51 ΜΑΧ ΠΟΣ_ΣΥΜ_ΣΧ 52 ΣΧ_ΜΕΓ_ΠΟΣ_ΣΥΜ ΟΝ_ΣΧ 53 Αλλιώς 54 Αν ΠΟΣ_ΣΥΜ_ΣΧ > ΜΑΧ τότε 55 ΜΑΧ ΠΟΣ_ΣΥΜ_ΣΧ 56 ΣΧ_ΜΕΓ_ΠΟΣ_ΣΥΜ ΟΝ_ΣΧ 57 Τέλος_αν 58 Τέλος_αν 59 Εμφάνισε Δώστε όνομα επόμενου σχολείου. Για τερματισμό δώστε τη λέξη ΤΕΛΟΣ 60 Διάβασε ΟΝ_ΣΧ 61 Μέχρις_ότου ΟΝ_ΣΧ = ΤΕΛΟΣ 62 Εμφάνισε Εξετάστηκαν για συμμετοχή στα σεμινάρια:, Εξεταζόμενοι, παιδιά 63 Εμφάνισε Από αυτά αγόρια ήταν:, Σύνολο_ΑΓ, και κορίτσια:, Σύνολο_ΚΟΡ 64 Αν Σύνολο_ΚΟΡ < > 0 τότε 65 ΠΟΣ_ΚΟΡ_ΣΥΜ ( Σύνολο_ΚΟΡ_ΣΥΜ / Σύνολο_ΚΟΡ ) * Εμφάνισε Ποσοστό συμμετοχής κοριτσιών στα κορίτσια συνολικά :, ΠΟΣ_ΚΟΡ_ΣΥΜ, % 67 Αλλιώς 68 Εμφάνισε Δεν εξετάστηκαν κορίτσια για το αν θα συμμετάσχουν στα σεμινάρια 69 Τέλος_αν 70 Εμφάνισε Το σχολείο με το μεγαλύτερο ποσοστό συμμετοχής, ΣΧ_ΜΕΓ_ΠΟΣ_ΣΥΜ 71 Τέλος ΘΕΜΑ_Γ Παρατηρήσεις 1. Η ύπαρξη ενημερωτικών μηνυμάτων πριν από κάθε εντολή εισόδου Διάβασε είναι προαιρετική. 2. Σχόλια χρησιμοποιήθηκαν για διευκόλυνση του χρήστη. 3. Το τμήμα εντολών που αφορά το ερώτημα Γ4-δ θα μπορούσε να γραφεί ισοδύναμα και ως εξής: Να δοθεί πριν από την αρχική εντολή επανάληψης μια πλαστή πολύ μικρή αρχική τιμή στη μεταβλητή ΜΑΧ πχ -1. Στη συνέχεια εκεί που θα ψάξουμε να βρούμε το σχολεία με το μεγαλύτερο ποσοστό θα γράψουμε αντί των εντολών τις παρακάτω εντολές: Αν ΠΟΣ_ΣΥΜ_ΣΧ > ΜΑΧ τότε ΜΑΧ ΠΟΣ_ΣΥΜ_ΣΧ ΣΧ_ΜΕΓ_ΠΟΣ_ΣΥΜ ΟΝ_ΣΧ Τέλος_αν ΤΕΛΟΣ 7ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ

14 ΑΡΧΗ 8ΗΣ ΣΕΛΙΔΑΣ ΘΕΜΑ Δ (Ενδεικτική απάντηση) 1 ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ 2 ΜΕΤΑΒΛΗΤΕΣ 3 ΑΚΕΡΑΙΕΣ: Μ, Δ, Ι, Υ, Α[80], ΣΥΧΝ[20], ΜΟ[80], ΠΛ, Κ 4 ΠΡΑΓΜΑΤΙΚΕΣ: ΒΑΘ[80, 24], Β, Σ 5 ΧΑΡΑΚΤΗΡΕΣ: ΟΝΕΠ[80], ΚΟΠΑΝΑΤΖΗΔΕΣ[80], ΠΡΟΣ, ΑΠ 6 ΛΟΓΙΚΕΣ: ΥΠΑΡΧΟΥΝ_ΒΑΘΜΟΙ 7 ΑΡΧΗ! Δ2-ερώτημα 8 ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 80 9 ΓΡΑΨΕ Δώστε το ονοματεπώνυμο του, Μ, -ου μαθητή 10 ΔΙΑΒΑΣΕ ΟΝΕΠ[Μ] 11 ΓΙΑ Δ ΑΠΟ 1 ΜΕΧΡΙ ΓΡΑΨΕ ΠΗΡΕ ΜΕΡΟΣ ΣΤΟ ΔΙΑΓΩΝΙΣΜΑ; ΝΑΙ/ΟΧΙ 13 ΔΙΑΒΑΣΕ ΑΠ 14 ΑΝ ΑΠ = ΝΑΙ ΤΟΤΕ 15 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 16 ΓΡΑΨΕ Δώστε βαθμολογία διαγωνίσματος 17 ΔΙΑΒΑΣΕ ΒΑΘ[Μ, Δ] 18 ΜΕΧΡΙΣ_ΟΤΟΥ ΒΑΘ[Μ, Δ] > = 1 ΚΑΙ ΒΑΘ[Μ, Δ] < = ΑΛΛΙΩΣ 20 ΒΑΘ[Μ, Δ] ΤΕΛΟΣ_ΑΝ 22 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 23 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ! Δ3-ερώτημα 24 Κ 0 25 ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ Α[Μ] ΑΠΟΥΣΙΕΣ(ΒΑΘ, Μ) 27 ΑΝ Α[Μ] > (0.6 * 24) ΤΟΤΕ 28 Κ Κ ΚΟΠΑΝΑΤΖΗΔΕΣ[Κ] ΟΝΕΠ[Μ] 30 ΤΕΛΟΣ_ΑΝ 31 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 32 ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Κ 33 ΓΙΑ Υ ΑΠΟ Κ ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ ΑΝ ΚΟΠΑΝΑΤΖΗΔΕΣ[Υ-1] > ΚΟΠΑΝΑΤΖΗΔΕΣ[Υ] ΤΟΤΕ 35 ΠΡΟΣ ΚΟΠΑΝΑΤΖΗΔΕΣ[Υ-1] 36 ΚΟΠΑΝΑΤΖΗΔΕΣ[Υ-1] ΚΟΠΑΝΑΤΖΗΔΕΣ[Υ] 37 ΚΟΠΑΝΑΤΖΗΔΕΣ[Υ] ΠΡΟΣ 38 ΤΕΛΟΣ_ΑΝ 39 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 40 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 41 ΓΡΑΨΕ ΛΙΣΤΑ ΜΕ ΚΟΠΑΝΑΤΖΗΔΕΣ ΜΑΘΗΤΕΣ ΣΤΑ ΔΙΑΓΩΝΙΣΜΑΤΑ 42 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Κ 43 ΓΡΑΨΕ ΚΟΠΑΝΑΤΖΗΔΕΣ[Ι] ΤΕΛΟΣ 8ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ

15 ΑΡΧΗ 9ΗΣ ΣΕΛΙΔΑΣ 44 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ! Δ4-ερώτημα 45 ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ Σ 0 47 ΓΙΑ Δ ΑΠΟ 1 ΜΕΧΡΙ ΑΝ ΒΑΘ[Μ, Δ] < > -1 ΤΟΤΕ 49 Σ Σ + ΒΑΘ[Μ, Δ] 50 ΤΕΛΟΣ_ΑΝ 51 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 52 Β Σ / (24 - Α[Μ]) 53 ΜΟ[Μ] Α_Μ(Β) 54 ΑΝ Β ΜΟ[Μ] > = 0.5 ΤΟΤΕ 55 ΜΟ[Μ] ΜΟ[Μ] ΤΕΛΟΣ_ΑΝ 57 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 58 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΣΥΧΝ[Ι] 0 60 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 61 ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ ΣΥΧΝ[ΜΟ[Μ]] ΣΥΧΝ[ΜΟ[Μ]] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 64 ΥΠΑΡΧΟΥΝ_ΒΑΘΜΟΙ ΨΕΥΔΗΣ 65 ΠΛΗΘΟΣ 0 66 Ι 1 67 ΟΣΟ (Ι < = 20) ΚΑΙ (ΠΛΗΘΟΣ< 2) ΕΠΑΝΑΛΑΒΕ 68 ΑΝ ΣΥΧΝ[Ι] > 30 ΤΟΤΕ 69 ΓΡΑΨΕ Ι 70 ΠΛΗΘΟΣ ΠΛΗΘΟΣ ΥΠΑΡΧΟΥΝ_ΒΑΘΜΟΙ ΑΛΗΘΗΣ 72 ΤΕΛΟΣ_ΑΝ 73 Ι Ι ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 75 ΑΝ ΥΠΑΡΧΟΥΝ_ΒΑΘΜΟΙ = ΨΕΥΔΗΣ ΤΟΤΕ 76 ΓΡΑΨΕ Κανένας βαθμός δεν εμφανίστηκε περισσότερο από 30 φορές. 77 ΤΕΛΟΣ_ΑΝ 78 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ! Δ5-ερώτημα 79 ΣΥΝΑΡΤΗΣΗ ΑΠΟΥΣΙΕΣ(Χ, Ι):ΑΚΕΡΑΙΑ 80 ΜΕΤΑΒΛΗΤΕΣ 81 ΑΚΕΡΑΙΕΣ: Ι, Υ, ΠΛ 82 ΠΡΑΓΜΑΤΙΚΕΣ: Χ[80, 24] 84 ΑΡΧΗ 83 ΠΛ 0 85 ΓΙΑ Υ ΑΠΟ 1 ΜΕΧΡΙ ΑΝ Χ[Ι, Υ] = - 1 ΤΟΤΕ 87 ΠΛ ΠΛ ΤΕΛΟΣ_ΑΝ 89 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ 9ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ

16 ΑΡΧΗ 10ΗΣ ΣΕΛΙΔΑΣ 90 ΑΠΟΥΣΙΕΣ ΠΛ 91 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ Παρατηρήσεις 1. Οι γραμμές του προγράμματος θα μπορούσαν να γραφούν ισοδύναμα: ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20 ΣΥΧΝ[Ι] 0 ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 80 ΑΝ ΜΟ[Μ] = Ι ΤΟΤΕ ΣΥΧΝ[Ι] ΣΥΧΝ[Ι] + 1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 2. Τα ονόματα των τυπικών παραμέτρων (Χ, Ι) της συνάρτησης θα μπορούσαν να είναι τα ίδια με τα αντίστοιχα των πραγματικών παραμέτρων (ΒΑΘ, Μ) αρκεί να δηλωθούν ξανά μέσα στο τμήμα μεταβλητών της συνάρτησης. 3. Σχόλια χρησιμοποιήθηκαν για διευκόλυνση του αναγνώστη. 4. Εκτός από την περίπτωση που το απαιτούσε η εκφώνηση, η ύπαρξη άλλων ενημερωτικών μνημάτων πριν από κάθε εντολή εισόδου ΔΙΑΒΑΣΕ, είναι προαιρετική. 5. Η λογική μεταβλητή ΥΠΑΡΧΟΥΝ_ΒΑΘΜΟΙ θα μπορούσε να μην συμπεριληφθεί στην απάντηση του ερωτήματος και η λύση να είναι ισοδύναμη με τη χρήση μόνο της ακέραιης μεταβλητής ΠΛΗΘΟΣ ως εξής: ΠΛΗΘΟΣ 0 Ι 1 ΟΣΟ (Ι < = 20) ΚΑΙ (ΠΛΗΘΟΣ< 2) ΕΠΑΝΑΛΑΒΕ ΑΝ ΣΥΧΝ[Ι] > 30 ΤΟΤΕ ΓΡΑΨΕ Ι ΠΛΗΘΟΣ ΠΛΗΘΟΣ + 1 ΤΕΛΟΣ_ΑΝ Ι Ι +1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ ΠΛΗΘΟΣ = 0 ΤΟΤΕ ΓΡΑΨΕ Κανένας βαθμός δεν εμφανίστηκε περισσότερο από 30 φορές. ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ 10ΗΣ ΑΠΟ 10 ΣΕΛΙΔΕΣ

ΘΕΜΑ Α. 1. Στην εντολή εκχώρησης Χ ΨΕΥΔΗΣ η μεταβλητή Χ είναι τύπου χαρακτήρες.

ΘΕΜΑ Α. 1. Στην εντολή εκχώρησης Χ ΨΕΥΔΗΣ η μεταβλητή Χ είναι τύπου χαρακτήρες. ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΤΕΤΑΡΤΗ 08/04/2015- ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΕΞΙ (6) ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιο

Διαβάστε περισσότερα

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1 ΣΩΣΤΟ 2 ΛΑΘΟΣ 3 ΛΑΘΟΣ 4 ΛΑΘΟΣ 5 - ΣΩΣΤΟ Α5. Α3.

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1 ΣΩΣΤΟ 2 ΛΑΘΟΣ 3 ΛΑΘΟΣ 4 ΛΑΘΟΣ 5 - ΣΩΣΤΟ Α5. Α3. ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΤΕΤΑΡΤΗ 08/04/2015 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΔΕΚΑ (10) ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1

Διαβάστε περισσότερα

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙΔΕΣ

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙΔΕΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 27 ΜΑΪΟΥ 2016 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

καθώς και το παρακάτω τμήμα αλγορίθμου γραμμένο σε «ΓΛΩΣΣΑ»:

καθώς και το παρακάτω τμήμα αλγορίθμου γραμμένο σε «ΓΛΩΣΣΑ»: ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΠΑΡΑΣΚΕΥΗ 25/04/2014 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ 2 ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ:

Διαβάστε περισσότερα

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙ ΕΣ

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙ ΕΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 27 ΜΑΪΟΥ 2016 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

1. Δεν μπορεί να γίνει κλήση μίας διαδικασίας μέσα από μία συνάρτηση.

1. Δεν μπορεί να γίνει κλήση μίας διαδικασίας μέσα από μία συνάρτηση. ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΚΥΡΙΑΚΗ 24/04/2016 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΕΠΠ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΕΞΙ (6) ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιο σας τον αριθμό για καθεμία από τις παρακάτω

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 29 ΜΑΪΟΥ 2013 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙΔΕΣ

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙΔΕΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΛΑΙΟ ΣΥΣΤΗΜΑ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 27 ΜΑΪΟΥ 2016 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 24 ΙΟΥΝΙΟΥ 2014 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 29 ΜΑΪΟΥ 2013 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 6 ΙΟΥΝΙΟΥ 2014 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΕΥΤΕΡΑ 23 MAΪΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 27 ΜΑΪΟΥ 2015 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 27 ΜΑΪΟΥ 2015 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 27 ΜΑΪΟΥ 2015 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΠΡΟΓΡΑΜΜΑ Κύριο ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Γ ΑΡΧΗ ΙΑΒΑΣΕ Α, Β, Γ ΚΑΛΕΣΕ ιαδ1(α, Β, Γ) ΓΡΑΨΕ Α, Β, Γ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ Κύριο ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Γ ΑΡΧΗ ΙΑΒΑΣΕ Α, Β, Γ ΚΑΛΕΣΕ ιαδ1(α, Β, Γ) ΓΡΑΨΕ Α, Β, Γ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 30 MAΪΟΥ 2006 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

Ανακτήθηκε από την ΕΚΠΑΙΔΕΥΤΙΚΗ ΚΛΙΜΑΚΑ edu.klimaka.gr ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ

Ανακτήθηκε από την ΕΚΠΑΙΔΕΥΤΙΚΗ ΚΛΙΜΑΚΑ edu.klimaka.gr ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 30 MAΪΟΥ 2006 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΕΥΤΕΡΑ 23 MAΪΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Δ ΕΣΠΕΡΙΝΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Δ ΕΣΠΕΡΙΝΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Δ ΕΣΠΕΡΙΝΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 27 ΜΑΪΟΥ 2015 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΘΕΜΑ Α ΑΠΑΝΤΗΣΕΙΣ Α1. α. Παραβιάζει τα κριτήρια της καθοριστικότητας και της περατότητας β. Αιτιολόγηση: ο αλγόριθμος παραβιάζει το κριτήριο

Διαβάστε περισσότερα

ΠΡΟΓΡΑΜΜΑ Κύριο ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Γ ΑΡΧΗ ΙΑΒΑΣΕ Α, Β, Γ ΚΑΛΕΣΕ ιαδ1(α, Β, Γ) ΓΡΑΨΕ Α, Β, Γ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ Κύριο ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α, Β, Γ ΑΡΧΗ ΙΑΒΑΣΕ Α, Β, Γ ΚΑΛΕΣΕ ιαδ1(α, Β, Γ) ΓΡΑΨΕ Α, Β, Γ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 30 MAΪΟΥ 2006 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΜΟΝΟ ΝΕΟ ΣΥΣΤΗΜΑ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΜΟΝΟ ΝΕΟ ΣΥΣΤΗΜΑ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΜΟΝΟ ΝΕΟ ΣΥΣΤΗΜΑ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 27 ΜΑΪΟΥ 2016 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 6 ΙΟΥΝΙΟΥ 2014 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ - ΕΣΠΕΡΙΝΩΝ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΕΥΤΕΡΑ 23 ΜΑΪΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 6 ΙΟΥΝΙΟΥ 2014 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΜΟΝΟ ΝΕΟ ΣΥΣΤΗΜΑ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΜΟΝΟ ΝΕΟ ΣΥΣΤΗΜΑ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΜΟΝΟ ΝΕΟ ΣΥΣΤΗΜΑ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 27 ΜΑΪΟΥ 2016 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ

Διαβάστε περισσότερα

Γκύζη 14-Αθήνα Τηλ :

Γκύζη 14-Αθήνα Τηλ : ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΔΕΥΤΕΡΑ 23 ΜΑΪΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ)

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 29 ΜΑΪΟΥ 2013 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΕΥΤΕΡΑ 23 MAΪΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 2ΗΣ ΣΕΛΙ ΑΣ ΜΟΝΟ ΝΕΟ ΣΥΣΤΗΜΑ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 2ΗΣ ΣΕΛΙ ΑΣ ΜΟΝΟ ΝΕΟ ΣΥΣΤΗΜΑ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 2ΗΣ ΣΕΛΙ ΑΣ ΜΟΝΟ ΝΕΟ ΣΥΣΤΗΜΑ Γ ΗΜΕΡΗΣΙΩΝ Α4. Έστω ο μονοδιάστατος πίνακας Α: 5 2 3 8 7 4 10 12 Να σχεδιάσετε τον πίνακα Β[6] μετά την εκτέλεση των παρακάτω εντολών: 1. Β[Α[1] Α[3]] Α[5] 2. Β[Α[7]

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 14 ΙΟΥΝΙΟΥ 2013 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ

Διαβάστε περισσότερα

Ανάπτυξη Εφαρμογών. ΑΝ Β[i] > 0 ΚΑΙ Β[i] > Α[i] ΤΟΤΕ ΜΑΧ Β[i] ΑΛΛΙΩΣ_ΑΝ Β[i] > 0 ΚΑΙ Β[i] < = Α[i] ΤΟΤΕ

Ανάπτυξη Εφαρμογών. ΑΝ Β[i] > 0 ΚΑΙ Β[i] > Α[i] ΤΟΤΕ ΜΑΧ Β[i] ΑΛΛΙΩΣ_ΑΝ Β[i] > 0 ΚΑΙ Β[i] < = Α[i] ΤΟΤΕ Ανάπτυξη Εφαρμογών προσανατολισμού ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη. 1)

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 27 ΜΑΪΟΥ 2015 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη

Διαβάστε περισσότερα

Για Ι από 2 μέχρι 10 με_βήμα 0 S S+I Τέλος_επανάληψης Εμφάνισε S Μονάδες 5

Για Ι από 2 μέχρι 10 με_βήμα 0 S S+I Τέλος_επανάληψης Εμφάνισε S Μονάδες 5 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΣΑΒΒΑΤΟ 4 ΙΟΥΝΙΟΥ 2005 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

μεταβλητής Χ Χ ΑΛΗΘΗΣ Χ 11.0 13.0 Χ 7 > 4 Χ ΨΕΥ ΗΣ Μονάδες 10 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ - ΕΣΠΕΡΙΝΩΝ

μεταβλητής Χ Χ ΑΛΗΘΗΣ Χ 11.0 13.0 Χ 7 > 4 Χ ΨΕΥ ΗΣ Μονάδες 10 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ - ΕΣΠΕΡΙΝΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ - ΕΣΠΕΡΙΝΩΝ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 1 ΙΟΥΝΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

Α2. ίνεται το παρακάτω τμήμα αλγορίθμου: Για i από 3 μέχρι Α με_βήμα Β Εμφάνισε i Τέλος_επανάληψης ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΤΕΛΟΣ 1ΗΣ ΑΠΟ 6 ΣΕΛΙ ΕΣ

Α2. ίνεται το παρακάτω τμήμα αλγορίθμου: Για i από 3 μέχρι Α με_βήμα Β Εμφάνισε i Τέλος_επανάληψης ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΤΕΛΟΣ 1ΗΣ ΑΠΟ 6 ΣΕΛΙ ΕΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΠΑΝΕΛΛΑ ΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΕΣΠΕΡΙΝΟΥ ΕΠΑΛ (ΟΜΑ ΑΣ Β ) ΣΑΒΒΑΤΟ 22 ΜΑΪΟΥ 2010 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 2ΗΣ ΣΕΛΙΔΑΣ Γ Α... Β

ΑΡΧΗ 2ΗΣ ΣΕΛΙΔΑΣ Γ Α... Β ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΠΡΟΣΟΜΟΙΩΣΗ ΑΠΟΛΥΤΗΡΙΩΝ ΕΞΕΤΑΣΕΩΝ Γ' ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΔΕΥΤΕΡΑ 11 ΑΠΡΙΛΙΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ

Διαβάστε περισσότερα

μεταβλητής Χ Χ ΑΛΗΘΗΣ Χ Χ 7 > 4 Χ ΨΕΥ ΗΣ Μονάδες 10

μεταβλητής Χ Χ ΑΛΗΘΗΣ Χ Χ 7 > 4 Χ ΨΕΥ ΗΣ Μονάδες 10 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 1 ΙΟΥΝΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

μεταβλητής Χ Χ ΑΛΗΘΗΣ Χ Χ 7 > 4 Χ ΨΕΥ ΗΣ Μονάδες 10

μεταβλητής Χ Χ ΑΛΗΘΗΣ Χ Χ 7 > 4 Χ ΨΕΥ ΗΣ Μονάδες 10 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 1 ΙΟΥΝΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 1 ΙΟΥΝΙΟΥ 2004 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

Β.1. i. Να εξηγήσετε τι εννοούμε με τον όρο μεταφερσιμότητα των προγραμμάτων. Μονάδες 3

Β.1. i. Να εξηγήσετε τι εννοούμε με τον όρο μεταφερσιμότητα των προγραμμάτων. Μονάδες 3 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ 1 ο ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 31 MAΪΟΥ 2007 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

ΘΕΜΑ 1 ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ

ΘΕΜΑ 1 ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ 1 ο ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΣΑΒΒΑΤΟ 31 MAΪΟΥ 2008 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ

ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 8 ΙΟΥΛΙΟΥ 2010 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1. ΣΩΣΤΟ 2. ΛΑΘΟΣ 3. ΛΑΘΟΣ 4. ΣΩΣΤΟ 5. ΛΑΘΟΣ Α2. Α. Χ <> 0 Β. Ι <= 10 C. X D. 1 E. Γ Α. Ι <= 10 Β. Χ <> 0 C. X D. 1 E. Γ Α3.

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1. ΣΩΣΤΟ 2. ΛΑΘΟΣ 3. ΛΑΘΟΣ 4. ΣΩΣΤΟ 5. ΛΑΘΟΣ Α2. Α. Χ <> 0 Β. Ι <= 10 C. X D. 1 E. Γ Α. Ι <= 10 Β. Χ <> 0 C. X D. 1 E. Γ Α3. ΘΕΜΑ Α Α1. ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΠΑΡΑΣΚΕΥΗ 25/04/2014 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ 2 ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ:

Διαβάστε περισσότερα

περισσότερα από ένα παραδείγµατα εντολών της Στήλης Β).

περισσότερα από ένα παραδείγµατα εντολών της Στήλης Β). ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 3 ΙΟΥΝΙΟΥ 2003 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 6 ΙΟΥΝΙΟΥ 2014 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΘΕΜΑ 1 ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ

ΘΕΜΑ 1 ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ 1 ο ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΣΑΒΒΑΤΟ 31 MAΪΟΥ 2008 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ Α3. α. (σελ. 183-184) Στοίβα: ώθηση, απώθηση Ουρά:

Διαβάστε περισσότερα

Αν τότε. Αν Χ>Y και Y 1 τότε Ζ Χ/(Y-1) Εμφάνισε Ζ αλλιώς_αν Χ>Y και Y=1 τότε Ζ Y/X Εμφάνισε Ζ Τέλος_αν ... αλλιώς. Τέλος_αν.

Αν τότε. Αν Χ>Y και Y 1 τότε Ζ Χ/(Y-1) Εμφάνισε Ζ αλλιώς_αν Χ>Y και Y=1 τότε Ζ Y/X Εμφάνισε Ζ Τέλος_αν ... αλλιώς. Τέλος_αν. ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 27 ΜΑΪΟΥ 2015 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ)

Διαβάστε περισσότερα

ΠΡΟΤΕΙΝΟΜΕΝΟ ΔΙΑΓΩΝΙΣΜΑ ΑΕΠΠ. (Α) Να απαντήσετε στη παρακάτω ερώτηση : Τι είναι ένα υποπρόγραμμα; Τι γνωρίζετε για τα χαρακτηριστικά του; (10 Μονάδες)

ΠΡΟΤΕΙΝΟΜΕΝΟ ΔΙΑΓΩΝΙΣΜΑ ΑΕΠΠ. (Α) Να απαντήσετε στη παρακάτω ερώτηση : Τι είναι ένα υποπρόγραμμα; Τι γνωρίζετε για τα χαρακτηριστικά του; (10 Μονάδες) ΠΡΟΤΕΙΝΟΜΕΝΟ ΔΙΑΓΩΝΙΣΜΑ ΑΕΠΠ ΘΕΜΑ 1 ο (Α) Να απαντήσετε στη παρακάτω ερώτηση : Τι είναι ένα υποπρόγραμμα; Τι γνωρίζετε για τα χαρακτηριστικά του; (10 Μονάδες) (Β) Να σημειώσετε με κατάλληλο τρόπο ανάλογα

Διαβάστε περισσότερα

β. Ποια είναι η «τιμή φρουρός» στο παρακάτω τμήμα αλγορίθμου γραμμένο σε «ψευδογλώσσα»; Διάβασε όνομα Όσο όνομα < > ΤΕΛΟΣ επανάλαβε Εμφάνισε όνομα

β. Ποια είναι η «τιμή φρουρός» στο παρακάτω τμήμα αλγορίθμου γραμμένο σε «ψευδογλώσσα»; Διάβασε όνομα Όσο όνομα < > ΤΕΛΟΣ επανάλαβε Εμφάνισε όνομα ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΘΕΜΑ Α. Α1. Δίνεται το παρακάτω τμήμα αλγορίθμου γραμμένο σε «ψευδογλώσσα» το οποίο παραβιάζει δύο(2) αλγοριθμικά κριτήρια: Κ 1 Λ 0 Αρχή_επανάληψης

Διαβάστε περισσότερα

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων;

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων; ΦΡΟΝΤΙΣΤΗΡΙΑΚΟΣ ΟΡΓΑΝΙΣΜΟΣ ΘΕΜΑ Α ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ 01/03/2015 Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1.

Διαβάστε περισσότερα

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων;

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων; ΦΡΟΝΤΙΣΤΗΡΙΑΚΟΣ ΟΡΓΑΝΙΣΜΟΣ ΘΕΜΑ Α ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ 01/03/2015 Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1.

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 6/04/2014

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 6/04/2014 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 6/04/2014 ΘΕΜΑ 1 Ο Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις και δίπλα τη λέξη Σωστό, αν είναι

Διαβάστε περισσότερα

ΘΕΜΑ 1ο Α. 1. Ποια είναι τα κυριότερα χρησιμοποιούμενα γεωμετρικά σχήματα σε ένα διάγραμμα ροής και τι ενέργεια ή λειτουργία δηλώνει το καθένα;

ΘΕΜΑ 1ο Α. 1. Ποια είναι τα κυριότερα χρησιμοποιούμενα γεωμετρικά σχήματα σε ένα διάγραμμα ροής και τι ενέργεια ή λειτουργία δηλώνει το καθένα; ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 30 ΜΑΪΟΥ 2008 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ

Διαβάστε περισσότερα

Β. ίνεται το παρακάτω τμήμα δηλώσεων ενός προγράμματος σε «ΓΛΩΣΣΑ»: ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Ζ[15] ΠΡΑΓΜΑΤΙΚΕΣ: Ω

Β. ίνεται το παρακάτω τμήμα δηλώσεων ενός προγράμματος σε «ΓΛΩΣΣΑ»: ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Ζ[15] ΠΡΑΓΜΑΤΙΚΕΣ: Ω ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ 1ο ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 10 ΙΟΥΛΙΟΥ 2009 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ. 2. Οι συναρτήσεις επιτρέπεται να µεταβάλλουν τις τιµές των παραµέτρων που δέχονται από το κυρίως πρόγραµµα.

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ. 2. Οι συναρτήσεις επιτρέπεται να µεταβάλλουν τις τιµές των παραµέτρων που δέχονται από το κυρίως πρόγραµµα. ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΟΝΟΜΑΤΕΠΩΝΥΜΟ ΘΕΜΑ 1 Ο Α. Να χαρακτηρίσετε καθεµιά από τις προτάσεις που ακολουθούν γράφοντας στο τετράδιό σας, δίπλα από τον αριθµό κάθε πρότασης, το γράµµα Σ, αν αυτή είναι

Διαβάστε περισσότερα

ΘΕΜΑΤΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΕΠΑΝΑΛΗΠΤΙΚΟ 10/4/2016

ΘΕΜΑΤΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΕΠΑΝΑΛΗΠΤΙΚΟ 10/4/2016 ΘΕΜΑΤΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΕΠΑΝΑΛΗΠΤΙΚΟ 10/4/2016 ΘΕΜΑ 1ο Α. Να γράψετε τον αριθμό κάθε πρότασης και δίπλα αν είναι Σωστή(Σ) ή Λανθασμένη(Λ). 1. Το αντικείμενο

Διαβάστε περισσότερα

2015 1-5 1. 5 5 4. 10 2. . 3. 6 3. . 6

2015 1-5 1. 5 5 4. 10 2. . 3. 6 3. . 6 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθµό καθεµίας από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν

Διαβάστε περισσότερα

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ... ΜΕΧΡΙΣ_ΟΤΟΥ

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ... ΜΕΧΡΙΣ_ΟΤΟΥ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΕΥΤΕΡΑ 7 ΙΟΥΛΙΟΥ 2008 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ

Διαβάστε περισσότερα

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη

Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΔΕΥΤΕΡΑ 23 MAΪΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ)

Διαβάστε περισσότερα

ΘΕΜΑ 1ο. Μονάδες 10. Β. ίνεται το παρακάτω τμήμα αλγορίθμου: Όσο Ι < 10 επανάλαβε Εμφάνισε Ι Ι Ι + 3 Τέλος_επανάληψης ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ

ΘΕΜΑ 1ο. Μονάδες 10. Β. ίνεται το παρακάτω τμήμα αλγορίθμου: Όσο Ι < 10 επανάλαβε Εμφάνισε Ι Ι Ι + 3 Τέλος_επανάληψης ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ 1ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 4 ΙΟΥΛΙΟΥ 2007 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ Γ ΛΥΚΕΙΟΥ - 02/05/2014 ΘΕΜΑ Α Α1. Έστω ο παρακάτω αλγόριθμος ταξινόμησης: Για κ από.. μέχρι 19 Για λ από 19 μέχρι κ με_βήμα -1

Διαβάστε περισσότερα

ÔÏÕËÁ ÓÁÑÑÇ ÊÏÌÏÔÇÍÇ

ÔÏÕËÁ ÓÁÑÑÇ ÊÏÌÏÔÇÍÇ ΤΑΞΗ: ΚΑΤΕΥΘΥΝΣΗ: ΜΑΘΗΜΑ: ΘΕΜΑ Α Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ (2ος Κύκλος) ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ηµεροµηνία: Παρασκευή 25 Απριλίου 2014 ιάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ ΤΕΧΝ/ΚΗΣ ΚΑΤ/ΝΣΗΣ (Πλ. & Υπ.) 2006 ΕΚΦΩΝΗΣΕΙΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ ΤΕΧΝ/ΚΗΣ ΚΑΤ/ΝΣΗΣ (Πλ. & Υπ.) 2006 ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ 1 ο ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ ΤΕΧΝ/ΚΗΣ ΚΑΤ/ΝΣΗΣ (Πλ. & Υπ.) 2006 ΕΚΦΩΝΗΣΕΙΣ Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και

Διαβάστε περισσότερα

ΘΕΜΑ 1 ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ

ΘΕΜΑ 1 ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ 1 ο ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 27 MAΪΟΥ 2009 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

Γ.Κονδύλη 1 & Όθωνος-Μαρούσι Τηλ. Κέντρο: ,

Γ.Κονδύλη 1 & Όθωνος-Μαρούσι Τηλ. Κέντρο: , Γ.Κονδύλη 1 & Όθωνος-Μαρούσι Τηλ. Κέντρο:210-61.24.000, http://www.akadimos.gr ΠΡΟΤΕΙΝΟΜΕΝΑ ΘΕΜΑΤΑ 2014 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ Επιμέλεια θεμάτων

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΘΕΜΑ 1ο Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι σωστή,

Διαβάστε περισσότερα

Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ. Óõíåéñìüò ΕΚΦΩΝΗΣΕΙΣ

Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ. Óõíåéñìüò ΕΚΦΩΝΗΣΕΙΣ 1 ΘΕΜΑ 1 o Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ Α. Να γράψετε στην κόλλα σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1 5 και δίπλα τη λέξη

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 08 / 02 / 2015 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι. ΜΙΧΑΛΕΑΚΟΣ- Α.ΚΑΤΡΑΚΗ - Π.

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 08 / 02 / 2015 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι. ΜΙΧΑΛΕΑΚΟΣ- Α.ΚΑΤΡΑΚΗ - Π. ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 08 / 02 / 2015 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι. ΜΙΧΑΛΕΑΚΟΣ- Α.ΚΑΤΡΑΚΗ - Π.ΣΙΟΤΡΟΠΟΣ ΘΕΜΑ Α Α1. Να γράψετε στο γραπτό σας τον αριθμό καθεμιάς από τις παρακάτω

Διαβάστε περισσότερα

ΤΡΙΩΡΗ ΓΡΑΠΤΗ ΔΟΚΙΜΑΣΙΑ

ΤΡΙΩΡΗ ΓΡΑΠΤΗ ΔΟΚΙΜΑΣΙΑ ΤΡΙΩΡΗ ΓΡΑΠΤΗ ΔΟΚΙΜΑΣΙΑ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 ο Α. Δίνεται η εντολή εκχώρησης: τ κ < λ Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος. Να δικαιολογήσετε

Διαβάστε περισσότερα

Για Ι από 2 μέχρι 10 με_βήμα 0 S S+I Τέλος_επανάληψης Εμφάνισε S Μονάδες 5

Για Ι από 2 μέχρι 10 με_βήμα 0 S S+I Τέλος_επανάληψης Εμφάνισε S Μονάδες 5 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΣΑΒΒΑΤΟ 4 ΙΟΥΝΙΟΥ 2005 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2013 ΕΚΦΩΝΗΣΕΙΣ

ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2013 ΕΚΦΩΝΗΣΕΙΣ ΤΑΞΗ: ΚΑΤΕΥΘΥΝΣΗ: ΜΑΘΗΜΑ: Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ (2ος Κύκλος) ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 09/12/2012 ΑΠΑΝΤΗΣΕΙΣ. Σελίδα 1 από 9 ΔΙΑΓΩΝΙΣΜΑ ΕΚΠ. ΕΤΟΥΣ 2012-2013

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 09/12/2012 ΑΠΑΝΤΗΣΕΙΣ. Σελίδα 1 από 9 ΔΙΑΓΩΝΙΣΜΑ ΕΚΠ. ΕΤΟΥΣ 2012-2013 ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 09/12/2012 ΑΠΑΝΤΗΣΕΙΣ Α1. Τμήμα Αριθμός επαναλήψεων Α 3 Β 4 Γ ΚΑΜΙΑ Δ ΑΠΕΙΡΕΣ Α2. 1- γ, θ 2- η 3- κ 4- ζ Α3. Τμήμα Σωστή απάντηση Α 3 Β 3 Γ 4 Δ 3 Α4.

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΤΑΞΗ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΤΑΞΗ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ EΠΑΝΑΛΗΠΤΙΚΕΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΕΣΠΕΡΙΝΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 4 ΙΟΥΛΙΟΥ 2006 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ

Διαβάστε περισσότερα

Φροντιστήρια Επίγνωση Προτεινόμενα Θέματα Πανελλαδικών ΑΕΠΠ 2015

Φροντιστήρια Επίγνωση Προτεινόμενα Θέματα Πανελλαδικών ΑΕΠΠ 2015 Φροντιστήρια Επίγνωση Προτεινόμενα Θέματα Πανελλαδικών ΑΕΠΠ 2015 Βάλβης Δημήτριος Μηχανικός Πληροφορικής ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: ΘΕΜΑ Α

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: ΘΕΜΑ Α ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 03-11-2013 ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-4 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη

Διαβάστε περισσότερα

ΘΕΜΑΤΑ ΚΑΙ ΑΠΑΝΤΗΣΕΙΣ ΠΑΝΕΛΛΑΔΙΚΩΝ ΕΞΕΤΑΣΕΩΝ 2013 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΘΕΜΑΤΑ ΚΑΙ ΑΠΑΝΤΗΣΕΙΣ ΠΑΝΕΛΛΑΔΙΚΩΝ ΕΞΕΤΑΣΕΩΝ 2013 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη ΣΩΣΤΟ, αν η πρόταση

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 29 ΜΑΪΟΥ 2013 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΘΕΜΑΤΑ ΘΕΜΑ A Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν

Διαβάστε περισσότερα

Μονάδες 8 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

Μονάδες 8 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 9 ΙΟΥΝΙΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ

Διαβάστε περισσότερα

Ανάπτυξη Εφαρμογών τεχνολογικής κατεύθυνσης

Ανάπτυξη Εφαρμογών τεχνολογικής κατεύθυνσης Ανάπτυξη Εφαρμογών τεχνολογικής κατεύθυνσης ΘΕΜΑ Α Α1. Αναφέρετε ποια είναι τα στάδια επίλυσης ενός προβλήματος. Α2. Τι ονομάζουμε δομή ενός προβλήματος και ποια είναι τα πλεονεκτήματα από την εύρεση της

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 29 ΜΑΪΟΥ 2013 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

Αν τότε. αλλιώς. Τέλος_αν. Τέλος_αν

Αν τότε. αλλιώς. Τέλος_αν. Τέλος_αν Α Π Α Ν Τ Η Σ Ε Ι Σ Θ Ε Μ Α Τ Ω Ν Π Α Ν Ε Λ Λ Α Δ Ι Κ Ω Ν Ε Ξ Ε Τ Α Σ Ε Ω Ν 2 0 1 5 Α Ν Α Π Τ Υ Ξ Η Ε Φ Α Ρ Μ Ο Γ Ω Ν Σ Ε Π Ρ Ο Γ Ρ Α Μ Μ Α Τ Ι Σ Τ Ι Κ Ο Π Ε Ρ Ι Β Α Λ Λ Ο Ν Τ Ε Χ Ν Ο Λ Ο Γ Ι Κ Η Σ Κ Α

Διαβάστε περισσότερα

Τ και τιµή του Β θετική µετατρέπεται ισοδύναµα στην εντολή Όσο ως εξής:

Τ και τιµή του Β θετική µετατρέπεται ισοδύναµα στην εντολή Όσο ως εξής: ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ ΕΞΕΤΑΣΕΙΣ ΠΡΟΣΟΜΟΙΩΣΗΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 12 ΙΑΝΟΥΑΡΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

Γενικές εξετάσεις 2014 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Τεχνολογική Κατεύθυνση

Γενικές εξετάσεις 2014 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Τεχνολογική Κατεύθυνση Φροντιστήρια δυαδικό 1 ΦΡΟΝΤΙΣΤΗΡΙΑ δυαδικό Γενικές εξετάσεις 2014 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Τεχνολογική Κατεύθυνση Τα θέματα επεξεργάστηκαν οι καθηγητές των Φροντιστηρίων «δυαδικό»

Διαβάστε περισσότερα

ΘΕΜΑ 1ο Α. 1. Τι είναι οι τελεστές και ποιες είναι οι κατηγορίες των τελεστών; 2. Να δώσετε τον ορισμό της δομής δεδομένων.

ΘΕΜΑ 1ο Α. 1. Τι είναι οι τελεστές και ποιες είναι οι κατηγορίες των τελεστών; 2. Να δώσετε τον ορισμό της δομής δεδομένων. ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 1 ΙΟΥΝΙΟΥ 2007 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ

Διαβάστε περισσότερα

Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ ÏÅÖÅ

Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ ÏÅÖÅ 1 Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 ο ΕΚΦΩΝΗΣΕΙΣ Α. Να γράψετε στην κόλλα σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1 5 και δίπλα τη λέξη

Διαβάστε περισσότερα

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ 1ης ΣΕΛΙ ΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΔΙΑΓΩΝΙΣΜΑ ΠΕΡΙΟΔΟΥ : ΑΠΡΙΛΙΟΥ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ : 6 ΘΕΜΑ Α : Α1. Να γράψετε

Διαβάστε περισσότερα

III. Πως μετατρέπεται το πηγαίο πρόγραμμα σε εκτελέσιμο πρόγραμμα;

III. Πως μετατρέπεται το πηγαίο πρόγραμμα σε εκτελέσιμο πρόγραμμα; ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ: Θέμα 1ο I. Τι πρέπει να ικανοποιεί ένα κομμάτι κώδικα ώστε να χαρακτηριστεί ως υποπρόγραμμα; Τα υποπρογράμματα πρέπει

Διαβάστε περισσότερα

3. Αλγόριθμοι + ομές εδομένων = Προγράμματα.

3. Αλγόριθμοι + ομές εδομένων = Προγράμματα. ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ EΠΑΝΑΛΗΠΤΙΚΕΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 5 ΙΟΥΛΙΟΥ 2007 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ

Διαβάστε περισσότερα

Α2. Να γράψετε τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β που αντιστοιχεί σωστά.

Α2. Να γράψετε τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β που αντιστοιχεί σωστά. ΔΙΑΓΩΝΙΣΜΑ ΕΚΠ. ΕΤΟΥΣ 2016-2017 ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / Γ ΟΙΚ & ΠΛΗΡ (ΘΕΡΙΝΑ) ΗΜΕΡΟΜΗΝΙΑ: 13-11-2016 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: ΓΙΑΝΝΗΣ ΜΙΧΑΛΕΑΚΟΣ- ΑΝΝΑ ΚΑΤΡΑΚΗ ΘΕΜΑ Α Α1. Να γράψετε τους αριθμούς για κάθε

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 1 ΙΟΥΝΙΟΥ 2004 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / Γ ΓΕ.Λ. ΟΙΚ & ΠΛΗΡ (ΘΕΡΙΝΑ) ΗΜΕΡΟΜΗΝΙΑ: ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: ΓΙΑΝΝΗΣ ΜΙΧΑΛΕΑΚΟΣ ΘΕΜΑ Α

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / Γ ΓΕ.Λ. ΟΙΚ & ΠΛΗΡ (ΘΕΡΙΝΑ) ΗΜΕΡΟΜΗΝΙΑ: ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: ΓΙΑΝΝΗΣ ΜΙΧΑΛΕΑΚΟΣ ΘΕΜΑ Α ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / Γ ΓΕ.Λ. ΟΙΚ & ΠΛΗΡ (ΘΕΡΙΝΑ) ΗΜΕΡΟΜΗΝΙΑ: 25-9-2016 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: ΓΙΑΝΝΗΣ ΜΙΧΑΛΕΑΚΟΣ ΘΕΜΑ Α Α1. Να γράψετε τον αριθμό για καθεμία από τις παρακάτω προτάσεις 1-5 και, δίπλα,

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2013-2014

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2013-2014 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2013-2014 Επιμέλεια: Ομάδα Διαγωνισμάτων από το Στέκι των Πληροφορικών Θέμα Α A1. Να γράψετε στο τετράδιό σας τους

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ. 1ο ΓΕΛ ΠΕΥΚΗΣ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ B' ΤΕΤΡΑΜΗΝΟΥ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ. 1ο ΓΕΛ ΠΕΥΚΗΣ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ B' ΤΕΤΡΑΜΗΝΟΥ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ 1ο ΓΕΛ ΠΕΥΚΗΣ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ B' ΤΕΤΡΑΜΗΝΟΥ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α Α1. Δίνεται το παρακάτω πρόγραμμα σε ΓΛΩΣΣΑ ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Α2

Διαβάστε περισσότερα

www.lazarinis.gr ΑΕΠΠ - ΗΜΕΡΗΣΙΑ ΛΥΚΕΙΑ 2011 - ΘΕΜΑΤΑ ΚΑΙ ΛΥΣΕΙΣ

www.lazarinis.gr ΑΕΠΠ - ΗΜΕΡΗΣΙΑ ΛΥΚΕΙΑ 2011 - ΘΕΜΑΤΑ ΚΑΙ ΛΥΣΕΙΣ Σελίδα 1 από 12 www.lazarinis.gr ΑΕΠΠ - ΗΜΕΡΗΣΙΑ ΛΥΚΕΙΑ 2011 - ΘΕΜΑΤΑ ΚΑΙ ΛΥΣΕΙΣ Σε συνεργασία µε τις εκδόσεις ΕΛΛΗΝΟΕΚ ΟΤΙΚΗ κυκλοφορούν τα βοηθήµατα «Ανάπτυξη Εφαρµογών σε Προγραµµατιστικό Περιβάλλον:

Διαβάστε περισσότερα

ΑΠΑΝΤΗΣΕΙΣ. Επιμέλεια: Ομάδα Πληροφορικής της Ώθησης

ΑΠΑΝΤΗΣΕΙΣ. Επιμέλεια: Ομάδα Πληροφορικής της Ώθησης ΑΠΑΝΤΗΣΕΙΣ Επιμέλεια: Ομάδα Πληροφορικής της Ώθησης 1 Τετάρτη, 27 Μα ου 2015 ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ Γ ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2011-2012 Επιμέλεια: Ομάδα Διαγωνισμάτων από το Στέκι των Πληροφορικών Θέμα Α Α1. Να γράψετε στο τετράδιό σας τον

Διαβάστε περισσότερα