Δομές Επανάληψης. Όσο μέχρις ότου για. 22/11/08 Ανάπτυξη εφαρμογών 1

Save this PDF as:
 WORD  PNG  TXT  JPG

Μέγεθος: px
Εμφάνιση ξεκινά από τη σελίδα:

Download "Δομές Επανάληψης. Όσο μέχρις ότου για. 22/11/08 Ανάπτυξη εφαρμογών 1"

Transcript

1 Δομές Επανάληψης Όσο μέχρις ότου για 22/11/08 Ανάπτυξη εφαρμογών 1

2 Όσο. επανάλαβε Όσο Συνθήκη επανάλαβε Εντολή1 Εντολή2.. Ομάδα εντολών Συνθήκη Αληθής Ομάδα εντολών Εντολή Ν Τέλος_Επανάληψης Ψευδής 1. Πρώτα ελέγχεται η συνθήκη 2. Αν είναι αληθινή εκτελείται η ομάδα εντολών και μετά ελέγχεται ξανά η συνθήκη 3. Όταν η συνθήκη γίνει ψευδής τερματίζεται η επανάληψη και ο έλεγχος μεταφέρεται στην πρώτη εντολή μετά το τέλος επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 2

3 Εμφάνιση διαδοχικών ακεραίων από 1 μέχρι 100 με όσο.. επανάλαβε αρχή Αλγόριθμος ΟΣΟ1 Κ 1 Κ 1 Όσο Κ<=100 επανάλαβε Εμφάνισε Κ Κ<=100 Αληθής Κ Κ+1 Κ Κ+1 Τέλος Επανάληψης Ψευδής Εμφάνισε Κ Τέλος ΟΣΟ1 τέλος 22/11/08 Ανάπτυξη εφαρμογών 3

4 Μέχρις ότου Αρχή_ Επανάληψης Ομάδα εντολών Συνθήκη Αληθής ψευδής Εντολή1 Εντολή2.. Εντολή Ν Ομάδα εντολών Μέχρις_ότου Συνθήκη = αληθής 1. ΠΡΩΤΑ εκτελείται η ομάδα εντολών ανεξάρτητα από την συνθήκη 2. Ελέγχεται η συνθήκη και αν είναι ψευδής επαναλαμβάνεται η ομάδα εντολών 3. Όταν η συνθήκη γίνει αληθής τερματίζεται η επανάληψη και ο έλεγχος μεταφέρεται στην πρώτη εντολή μετά το τέλος επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 4

5 Εμφάνιση διαδοχικών ακεραίων από 1 μέχρι 100 με Μέχρις_ότου Κ>100 αρχή Κ 1 Εμφάνισε Κ Κ Κ+1 Ψευδής Αλγόριθμος Μέχρις1 Κ 1 Αρχή επανάληψης Εμφάνισε Κ Κ Κ+1 Μέχρις_ότου Κ>100 Τέλος Μέχρις1 Αληθής τέλος 22/11/08 Ανάπτυξη εφαρμογών 5

6 Για από μέχρι.. με_βήμα Για Μ από Τ1 μέχρι Τ2 με_βήμα β εντολή1 Μ Τ1 εντολή2. εντολή ν Ομάδα εντολών Μ<=Τ2 Όχι Ναι Ομάδα εντολών Μ Μ +β Τέλος_ επανάληψης 1. Αρχικά η μεταβλητή Μ παίρνει την αρχική τιμή Τ1 2. Ελέγχεται αν η Μ είναι Μικρότερη της τελικής τιμής Τ2 3. Αν είναι εκτελείται η ομάδα εντολών του βρόχου και η Μ παίρνει την επόμενη τιμή της 4. Ο βρόχος τερματίζεται όταν η Μ πάρει τιμή μεγαλύτερη της Τ2 5. Το βήμα μπορεί να παραλειφθεί όταν είναι 1 6. Όταν Τ2>=Τ1 τότε πρέπει το βήμα να είναι θετικό, ενώ όταν Τ2<=Τ1 πρέπει το βήμα να είναι αρνητικό ( στις αντίθετες περιπτώσεις δεν εκτελείται ο βρόχος επανάληψης ) 7. Όταν το βήμα είναι 0 έχουμε ατέρμονα βρόχο ( άπειρες επαναλήψεις) 22/11/08 Ανάπτυξη εφαρμογών 6

7 Εμφάνιση διαδοχικών ακεραίων από 1 μέχρι 100 με Για..από μέχρι.. αρχή Αλγόριθμος Για1 Κ 1 Για Κ από 1 μέχρι 100 Εμφάνισε Κ Κ<=100 Αληθής Κ Κ+1 Τέλος Επανάληψης Ψευδής Εμφάνισε Κ Τέλος Για1 τέλος 22/11/08 Ανάπτυξη εφαρμογών 7

8 Διαφορές Όσο επανάλαβε Έλεγχος στην αρχή Εκτέλεση όταν συνθήκη είναι αληθής Τερματισμός όταν συνθήκη γίνει ψευδής Μπορεί να μην εκτελεστεί ο βρόχος καμιά φορά ( αρχική συνθήκη ψευδής) Μέχρις_ότου Έλεγχος στο τέλος Εκτέλεση όταν συνθήκη είναι ψευδής Τερματισμός όταν συνθήκη γίνει αληθής Οι εντολές του βρόχου εκτελούνται οπωσδήποτε μια φορά ( γιατί ο έλεγχος γίνεται μετά) 1. Και οι δυο δομές χρησιμοποιούνται όταν δεν γνωρίζουμε το πλήθος των επαναλήψεων 2. Η συνθήκη πρέπει να ενημερώνεται κάθε φορά που τερματίζονται οι εντολές του βρόχου ώστε κάποια στιγμή να αλλάξει ( Αληθής σε ψευδή για την όσο, ψευδής σε αληθή για την μέχρις ότου). Αν δεν γίνει αυτό θα έχουμε άπειρες επαναλήψεις ( ατέρμων βρόχος) 22/11/08 Ανάπτυξη εφαρμογών 8

9 Εμφωλευμένοι βρόχοι Επιτρεπτοί Για Κ Για Λ. Τέλος επανάληψης Για Μ.... Τέλος επανάληψης Τέλος Επανάληψης Μη Επιτρεπτοί Για Κ Για Λ. Τέλος επανάληψης Για Μ.... Τέλος επανάληψης Τέλος Επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 9

10 Μετατροπή της δομής Όσο σε Μέχρις ότου Αρχική τιμή Σ Όσο Σ επανάλαβε Εντολή 1 Εντολή 2 Εντολή ν Ενημέρωση τιμής Σ Τέλος επανάληψης Αρχική τιμή Σ Αρχή επανάληψης Εντολή 1 Εντολή 2 Εντολή ν Ενημέρωση τιμής Σ Μέχρις_ότου ΌΧΙ Σ Η συνθήκη στην μέχρις ότου είναι η άρνηση της συνθήκης στης όσο Πχ ( α>0) και (β>0) (α<=0) ή ( β(<=0) 22/11/08 Ανάπτυξη εφαρμογών 10

11 Μετατροπή της δομής Όσο σε Μέχρις ότου Α 6 Β 10 Όσο (Α>0 και Β <30) επανάλαβε Εμφάνισε Α Εμφάνισε Β Α Α-2 Β Β+3 Τέλος επανάληψης Α 6 Β 10 Αρχή επανάληψης Εμφάνισε Α Εμφάνισε Β Α Α-2 Β Β+3 Μέχρις_ότου (Α<=0 ή Β>=30) Η συνθήκη στην μέχρις ότου είναι η άρνηση της συνθήκης στης όσο 22/11/08 Ανάπτυξη εφαρμογών 11

12 Μετατροπή της δομής Για σε όσο Για Μ από Τ1 μέχρι Τ2 με βήμα β Εντολή 1 Εντολή 2 Εντολή ν Τέλος επανάληψης Μ Τ1 Όσο Μ <=Τ2 επανάλαβε Εντολή 1 Εντολή 2 Εντολή ν Μ Μ + β Τέλος επανάληψης Αν Τ1>Τ2 τότε η συνθήκη γίνεται Όσο Μ>=Τ2 και το βήμα β<0 22/11/08 Ανάπτυξη εφαρμογών 12

13 Μετατροπή της δομής Για σε όσο Για κ από 100 μέχρι 20 με βήμα -5 Κ 100 Όσο Κ>=20 επανάλαβε Εμφάνισε Κ Τέλος επανάληψης Εμφάνισε Κ Κ Κ-5 Τέλος επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 13

14 Μετρητές, αθροιστές Διάβασμα βάρους 50 κιβωτίων και υπολογισμός μέσης τιμής Αλγόριθμος Μετρητές_Αθροιστές Μ 0! Μετρητής, αρχική τιμή 0 ΆΘροισμα 0! Αθροιστής, αρχική τιμή 0 Διάβασε Βάρος! Πρώτη τιμή βάρους Όσο Μ<=50 επανάλαβε Αθροισμα Αθροισμα +Βάρος Μ Μ+1 Διάβασε Βάρος Τέλος Επανάληψης Μέση_τιμή Άθροισμα / Μ Εμφάνισε Μέση_τιμή Τέλος Μετρητές_Αθροιστές!Ενημέρωση αθροιστή!ενημέρωση μετρητή! Επόμενη τιμή βάρους 22/11/08 Ανάπτυξη εφαρμογών 14

15 Αλγόριθμος Παραγοντικό Διάβασε Ν Ρ 1 Αν Ν =0 τότε Ρ 1 Αλλιώς Κ 1 Όσο Κ <=Ν επανάλαβε Ρ Ρ*Ι Κ Κ+1 Τέλος Επανάληψης Τέλος_αν Εμφάνισε Ρ Τέλος Παραγοντικό Πολλαπλασιαστές 22/11/08 Ανάπτυξη εφαρμογών 15

16 Υπολογισμός Μέγιστου πολλών αριθμών γνωστού πλήθους - γνωστού εύρους τιμών Να γραφεί αλγόριθμος που αφού διαβάσει τις θερμοκρασίες κάθε μέρας για όλο το χρόνο ( 365 μέρες) για την Αθήνα, να βρίσκει την υψηλότερη και την χαμηλότερη τιμή τους Αρχική τιμή μέγιστου η μικρότερη πιθανή τιμή Αρχική τιμή ελάχιστου η μεγαλύτερη πιθανή τιμή Αλγόριθμος Μέγιστος_ελάχιστος Μax -273! Δεν υπάρχει μικρότερη Min +100! Δεν υπάρχει μεγαλύτερη Για Κ από 1 μέχρι 365 Διάβασε Θ Αν Θ>Max τότε Max Θ Τέλος_αν Αν Θ<Min τότε Min Θ Τέλος_αν Τέλος_επανάληψης Εμφάνισε Min, Max Τέλος Μέγιστος_ελάχιστος 22/11/08 Ανάπτυξη εφαρμογών 16

17 Υπολογισμός Μέγιστου πολλών αριθμών γνωστού πλήθους -άγνωστου εύρους τιμών Να γραφεί αλγόριθμος που αφού διαβάσει 50 τυχαίους αριθμούς να βρίσκει τον μεγαλύτερο και τον μικρότερο Αρχικές τιμές μέγιστου και ελάχιστου η πρώτη τιμή Αλγόριθμος Μέγιστος_ελάχιστος Διάβασε Α Μέγιστος Α Ελάχιστος Α Για Κ από 1 μέχρι 49 Διάβασε Α Αν Α> Μέγιστος τότε Μέγιστος Θ Τέλος_αν Αν Α < Ελάχιστος τότε Ελάχιστος Α Τέλος_αν Τέλος_επανάληψης Εμφάνισε Μέγιστος, Ελάχιστος Τέλος Μέγιστος_ελάχιστος 22/11/08 Ανάπτυξη εφαρμογών 17

18 Υπολογισμός Μέγιστου πολλών αριθμών άγνωστου πλήθους -άγνωστου εύρους τιμών Να γραφεί αλγόριθμος που αφού διαβάσει 50 τυχαίους θετικούς αριθμούς να βρίσκει τον μεγαλύτερο και τον μικρότερο Αρχικές τιμές μέγιστου και ελάχιστου η πρώτη τιμή Αλγόριθμος Μέγιστος_ελάχιστος Διάβασε Α Μέγιστος Α Ελάχιστος Α Όσο Α>0 επανάλαβε Αν Α> Μέγιστος τότε Μέγιστος Θ Τέλος_αν Αν Α < Ελάχιστος τότε Ελάχιστος Α Τέλος_αν Διάβασε Α Τέλος_επανάληψης Εμφάνισε Μέγιστος, Ελάχιστος Τέλος Μέγιστος_ελάχιστος 22/11/08 Ανάπτυξη εφαρμογών 18

19 Έλεγχος εγκυρότητας τιμών εισόδου 1 ος Τρόπος Εξασφάλιση έγκυρου βαθμού λυκείου ( 0-20) 2 ος Τρόπος Αρχή επανάληψης Γράψε δώσε βαθμό από 0-20: Διάβασε β Μέχρις_ότου ( β >=0 και β<=20) Γράψε δώσε βαθμό από 0-20: Διάβασε β Όσο ( β<0 ή β>20) επανάλαβε Γράψε δώσε βαθμό από 0-20: Διάβασε β Τέλος_επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 19

20 Δημιουργία πίνακα τιμών Αλγόριθμος Εμφάνιση Α 0 Β 0 Για Ι από 2 μέχρι 12 με βήμα 3 Α Α+Ι Αν Α<=8 τότε Για J από 1 μέχρι Α Β Β+1 Τέλος_επανάληψης Τέλος_αν Γράψε I, J, A, B Τέλος_επανάληψης Φάσεις I J A B Αρχή?? η η η η Έξοδος /11/08 Ανάπτυξη εφαρμογών 20

21 Πολλαπλασιασμός αλά ρωσικά Αρχή Διάβασε Μ1, Μ2 Ρ 0 Μ2>0 όχι όχι Ναι Μ2 mod 2=1 Εμφάνισε Ρ Μ1 Μ1*2 Μ2 [Μ2/2] Ναι Ρ Ρ + Μ1 Τέλος 22/11/08 Ανάπτυξη εφαρμογών 21

22 Όταν δεν πρέπει να ξεπεράσουμε μια οριακή τιμή Διάβασμα βάρους κιβωτίων που το συνολικό βάρος δεν πρέπει να ξεπεράσει το 800 kg και υπολογισμός μέσης τιμής Αλγόριθμος Θέμα_3ο Μ 0! Μετρητής, αρχική τιμή 0 ΆΘροισμα 0! Αθροιστής, αρχική τιμή 0 Διάβασε Βάρος! Πρώτη τιμή βάρους Όσο (Άθροισμα+ Βάρος) <=800 επανάλαβε Αθροισμα Αθροισμα +Βάρος!Ενημέρωση αθροιστή Μ Μ+1!Ενημέρωση μετρητή Διάβασε Βάρος! Επόμενη τιμή βάρους Τέλος Επανάληψης Μέση_τιμή Άθροισμα / Μ Εμφάνισε Μέση_τιμή Τέλος Μετρητές_Αθροιστές 22/11/08 Ανάπτυξη εφαρμογών 22

23 Όταν δεν πρέπει να ξεπεράσουμε μια οριακή τιμή Διάβασμα βάρους κιβωτίων που το συνολικό βάρος δεν πρέπει να ξεπεράσει το 800 kg και υπολογισμός μέσης τιμής Αλγόριθμος Θέμα_3ο Μ 0! Μετρητής, αρχική τιμή 0 ΆΘροισμα 0! Αθροιστής, αρχική τιμή 0 Αρχή_Επανάληψης Διάβασε Βάρος! Πρώτη τιμή βάρους Αν Αθροισμα +Βάρος<=800 τότε Αθροισμα Αθροισμα +Βάρος!Ενημέρωση αθροιστή Μ Μ+1 Τέλος_αν Μέχρις_ότου (Άθροισμα+ Βάρος) >800 Μέση_τιμή Άθροισμα / Μ Εμφάνισε Μέση_τιμή Τέλος Μετρητές_Αθροιστές 22/11/08 Ανάπτυξη εφαρμογών 23

24 Μετατροπή αδόμητου αλγόριθμου σε δομημένο 1 Αρχή 2. Αν Σ1=Ψευδής πήγαινε 9 3. εντολή2 4 Αν Σ2 τότε Εντολή4 Πήγαινε 10 Αλλιώς Εντολή5 Τέλος_αν 6 πήγαινε 2 Τέλος ΑΡΧΗ ΟΣΟ (Σ1=Αληθής) επανάλαβε εντολή2 Αν Σ2 =Αληθής τότε Εντολή 4 Σ1 =Ψευδής Αλλιώς Εντολή5 Τέλος_αν ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ 22/11/08 Ανάπτυξη εφαρμογών 24

25 Μετατροπή αδόμητου αλγόριθμου σε δομημένο 1 Αρχή 2. Αν Σ1=ΑΛΗΘΉΣ Τότε εντολή1 Αν Σ2 =ΑΛΗΘΗΣ τότε Εντολή2 Εντολή3 Πήγαινε εντολή 5 Τέλος_αν εντολή4 Εντολή5 πήγαινε 2 Τέλος_ΑΝ Εντολή 6 ΤΕΛΟΣ ΑΡΧΗ ΟΣΟ (Σ1=Αληθής) επανάλαβε εντολή1 Αν Σ2 =Αληθής τότε Εντολή 2 Εντολή 3 Αλλιώς Εντολή4 Τέλος_αν Εντολή 5 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Εντολή6 ΤΕΛΟΣ 22/11/08 Ανάπτυξη εφαρμογών 25

26 22/11/08 Ανάπτυξη εφαρμογών 26

27 Δομές Επανάληψης Όσο μέχρις ότου για 22/11/08 Ανάπτυξη εφαρμογών 1

28 Όσο. επανάλαβε Όσο Συνθήκη επανάλαβε Εντολή1 Εντολή2.. Ομάδα εντολών Συνθήκη Αληθής Ομάδα εντολών Εντολή Ν Τέλος_Επανάληψης Ψευδής 1. Πρώτα ελέγχεται η συνθήκη 2. Αν είναι αληθινή εκτελείται η ομάδα εντολών και μετά ελέγχεται ξανά η συνθήκη 3. Όταν η συνθήκη γίνει ψευδής τερματίζεται η επανάληψη και ο έλεγχος μεταφέρεται στην πρώτη εντολή μετά το τέλος επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 2

29 Εμφάνιση διαδοχικών ακεραίων από 1 μέχρι 100 με όσο.. επανάλαβε αρχή Κ 1 Κ<=100 Ψευδής Αληθής Κ Κ+1 Εμφάνισε Κ Αλγόριθμος ΟΣΟ1 Κ 1 Όσο Κ<=100 επανάλαβε Εμφάνισε Κ Κ Κ+1 Τέλος Επανάληψης Τέλος ΟΣΟ1 τέλος 22/11/08 Ανάπτυξη εφαρμογών 3

30 Μέχρις ότου Ομάδα εντολών Συνθήκη Αληθής ψευδής Αρχή_ Επανάληψης Εντολή1 Εντολή2.. Εντολή Ν Ομάδα εντολών Μέχρις_ότου Συνθήκη = αληθής 1. ΠΡΩΤΑ εκτελείται η ομάδα εντολών ανεξάρτητα από την συνθήκη 2. Ελέγχεται η συνθήκη και αν είναι ψευδής επαναλαμβάνεται η ομάδα εντολών 3. Όταν η συνθήκη γίνει αληθής τερματίζεται η επανάληψη και ο έλεγχος μεταφέρεται στην πρώτη εντολή μετά το τέλος επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 4

31 Εμφάνιση διαδοχικών ακεραίων από 1 μέχρι 100 με Μέχρις_ότου Κ>100 αρχή Κ 1 Εμφάνισε Κ Κ Κ+1 Ψευδής Αλγόριθμος Μέχρις1 Κ 1 Αρχή επανάληψης Εμφάνισε Κ Κ Κ+1 Μέχρις_ότου Κ>100 Τέλος Μέχρις1 Αληθής τέλος 22/11/08 Ανάπτυξη εφαρμογών 5

32 Μ Τ1 Μ<=Τ2 Όχι Ναι Για από μέχρι.. με_βήμα Ομάδα εντολών Μ Μ +β Για Μ από Τ1 μέχρι Τ2 με_βήμα β εντολή1 εντολή2 22/11/08 Ανάπτυξη εφαρμογών 6. εντολή ν Τέλος_ επανάληψης Ομάδα εντολών 1. Αρχικά η μεταβλητή Μ παίρνει την αρχική τιμή Τ1 2. Ελέγχεται αν η Μ είναι Μικρότερη της τελικής τιμής Τ2 3. Αν είναι εκτελείται η ομάδα εντολών του βρόχου και η Μ παίρνει την επόμενη τιμή της 4. Ο βρόχος τερματίζεται όταν η Μ πάρει τιμή μεγαλύτερη της Τ2 5. Το βήμα μπορεί να παραλειφθεί όταν είναι 1 6. Όταν Τ2>=Τ1 τότε πρέπει το βήμα να είναι θετικό, ενώ όταν Τ2<=Τ1 πρέπει το βήμα να είναι αρνητικό ( στις αντίθετες περιπτώσεις δεν εκτελείται ο βρόχος επανάληψης ) 7. Όταν το βήμα είναι 0 έχουμε ατέρμονα βρόχο ( άπειρες επαναλήψεις)

33 Εμφάνιση διαδοχικών ακεραίων από 1 μέχρι 100 με Για..από μέχρι.. αρχή Αλγόριθμος Για1 Κ 1 Κ<=100 Αληθής Κ Κ+1 Για Κ από 1 μέχρι 100 Εμφάνισε Κ Τέλος Επανάληψης Ψευδής Εμφάνισε Κ Τέλος Για1 τέλος 22/11/08 Ανάπτυξη εφαρμογών 7

34 Διαφορές Όσο επανάλαβε Έλεγχος στην αρχή Εκτέλεση όταν συνθήκη είναι αληθής Τερματισμός όταν συνθήκη γίνει ψευδής Μπορεί να μην εκτελεστεί ο βρόχος καμιά φορά ( αρχική συνθήκη ψευδής) Μέχρις_ότου Έλεγχος στο τέλος Εκτέλεση όταν συνθήκη είναι ψευδής Τερματισμός όταν συνθήκη γίνει αληθής Οι εντολές του βρόχου εκτελούνται οπωσδήποτε μια φορά ( γιατί ο έλεγχος γίνεται μετά) 1. Και οι δυο δομές χρησιμοποιούνται όταν δεν γνωρίζουμε το πλήθος των επαναλήψεων 2. Η συνθήκη πρέπει να ενημερώνεται κάθε φορά που τερματίζονται οι εντολές του βρόχου ώστε κάποια στιγμή να αλλάξει ( Αληθής σε ψευδή για την όσο, ψευδής σε αληθή για την μέχρις ότου). Αν δεν γίνει αυτό θα έχουμε άπειρες επαναλήψεις ( ατέρμων βρόχος) 22/11/08 Ανάπτυξη εφαρμογών 8

35 Εμφωλευμένοι βρόχοι Επιτρεπτοί Για Κ Για Λ. Τέλος επανάληψης Για Μ.... Τέλος επανάληψης Τέλος Επανάληψης Μη Επιτρεπτοί Για Κ Για Λ. Τέλος επανάληψης Για Μ.... Τέλος επανάληψης Τέλος Επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 9

36 Μετατροπή της δομής Όσο σε Μέχρις ότου Αρχική τιμή Σ Όσο Σ επανάλαβε Εντολή 1 Εντολή 2 Εντολή ν Ενημέρωση τιμής Σ Τέλος επανάληψης Αρχική τιμή Σ Αρχή επανάληψης Εντολή 1 Εντολή 2 Εντολή ν Ενημέρωση τιμής Σ Μέχρις_ότου ΌΧΙ Σ Η συνθήκη στην μέχρις ότου είναι η άρνηση της συνθήκης στης όσο Πχ ( α>0) και (β>0) (α<=0) ή ( β(<=0) 22/11/08 Ανάπτυξη εφαρμογών 10

37 Μετατροπή της δομής Όσο σε Μέχρις ότου Α 6 Β 10 Όσο (Α>0 και Β <30) επανάλαβε Εμφάνισε Α Εμφάνισε Β Α Α-2 Β Β+3 Τέλος επανάληψης Α 6 Β 10 Αρχή επανάληψης Εμφάνισε Α Εμφάνισε Β Α Α-2 Β Β+3 Μέχρις_ότου (Α<=0 ή Β>=30) Η συνθήκη στην μέχρις ότου είναι η άρνηση της συνθήκης στης όσο 22/11/08 Ανάπτυξη εφαρμογών 11

38 Μετατροπή της δομής Για σε όσο Για Μ από Τ1 μέχρι Τ2 με βήμα β Εντολή 1 Εντολή 2 Εντολή ν Τέλος επανάληψης Μ Τ1 Όσο Μ <=Τ2 επανάλαβε Εντολή 1 Εντολή 2 Εντολή ν Μ Μ + β Τέλος επανάληψης Αν Τ1>Τ2 τότε η συνθήκη γίνεται Όσο Μ>=Τ2 και το βήμα β<0 22/11/08 Ανάπτυξη εφαρμογών 12

39 Μετατροπή της δομής Για σε όσο Για κ από 100 μέχρι 20 με βήμα -5 Κ 100 Όσο Κ>=20 επανάλαβε Εμφάνισε Κ Τέλος επανάληψης Εμφάνισε Κ Κ Κ-5 Τέλος επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 13

40 Μετρητές, αθροιστές Διάβασμα βάρους 50 κιβωτίων και υπολογισμός μέσης τιμής Αλγόριθμος Μετρητές_Αθροιστές Μ 0! Μετρητής, αρχική τιμή 0 ΆΘροισμα 0! Αθροιστής, αρχική τιμή 0 Διάβασε Βάρος! Πρώτη τιμή βάρους Όσο Μ<=50 επανάλαβε Αθροισμα Αθροισμα +Βάρος Μ Μ+1 Διάβασε Βάρος Τέλος Επανάληψης Μέση_τιμή Άθροισμα / Μ Εμφάνισε Μέση_τιμή Τέλος Μετρητές_Αθροιστές!Ενημέρωση αθροιστή!ενημέρωση μετρητή! Επόμενη τιμή βάρους 22/11/08 Ανάπτυξη εφαρμογών 14

41 Αλγόριθμος Παραγοντικό Διάβασε Ν Ρ 1 Αν Ν =0 τότε Ρ 1 Αλλιώς Κ 1 Όσο Κ <=Ν επανάλαβε Ρ Ρ*Ι Κ Κ+1 Τέλος Επανάληψης Τέλος_αν Εμφάνισε Ρ Τέλος Παραγοντικό Πολλαπλασιαστές 22/11/08 Ανάπτυξη εφαρμογών 15

42 Υπολογισμός Μέγιστου πολλών αριθμών γνωστού πλήθους - γνωστού εύρους τιμών Να γραφεί αλγόριθμος που αφού διαβάσει τις θερμοκρασίες κάθε μέρας για όλο το χρόνο ( 365 μέρες) για την Αθήνα, να βρίσκει την υψηλότερη και την χαμηλότερη τιμή τους Αρχική τιμή μέγιστου η μικρότερη πιθανή τιμή Αρχική τιμή ελάχιστου η μεγαλύτερη πιθανή τιμή Αλγόριθμος Μέγιστος_ελάχιστος Μax -273! Δεν υπάρχει μικρότερη Min +100! Δεν υπάρχει μεγαλύτερη Για Κ από 1 μέχρι 365 Διάβασε Θ Αν Θ>Max τότε Max Θ Τέλος_αν Αν Θ<Min τότε Min Θ Τέλος_αν Τέλος_επανάληψης Εμφάνισε Min, Max Τέλος Μέγιστος_ελάχιστος 22/11/08 Ανάπτυξη εφαρμογών 16

43 Υπολογισμός Μέγιστου πολλών αριθμών γνωστού πλήθους -άγνωστου εύρους τιμών Να γραφεί αλγόριθμος που αφού διαβάσει 50 τυχαίους αριθμούς να βρίσκει τον μεγαλύτερο και τον μικρότερο Αρχικές τιμές μέγιστου και ελάχιστου η πρώτη τιμή Αλγόριθμος Μέγιστος_ελάχιστος Διάβασε Α Μέγιστος Α Ελάχιστος Α Για Κ από 1 μέχρι 49 Διάβασε Α Αν Α> Μέγιστος τότε Μέγιστος Θ Τέλος_αν Αν Α < Ελάχιστος τότε Ελάχιστος Α Τέλος_αν Τέλος_επανάληψης Εμφάνισε Μέγιστος, Ελάχιστος Τέλος Μέγιστος_ελάχιστος 22/11/08 Ανάπτυξη εφαρμογών 17

44 Υπολογισμός Μέγιστου πολλών αριθμών άγνωστου πλήθους -άγνωστου εύρους τιμών Να γραφεί αλγόριθμος που αφού διαβάσει 50 τυχαίους θετικούς αριθμούς να βρίσκει τον μεγαλύτερο και τον μικρότερο Αρχικές τιμές μέγιστου και ελάχιστου η πρώτη τιμή Αλγόριθμος Μέγιστος_ελάχιστος Διάβασε Α Μέγιστος Α Ελάχιστος Α Όσο Α>0 επανάλαβε Αν Α> Μέγιστος τότε Μέγιστος Θ Τέλος_αν Αν Α < Ελάχιστος τότε Ελάχιστος Α Τέλος_αν Διάβασε Α Τέλος_επανάληψης Εμφάνισε Μέγιστος, Ελάχιστος Τέλος Μέγιστος_ελάχιστος 22/11/08 Ανάπτυξη εφαρμογών 18

45 1 ος Τρόπος Εξασφάλιση έγκυρου βαθμού λυκείου ( 0-20) 2 ος Τρόπος Έλεγχος εγκυρότητας τιμών εισόδου Αρχή επανάληψης Γράψε δώσε βαθμό από 0-20: Διάβασε β Μέχρις_ότου ( β >=0 και β<=20) Γράψε δώσε βαθμό από 0-20: Διάβασε β Όσο ( β<0 ή β>20) επανάλαβε Γράψε δώσε βαθμό από 0-20: Διάβασε β Τέλος_επανάληψης 22/11/08 Ανάπτυξη εφαρμογών 19

46 Δημιουργία πίνακα τιμών Αλγόριθμος Εμφάνιση Α 0 Β 0 Για Ι από 2 μέχρι 12 με βήμα 3 Α Α+Ι Αν Α<=8 τότε Για J από 1 μέχρι Α Β Β+1 Τέλος_επανάληψης Τέλος_αν Γράψε I, J, A, B Τέλος_επανάληψης Φάσεις I J A B Αρχή?? η η η η Έξοδος /11/08 Ανάπτυξη εφαρμογών 20

47 Πολλαπλασιασμός αλά ρωσικά Αρχή Διάβασε Μ1, Μ2 Ρ 0 Μ2>0 όχι όχι Ναι Μ2 mod 2=1 Εμφάνισε Ρ Μ1 Μ1*2 Μ2 [Μ2/2] Ναι Ρ Ρ + Μ1 Τέλος 22/11/08 Ανάπτυξη εφαρμογών 21

48 Όταν δεν πρέπει να ξεπεράσουμε μια οριακή τιμή Διάβασμα βάρους κιβωτίων που το συνολικό βάρος δεν πρέπει να ξεπεράσει το 800 kg και υπολογισμός μέσης τιμής Αλγόριθμος Θέμα_3ο Μ 0! Μετρητής, αρχική τιμή 0 ΆΘροισμα 0! Αθροιστής, αρχική τιμή 0 Διάβασε Βάρος! Πρώτη τιμή βάρους Όσο (Άθροισμα+ Βάρος) <=800 επανάλαβε Αθροισμα Αθροισμα +Βάρος!Ενημέρωση αθροιστή Μ Μ+1!Ενημέρωση μετρητή Διάβασε Βάρος! Επόμενη τιμή βάρους Τέλος Επανάληψης Μέση_τιμή Άθροισμα / Μ Εμφάνισε Μέση_τιμή Τέλος Μετρητές_Αθροιστές 22/11/08 Ανάπτυξη εφαρμογών 22

49 Όταν δεν πρέπει να ξεπεράσουμε μια οριακή τιμή Διάβασμα βάρους κιβωτίων που το συνολικό βάρος δεν πρέπει να ξεπεράσει το 800 kg και υπολογισμός μέσης τιμής Αλγόριθμος Θέμα_3ο Μ 0! Μετρητής, αρχική τιμή 0 ΆΘροισμα 0! Αθροιστής, αρχική τιμή 0 Αρχή_Επανάληψης Διάβασε Βάρος! Πρώτη τιμή βάρους Αν Αθροισμα +Βάρος<=800 τότε Αθροισμα Αθροισμα +Βάρος!Ενημέρωση αθροιστή Μ Μ+1 Τέλος_αν Μέχρις_ότου (Άθροισμα+ Βάρος) >800 Μέση_τιμή Άθροισμα / Μ Εμφάνισε Μέση_τιμή Τέλος Μετρητές_Αθροιστές 22/11/08 Ανάπτυξη εφαρμογών 23

50 Μετατροπή αδόμητου αλγόριθμου σε δομημένο 1 Αρχή 2. Αν Σ1=Ψευδής πήγαινε 9 3. εντολή2 4 Αν Σ2 τότε Εντολή4 Πήγαινε 10 Αλλιώς Εντολή5 Τέλος_αν 6 πήγαινε 2 Τέλος ΑΡΧΗ ΟΣΟ (Σ1=Αληθής) επανάλαβε εντολή2 Αν Σ2 =Αληθής τότε Εντολή 4 Σ1 =Ψευδής Αλλιώς Εντολή5 Τέλος_αν ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ 22/11/08 Ανάπτυξη εφαρμογών 24

51 Μετατροπή αδόμητου αλγόριθμου σε δομημένο 1 Αρχή 2. Αν Σ1=ΑΛΗΘΉΣ Τότε εντολή1 Αν Σ2 =ΑΛΗΘΗΣ τότε Εντολή2 Εντολή3 Πήγαινε εντολή 5 Τέλος_αν εντολή4 Εντολή5 πήγαινε 2 Τέλος_ΑΝ Εντολή 6 ΤΕΛΟΣ ΑΡΧΗ ΟΣΟ (Σ1=Αληθής) επανάλαβε εντολή1 Αν Σ2 =Αληθής τότε Εντολή 2 Εντολή 3 Αλλιώς Εντολή4 Τέλος_αν Εντολή 5 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ Εντολή6 ΤΕΛΟΣ 22/11/08 Ανάπτυξη εφαρμογών 25

52 22/11/08 Ανάπτυξη εφαρμογών 26

Επαναληπτικές Διαδικασίες

Επαναληπτικές Διαδικασίες Επαναληπτικές Διαδικασίες Οι επαναληπτικές δομές ( εντολές επανάληψης επαναληπτικά σχήματα ) χρησιμοποιούνται, όταν μια ομάδα εντολών πρέπει να εκτελείται αρκετές- πολλές φορές ανάλογα με την τιμή μιας

Διαβάστε περισσότερα

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΙΜΕΛΕΙΑ: ΜΑΡΙΑ Σ. ΖΙΩΓΑ ΚΑΘΗΓΗΤΡΙΑ ΠΛΗΡΟΦΟΡΙΚΗΣ ΘΕΩΡΙΑ 2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ 1) Πότε χρησιμοποιείται η δομή επανάληψης

Διαβάστε περισσότερα

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΙΜΕΛΕΙΑ: ΜΑΡΙΑ Σ. ΖΙΩΓΑ ΚΑΘΗΓΗΤΡΙΑ ΠΛΗΡΟΦΟΡΙΚΗΣ ΑΣΚΗΣΕΙΣ 2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΕΡΩΤΗΣΕΙΣ ΣΩΣΤΟ ΛΑΘΟΣ Σημειώστε αν είναι

Διαβάστε περισσότερα

1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες εντολές (μορφές) της;

1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες εντολές (μορφές) της; 1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες (μορφές) της; Η δομή επανάληψης χρησιμοποιείται όταν μια σειρά εντολών πρέπει να εκτελεστεί σε ένα σύνολο περιπτώσεων, που έχουν κάτι

Διαβάστε περισσότερα

Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΔΙΑΓΩΝΙΣΜΑ ΣΤΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ 15 / 01 / 2012

Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΔΙΑΓΩΝΙΣΜΑ ΣΤΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ 15 / 01 / 2012 ΘΕΜΑ 1 ο Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΔΙΑΓΩΝΙΣΜΑ ΣΤΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ 15 / 01 / 2012 A. Να σημειώσετε αν είναι σωστή ή λανθασμένη η καθεμιά από τις παρακάτω

Διαβάστε περισσότερα

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΑΡΧΗ 1ης ΣΕΛΙ ΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΔΙΑΓΩΝΙΣΜΑ ΠΕΡΙΟΔΟΥ : ΝΟΕΜΒΡΙΟΥ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ : 7 ΘΕΜΑ Α : Α1

Διαβάστε περισσότερα

Σε καθεμιά από τις παρακάτω περιπτώσεις, να μετατρέψετε τη δομή επανάληψης ΟΣΟ στην δομή ΑΠΑΝΤΗΣΗ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΜΕΧΡΙΣ_ΟΤΟΥ Α<-54

Σε καθεμιά από τις παρακάτω περιπτώσεις, να μετατρέψετε τη δομή επανάληψης ΟΣΟ στην δομή ΑΠΑΝΤΗΣΗ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΜΕΧΡΙΣ_ΟΤΟΥ Α<-54 Άσκηση_1 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Σε καθεμιά από τις παρακάτω περιπτώσεις, να μετατρέψετε τη δομή επανάληψης ΟΣΟ στην δομή επανάληψης ΜΕΧΡΙΣ_ΟΤΟΥ. 1 η Περίπτωση Κ 0 ΌΣΟ Λ > 5 ΕΠΑΝΑΛΑΒΕ

Διαβάστε περισσότερα

ΑΡΧΗ 1ης ΣΕΛΙΔΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ

ΑΡΧΗ 1ης ΣΕΛΙΔΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΑΡΧΗ 1ης ΣΕΛΙΔΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΔΙΑΓΩΝΙΣΜΑ ΠΕΡΙΟΔΟΥ : ΟΚΤΩΒΡΙΟΥ 2015 ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ : 7 ΘΕΜΑ Α

Διαβάστε περισσότερα

ΘΕΜΑΤΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 1/12/2013

ΘΕΜΑΤΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 1/12/2013 ΘΕΜΑΤΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 1/12/2013 ΘΕΜΑ 1 ο Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις και δίπλα τη λέξη Σωστό,

Διαβάστε περισσότερα

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον 2.4.5 8.2 Δομή Επανάληψης Δομές Επανάληψης Οι δομές επανάληψης χρησιμοποιούνται στις περιπτώσεις όπου μια συγκεκριμένη ακολουθία εντολών πρέπει να εκτελεστεί

Διαβάστε περισσότερα

Η Δομή Επανάληψης. Εισαγωγή στην δομή επανάληψης Χρονική διάρκεια: 3 διδακτικές ώρες

Η Δομή Επανάληψης. Εισαγωγή στην δομή επανάληψης Χρονική διάρκεια: 3 διδακτικές ώρες Η Δομή Επανάληψης Εισαγωγή στην δομή επανάληψης Χρονική διάρκεια: 3 διδακτικές ώρες Οι 2 πρώτες διδακτικές ώρες στην τάξη Η τρίτη διδακτική ώρα στο εργαστήριο Γενικός Διδακτικός Σκοπός Ενότητας Να εξοικειωθούν

Διαβάστε περισσότερα

Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2. Α1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων πληροφορικής

Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2. Α1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων πληροφορικής Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2 Α1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων πληροφορικής Α2. Ο αλγόριθμος αποτελείται από ένα πεπερασμένο σύνολο εντολών Α3. Ο αλγόριθμος

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙ ΩΝ: 6

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙ ΩΝ: 6 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙ ΩΝ: 6 ΘΕΜΑ 1 ο Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές (Σ) η λανθασµένες

Διαβάστε περισσότερα

Ημερομηνία: Τρίτη 27 Δεκεμβρίου 2016 Διάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ

Ημερομηνία: Τρίτη 27 Δεκεμβρίου 2016 Διάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ ΤΑΞΗ: ΜΑΘΗΜΑ: Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΑΕΠΠ ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ Ημερομηνία: Τρίτη 27 Δεκεμβρίου 2016 Διάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας το γράμμα κάθε πρότασης και δίπλα σε

Διαβάστε περισσότερα

ΑΕΠΠ 2o Επαναληπτικό Διαγώνισμα

ΑΕΠΠ 2o Επαναληπτικό Διαγώνισμα ΑΕΠΠ 2o Επαναληπτικό Διαγώνισμα Ονοματεπώνυμο: ΘΕΜΑ 1 A. Να γράψετε τους κανόνες που πρέπει να ακολουθούνται στη χρήση των εμφωλευμένων βρόχων. Β. Na γίνει ο πολλαπλασιασμός 15 * 45 αλά ρώσικα και να γραφεί

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός: Θέμα 1ο Α) Απαντήστε στις παρακάτω ερωτήσεις επιλέγοντας Σ (Σωστό) ή Λ (Λάθος). 1. Η ομάδα εντολών μέσα στην Αρχή_επανάληψης..μέχρις_ότου

Διαβάστε περισσότερα

Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές (Σ) η λανθασμένες (Λ).

Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές (Σ) η λανθασμένες (Λ). ΚΟΡΥΦΑΙΟ ΦΡΟΝΤΙΣΤΗΡΙΟ korifeo.gr ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: 6 ΘΕΜΑ 1 ο Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις

Διαβάστε περισσότερα

Να γράψετε τα αποτελέσματα αυτού του αλγόριθμου για Χ=13, Χ=9 και Χ=22. Και στις 3 περιπτώσεις το αποτέλεσμα του αλγορίθμου είναι 1

Να γράψετε τα αποτελέσματα αυτού του αλγόριθμου για Χ=13, Χ=9 και Χ=22. Και στις 3 περιπτώσεις το αποτέλεσμα του αλγορίθμου είναι 1 Άσκηση 1. Δίνεται ο παρακάτω αλγόριθμος: ΑΛΓΟΡΙΘΜΟΣ ΕΛΕΓΧΟΣ_ΑΝΑΘΕΣΗΣ ΔΙΑΒΑΣΕ X ΌΣΟ Χ > 1 ΕΠΑΝΑΛΑΒΕ ΑΝ Χ MOD 2 = 0 ΤΟΤΕ Χ Χ / 2 Χ 3 * Χ + 1 ΑΠΟΤΕΛΕΣΜΑΤΑ // Χ // ΤΕΛΟΣ ΕΛΕΓΧΟΣ_ΑΝΑΘΕΣΗΣ Να γράψετε τα αποτελέσματα

Διαβάστε περισσότερα

ΑΕΠΠ 4o Επαναληπτικό Διαγώνισμα

ΑΕΠΠ 4o Επαναληπτικό Διαγώνισμα ΑΕΠΠ 4o Επαναληπτικό Διαγώνισμα Ονοματεπώνυμο: ΘΕΜΑ 1 A. Να γράψετε τους κανόνες που πρέπει να ακολουθούνται στη χρήση των εμφωλευμένων βρόχων. B. Να χαρακτηρίσετε ως σωστή (Σ) ή λάθος (Λ) καθεμία από

Διαβάστε περισσότερα

Δομές Ακολουθίας- Επιλογής - Επανάληψης. Δομημένος Προγραμματισμός

Δομές Ακολουθίας- Επιλογής - Επανάληψης. Δομημένος Προγραμματισμός Δομές Ακολουθίας- Επιλογής - Επανάληψης Δομημένος Προγραμματισμός 1 Βασικές Έννοιες αλγορίθμων Σταθερές Μεταβλητές Εκφράσεις Πράξεις Εντολές 2 Βασικές Έννοιες Αλγορίθμων Σταθερά: Μια ποσότητα που έχει

Διαβάστε περισσότερα

Κεφάλαια Εντολές επανάληψης. Τρεις εντολές επανάληψης. Επιλογή εντολής επανάληψης ΟΣΟ...ΕΠΑΝΑΛΑΒΕ. Σύνταξη στη ΓΛΩΣΣΑ

Κεφάλαια Εντολές επανάληψης. Τρεις εντολές επανάληψης. Επιλογή εντολής επανάληψης ΟΣΟ...ΕΠΑΝΑΛΑΒΕ. Σύνταξη στη ΓΛΩΣΣΑ Εντολές επανάληψης Κεφάλαια 02-08 οµές Επανάληψης Επιτρέπουν την εκτέλεση εντολών περισσότερες από µία φορά Οι επαναλήψεις ελέγχονται πάντοτε από κάποια συνθήκη η οποία καθορίζει την έξοδο από το βρόχο

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ Α3. α. (σελ. 183-184) Στοίβα: ώθηση, απώθηση Ουρά:

Διαβάστε περισσότερα

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΔΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 19/12/2008. Τμήμα ΓΤ1 Όνομα:...

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΔΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 19/12/2008. Τμήμα ΓΤ1 Όνομα:... ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΔΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 19/12/2008 Τμήμα ΓΤ1 Όνομα:... ΘΕΜΑ 1 ο. Α) Να γράψετε στο φύλλο απαντήσεών σας Σ εάν κρίνετε ότι η πρόταση είναι σωστή και

Διαβάστε περισσότερα

i 1 Όσο i <> 100 επανάλαβε i i + 2 Γράψε A[i] Τέλος_επανάληψης

i 1 Όσο i <> 100 επανάλαβε i i + 2 Γράψε A[i] Τέλος_επανάληψης ΘΕΜΑ Α A1 Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις α-δ και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν είναι λανθασμένη. a. Σε μία εντολή εκχώρησης του αποτελέσματος

Διαβάστε περισσότερα

Μάριος Αγγελίδης

Μάριος Αγγελίδης Δομή Επανάληψης Ενότητες βιβλίου: 2.4.5, 8.2, 8.2.1, 8.2.2, 8.2.3 Ώρες διδασκαλίας: 5 Η δομή επανάληψης χρησιμοποιείται όταν έχουμε μία ομάδα εντολών που θέλουμε να εκτελεστούν πολλές φορές. Υπάρχουν τρείς

Διαβάστε περισσότερα

Παράδειγμα 2. Λύση & Επεξηγήσεις. Τέλος_επανάληψης Εμφάνισε "Ναι" Τέλος Α2

Παράδειγμα 2. Λύση & Επεξηγήσεις. Τέλος_επανάληψης Εμφάνισε Ναι Τέλος Α2 Διδακτική πρόταση ΕΝΟΤΗΤΑ 2η, Θέματα Θεωρητικής Επιστήμης των Υπολογιστών Κεφάλαιο 2.2. Παράγραφος 2.2.7.4 Εντολές Όσο επανάλαβε και Μέχρις_ότου Η διαπραγμάτευση των εντολών επανάληψης είναι σημαντικό

Διαβάστε περισσότερα

2ο ΓΕΛ ΑΓ.ΔΗΜΗΤΡΙΟΥ ΑΕΠΠ ΘΕΟΔΟΣΙΟΥ ΔΙΟΝ ΠΡΟΣΟΧΗ ΣΤΑ ΠΑΡΑΚΑΤΩ

2ο ΓΕΛ ΑΓ.ΔΗΜΗΤΡΙΟΥ ΑΕΠΠ ΘΕΟΔΟΣΙΟΥ ΔΙΟΝ ΠΡΟΣΟΧΗ ΣΤΑ ΠΑΡΑΚΑΤΩ ΠΡΟΣΟΧΗ ΣΤΑ ΠΑΡΑΚΑΤΩ ΣΤΑΘΕΡΕΣ είναι τα μεγέθη που δεν μεταβάλλονται κατά την εκτέλεση ενός αλγόριθμου. Εκτός από τις αριθμητικές σταθερές (7, 4, 3.5, 100 κλπ), τις λογικές σταθερές (αληθής και ψευδής)

Διαβάστε περισσότερα

Επιλογή και επανάληψη. Λογική έκφραση ή συνθήκη

Επιλογή και επανάληψη. Λογική έκφραση ή συνθήκη Επιλογή και επανάληψη Η ύλη που αναπτύσσεται σε αυτό το κεφάλαιο είναι συναφής µε την ύλη που αναπτύσσεται στο 2 ο κεφάλαιο. Όπου υπάρχουν διαφορές αναφέρονται ρητά. Προσέξτε ιδιαίτερα, πάντως, ότι στο

Διαβάστε περισσότερα

Στήλη Β Προτάσεις. 1. Όσο συνθήκη επανάλαβε εντολές Τέλος_επανάληψης 2. Αρχή_επανάληψης εντολές Μέχρις_ότου συνθήκη

Στήλη Β Προτάσεις. 1. Όσο συνθήκη επανάλαβε εντολές Τέλος_επανάληψης 2. Αρχή_επανάληψης εντολές Μέχρις_ότου συνθήκη ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 1 ΙΟΥΝΙΟΥ 2004 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ)

Διαβάστε περισσότερα

Παρατηρήσεις για την δομή Όσο..επανάλαβε( ΣΟΣ)

Παρατηρήσεις για την δομή Όσο..επανάλαβε( ΣΟΣ) Δομή επανάληψης: Αποτελείται από ένα σύνολο εντολών που εκτελούνται πολλές φορές (αυτοματοποιημένα). Εφαρμόζεται όταν μια σειρά εντολών πρέπει να εκτελεστεί σε ένα σύνολο περιπτώσεων, που έχουν κάτι κοινό.

Διαβάστε περισσότερα

Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2

Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2 Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2 1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων Πληροφορικής 2. Ο αλγόριθμος αποτελείται από ένα πεπερασμένο σύνολο εντολών 3. Ο αλγόριθμος

Διαβάστε περισσότερα

Παλλατίδειο ΓΕΛ Σιδηροκάστρου

Παλλατίδειο ΓΕΛ Σιδηροκάστρου Δομή Επανάληψης 2000 Θέμα 2 ο Έστω τμήμα αλγορίθμου με μεταβλητές A, B, C, D, X και Υ. D 2 Για Χ από 2 μέχρι 5 με_βήμα 2 Α 10 * Χ Β 5 * Χ + 10 C Α + Β (5 * Χ) D 3 * D - 5 Υ A + B C + D Να βρείτε τις τιμές

Διαβάστε περισσότερα

Α1. Να χαρακτηρίσετε καθεμία από τις παρακάτω προτάσεις με τη λέξη Σωστή ή με τη λέξη Λάθος.

Α1. Να χαρακτηρίσετε καθεμία από τις παρακάτω προτάσεις με τη λέξη Σωστή ή με τη λέξη Λάθος. ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / Γ- ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ (ΘΕΡΙΝΑ) ΗΜΕΡΟΜΗΝΙΑ: 08-11-2015 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι.ΜΙΧΑΛΕΑΚΟΣ- Α.ΚΑΤΡΑΚΗ - Π.ΣΙΟΤΡΟΠΟΣ ΘΕΜΑ Α Α1. Να χαρακτηρίσετε καθεμία από τις παρακάτω προτάσεις

Διαβάστε περισσότερα

ΚΕΦΑΛΑΙΑ & 8.2 (ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ) ΘΕΩΡΙΑ

ΚΕΦΑΛΑΙΑ & 8.2 (ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ) ΘΕΩΡΙΑ ΚΕΦΑΛΑΙΑ 2.4.5 & 8.2 (ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ) ΘΕΩΡΙΑ Ερωτήσεις Σωστό / Λάθος 1. Στη δομή Για... από... μέχρι η αρχική τιμή του μετρητή πρέπει να είναι πάντα μικρότερη από την τελική. 2. Η δομή Όσο... επανάλαβε

Διαβάστε περισσότερα

Γ ΤΑΞΗ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

Γ ΤΑΞΗ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΤΑΞΗ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α [40 μόρια] α) Να επιλέξτε το γράμμα Σ, αν μια πρόταση είναι σωστή και το γράμμα

Διαβάστε περισσότερα

ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΜΗΜΑ: ΟΝΟΜΑΤΕΠΩΝΥΜΟ: ΗΜΕΡΟΜΗΝΙΑ: 05/01/2012 Θέμα 1 ο Α1) Να γράψετε στο τετράδιό σας τους αριθμούς 1 έως και 4 και δίπλα τα γράμματα Σ ή Λ, ανάλογα

Διαβάστε περισσότερα

Αλγοριθμική Δομή Επανάληψης

Αλγοριθμική Δομή Επανάληψης Ημερίδα : «Διδακτικές προσεγγίσεις στα μαθήματα Ανάπτυξη εφαρμογών και Προγραμματιμός» Αλγοριθμική Δομή Επανάληψης Γεώργιος Χρ. Μακρής Διδακτικοί στόχοι στις δομές επανάληψης Να μπορούν να ξεχωρίζουν οι

Διαβάστε περισσότερα

Τρίτη, 1 Ιουνίου 2004 ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ Γ ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ

Τρίτη, 1 Ιουνίου 2004 ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ Γ ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΘΕΜΑ 1 ο ο Τρίτη, 1 Ιουνίου 2004 ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ Γ ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι

Διαβάστε περισσότερα

Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον. τελική επανάληψη /4/2015 1

Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον. τελική επανάληψη /4/2015 1 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον τελική επανάληψη 2015 7/4/2015 1 Α -Β θέμα 40Μ+20Μ Ορθά συντακτικώς γραμμένες προτάσεις, λέξεις κλειδιά, ολοκληρωμένες φράσεις Χρήση κριτικής σκέψης σε

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΘΕΜΑ Α Α1. Να γράψετε τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή ή τη λέξη ΛΑΘΟΣ, αν είναι

Διαβάστε περισσότερα

ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ 2016 Α.Ε.Π.Π. Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ. Θέματα και Απαντήσεις

ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ 2016 Α.Ε.Π.Π. Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ. Θέματα και Απαντήσεις ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ 2016 Α.Ε.Π.Π. Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Θέματα και Απαντήσεις Επιμέλεια: Ομάδα Πληροφορικής www.othisi.gr 2 Παρασκευή, 27 Μα ου 2016 ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ Γ ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ

Διαβάστε περισσότερα

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙΔΕΣ

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙΔΕΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 27 ΜΑΪΟΥ 2016 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

Επαναληπτικές δοµές. µτ α.τ. Όχι. ! απαγορεύεται µέσα σε µία ΓΙΑ να µεταβάλλουµε τον µετρητή! διότι δεν θα ξέρουµε µετά πόσες επαναλήψεις θα γίνουν

Επαναληπτικές δοµές. µτ α.τ. Όχι. ! απαγορεύεται µέσα σε µία ΓΙΑ να µεταβάλλουµε τον µετρητή! διότι δεν θα ξέρουµε µετά πόσες επαναλήψεις θα γίνουν Επαναληπτικές δοµές Η λογική των επαναληπτικών διαδικασιών εφαρµόζεται όπου µία ακολουθία εντολών εφαρµόζεται σε ένα σύνολο περιπτώσεων που έχουν κάτι κοινό. Όταν ψάχνουµε θέση για να παρκάρουµε κοντά

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: ΘΕΜΑ Α

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: ΘΕΜΑ Α ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 03-11-2013 ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-4 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη

Διαβάστε περισσότερα

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 16/12/2008. Τµήµα ΓΤ2 Όνοµα:...

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 16/12/2008. Τµήµα ΓΤ2 Όνοµα:... ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 16/12/2008 Τµήµα ΓΤ2 Όνοµα:... ΘΕΜΑ 1 ο. Α) Να γράψετε στο φύλλο απαντήσεών σας Σ εάν κρίνετε ότι η πρόταση είναι σωστή και

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ/Γ ΟΙΚΟΝΟΜΙΚΩΝ & ΠΛΗΡΟΦΟΡΙΚΗΣ-ΘΕΡΙΝΑ ΗΜΕΡΟΜΗΝΙΑ: 12/11/2017 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: ΚΑΤΡΑΚΗ Α.-ΣΙΟΤΡΟΠΟΣ Π.-ΛΙΟΔΑΚΗΣ Ε.

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ/Γ ΟΙΚΟΝΟΜΙΚΩΝ & ΠΛΗΡΟΦΟΡΙΚΗΣ-ΘΕΡΙΝΑ ΗΜΕΡΟΜΗΝΙΑ: 12/11/2017 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: ΚΑΤΡΑΚΗ Α.-ΣΙΟΤΡΟΠΟΣ Π.-ΛΙΟΔΑΚΗΣ Ε. ΔΙΑΓΩΝΙΣΜΑ ΕΚΠ. ΕΤΟΥΣ 2017-2018 ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ/Γ ΟΙΚΟΝΟΜΙΚΩΝ & ΠΛΗΡΟΦΟΡΙΚΗΣ-ΘΕΡΙΝΑ ΗΜΕΡΟΜΗΝΙΑ: 12/11/2017 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: ΚΑΤΡΑΚΗ Α.-ΣΙΟΤΡΟΠΟΣ Π.-ΛΙΟΔΑΚΗΣ Ε. ΘΕΜΑ Α Α1. Να γράψετε τον αριθμό

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ομή Επανάληψης

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ομή Επανάληψης ΕΠ.1 Να αναπτυχθεί αλγόριθμος που θα εκτυπώνει τους διψήφιους άρτιους ακέραιους. Η άσκηση στην ουσία θα πρέπει να εκτυπώσει του αριθμούς 10, 12, 14,.,96, 98. Μεμιαπρώτηματιάθαμπορούσαμενατηνλύσουμεμετοναπροσπελάσουμετιςτιμές

Διαβάστε περισσότερα

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΠΛΗΡΟΦΟΡΙΚΗ

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΠΛΗΡΟΦΟΡΙΚΗ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΠΛΗΡΟΦΟΡΙΚΗ Ον/μο:.. Γ Λυκείου Ύλη:1-2 Τεχν. Κατ. 03-11-13 ΘΕΜΑ 1 ο Α. 1)Ποιες κατηγορίες προβλημάτων γνωρίζετε; 2)Να αναπτύξετε τα κριτήρια που πρέπει να ικανοποιεί ένας αλγόριθμος. 3)Ποια

Διαβάστε περισσότερα

3. Να γραφεί πρόγραμμα που θα διαβάζει 100 ακεραίους αριθμούς από το πληκτρολόγιο και θα υπολογίζει το άθροισμά τους.

3. Να γραφεί πρόγραμμα που θα διαβάζει 100 ακεραίους αριθμούς από το πληκτρολόγιο και θα υπολογίζει το άθροισμά τους. ΑΕσΠΠ-Δομή Επανάληψης 9 ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ 1. Να γραφεί πρόγραμμα που να υπολογίζει το άθροισμα των πρώτων 100 φυσικών αριθμών. 2. Να τροποποιηθεί ο παραπάνω πρόγραμμα ώστε να υπολογίζει το άθροισμα των πρώτων

Διαβάστε περισσότερα

Ασκή σεις στή δομή επανα λήψής

Ασκή σεις στή δομή επανα λήψής Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον 1 Ασκή σεις στή δομή επανα λήψής Ανάγνωση Στοιχείων Εύρεση Πλήθους 1. Να γραφεί αλγόριθμος ο οποίος να διαβάζει Ν πραγματικούς αριθμούς. Αλγόριθμος Άσκηση1

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ & ΥΠΗΡΕΣΙΩΝ 2005

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ & ΥΠΗΡΕΣΙΩΝ 2005 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ & ΥΠΗΡΕΣΙΩΝ 2005 ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ 1ο Α. 1. Να αναφέρετε ονοµαστικά τα κριτήρια που πρέπει απαραίτητα

Διαβάστε περισσότερα

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙ ΕΣ

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙ ΕΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 27 ΜΑΪΟΥ 2016 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

Ο αλγόριθμος πρέπει να τηρεί κάποια κριτήρια

Ο αλγόριθμος πρέπει να τηρεί κάποια κριτήρια Αλγόριθμος είναι μια πεπερασμένη σειρά ενεργειών, αυστηρά καθορισμένων και εκτελέσιμων σε πεπερασμένο χρόνο, που στοχεύουν στην επίλυση ενός προβλήματος. Ο αλγόριθμος πρέπει να τηρεί κάποια κριτήρια Είσοδος:

Διαβάστε περισσότερα

Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι.

Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. σύγχρονο Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. μαθητικό φροντιστήριο 25ης Μαρτίου 111 ΠΕΤΡΟΥΠΟΛΗ 210 50 20 990 210 50 27 990 25ης Μαρτίου 74 ΠΕΤΡΟΥΠΟΛΗ 210 50 50 658 210 50 60 845 Γραβιάς 85 ΚΗΠΟΥΠΟΛΗ

Διαβάστε περισσότερα

ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ 05/01/2010 ΘΕΜΑ 1 ο Α) Δίνεται η παρακάτω ακολουθία εντολών αλγορίθμου: ΑΛΓΟΡΙΘΜΟΣ Θέμα1 ΔΙΑΒΑΣΕ Ν Σ 0 π 0 ΓΙΑ ψ ΑΠΟ -1 ΜΕΧΡΙ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ Γ ΛΥΚΕΙΟΥ - 02/05/2014 ΘΕΜΑ Α Α1. Έστω ο παρακάτω αλγόριθμος ταξινόμησης: Για κ από.. μέχρι 19 Για λ από 19 μέχρι κ με_βήμα -1

Διαβάστε περισσότερα

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον. Διάρκεια 3 ώρες. Όνομα... Επώνυμο... Βαθμός...

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον. Διάρκεια 3 ώρες. Όνομα... Επώνυμο... Βαθμός... 1 Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Διάρκεια 3 ώρες Στοιχεία Μαθητή: Όνομα... Επώνυμο... Βαθμός... 2 Θεμα Α (30%) Α1 ΣΩΣΤΟ - ΛΑΘΟΣ 1. Ένα υποπρόγραμμα δεν μπορεί να κληθεί περισσότερες

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 1 ΙΟΥΝΙΟΥ 2004 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. 1. ΣΩΣΤΟ 2. ΛΑΘΟΣ 3. ΛΑΘΟΣ 4. ΣΩΣΤΟ 5. ΣΩΣΤΟ (2 μονάδες για κάθε ερώτημα)

ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. 1. ΣΩΣΤΟ 2. ΛΑΘΟΣ 3. ΛΑΘΟΣ 4. ΣΩΣΤΟ 5. ΣΩΣΤΟ (2 μονάδες για κάθε ερώτημα) ΑΕΠΠ Γ Λυκείου Οικ. & Πληρ.- Θερινά 11-02 - 2018 Κατράκη Α.-Σιότροπος Π.-Λιοδάκης Ε. ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1. ΣΩΣΤΟ 2. ΛΑΘΟΣ 3. ΛΑΘΟΣ 4. ΣΩΣΤΟ 5. ΣΩΣΤΟ (2 μονάδες για κάθε ερώτημα) Α2. α. Δικαιολογείται

Διαβάστε περισσότερα

ΘΕΜΑ 1 ο. Στήλη Β Προτάσεις. β. Ο βρόχος επανάληψης τερµατίζεται, όταν η συνθήκη είναι αληθής. όταν η συνθήκη είναι ψευδής.

ΘΕΜΑ 1 ο. Στήλη Β Προτάσεις. β. Ο βρόχος επανάληψης τερµατίζεται, όταν η συνθήκη είναι αληθής. όταν η συνθήκη είναι ψευδής. ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 1 ΙΟΥΝΙΟΥ 2004 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ: Θέμα 1ο I. Δίνεται το παρακάτω τμήμα αλγορίθμου. Να εξετάσετε αν ικανοποιεί τα αλγοριθμικά κριτήρια. Γράψε 'Δώσε

Διαβάστε περισσότερα

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙΔΕΣ

ΤΕΛΟΣ 1ΗΣ ΑΠΟ 5 ΣΕΛΙΔΕΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΘΕΜΑ 1 ο ΕΞΕΤΑΣΕΙΣ Β ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΣΑΒΒΑΤΟ 23 ΙΑΝΟΥΑΡΙΟΥ 2016 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 02/11/2014 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι. ΜΙΧΑΛΕΑΚΟΣ - Π. ΣΙΟΤΡΟΠΟΣ- Α. ΚΑΤΡΑΚΗ

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 02/11/2014 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι. ΜΙΧΑΛΕΑΚΟΣ - Π. ΣΙΟΤΡΟΠΟΣ- Α. ΚΑΤΡΑΚΗ ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 02/11/2014 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι. ΜΙΧΑΛΕΑΚΟΣ - Π. ΣΙΟΤΡΟΠΟΣ- Α. ΚΑΤΡΑΚΗ ΘΕΜΑ Α Α1. Να χαρακτηρίσετε τις προτάσεις που ακολουθούν, γράφοντας δίπλα

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΘΕΜΑ Α ΑΠΑΝΤΗΣΕΙΣ Α1. α. Παραβιάζει τα κριτήρια της καθοριστικότητας και της περατότητας β. Αιτιολόγηση: ο αλγόριθμος παραβιάζει το κριτήριο

Διαβάστε περισσότερα

ΔΙΑΓΩΝΙΣΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ:- Γ ΛΥΚΕΙΟΥ ΤΜΗΜΑΤΑ: ΓΟ4 ΓΟ7 (ΖΩΓΡΑΦΟΥ) ΓΟ5 ΓΟ6 (ΧΟΛΑΡΓΟΣ) HM/NIA: 15/1/2017

ΔΙΑΓΩΝΙΣΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ:- Γ ΛΥΚΕΙΟΥ ΤΜΗΜΑΤΑ: ΓΟ4 ΓΟ7 (ΖΩΓΡΑΦΟΥ) ΓΟ5 ΓΟ6 (ΧΟΛΑΡΓΟΣ) HM/NIA: 15/1/2017 ΔΙΑΓΩΝΙΣΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ:- Γ ΛΥΚΕΙΟΥ ΤΜΗΜΑΤΑ: ΓΟ4 ΓΟ7 (ΖΩΓΡΑΦΟΥ) ΓΟ5 ΓΟ6 (ΧΟΛΑΡΓΟΣ) HM/NIA: 15/1/2017 ΘΕΜΑ Α (Α1) Δίνεται η παρακάτω ακολουθία εντολών αλγορίθμου:

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΣΧ... ΕΤΤΟΣΣ 22000099-22001100 Επιμέλεια : Ομάδα Διαγωνισμάτων από Το στέκι των πληροφορικών Θέμα 1 ο Α. Δίνεται η παρακάτω ακολουθία

Διαβάστε περισσότερα

Γκύζη 14-Αθήνα Τηλ :

Γκύζη 14-Αθήνα Τηλ : ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΔΕΥΤΕΡΑ 23 ΜΑΪΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ)

Διαβάστε περισσότερα

Β ΛΥΚΕΙΟΥ ΕΙΣΑΓΩΓΗ ΣΤΙΣ ΑΡΧΕΣ ΤΗΣ ΕΠΙΣΤΗΜΗΣ ΤΩΝ Η/Υ

Β ΛΥΚΕΙΟΥ ΕΙΣΑΓΩΓΗ ΣΤΙΣ ΑΡΧΕΣ ΤΗΣ ΕΠΙΣΤΗΜΗΣ ΤΩΝ Η/Υ ΕΡΩΤΗΣΕΙΣ Να γράψετε στο γραπτό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-4 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη. 1. Ένας αλγόριθμος είναι μία πεπερασμένη

Διαβάστε περισσότερα

ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 30 MAΪΟΥ ΑΕΠΠ

ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 30 MAΪΟΥ ΑΕΠΠ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 30 MAΪΟΥ 2008 - ΑΕΠΠ ΘΕΜΑ 1ο Α. 1. Ποια είναι τα κυριότερα χρησιμοποιούμενα γεωμετρικά σχήματα σε ένα διάγραμμα ροής και τι ενέργεια ή

Διαβάστε περισσότερα

! ΘΕΜΑ A Α2. ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΛΥΚΕΙΟΥ. Ονοµατεπώνυµο:

! ΘΕΜΑ A Α2. ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΛΥΚΕΙΟΥ. Ονοµατεπώνυµο: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ Ονοµατεπώνυµο: Καθηγητής: ΒΛΙΣΙΔΗΣ Γ.! ΘΕΜΑ A Α1. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη

Διαβάστε περισσότερα

8. Επιλογή και επανάληψη

8. Επιλογή και επανάληψη 8. Επιλογή και επανάληψη 8.1 Εντολές Επιλογής ΕΣΕΠ06-Θ1Β5 Η ιεραρχία των λογικών τελεστών είναι µικρότερη των αριθµητικών. ΕΣ07-Θ1Γ5 Η σύγκριση λογικών δεδοµένων έχει έννοια µόνο στην περίπτωση του ίσου

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ 2012

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ 2012 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ 2012 ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή,

Διαβάστε περισσότερα

επιµέλεια Θοδωρής Πιερράτος

επιµέλεια Θοδωρής Πιερράτος Ερωτήσεις Σωστό Λάθος 1. Στη δοµή επανάληψης Όσο... επανάλαβε ο έλεγχος της συνθήκης γίνεται στην αρχή, δηλαδή πριν εκτελεστεί οποιαδήποτε εντολή που περιέχεται στη δοµή. 2. Ο µετρητής που ελέγχει τη συνθήκη

Διαβάστε περισσότερα

Μονάδες 8. ΘΕΜΑ Β Β1. Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι εντολές εκχώρησης και εξόδου.

Μονάδες 8. ΘΕΜΑ Β Β1. Δίνεται το παρακάτω τμήμα αλγορίθμου, στο οποίο έχουν αριθμηθεί οι εντολές εκχώρησης και εξόδου. Α Π Α Ν Τ Η Σ Ε Ι Σ Θ Ε Μ Α Τ Ω Ν Π Α Ν Ε Λ Λ Α Δ Ι Κ Ω Ν Ε Ξ Ε Τ Α Σ Ε Ω Ν 2 0 1 6 Α Ν Α Π Τ Υ Ξ Η Ε Φ Α Ρ Μ Ο Γ Ω Ν Σ Ε Π Ρ Ο Γ Ρ Α Μ Μ Α Τ Ι Σ Τ Ι Κ Ο Π Ε Ρ Ι Β Α Λ Λ Ο Ν Π Ρ Ο Σ Α Ν Α Τ Ο Λ Ι Σ Μ Ο

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1Ο Α1. Να χαρακτηρίσετε τις παρακάτω προτάσεις σαν Σωστό ή Λάθος. 1. Ο υπολογιστής είναι ο ταχύτερος μηχανισμός επεξεργασίας δεδομένων. 2. Οι εντολές

Διαβάστε περισσότερα

Φάσμα. προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι.

Φάσμα. προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. σύγχρονο Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. μαθητικό φροντιστήριο 25ης Μαρτίου 111 - ΠΕΤΡΟΥΠΟΛΗ - 210 50 20 990-210 50 27 990 25ης Μαρτίου 74 - ΠΕΤΡΟΥΠΟΛΗ - 210 50 50 658-210 50 60 845 Γραβιάς 85 -

Διαβάστε περισσότερα

ΕΝΔΕΙΚΤΙΚΕΣ ΑΣΚΗΣΕΙΣ ΕΡΩΤΗΣΕΙΣ ΑΞΙΟΛΟΓΗΣΗΣ ΓΙΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ

ΕΝΔΕΙΚΤΙΚΕΣ ΑΣΚΗΣΕΙΣ ΕΡΩΤΗΣΕΙΣ ΑΞΙΟΛΟΓΗΣΗΣ ΓΙΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ ΕΝΔΕΙΚΤΙΚΕΣ ΑΣΚΗΣΕΙΣ ΕΡΩΤΗΣΕΙΣ ΑΞΙΟΛΟΓΗΣΗΣ ΓΙΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ Ερωτήσεις Ανάπτυξης 1. Να περιγράψετε τη δομή της λίστας και τη διαδικασία εισαγωγής και διαγραφής ενός κόμβου. 3.9.1 Σελ 71-72

Διαβάστε περισσότερα

Γκύζη 14-Αθήνα Τηλ :

Γκύζη 14-Αθήνα Τηλ : ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ ΙΟΥΝΙΟΥ 202 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ) ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ

Διαβάστε περισσότερα

4.4 Μετατροπή από μία μορφή δομής επανάληψης σε μία άλλη.

4.4 Μετατροπή από μία μορφή δομής επανάληψης σε μία άλλη. 4.4 Μετατροπή από μία μορφή δομής επανάληψης σε μία άλλη. Η μετατροπή μιας εντολής επανάληψης σε μία άλλη ή στις άλλες δύο εντολές επανάληψης, αποτελεί ένα θέμα που αρκετές φορές έχει εξεταστεί σε πανελλαδικό

Διαβάστε περισσότερα

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1 ΣΩΣΤΟ 2 ΛΑΘΟΣ 3 ΛΑΘΟΣ 4 ΛΑΘΟΣ 5 - ΣΩΣΤΟ Α5. Α3.

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1 ΣΩΣΤΟ 2 ΛΑΘΟΣ 3 ΛΑΘΟΣ 4 ΛΑΘΟΣ 5 - ΣΩΣΤΟ Α5. Α3. ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΤΕΤΑΡΤΗ 08/04/2015 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΔΕΚΑ (10) ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1

Διαβάστε περισσότερα

2. Ένα από τα στάδια αντιμετώπισης ενός προβλήματος είναι η ανάλυση.

2. Ένα από τα στάδια αντιμετώπισης ενός προβλήματος είναι η ανάλυση. ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΕΣΠΕΡΙΝΟΥ ΕΠΑΛ (ΟΜΑΔΑΣ Β ) ΣΑΒΒΑΤΟ 22 ΜΑΪΟΥ 2010 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α Α1. Να χαρακτηρίσετε

Διαβάστε περισσότερα

Ψευδοκώδικας. November 7, 2011

Ψευδοκώδικας. November 7, 2011 Ψευδοκώδικας November 7, 2011 Οι γλώσσες τύπου ψευδοκώδικα είναι ένας τρόπος περιγραφής αλγορίθμων. Δεν υπάρχει κανένας τυπικός ορισμός της έννοιας του ψευδοκώδικα όμως είναι κοινός τόπος ότι οποιαδήποτε

Διαβάστε περισσότερα

Γ ΤΑΞΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ÑÏÌÂÏÓ

Γ ΤΑΞΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ÑÏÌÂÏÓ Γ ΤΑΞΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1ο Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό,αν είναι σωστή,

Διαβάστε περισσότερα

Προτεινόμενα Θέματα ΑΕΠΠ

Προτεινόμενα Θέματα ΑΕΠΠ Προτεινόμενα Θέματα ΑΕΠΠ ΘΕΜΑ Α Α1. Να χαρακτηρίσετε αν κάθε μία από τις παρακάτω προτάσεις είναι σωστή (Σ) ή λανθασμένη (Λ). Αιτιολογήσετε κάθε σας απάντηση 1. Η μερικώς περιορισμένη εμβέλεια προσφέρει

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ. Πως γίνεται ο ορισμός μιας διαδικασίας; Να δοθούν σχετικά παραδείγματα. ΑΡΧΗ Εντολές ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ. Πως γίνεται ο ορισμός μιας διαδικασίας; Να δοθούν σχετικά παραδείγματα. ΑΡΧΗ Εντολές ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ Πως γίνεται ο ορισμός μιας διαδικασίας; Να δοθούν σχετικά παραδείγματα. Οι διαδικασίες μπορούν να εκτελέσουν οποιαδήποτε λειτουργία και δεν επιστρέφουν μια τιμή όπως οι συναρτήσεις. Κάθε διαδικασία έχει

Διαβάστε περισσότερα

ΘΕΜΑΤΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΕΠΑΝΑΛΗΠΤΙΚΟ 10/4/2016

ΘΕΜΑΤΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΕΠΑΝΑΛΗΠΤΙΚΟ 10/4/2016 ΘΕΜΑΤΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΕΠΑΝΑΛΗΠΤΙΚΟ 10/4/2016 ΘΕΜΑ 1ο Α. Να γράψετε τον αριθμό κάθε πρότασης και δίπλα αν είναι Σωστή(Σ) ή Λανθασμένη(Λ). 1. Το αντικείμενο

Διαβάστε περισσότερα

Συμβουλές και Μεθοδολογία Ασκήσεων Ψευδογλώσσας / ΓΛΩΣΣΑΣ

Συμβουλές και Μεθοδολογία Ασκήσεων Ψευδογλώσσας / ΓΛΩΣΣΑΣ Ψευδογλώσσας / ΓΛΩΣΣΑΣ Χρήση εντολών Εισόδου Εξόδου Α) Εντολές εισόδου Όσον αφορά στη Ψευδογλώσσα, για την κατάλληλη επιλογή εντολής εισόδου διαβάζουμε προσεχτικά την εκφώνηση. Αν η εκφώνηση αναφέρει «να

Διαβάστε περισσότερα

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον 2o Επαναληπτικό Διαγώνισμα Κεφ: 2 ο 7 ο 8 ο ΗΜΕΡΟΜΗΝΙΑ 21/ 10/ 2017

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον 2o Επαναληπτικό Διαγώνισμα Κεφ: 2 ο 7 ο 8 ο ΗΜΕΡΟΜΗΝΙΑ 21/ 10/ 2017 ΜΑΘΗΜΑ Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΔΙΑΓΩΝΙΣΜΑ 2o Επαναληπτικό Διαγώνισμα ΥΛΗ Κεφ: 2 ο 7 ο 8 ο ΗΜΕΡΟΜΗΝΙΑ 21/ 10/ 2017 Θέμα Α A1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από

Διαβάστε περισσότερα

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ

(1) Σ 0 (2) Κ 0 (3) Αρχή_Επανάληψης (4) ιάβασε Χ (5) Σ Σ+Χ (6) Αν Χ>0 τότε (7) Κ Κ+1 (8) Τέλος_Αν (9) Μέχρις_ότου Σ>1000 (10) Εμφάνισε Χ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΕΥΤΕΡΑ 23 MAΪΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

Γεώργιος Δ. Παλτεζανάκης

Γεώργιος Δ. Παλτεζανάκης Η ύλη του μαθήματος μας εισάγει στον δομημένο προγραμματισμό. Ένα καλό αυτής της τεχνικής είναι ότι αν ο μαθητής γνωρίζει κάποιους βασικούς αλγόριθμους μπορεί με συνδυασμό τους να οικοδομήσει άλλους πιο

Διαβάστε περισσότερα

2 Ο ΔΙΑΓΩΝΙΣΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΟΝ Γ ΛΥΚΕΙΟΥ ΖΗΤΗΜΑ 1ο

2 Ο ΔΙΑΓΩΝΙΣΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΟΝ Γ ΛΥΚΕΙΟΥ ΖΗΤΗΜΑ 1ο This image cannot currently be displayed. ΕΠΩΝΥΜΟ:... ΟΝΟΜΑ:... ΤΣΙΜΙΣΚΗ &ΚΑΡΟΛΟΥ ΝΤΗΛ ΓΩΝΙΑ THΛ: 270727 222594 ΑΡΤΑΚΗΣ 12 - Κ. ΤΟΥΜΠΑ THΛ: 919113 949422 ΤΜΗΜΑ:... ΗΜΕΡΟΜΗΝΙΑ:...2/2/2014... 2 Ο ΔΙΑΓΩΝΙΣΜΑ

Διαβάστε περισσότερα

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑΤΩΝ. ΘΕΜΑ Α Α1. 1. Λάθος 2 Λάθος 3. Σωστό 4. Λάθος 5. Σωστό Α2. ΧΑΡΑΚΤΗΡΕΣ ΑΛΗΘΗΣ ΠΡΑΓΜΑΤΙΚΕΣ - 2.0 ΑΚΕΡΑΙΕΣ 4

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑΤΩΝ. ΘΕΜΑ Α Α1. 1. Λάθος 2 Λάθος 3. Σωστό 4. Λάθος 5. Σωστό Α2. ΧΑΡΑΚΤΗΡΕΣ ΑΛΗΘΗΣ ΠΡΑΓΜΑΤΙΚΕΣ - 2.0 ΑΚΕΡΑΙΕΣ 4 ΘΕΜΑ Α Α1. 1. Λάθος 2 Λάθος 3. Σωστό 4. Λάθος 5. Σωστό ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 1 ΙΟΥΝΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 09/12/2012 ΑΠΑΝΤΗΣΕΙΣ. Σελίδα 1 από 9 ΔΙΑΓΩΝΙΣΜΑ ΕΚΠ. ΕΤΟΥΣ 2012-2013

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 09/12/2012 ΑΠΑΝΤΗΣΕΙΣ. Σελίδα 1 από 9 ΔΙΑΓΩΝΙΣΜΑ ΕΚΠ. ΕΤΟΥΣ 2012-2013 ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 09/12/2012 ΑΠΑΝΤΗΣΕΙΣ Α1. Τμήμα Αριθμός επαναλήψεων Α 3 Β 4 Γ ΚΑΜΙΑ Δ ΑΠΕΙΡΕΣ Α2. 1- γ, θ 2- η 3- κ 4- ζ Α3. Τμήμα Σωστή απάντηση Α 3 Β 3 Γ 4 Δ 3 Α4.

Διαβάστε περισσότερα

Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές αλγοριθμικές δομές

Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές αλγοριθμικές δομές Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές αλγοριθμικές δομές Βασικές Αλγοριθμικές Δομές 2 Εισαγωγή Οι αλγοριθμικές δομές εκφράζουν διαφορετικούς τρόπους γραφής ενός αλγορίθμου.

Διαβάστε περισσότερα

Γενικές εξετάσεις 2014 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Τεχνολογική Κατεύθυνση

Γενικές εξετάσεις 2014 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Τεχνολογική Κατεύθυνση Φροντιστήρια δυαδικό 1 ΦΡΟΝΤΙΣΤΗΡΙΑ δυαδικό Γενικές εξετάσεις 2014 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Τεχνολογική Κατεύθυνση Τα θέματα επεξεργάστηκαν οι καθηγητές των Φροντιστηρίων «δυαδικό»

Διαβάστε περισσότερα

Α2. Να αναφέρετε ονομαστικά τις βασικές λειτουργίες που εκτελεί ένας υπολογιστής (Μονάδες 3)

Α2. Να αναφέρετε ονομαστικά τις βασικές λειτουργίες που εκτελεί ένας υπολογιστής (Μονάδες 3) Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΘΕΜΑ Α Α1. Να χαρακτηρίσετε σωστή (Σ) ή λανθασμένη (Λ) καθεμία από τις παρακάτω προτάσεις: 1. Ένα επιλύσιμο πρόβλημα είναι και δομημένο. 2. Ένας από τους

Διαβάστε περισσότερα

Τ και τιµή του Β θετική µετατρέπεται ισοδύναµα στην εντολή Όσο ως εξής:

Τ και τιµή του Β θετική µετατρέπεται ισοδύναµα στην εντολή Όσο ως εξής: ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ ΕΞΕΤΑΣΕΙΣ ΠΡΟΣΟΜΟΙΩΣΗΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 12 ΙΑΝΟΥΑΡΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

Θέμα 1 ο. Επαναληπτικό ΛΥΣΕΙΣ

Θέμα 1 ο. Επαναληπτικό ΛΥΣΕΙΣ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΣΤΡΙΤΣΙΟΥ ΠΑΡΑΣΚΕΥΗ 5 Μαΐου 2014 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

ΑΓΙΑΣ ΒΑΡΒΑΡΑΣ 21 & ΠΕΡΙΚΛΕΟΥΣ, Π. ΦΑΛΗΡΟ

ΑΓΙΑΣ ΒΑΡΒΑΡΑΣ 21 & ΠΕΡΙΚΛΕΟΥΣ, Π. ΦΑΛΗΡΟ ΑΓΙΑΣ ΒΑΡΒΑΡΑΣ 21 & ΠΕΡΙΚΛΕΟΥΣ, Π ΦΑΛΗΡΟ ΤΗΛ-FAX: 210 9851164,, Ε-mail: info@neapaideiaedugr ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 1 ΙΟΥΝΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ

Διαβάστε περισσότερα

ΑΠΑΝΤΗΣΕΙΣ. Επιµέλεια: Οµάδα Πληροφορικής της Ώθησης

ΑΠΑΝΤΗΣΕΙΣ. Επιµέλεια: Οµάδα Πληροφορικής της Ώθησης ΑΠΑΝΤΗΣΕΙΣ Επιµέλεια: Οµάδα Πληροφορικής της Ώθησης 1 ευτέρα, 23 Μα ου 2011 ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ Γ ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό

Διαβάστε περισσότερα