5.69 Να σχηματίσετε τον πίνακα τιμών του παρακάτω αλγορίθμου. Τί θα εκτυπωθεί τελικά;

Μέγεθος: px
Εμφάνιση ξεκινά από τη σελίδα:

Download "5.69 Να σχηματίσετε τον πίνακα τιμών του παρακάτω αλγορίθμου. Τί θα εκτυπωθεί τελικά;"

Transcript

1 Πίνακες τιμών 5.69 Να σχηματίσετε τον πίνακα τιμών του παρακάτω αλγορίθμου. Τί θα εκτυπωθεί τελικά; Αλγόριθμος Κ38 α 3 β 0 Για i από 51 μέχρι 10 με_βήμα -11 α α + 2 Αν α > 4 τότε β β + i div α Αλλιώς β β - i Τέλος_αν α α - β Εκτύπωσε α, β Τέλος Κ Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθούν σαν είσοδος οι τιμές 100 και 200 και τις τιμές θα έχουν οι μεταβλητές α, β και γ στο τέλος του αλγορίθμου; Αλγόριθμος Κ38 Διάβασε α, β β β div α 71

2 Για y από 1 μέχρι 3 Αν α = β τότε t α α β + t β β + 2 γ α + β + t Αλλιώς β β div 2 α α mod 3 γ 0 Τέλος_αν Εμφάνισε α, β, γ Τέλος Κ Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθούν σαν είσοδος οι τιμές 10 και 20. Αλγόριθμος Κ38 Διάβασε x, y Για κ από 5 μέχρι 1 με_βήμα 2 x x y y Αν y > x τότε Εμφάνισε x + κ Αλλιώς Εμφάνισε y + κ Τέλος_αν Τέλος Κ Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθούν σαν είσοδος οι τιμές 5 και 10. Αλγόριθμος Κ38 Διάβασε β, α Για i από 1 μέχρι 3 α α

3 γ α ^ 2 δ β 2 Για i από 1 μέχρι 5 με_βήμα 2 α α + i β β 1 γ γ + δ δ α + β Εμφάνισε α, β, γ, δ Τέλος Κ Να σχηματίσετε τον πίνακα τιμών για τo παρακάτω τμήμα αλγορίθμου. Τί θα εκτυπωθεί τελικά; α 3 Για β από -5 μέχρι 0 με_βήμα 2 α α + β - 1 Εκτύπωσε α 5.74 Ποια είναι η τελική τιμή της μεταβλητής Μ μετά την εκτέλεση των παρακάτω εντολών; Μ 10 Για Κ από (Μ mod 100) μέχρι Μ * 2 με_βήμα 2 * Μ + 3 Μ Μ Δίνεται το παρακάτω τμήμα αλγορίθμου: Χ 5 Υ 3 Ζ 4 Για i από 5 μέχρι 1 με_βήμα 2 Αν Χ = Υ + Ζ τότε Χ Υ 1 Ζ Υ 1 αλλιώς Υ Υ 1 Ζ Ζ 1 Τέλος_αν 73

4 Εμφάνισε Χ, Υ, Ζ α) Ποιες οι τιμές των μεταβλητών Χ, Υ και Ζ που θα εμφανίσει; β) Αντί για Για i από 5 μέχρι 1 με_βήμα 2, θα μπορούσαμε να γράψουμε ισοδύναμα Για i από 1 μέχρι 3 ; 5.76 Να σχηματίσετε τον πίνακα τιμών του παρακάτω αλγορίθμου. Τι θα εκτυπωθεί τελικά; Αλγόριθμος Κ38 α 2 β 1 Όσο α >= β και α div 10 < 1 επανάλαβε α α ^ 2 Αν α div β > 2 τότε β β + 1 Αλλιώς α α + 1 Τέλος_αν Εκτύπωσε α, β Τέλος Κ Να σχηματίσετε τον πίνακα τιμών του παρακάτω αλγορίθμου. Τί θα εκτυπωθεί τελικά; Αλγόριθμος Κ38 α 321 β 7 Όσο α div 10 > 0 επανάλαβε α α div β Αν (β > α div 2) τότε β β * 3 Αλλιώς β β + 3 Τέλος_αν Εκτύπωσε α, β Τέλος Κ38 74

5 5.78 Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθούν σαν είσοδος οι αριθμοί 5 και 10. Αλγόριθμος Κ38 Διάβασε α, β γ α + 5 δ β mod 2 Όσο α < β και όχι β < 0 επανάλαβε α α + 1 β β 1 γ δ div 3 δ β * 2 Εμφάνισε α, β, γ + δ Τέλος Κ Να βρείτε τι θα τυπώσει το παρακάτω τμήμα προγράμματος για τις μεταβλητές x και y. x 2 y 3 ΌΣΟ y <= 17 ΕΠΑΝΑΛΑΒΕ x x + 2 y y + 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΌΣΟ x < 0 ΕΠΑΝΑΛΑΒΕ x x 1 y y + 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ x, y 5.80 Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθούν σαν είσοδος οι τιμές 100 και 200 και τις τιμές θα έχουν οι μεταβλητές α, β και γ στο τέλος του αλγορίθμου; Αλγόριθμος Κ38 Διάβασε α, β γ β mod 10 Όσο α 0 επανάλαβε Αν α = 10 τότε γ α mod 10 Αλλιώς 75

6 Αν α < 10 τότε γ α mod 90 Αλλιώς γ α mod 80 Τέλος_αν Τέλος_αν α α 25 Εμφάνισε α, β, γ Τέλος Κ Ποιες είναι οι τιμές των μεταβλητών y και z που θα εκτυπωθούν κατά την εκτέλεση του παρακάτω τμήματος αλγορίθμου; y 4 z 2 z z 1 y y + 1 Εκτύπωσε y, z Μέχρις_ότου z = 0 ή y = Τι θα εμφανίσει ο ακόλουθος αλγόριθμος αν δοθούν σαν είσοδος οι τιμές 10 και 20. Αλγόριθμος Κ38 Διάβασε x, y Αν x + y 0 τότε x 4 y 8 Τέλος_αν Αν y > 0 τότε Αν x < 0 τότε Εμφάνισε x Αλλιώς Εμφάνισε y Τέλος_αν Τέλος_αν 76

7 x x div 2 Μέχρις_ότου x < 5 Τέλος Κ Τι τιμές έχουν οι μεταβλητές x και y μετά τέλος του παρακάτω τμήματος προγράμματος για είσοδο α) το 0 και β) 5 ΔΙΑΒΑΣΕ x y 2 + (x + 1) div 4 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ x > y ΤΟΤΕ y y 1 x x 2 ΑΛΛΙΩΣ y y 2 x x + 1 ΤΕΛΟΣ_ΑΝ ΜΕΧΡΙΣ_ΟΤΟΥ x > y ΚΑΙ y < Να σχηματίσετε τον πίνακα τιμών του παρακάτω αλγορίθμου. Τί θα εκτυπωθεί τελικά; β 0 γ 2 Για i από 1 μέχρι 3 α 20 * i β β + α div 4 α γ + α Μέχρις_ότου (β > 20 * i) β (3 * α) div 2 γ α div γ Εμφάνισε α, β 5.85 Τι θα εμφανίσει ο ακόλουθος αλγόριθμος και οι τιμές θα έχουν οι μεταβλητές α και β μετά το τέλος του αλγορίθμου; Αλγόριθμος Κ38 Για i από 1 μέχρι 3 α 10 β 5 77

8 Αν α > 5 τότε Εμφάνισε α ^ 2 Αλλιώς Εμφάνισε α + 2 Τέλος_αν α α 2 Μέχρις_ότου α < β Τέλος Κ Μετά την εκτέλεση των παρακάτω εντολών τι τιμή αποκτάει η μεταβλητή Α; Α 0 Κ 30 Λ 50 Α Α + 1 Λ Λ 15 Μέχρις_ότου Λ < 30 Κ Κ + 12 Μέχρις_ότου Κ > Μετά την εκτέλεση των παρακάτω εντολών τι τιμή αποκτάει η μεταβλητή Α; Για Κ από 3 μέχρι 12 με_βήμα 4 Α 0 Για Λ από 23 μέχρι 12 με_βήμα 7 Α Α Δίνεται το παρακάτω τμήμα προγράμματος. 78

9 Α 0 Β 0 ΓΙΑ i ΑΠΟ 2 ΜΕΧΡΙ 14 ΜΕ_ΒΗΜΑ 3 Α Α + i ΑΝ Α < = 8 ΤΟΤΕ ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Α Β Β + 1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ Α, Β Να γίνει πίνακας στον οποίο να φαίνονται οι τιμές των μεταβλητών i, j, Α και Β μετά το τέλος κάθε εξωτερικής επανάληψης.τι θα εμφανιστεί στην οθόνη του υπολογιστή; 5.89 Τι θα εμφανίσει το παρακάτω σύνολο εντολών; Για κ από 3 μέχρι 9 με_βήμα 5 Για λ από 12 μέχρι 4 με_βήμα -7 Για μ από 20 μέχρι 31 με_βήμα 9 Εμφάνισε λ-μ+κ, λ+μ-κ Εμφάνισε κ+λ, κ-λ Εμφάνισε κ, λ, μ 5.90 Τι θα εκτυπώσει το ακόλουθο τμήμα προγράμματος. Χ 4 Υ 3 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ Χ Χ div 2 Υ Χ mod 4 ΓΡΑΨΕ Χ =, Χ, Υ =, Υ ΜΕΧΡΙΣ_ΟΤΟΥ Χ = 0 Ή Υ < > 1 79

10 Χ Χ 1 Υ Υ + 1 temp X X Y Y temp ΓΡΑΨΕ Χ =, Χ, Υ =, Υ ΜΕΧΡΙΣ_ΟΤΟΥ Υ = 1 Ή X mod 2 < > 0 X X * X mod 2 Y Y div 2 mod 3 ΓΡΑΨΕ Χ =, Χ, Υ =, Υ Χ 2 * Χ mod (Y + 1) * 2 Y X div (X 1) mod (X 1) ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ Χ =, Χ, Υ =, Υ Κατανόηση της δομής επανάληψης 5.91 Πόσες φορές θα εκτελεστεί η εντολή ΓΡΑΨΕ σε καθένα από τα παρακάτω τμήματα προγράμματος μετά την εκτέλεσή τους; α) i 0 s 0 ΌΣΟ i < > 3 ΕΠΑΝΑΛΑΒΕ s s + i i i + 2 ΓΡΑΨΕ ΚΑΛΗΜΕΡΑ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ γ) ΓΙΑ i ΑΠΟ 3 ΜΕΧΡΙ 2 ΓΙΑ κ ΑΠΟ 2 ΜΕΧΡΙ i ΓΡΑΨΕ ΚΑΛΗΜΕΡΑ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ β) i 0 s 0 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ s s + i i i + 2 ΓΡΑΨΕ ΚΑΛΗΜΕΡΑ ΜΕΧΡΙΣ_ΟΤΟΥ i = 3 δ) ΓΙΑ i ΑΠΟ 3 ΜΕΧΡΙ 2 ΓΙΑ κ ΑΠΟ 2 ΜΕΧΡΙ i ΓΡΑΨΕ ΚΑΛΗΜΕΡΑ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 80

11 ε) Α 10 ΌΣΟ Α < > 0 ΕΠΑΝΑΛΑΒΕ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3 Α Α 2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ΚΑΛΗΜΕΡΑ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ζ) ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3 ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 7 ΜΕ ΒΗΜΑ 2 ΓΡΑΨΕ i ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ ΚΑΛΗΜΕΡΑ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ στ) ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3 ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 7 ΜΕ ΒΗΜΑ 2 ΓΡΑΨΕ ΚΑΛΗΜΕΡΑ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ θ) ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 3 ΓΙΑ k ΑΠΟ 1 ΜΕΧΡΙ 3 ΓΙΑ d ΑΠΟ 1 ΜΕΧΡΙ k ΓΡΑΨΕ ΚΑΛΗΜΕΡΑ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 5.92 Ποια είναι η αρχική τιμή του Ψ, ώστε το διπλανό τμήμα αλγορίθμου να πραγματοποιήσει: α) 10 επαναλήψεις β) Καμία επανάληψη γ) 1 επανάληψη Κ Ψ Όσο Κ < 10 επανάλαβε Εμφάνισε Κ Κ Κ Δίνεται η δομή Για i από 1 μέχρι 10. Ποιες από τις παρακάτω θα εκτελέσουν το ίδιο πλήθος επαναλήψεων; (Περισσότερα από ένα σωστά.) α) Για i από 0 μέχρι 9 β) Για i από 0 μέχρι 10 με_βήμα 1 γ) Για i από 10 μέχρι 100 με_βήμα 10 δ) Για i από 0 μέχρι 100 με_βήμα 10 ε) Για i από 12 μέχρι 12 με_βήμα 2 στ) Για i από 50 μέχρι 50 με_βήμα Ποια πρέπει να είναι η τιμή του Α, ώστε το διπλανό τμήμα αλγορίθμου να πραγματοποιήσει: α) 10 επαναλήψεις β) Καμία επανάληψη γ) Άπειρες επαναλήψεις δ) 19 επαναλήψεις Για i από 10 μέχρι 1 με_βήμα Α Εμφάνισε i 81

12 5.95 Ποια πρέπει να είναι η τιμή του Α, ώστε το διπλανό τμήμα αλγορίθμου να πραγματοποιήσει: α) 3 επαναλήψεις β) Καμία επανάληψη δ) 7 επαναλήψεις Για i από A μέχρι -3 με_βήμα -2 Εμφάνισε i 5.96 Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου Α, Β θετικές ακέραιες σταθερές. Για i από A μέχρι Β με_βήμα -3 Εμφάνισε i α) Πόσες φορές θα εκτελεστεί η εντολή Εμφάνισε i αν B = A + 2. β) Ποια σχέση πρέπει να έχουν οι αριθμοί Α, Β έτσι ώστε η εντολή Εμφάνισε i να εκτελεστεί τουλάχιστον δύο (2) φορές Δίνεται το παρακάτω τμήμα αλγορίθμου, όπου Α θετική ακέραια σταθερά. κ 10 κ κ + Α Εμφάνισε κ Μέχρις_ότου κ > 20 Ποια θα πρέπει να είναι η μικρότερη τιμή του Α έτσι ώστε η εντολή Εμφάνισε κ να εκτελεστεί α) 3 επαναλήψεις β) 1 επανάληψη 5.98 Ποια πρέπει να είναι η τιμή του Α, ώστε το διπλανό τμήμα αλγορίθμου να πραγματοποιήσει: α) 5 επαναλήψεις β) Άπειρες επαναλήψεις γ) 1 επανάληψη x -10 x x * Μέχρις_ότου x <= A 5.99 Πόσες φορές θα εκτελεστούν οι παρακάτω επαναληπτικές δομές; κ 6 κ κ 2 Μέχρις_ότου κ 0 κ 6 Αρχη_επανάληψης κ κ 2 Μέχρις_ότου κ > 0 κ 1 κ κ 1 Μέχρις_ότου κ = 0 κ 0 κ κ + 1 Μέχρις_ότου κ < 0 82

13 5.100 Δίνεται η παρακάτω Για..από..μέχρι Για λ από Χ μέχρι Υ με_βήμα Ζ Εμφάνισε 'ΝΚ' Πόσες επαναλήψεις εκτελεί η Για..από..μέχρι αν: α) Χ = 5, Υ = 15, Ζ = -3 β) Χ = 21, Υ = 100, Ζ = 0 γ) Χ = 2010, Υ = 2010, Ζ = 1501 δ) Χ = 91, Υ = 91, Ζ = -91 ε) Χ = 2010, Υ = 2000, Ζ = 2 στ) Χ = 12, Υ = 91, Ζ = 8 ζ) Χ = 120, Υ = 20, Ζ = Πόσες φορές θα εκτελεστεί η εντολή Εμφάνισε Λ στο παρακάτω τμήμα αλγορίθμου; Σ 0 Για Κ από 2 μέχρι 120 με_βήμα 3 Διάβασε Χ Λ Α_Τ (Χ) Όσο Λ 0 επανάλαβε Εμφάνισε Λ Λ Λ Χ ^ Πόσες φορές θα εμφανιστεί η λέξη «καληνύχτα» στο παρακάτω τμήμα αλγορίθμου; x 3 Όσο x > 1 επανάλαβε x x 1 Εμφάνισε καληνύχτα Μέχρις_ότου x < 0 83

14 5.103 Στην εντολή Για Κ από Τ1 μέχρι Τ2 με_βήμα β Εντολές αν Τ1 Τ2 και β > 0, ποια είναι η σχέση της τελικής τιμής του Κ με το Τ Στην εντολή Για Κ από Τ1 μέχρι Τ2 με_βήμα β Εντολές αν Τ1 Τ2 και β > 0, ποια είναι η σχέση της τελικής τιμής του Κ με το Τ Για να τερματιστεί η εντολή Για Κ από Τ1 μέχρι Τ2 με_βήμα β Εντολές Πρέπει οι Εντολές να αυξάνουν ή να ελαττώνουν την τιμή του μετρητή Κ. Αυτή η πρόταση είναι σωστή; Πόσες φορές θα εκτελεστεί η εντολή Εμφάνισε ΒΟΤΣΗΣ στο παρακάτω τμήμα αλγορίθμου; Για Κ από 4 μέχρι 11 με_βήμα 3 Για Λ από 3 μέχρι 6 με_βήμα 2 Εμφάνισε ΒΟΤΣΗΣ Πόσες φορές θα εκτελεστεί η εντολή Εμφάνισε Α, Β. Α 10 Β 20 Β Β + Α Εμφάνισε Α, Β Μέχρις_ότου Β > 50 84

15 5.108 Να συμπληρώσετε τα κενά, έτσι ώστε οι παρακάτω βρόχοι να εκτελούνται από τέσσερις φορές. α) y 3 β) y 6 Όσο y > επανάλαβε Όσο y < 10 επανάλαβε y y 1 y y + γ) y 6 δ) y 2 Όσο y < 8 επανάλαβε Όσο y <> επανάλαβε y y + y y + 3 ε) y 5 στ) y 3 Όσο y <> 9 επανάλαβε Όσο y <= επανάλαβε y + y 2 * y Να συμπληρώσετε τα κενά, έτσι ώστε οι παρακάτω βρόχοι να εκτελούνται από τέσσερις φορές. α) y.. β) y 2 y y 2 y y.. Μέχρις_ότου y < 0 Μέχρις_ότου y = 0 γ) y 2 δ) y 2 y y + 3 y y.. Μέχρις_ότου y >.. Μέχρις_ότου y < Να συμπληρώσετε τα κενά, έτσι ώστε καθένας από τους παρακάτω βρόχους να εκτελείται από τέσσερις φορές. α) Για y από 1 μέχρι.. β) Για y από μέχρι 5 με_βήμα 2 w w * 2 Εκτύπωσε y γ) Για y από 0 μέχρι με_βήμα δ) Για y από 5 μέχρι. με_βήμα 0.1 Εκτύπωσε y Εκτύπωσε y 85

16 5.111 Να εξετάσετε αν τα παρακάτω τμήματα αλγορίθμου είναι ισοδύναμα: Χ 2 Χ 2 Υ 3 Για Υ από 3 μέχρι 0 με_βήμα -1 Οσο Υ <= 0 επανάλαβε Χ Χ + Υ Χ Χ + Υ Υ Υ - 1 Εμφάνισε Χ Εμφάνισε Χ Ποιο σύνολο εντολών είναι ισοδύναμο με το παρακάτω τμήμα αλγορίθμου; Γ 1 Για Κ από 120 μέχρι 4 με_βήμα 7 Γ Γ * Κ ^ 2 α) β) Γ 1 Γ 1 Κ 120 Κ 120 Όσο Κ 4 επανάλαβε Γ Γ * Κ ^ 2 Γ Γ * Κ ^ 2 Κ Κ 7 Κ Κ 7 Μέχρις_ότου Κ > 4 γ) δ) Γ 1 Γ 1 Κ 120 Κ 120 Όσο Κ 4 επανάλαβε Γ Γ * Κ ^ 2 Κ Κ 7 Κ Κ 7 Γ Γ * Κ ^ 2 Μέχρις_ότου Κ < Ποιο σύνολο εντολών είναι ισοδύναμο με το παρακάτω τμήμα αλγορίθμου; Για x από 3 μέχρι 5 Εμφάνισε x 86

17 α) x 3 β) x 3 Όσο x < 5 επανάλαβε Όσο x < 5 επανάλαβε Εμφάνισε x x x + 1 x x + 1 Εμφάνισε x γ) x 3 δ) x 3 Όσο x < = 5 επανάλαβε Εμφάνισε x Εμφάνισε x x x + 1 x x + 1 Μέχρις_ότου x > Ποια σύνολα εντολών είναι ισοδύναμα με το παρακάτω τμήμα αλγορίθμου; Α 1 Για i από 1 μέχρι 10 με_βήμα 2 Α Α * i α) Α 0 β) Α 1 i 1 i 1 Όσο i < = 10 επανάλαβε Όσο i < = 10 επανάλαβε i i + 2 A A * i A A * i i i + 2 γ) Α 1 δ) Α 1 i 1 i 1 A A * i A A * i i i + 2 i i + 2 Μέχρις_ότου i < 10 Μέχρις_ότου i = 10 ε) Α 1 στ) Α 1 i 1 i 1 A A * i i i + 2 i i + 2 A A * i Μέχρις_ότου i > 10 Μέχρις_ότου i > 10 87

18 5.115 Δίνεται το παρακάτω τμήμα αλγορίθμου da 0 dp 0 Για i από a μέχρι 4 με_βήμα 2 Αν i mod 2=0 τότε da da + 1 αλλιώς dp dp + 1 Τέλος_αν αν το αποτέλεσμα είναι da=0 και dp=3, τότε ποια τιμή θα μπορούσε να έχει το a; Περιγράψτε τι κάνει το παρακάτω τμήμα αλγορίθμου. s 0 p 0 Διάβασε a Όσο a > 0 επανάλαβε Αν a mod 2=1 τότε s s + a αλλιώς p p * a Τέλος_αν Διάβασε a Περιγράψτε τι κάνει το παρακάτω τμήμα αλγορίθμου. Σ 0 Για i από 100 μέχρι 999 με_βήμα 2 Σ Σ + i Ποιά είναι η εκφώνηση του προβλήματος που επιλύει ο παρακάτω αλγόριθμος; 88

19 Αλγόριθμος Κ38 ζ 1 Διάβασε υ Αν υ > 20 τότε ζ ζ*υ Τέλος_αν Εμφάνισε Υπάρχουν άλλα δεδομένα; Διάβασε β Μέχρις_ότου β = ΟΧΙ Εμφάνισε ζ Τέλος Κ Ποιά είναι η εκφώνηση του προβλήματος που επιλύει ο παρακάτω αλγόριθμος; Αλγόριθμος Κ38 χ 0 υ 0 Για κ από 1 μέχρι 120 Διάβασε α Αν α mod 3 = 0 τότε χ χ+1 αλλιώς υ υ+1 Τέλος_αν ζ 100*υ/120 Αποτελέσματα // χ, ζ // Τέλος Κ Ποιά λειτουργία επιτελεί το παρακάτω τμήμα αλγορίθμου; Διάβασε Ν Μέχρις_ότου (Ν < 0 ή Ν mod 7 = 0) και Ν > 0 89

20 5.121 Ποιο αποτέλεσμα Σ υπολογίζει το παρακάτω σύνολο εντολών; Σ 0 Διάβασε Χ Μέχρις_ότου Χ > 0 Ή Χ = 1111 Αν Χ 1111 τότε Σ Σ + Χ ^ 2 Τέλος_αν Μέχρις_ότου Χ = S1 0 S2 0 X 0 Όσο Χ<=10 επανέλαβε Αν Χ mod 3 =0 τότε S1 S1+X Αλλιώς S2 S2+X Τέλος_αν X X+1 α) Περιγράψτε τί κάνει το παραπάνω κομμάτι. β) Τί θα συνέβαινε αν παραλείπαμε την εντολή X X+1; γ) Τί θα συνέβαινε αν βάζαμε την εντολή X X+1 στο τμήμα αλλιώς; Περιγράψτε τι κάνει το παρακάτω τμήμα αλγορίθμου. Διάβασε Ν Μ Α_Τ (Ν) Σ 0 Όσο Σ Μ επανάλαβε Διάβασε Χ Σ Σ + Χ 90

21 5.124 Ποιο από τα παρακάτω σύνολα εντολών υπολογίζει το γινόμενο Γ =14. α) β) Γ 1 Γ 1 Κ 14 Κ 199 Όσο Κ < 199 επανάλαβε Όσο Κ 14 επανάλαβε Γ Γ * Κ Γ Γ * Κ Κ Κ + 3 Κ Κ 3 γ) δ) Γ 1 Γ 1 Κ 14 Κ 199 Όσο Κ < 201 επανάλαβε Όσο Κ 14 επανάλαβε Κ Κ + 3 Κ Κ 3 Γ Γ * Κ Γ Γ * Κ Ποιο από τα παρακάτω σύνολα εντολών διαβάζει μία ακέραια τιμή Ν, τέτοια ώστε να είναι θετική και πολλαπλάσιο των αριθμών 4 και 6; α) Διάβασε Ν Όσο Ν 0 Ή Ν mod 4 = 0 Ή Ν mod 6 = 0 επανάλαβε Διάβασε Ν β) Ν 8 Όσο Ν 0 Ή Ν mod 4 Διάβασε Ν 0 Ή Ν mod 6 0 επανάλαβε γ) Διάβασε Ν Όσο Ν 0 ΚΑΙ Ν mod 4 0 ΚΑΙ Ν mod 6 Διάβασε Ν 0 επανάλαβε δ) Διάβασε Ν Όσο Ν > 0 Ή Ν mod 4 = 0 Ή Ν mod 6 = 0 επανάλαβε Διάβασε Ν 91

22 5.126 Ποιά είναι η εκφώνηση του προβλήματος που επιλύει το παρακάτω πρόγραμμα; ΠΡΟΓΡΑΜΜΑ Κ38 ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: Χ, σ, Υ ΑΚΕΡΑΙΕΣ: φ, πληθ ΑΡΧΗ φ 0 πληθ 0 σ 0 ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΔΙΑΒΑΣΕ Χ ΑΝ Χ > 0 ΤΟΤΕ πληθ πληθ+1 σ σ+χ ΑΝ Χ < 50.3 ΤΟΤΕ φ φ+1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΑΝ ΜΕΧΡΙΣ_ΟΤΟΥ Χ <= 0 ΑΝ πληθ > 0 ΤΟΤΕ Υ 100*φ/πληθ ΓΡΑΨΕ σ, Υ ΑΛΛΙΩΣ ΓΡΑΨΕ 'Δε δόθηκαν δεδομένα' ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Να βρείτε τα λάθη στα παρακάτω τμήματα αλγορίθμου. α) α 0 β) Διάβασε β Για i από 8 μέχρι 8 με_βήμα 2 Για i από 1 μέχρι 5 με_βήμα β α α + 1 / i α α + i ^ 2 Εκτύπωσε α 92

23 5.128 Για τον υπολογισμό του αθροίσματος στη μεταβλητή S τα παρακάτω τμήματα αλγορίθμου είναι σωστά; Αν όχι, γιατί; α) S 0 β) S 1 M 1 M 1 Όσο Μ <= 99 επαναλάβε Όσο Μ <= 99 επανάλαβε Μ Μ + 2 Μ Μ + 2 S S + M S S + Μ γ) i 0 δ) i 1 S 0 S 0 Όσο i < 100 επανάλαβε Όσο i < 99 επανάλαβε S S + (i + 1) i i +2 i i + 2 S S + i Για την υπολογισμό του αθροίσματος: στη μεταβλητή S, τα παρακάτω τμήματα αλγορίθμου είναι σωστά; α) S 0 β) S 1 M 1 M 1 S S + M M M + 2 M M + 2 S S + M Μέχρις_ότου Μ > = 99 Μέχρις_ότου Μ = 99 γ. S 0 δ) S 0 M 2 M 1 S S + (M 1) S S + M M M + 2 M M + 2 Μέχρις_ότου Μ > = 99 Μέχρις_ότου Μ <= Ο παρακάτω αλγόριθμος έχει λάθη. Να προτείνετε διορθώσεις ώστε να λειτουργεί σωστά. 93

24 Αλγόριθμος Κ38 άθροισμα 0 Διάβασε αριθμός Όσο αριθμός > 0 επανάλαβε άθροισμα άθροισμα + αριθμός πλήθος πλήθος + 1 μέσος άθροισμα / πλήθος Εκτύπωσε μέσος Τέλος Κ Διαβάστε προσεκτικά τα παρακάτω τμήματα αλγορίθμων. Ποια είναι τα λάθη; Να τα διορθώσετε ώστε να λειτουργούν σωστά. α) Διάβασε μισθός β) Όσο μισθός <> 0 επανάλαβε άθροισμα 0 άθροισμα 0 Αν μισθός > μέγιστος τότε Αν μισθός > μέγιστος τότε μέγιστος μισθός μέγιστος μισθός Τέλος_αν Τέλος_αν Αν μισθός < ελάχιστος τότε Αν μισθός < ελάχιστος τότε ελάχιστος μισθός ελάχιστος μισθός Τέλος_αν Τέλος_αν άθροισμα άθροισμα + μισθός άθροισμα άθροισμα + μισθός Διάβασε μισθός Μέχρις_ότου μισθός <> Να βρείτε τα λάθη στα παρακάτω τμήματα αλγορίθμου: α) Για i από 10 μέχρι 2 με_βήμα 3 β) S 0 Για i από1 μέχρι 4 Για i από 3 μέχρι 3 β i ^ 2 5 Για j από 10 μέχρι 20 με_βήμα i Εκτύπωσε β S S + 1 Εκτύπωσε S 94

25 5.133 Να βρείτε τα λάθη στον παρακάτω κώδικα y 0 i 3 Όσο i <= 100 επανάλαβε Διάβασε x Αν x>= 3 τότε y y + x ^ 2 + x mod 7 Τέλος_αν Εμφάνισε y Ποιο κριτήριο δεν ικανοποιεί το παρακάτω τμήμα εντολών και γιατί; Σ 0 Διάβασε Χ Σ Σ + Τ_Ρ (Χ) Μέχρις_ότου Σ > 1000 Εμφάνισε Σ Ποιο κριτήριο δεν ικανοποιεί το παρακάτω τμήμα εντολών και γιατί; Α 10 Για i από 1 μέχρι 3 Α Α 10 Μέχρις_ότου Α = Ποιο κριτήριο δεν ικανοποιεί το παρακάτω τμήμα εντολών και γιατί; Α 0 Διάβασε Χ Όσο Τ_Ρ (Χ) + 3 < 19 επανάλαβε Α Α + Χ Διάβασε Χ Εμφάνισε Α 95

26 5.137 Ποιο κριτήριο δεν ικανοποιεί το παρακάτω τμήμα εντολών και γιατί; Διάβασε α, β α α/(β 1) β β + 1 Μέχρις_ότου α <= β Εμφάνισε α Ποιο κριτήριο δεν ικανοποιεί το παρακάτω τμήμα εντολών και γιατί; S 0 Για Ι από 2 μέχρι 10 με_βήμα 0 S S + Ι Εμφάνισε S Ποιο κριτήριο δεν ικανοποιεί το παρακάτω τμήμα εντολών και γιατί; Διάβασε Χ Χ Χ 1 Εμφάνισε Χ Μέχρις_ότου Α_Τ (Χ) < Χ Ποιο κριτήριο δεν ικανοποιεί το παρακάτω τμήμα εντολών και γιατί; x 5 y 0 x x +2 Αν x mod 2 = 0 τότε y y + 5 Αλλιώς y y 5 Τέλος_αν Μέχρις_ότου y > 2 96

27 5.141 Αν το περιεχόμενο της μεταβλητής Χ είναι απροσδιόριστο ποιο κριτήριο δεν ικανοποιεί το παρακάτω τμήμα εντολών; Γ 1 Για Κ από 1 μέχρι 100 Γ Γ * Χ Εμφάνισε Γ Να τοποθετήσετε τις παρακάτω εντολές στην ορθή σειρά. Ο παρακάτω αλγόριθμος πρέπει να υπολογίζει και να εμφανίζει το άθροισμα των θετικών διψήφιων άρτιων ακεραίων. Αλγόριθμος Κ38 α α + i i 8 Εμφάνισε α i i + 2 α 0 Όσο i < 97 επανάλαβε Τέλος Κ Δίνονται οι παρακάτω εντολές αλγορίθμου: S S + X Διάβασε Χ Όσο Χ div ΚΑΙ Χ div 100 < > 0 επανάλαβε Τέλος Κ38 Διάβασε Χ S 0 Αλγόριθμος Κ38 Εμφάνισε Το άθροισμα των τριψήφιων αριθμών είναι:, S α) Να διαταχθούν οι εντολές του παραπάνω αλγορίθμου στη σωστή σειρά. β) Ποια ακριβώς είναι η λειτουργία του παραπάνω αλγορίθμου; γ) Τι θα εμφανιστεί στην οθόνη του υπολογιστή αν δοθούν ωε δεδομένα στον παραπάνω αλγόριθμο με τη σειρά οι αριθμοί 200, 150, 480, 750, και 1100; Να τοποθετήσετε τις διπλανές εντολές στην ορθή σειρά. Το παρακάτω τμήμα αλγορίθμου πρέπει να διαβάζει την απάντηση του χρήστη, μέχρι να δοθεί Ν ή Ο. 97

28 Μέχρις_ότου απάντ = Ν ή απάντ = Ο Διάβασε απάντ Εμφάνισε Δώσε απάντηση Μετατροπές στην δομή επανάληψης Να μετατρέψετε τα παρακάτω τμήματα αλγορίθμων έτσι, ώστε να χρησιμοποιείται η επαναληπτική δομή όσο.επανάλαβε. α) x 2 β) x 2 Για y από 1 μέχρι 5 Για y από 1 μέχρι 4 με βήμα 3 x x + 3 x x 2 γ) x 2 δ) x -2 Για y από 5 μέχρι 5 με βήμα -2 Για y από 3 μέχρι 1 με βήμα -1 x x + 2 x x Να γράψετε το παρακάτω τμήμα αλγορίθμου χρησιμοποιώντας τη δομή επανάληψης Μέχρις_ότου και τη δομή επανάληψης Όσο επανάλαβε. α 5 Για i από 0 μέχρι 20 με_βήμα 3 β i^2 α α + β Εκτύπωσε i, β Να μετατρέψετε το παρακάτω τμήμα αλγορίθμων έτσι, ώστε να χρησιμοποιείται η επαναληπτική δομή όσο.επανάλαβε. neg 0 big 0 Διάβασε x 98

29 β 0 α Για i από 1 μέχρι 99 Διάβασε x Αν x < β τότε neg neg +1 Τέλος_αν Δίνεται το παρακάτω τμήμα αλγορίθμου: Για i από 20 μέχρι 1 με_βήμα 2 Εντολές α) Πόσες επαναλήψεις θα εκτελεστούν; β) Να γραφεί ισοδύναμο τμήμα αλγορίθμου χρησιμοποιώντας την επαναληπτική δομή Όσο επανάλαβε. γ) Να γραφεί ισοδύναμο τμήμα αλγορίθμου χρησιμοποιώντας την επαναληπτική δομή Μέχρις_ότου Να γράψετε τον παρακάτω τμήμα αλγορίθμου χρησιμοποιώντας τη δομή επανάληψης Μέχρις_ότου και τη δομή επανάληψης Για...από...μέχρι. Χ 2 Όσο Χ >= 1 επανάλαβε Χ Χ 2 Εκτύπωσε Χ Δίνεται το παρακάτω τμήμα αλγορίθμου: Χ 1 Όσο Χ < 100 επανάλαβε Εντολές Χ Χ + 1 Να ξαναγραφεί χρησιμοποιώντας την επαναληπτική δομή Για από μέχρι. 99

30 5.151 Να μετατρέψετε τα παρακάτω τμήματα αλγορίθμων έτσι, ώστε να χρησιμοποιείται η επαναληπτική δομή για από.μέχρι. α) y 0 β) y -7 x 1 x 0 Όσο x < 35 επανάλαβε Όσο y <> 3 επανάλαβε x x+1 x x 2 * y + 4 y y + x y y + 2 γ) x 5 δ) y 1 y 1 x 3 Όσο x < 2500 επανάλαβε Όσο x > - 6 επανάλαβε y y + 3 y y ^ 2 x x+y x x -2 y y * x x w 3 + y Να γραφεί το παρακάτω τμήμα αλγορίθμου χρησιμοποιώντας τη δομή για...από...μέχρι. Χ 3, Ψ -5 Όσο Χ < = 10 επανάλαβε Α Ψ * 3-3 Χ X + 6 Β Α - (Χ+1) / Να γραφεί το παρακάτω τμήμα αλγορίθμου χρησιμοποιώντας την δομή Όσο επανάλαβε. x 3 y x + 5 Διάβασε κ Αν y mod 3 = 0 τότε x κ ^ 2 Τέλος_αν y y + 3 Μέχρις_ότου y > = 30 ή κ <> 0 100

31 5.154 Να μετατραπούν οι ακόλουθοι αλγόριθμοι σε ισοδύναμους αλγορίθμους χρησιμοποιώντας τη δομή επανάληψης Μέχρις_ότου. α) Αλγόριθμος Α1 α 5 Όσο α >= 1 επανάλαβε Εμφάνισε α ^ 2 α α 2 Τέλος Α1 β) Αλγόριθμος Α2 α 1 Όσο α < 6 και α >= 1 επανάλαβε β α 2 α α + 2 Εμφάνισε α, β Τέλος Α2 γ) Αλγόριθμος Α3 άθροισμα 0 α 100 Όσο α > 200 επανάλαβε άθροισμα άθροισμα + α Εμφάνισε α α α 10 Εμφάνισε άθροισμα Τέλος Α3 δ) Αλγόριθμος Α4 πλήθος 0 α 200 Όσο α <= 500 ή α = 505 επανάλαβε πλήθος πλήθος + 1 α α + 50 Εμφάνισε πλήθος Τέλος Α Να γραφεί το παρακάτω τμήμα αλγορίθμου χρησιμοποιώντας την δομή Όσο επανάλαβε. Κ 3 Λ 8 Κ Κ * 2 Λ Λ + 3 Χ Κ 2*Λ Μέχρις_ότου Λ > = Να γραφεί το τμήμα αλγορίθμου της προηγούμενης άσκησης χρησιμοποιώντας την δομή για...από...μέχρι. 101

32 5.157 Να γραφεί το παρακάτω τμήμα αλγορίθμου χρησιμοποιώντας τη δομή μέχρις_ότου. ν -2 Για x από -7 μέχρι -25 με βήμα -4 μ ν * Δίνεται το παρακάτω τμήμα αλγορίθμου. Να μετατραπεί στις ισοδύναμες μορφές επανάληψης Όσο επανάλαβε και Για από μέχρι. Διάβασε Α Ι 1 Αν Α MOD 2 = 1 τότε A A DIV 3 Αλλιώς A A DIV 4 Τέλος_αν Ι Ι + 2 Μέχρις_ότου Ι >= Να συμπληρώσετε τον παρακάτω πίνακα: Όσο επανάλαβε Μέχρις_ότου Για... από... μέχρι α 2 Όσο α > 0 επανάλαβε Εκτύπωσε α α α 2 i 5 α 1 α α * i i i + 1 Μέχρις_ότου i > 0 α 1 Για i από 7 μέχρι 2 α α * α Εκτύπωσε α 102

33 5.160 Να μετατραπεί η παρακάτω δομή για.από..μέχρι στην επανάληπτική δομή μέχρις_ότου. Διάβασε α Για κ από1 μέχρι α με_βήμα 2 Εμφάνισε κ Να μετατραπεί το παρακάτω τμήμα αλγορίθμου, έτσι ώστε να χρησιμοποιεί τη δομή όσο επανάλαβε. y 14 Διάβασε x y y + x Μέχρις_ότου y > x και x >= Να γραφεί το παρακάτω τμήμα αλγορίθμου χρησιμοποιώντας τη δομή μέχρις_ότου. Χ 10, Ψ 2 Όσο Χ < = Α επανάλαβε Β Ψ * 3 Χ X Να γράψετε ξανά τα επόμενα τμήματα χρησιμοποιώντας την επαναληπτική δομή όσο..επανάλαβε α) w 20 β) Διάβασε κ Διάβασε x Σ 0 w w 1 Σ Σ + κ x x + w Διάβασε κ Μέχρις_ότου x > w Μέχρις_ότου κ = α) Ποια η λειτουργία του παρακάτω τμήματος προγράμματος; β) Να μετατρέψετε το παρακάτω τμήμα προγράμματος σε ισοδύναμο με χρήση της εντολής μέχρις_ότου. Να θεωρήσετε ότι το x είναι ακέραιος αριθμός. 103

34 κ 1 s 1 γ 1 ΔΙΑΒΑΣΕ x ΌΣΟ κ <= 1000 ΚΑΙ x <> 0 ΕΠΑΝΑΛΑΒΕ ΑΝ x mod 2 = 0 ΤΟΤΕ s s + x ΤΕΛΟΣ_ΑΝ ΑΝ x mod 3 = 0 ΤΟΤΕ γ γ * x ΤΕΛΟΣ_ΑΝ κ κ +1 ΔΙΑΒΑΣΕ x ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ s, γ Να γράψετε ξανά τα επόμενα τμήματα χρησιμοποιώντας την επαναληπτική δομή μέχρις_ότου. α) Διάβασε x β) Διάβασε x Όσο x < 0 ή x > 100 επανάλαβε Όσο x <> 0 επανάλαβε Διάβασε x Αν x > 0 τότε πλ πλ + 1 Τέλος_αν Διάβασε x Δίνεται το παρακάτω τμήμα αλγορίθμου: Για i από 1 μέχρι 20 Για j από 10 μέχρι 1 με_βήμα 2 Για k από 3 μέχρι 8 με_βήμα 3 Εντολές 104

35 α) Πόσες φορές θα εκτελεστούν οι εντολές; β) Να γραφεί ισοδύναμο τμήμα αλγορίθμου χρησιμοποιώντας την επαναληπτική δομή Όσο επανάλαβε. γ) Να γραφεί ισοδύναμο τμήμα αλγορίθμου χρησιμοποιώντας την επαναληπτική δομή Μέχρις_ότου Δίνεται το παρακάτω τμήμα αλγορίθμου. Να μετατρέψετε το τμήμα σε ισοδύναμο με την χρήση της δομής ΜΕΧΡΙΣ_ΟΤΟΥ. Β 10 ΓΡΑΨΕ Β ΟΣΟ Β > 0 ΕΠΑΝΕΛΑΒΕ ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10 ΜΕ_ΒΗΜΑ 2 Β Β-1 ΓΡΑΨΕ Β ΤΕΛΟΣ _ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ Β ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ Β Δίνεται το παρακάτω σύνολο εντολών. Να γραφεί ισοδύναμο τμήμα αλγορίθμου χρησιμοποιώντας την επαναληπτική δομή Όσο επανάλαβε. Διάβασε Ζ Μέχρις_ότου Ζ > 9 Διάβασε Υ Μέχρις_ότου Υ > 0 Διάβασε Χ Μέχρις_ότου Χ > Το παρακάτω σύνολο εντολών Α 0 Για Κ από 4 μέχρι 22 με_βήμα 2 Για Λ από Κ μέχρι Κ + 1 Α Α + Τ_Ρ (Κ) 105

36 μπορεί να γραφεί ισοδύναμα ως εξής: Α 0 Κ. Όσο Κ.. 22 επανέλαβε Α Α + Τ_Ρ (Κ) + Κ + Να συμπληρώσετε τα κενά Δίνεται το παρακάτω πρόγραμμα. ΠΡΟΓΡΑΜΜΑ Κ38 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Ι ΑΡΧΗ ΔΙΑΒΑΣΕ Χ ΑΝ Χ MOD 3 = 1 ΤΟΤΕ ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 5 Χ Χ + 4 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΛΛΙΩΣ ΓΙΑ Ι ΑΠΟ 9 ΜΕΧΡΙ 0 ΜΕ_ΒΗΜΑ 3 Χ Χ + Ι ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Κ38 Να γραφεί ισοδύναμο πρόγραμμα χωρίς τη χρήση επαναληπτικών δομών. Ασκήσεις με γνωστό αριθμό επαναλήψεων Να αναπτύξετε αλγόριθμο ο οποίος θα εκτυπώνει τους ακέραιους αριθμούς από 5 έως Να αναπτύξετε αλγόριθμο ο οποίος θα εκτυπώνει τους ακέραιους αριθμούς από 2 έως

37 5.173 Να αναπτύξετε αλγόριθμο ο οποίος θα εκτυπώνει τους ακέραιους αριθμούς από 0 έως 300, εκτός των αριθμών 100 και Να αναπτύξετε αλγόριθμο ο οποίος θα υπολογίζει και θα εκτυπώνει το άθροισμα των ακεραίων αριθμών από Να γράψετε αλγόριθμο ο οποίος θα υπολογίζει και θα εκτυπώνει το συνολικό άθροισμα των ακέραιων αριθμών από 10 μέχρι 20 και των ακεραίων από 90 μέχρι Να αναπτυχθεί αλγόριθμος που θα εκτυπώνει όλους τους τριψήφιους αριθμούς που έχουν όλα τους τα ψηφία περιττά (για παράδειγμα οι αριθμοί 157, 399, 911) Να αναπτυχθεί αλγόριθμος που θα εκτυπώνει όλους τους τετραψήφιους αριθμούς που έχουν ανά δυο τα ψηφία τους ίσα (για παράδειγμα οι αριθμοί 1212, 3939, 6868) Να γράψετε αλγόριθμο ο οποίος θα υπολογίζει και εμφανίζει το άθροισμα των πολλαπλασίων του 3 από 3 μέχρι Να γράψετε αλγόριθμο ο οποίος θα εκτυπώνει τους αριθμούς από 0 μέχρι 5 με βήμα 0, Να γραφεί αλγόριθμος που να υπολογίζει πόσα οχτάρια περιέχονται σε όλους τους ακέραιους αριθμούς από το 1 ως το Μόλις έχουν ανακοινωθεί δημοτικές εκλογές. Στο δημαρχείο του δήμου σας θέλουν να ελέγξουν αν 250 νέοι κάτοικοι του δήμου έχουν δικαίωμα να λάβουν εκλογικό βιβλιάριο. Επίσης, το δημαρχείο θέλει να κρατάει κάποια στατιστικά στοιχεία σχετικά με το ποσοστό έκδοσης εκλογικού βιβλιαρίου στο σύνολο των νέων δημοτών. Να αναπτύξετε αλγόριθμο ο οποίος θα βοηθήσει του υπεύθυνους του δημαρχείου να εκτελέσουν τον παραπάνω έλεγχο για τους 250 νέους κατοίκους. α) Αρχικά, ο αλγόριθμος θα διαβάζει το τρέχον έτος και το έτος γέννησης του πολίτη. β) Σε περίπτωση που ο πολίτης είναι μεγαλύτερος από 18, ο αλγόριθμος θα εκτυπώνει το μήνυμα "Δικαίωμα Έκδοσης Εκλογικού Βιβλιαρίου", αλλιώς ο αλγόριθμος θα εκτυπώνει σε πόσα χρόνια έχει δικαίωμα να λάβει εκλογικό βιβλιάριο, γ) Όταν ολοκληρωθεί ο έλεγχος για όλους τους πολίτες, ο αλγόριθμος θα εκτυπώνει τα μηνύματα: Αριθμός εκλογικών βιβλιαρίων και τον αριθμό των εκλογικών βιβλιαρίων. Ποσοστό έκδοσης και το ποσοστό έκδοσης Η χρέωση των ΙΧ αυτοκινήτων που μετακινούνται μ ένα οχηματαγωγό πλοίο είναι ανάλογη του μήκους τους ως εξής : έως και 2 μέτρα είναι 3, έως και 3 μέτρα είναι 6 και για παραπάνω από 3 μέτρα είναι 9. Να γίνει αλγόριθμος που θα διαβάζει τα μήκη 10 αυτοκινήτων που μετακινήθηκαν μ ένα οχηματαγωγό πλοίο και να υπολογίζει και εμφανίζει το συνολικό ποσό είσπραξης. 107

38 5.183 Σύμφωνα με το νέο φορολογικό νόμο ο συντελεστής φόρου για τους ιδιώτες φορολογούμενους απεικονίζεται στον παρακάτω πίνακα (κλιμακωτός υπολογισμός): Εισόδημα (σε ) Συντελεστής % Μέχρι και άνω 18 Ταυτόχρονα, υπάρχουν φοροελαφρύνσεις ανάλογα με τον αριθμό των παιδιών του φορολογούμενου, σύμφωνα με τον ακόλουθο πίνακα: αριθμός παιδιών Ποσό έκπτωσης ανά παιδί 4 και άνω 1800 Να γραφεί αλγόριθμος που για κάθε έναν από τους Έλληνες φορολογούμενους θα διαβάζει το όνομα, το εισόδημα που δήλωσε στην εφορία και το πλήθος παιδιών του και θα υπολογίζει και θα εκτυπώνει το φόρο που πρέπει να πληρωθεί. Ο αλγόριθμος θα εμφανίζει και το συνολικό ποσό που θα εισπράξει η εφορία τη φετινή χρονιά Οι υπάλληλοι μίας εταιρείας συμφώνησαν για το μήνα Δεκέμβριο να κρατηθούν από το μισθό τους δύο ποσά, ένα για την ενίσχυση του παιδικού χωριού SOS και ένα για την ενίσχυση των σκοπών της UNICEF. Ο υπολογισμός του ποσού των εισφορών εξαρτάται από τον αρχικό μισθό του κάθε υπαλλήλου και υπολογίζεται με βάση τα παρακάτω όρια μισθών: Μισθός ( ) Εισφορά % SOS Εισφορά % UNICEF Έως Μεγαλύτερο από Να γραφεί αλγόριθμος που να διαβάζει για τους 500 υπαλλήλους της εταιρείας το όνομα και τον μισθό τους και να εκτυπώνει το καθαρό ποσό που θα πάρει ο κάθε ένας ως μισθό τον μήνα Δεκέμβριο. Ο αλγόριθμος πρέπει επίσης τελικά να εκτυπώνει το συνολικό ποσό που θα δοθεί στο χωριό SOS καθώς και το ποσό που θα δοθεί στη UNICEF Η εταιρεία ΧΨΡΤΣ είναι εισηγμένη στο χρηματιστήριο και πρέπει να αποδώσει μέρισμα από τα κέρδη των μετοχών της στους μετόχους. Κάθε μέτοχος θα εισπράξει μέρισμα σύμφωνα με τον παρακάτω πίνακα 108

39 Πλήθος μετοχών % ποσοστό επί των κερδών Να αναπτύξετε αλγόριθμο που με δεδομένα τα κέρδη της εταιρείας, θα διαβάζει για τους μετόχους το πλήθος των μετοχών που έχουν και θα εκτυπώνει για κάθε έναν το μέρισμά τους καθώς και το συνολικό ποσό που θα αποδοθεί σε μερίσματα Ο κύκλος σπουδών μιας σχολής πληροφορικής αποτελείται από 50 μαθήματα και την εκπόνηση μιας διπλωματικής εργασίας. Ο βαθμός πτυχίου ενός αποφοίτου προκύπτει από το μέσο όρο των μαθημάτων επί τον συντελεστή 0,8 συν το βαθμό της διπλωματικής εργασίας επί τον συντελεστή 0,2. Με βάση αυτό το βαθμό, αναγράφεται στο πτυχίο ένας από τους ακόλουθους χαρακτηρισμούς: ΑΡΙΣΤΑ, αν 9 βαθμός 10 ΛΙΑΝ ΚΑΛΩΣ, αν 7 βαθμός < 9 ΚΑΛΩΣ, αν 5 βαθμός < 7. Να γράψετε αλγόριθμο ο οποίος: Διαβάζει τους βαθμούς ενός αποφοίτου στα 50 αυτά μαθήματα. Διαβάζει το βαθμό που πήρε στη διπλωματική του εργασία. Υπολογίζει κι εμφανίζει το μέσο όρο μαθημάτων. Υπολογίζει κι εμφανίζει το βαθμό πτυχίου. Εμφανίζει μήνυμα με τον κατάλληλο χαρακτηρισμό. (Σημείωση: Να θεωρήσετε ότι όλοι οι βαθμοί ανήκουν στο διάστημα [5, 10] ) Να γίνει πρόγραμμα που υπολογίζει και εκτυπώνει το πλήθος των μαθητών μιας τάξης είκοσι ατόμων οι οποίοι προβιβάστηκαν στην επόμενη τάξη. Για να προβιβαστούν οι μαθητές πρέπει: α) ο βαθμός τους να είναι πάνω από 8 και στα 4 μαθήματα που παρακολουθούν και β) ο μέσος όρος βαθμολογίας τους στα 4 μαθήματα που παρακολουθούν να είναι >=10. Το πρόγραμμα διαβάζει τους βαθμούς των μαθητών Σε ένα σχολείο της Ευρωπαϊκής Ένωσης η κατανομή των μαθητών σε τάξεις αγγλικών γίνεται με βάση την αξιολόγηση που τους έχει γίνει. Έτσι, αν ο μαθητής έχει αξιολογηθεί με Α πάει στο τμήμα 1, αν έχει αξιολογηθεί με Β πάει στο τμήμα 2, αν έχει αξιολογηθεί με C ή D πάει στο τμήμα 3, ενώ αν αξιολογηθεί με F δεν γίνεται δεκτός. Να γράψετε αλγόριθμο ο οποίος θα διαβάζει την αξιολόγηση για κάθε έναν από τους 120 μαθητές, θα τους κατανείμει στα αγγλικά και θα εκτυπώνει το πλήθος των μαθητών που έγιναν δεκτοί σε κάθε κατηγορία και το πλήθος των μαθητών του δεν έγιναν δεκτοί Σε ένα μικρό χωριό στις δημοτικές εκλογές ψήφισαν 200 ενώ ήταν εγγεγραμμένοι 233 άνθρωποι. Στη ψηφοφορία συμμετείχαν 4 κόμματα, τα ΚΑ, ΚΒ, ΚΓ, και ΚΔ. Να γίνει πρόγραμμα που να διαβάζει τις ψήφους των πολιτών και να υπολογίζει να τυπώνει το ποσοστό που έλαβε το κάθε κόμμα και το ποσοστό της αποχής. Οι ψήφοι θα δίνονται ως γράμματα Α, Β, Γ, Δ και θα αντιστοιχούν στα κόμματα ΚΑ, ΚΒ, ΚΓ και ΚΔ. 109

40 5.190 Ένα videoclub νοικιάζει στους πελάτες του βιντεοκασέτες τύπου VHS (κωδικός =1) και ταινίες σε DVD (κωδικός=2). Η ελάχιστη χρέωση για κάθε βιντεοκασέτα είναι 2,5 και για κάθε DVD 3 και ο μέγιστος χρόνος που μπορεί να κρατήσει ο πελάτης μια βιντεοκασέτα είναι 3 ημέρες, ενώ ένα DVD 4 ημέρες, χωρίς να χρεωθεί με επιπλέον ποσό. Η καθυστέρηση χρεώνεται με 1,.5 για κάθε βιντεοκασέτα και με 1,8 για κάθε DVD για κάθε ημέρα καθυστέρησης. Να γίνει αλγόριθμος που να διαβάζει τα στοιχεία 20 ενοικιάσεων πελατών (ονοματεπώνυμο πελάτη, κωδικός ταινίας (1 ή 2), ημέρες παρακράτησης) και να υπολογίζει και εκτυπώνει την αναλυτική χρέωση ανά πελάτη καθώς και την συνολική χρέωση και το μέσο όρο χρέωσης ανά είδος Το μηνιαίο οικογενειακό επίδομα που δικαιούται μια οικογένεια εξαρτάται από τον αριθμό των παιδιών της οικογένειας. Για την τρέχουσα χρονιά το μηνιαίο οικογενειακό επίδομα υπολογίζεται από τον εξής πίνακα: Αριθμός παιδιών Επίδομα για κάθε παιδί Ευρώ Ευρώ πάνω από 5 30 Ευρώ Να γραφεί αλγόριθμος ο οποίος θα διαβάζει για 200 οικογένειες το πλήθος των παιδιών και θα υπολογίζει πόσα χρήματα δικαιούται κάθε οικογένεια. Επίσης να υπολογίζεται και να εμφανίζεται το ποσοστό των πολύτεκνων οικογενειών Ένα σούπερ μάρκετ εκδίδει κάρτες αγορών για τους μόνιμους πελάτες του. Στις κάρτες αναγράφεται η αξία των προϊόντων για κάθε αγορά. Όταν ένας πελάτης κάνει 3 αγορές δικαιούται ένα δώρο. Αν το συνολικό ποσό των τριών αγορών υπερβαίνει τα 150 δίνεται δώρο αξίας 15, ενώ αν υπερβαίνει τα 300 δίνεται δώρο αξίας 40. Να αναπτύξετε πρόγραμμα το οποίο: α) θα διαβάζει τον αριθμό των πελατών που συμπλήρωσαν3 αγορές, β) θα διαβάζει τα ποσά των τριών αγορών και θα υπολογίζει το συνολικό ποσό αγορών για κάθε πελάτη του ερωτήματος (i), γ) θα εμφανίζει το συνολικό ποσό αγορών κάθε πελάτη και το ανάλογο μήνυμα Δικαιούται δώρα 15 ή Δικαιούται δώρο 40 ή Δεν δικαιούται δώρο Ο ιδιοκτήτης ενός χοιροστασίου αποφάσισε να πουλήσει το πενήντα τοις εκατό των 200 νεογέννητων χοίρων. Έχει 2 προσφορές: α) Η τιμή κάθε χοίρου καθορίζεται από το βάρος του και μόνο, δηλ. πολ/ται το βάρος του σε γραμμάρια επί μια τιμή για κάθε γραμμάριο, εκφρασμένη σε λεπτά του Ευρώ. β) Για κάθε χοίρο υπάρχει μια τιμή βάσης εκφρασμένη σε λεπτά του Ευρώ και για όσα νεογέννητα ξεπερνούν έναν συγκεκριμένο αριθμό γραμμαρίων που θα συμφωνήσει ο ιδιοκτήτης με τον αγοραστή, γίνεται χρέωση 2 λεπτών για το κάθε επιπλέον γραμμάριό τους. Αφού λοιπόν υπολογίσει πόσα χρήματα θα κερδίσει με τη μια προσφορά και πόσα με την άλλη, θα αποδεχθεί στο τέλος την πιο συμφέρουσα προσφορά. Να γραφεί αλγόριθμος που θα υλοποιεί την πιο πάνω λογική και θα εμφανίζει στο τέλος πόσα Ευρώ θα κερδίσει ο ιδιοκτήτης του χοιροστασίου με την πιο συμφέρουσα προσφορά. 110

41 5.194 Ένας σταθμός μέτρησης της ατμοσφαιρικής ρύπανσης υπολογίζει καθημερινά τις μέσες τιμές των μετρούμενων ποσοτήτων διοξειδίου του άνθρακα (CO 2 ) και διοξειδίου του θείου (SO 2 ). Να αναπτύξετε ένα πρόγραμμα το οποίο: α) θα διαβάζει τις μέσες τιμές των μετρήσεων CO 2 και SO 2 για όλες τις ημέρες, κατά τον μήνα Ιούνιο, β) θα υπολογίζει και θα εμφανίζει τη μέση τιμή του CO 2 και SO 2 για τον μήνα Ιούνιο, γ) θα υπολογίζει και θα εμφανίζει τον αριθμό των ημερών που οι τιμές ξεπέρασαν τα επιτρεπόμενα όρια (ξεχωριστά για κάθε διοξείδιο), δ) θα εμφανίζει το μήνυμα ΕΚΤΑΚΤΑ ΜΕΤΡΑ, αν οι ημέρες που ξεπεράστηκαν τα επιτρεπόμενα όρια είναι περισσότερες από 1/5 των ημερών του Ιουνίου. Δίνονται τα ανώτατα επιτρεπόμενα όρια CO 2 = 241 mgr και SO 2 = 340 mgr. Ο Ιούνιος έχει 30 ημέρες Ο ταμίας μιας μεγάλης επιχείρησης έχει κάθε μήνα το ίδιο πρόβλημα: πώς θα βρει τον απαραίτητο αριθμό χαρτονομισμάτων για την μισθοδοσία των 300 εργαζομένων της επιχείρησης. Σκέφτηκε να γράψει ένα πρόγραμμα το οποίο: α) Θα διαβάζει το μισθό κάθε εργαζομένου. β) Θα υπολογίζει και θα εκτυπώνει τον αριθμό χαρτονομισμάτων των 100, των 50, τω ν 20, των 10, των 5 και τον αριθμό κερμάτων των 2 και του 1, τα οποία αντιστοιχούν σε κάθε μισθό. Σε κάθε περίπτωση, ο μισθός να προκύπτει με τον ελάχιστο αριθμό νομισμάτων. γ) Θα εμφανίζει το άθροισμα των νομισμάτων από κάθε κατηγορία που απαιτούνται για την πληρωμή όλων των εργαζομένων Είστε ιδιοκτήτες μιας κατασκευαστικής εταιρείας. Η εταιρία σας διαθέτει 100 καινούργια διαμερίσματα. Για την πώληση των διαμερισμάτων χρεώνετε τους πελάτες σύμφωνα με τα παρακάτω: α) Αν το διαμέρισμα είναι μέχρι και εκατό πενήντα τετραγωνικά μέτρα, για κάθε τετραγωνικό μέτρο ο πελάτης χρεώνετε προς β) Αν το διαμέρισμα είναι από εκατό πενήντα τετραγωνικά και άνω, για κάθε επιπλέον τετραγωνικό μέτρο από τα εκατό πενήντα ο πελάτης χρεώνετε προς γ) Σε κάθε πώληση διαμερίσματος χρεώνετε 440 για έξοδα μεταβίβασης. Να αναπτύξετε αλγόριθμο ο οποίος θα διαβάζει τα τετραγωνικά μέτρα του διαμερίσματος και θα υπολογίζει και θα εκτυπώνει την τελική τιμή πώλησης για κάθε ένα από τα 100 διαμερίσματα Διατηρείτε εταιρία ενοικίασης αυτοκινήτων. Η εταιρία σας διαθέτει 75 αυτοκίνητα και χρεώνει τους πελάτες σύμφωνα με τα παρακάτω: Αν ο πελάτης διανύσει λιγότερα από εκατό (100) χιλιόμετρα, για κάθε χιλιόμετρο τον χρεώνει προς 0,7. Αν ο πελάτης διανύσει από εκατό (100) χιλιόμετρα και άνω, τότε για τα πρώτα 100 χιλιόμετρα χρεώνεται με 0,7 ανά χιλιόμετρο και για τα υπόλοιπα χρεώνεται με 0,55. Σε κάθε ενοικίαση αυτοκινήτου χρεώνει 30 για έξοδα συντήρησης. Να αναπτύξετε αλγόριθμο ο οποίος θα διαβάζει τα χιλιόμετρα που διένυσε ο πελάτης και θα υπολογίζει και θα εμφανίζει την τελική χρέωση ενοικίασης για κάθε ένα από τα 75 αυτοκίνητα. 111

42 5.198 Μόλις έχουν ανακοινωθεί οι βαθμοί των εξετάσεων από το Υπουργείο. Στο σχολείο, ελέγχονται τα αποτελέσματα με σκοπό να εντοπίσουν τους μαθητές που ο προφορικός βαθμός τους είναι τουλάχιστον 4 μονάδες μικρότερος από το βαθμό του γραπτού. Επίσης, το σχολείο θέλει να κρατάει κάποια στατιστικά στοιχεία σχετικά με το πόσοι τελικά μαθητές θα έχουν το δικαίωμα να βελτιώσουν το βαθμό τους με προφορική εξέταση. Να αναπτύξετε αλγόριθμο ο οποίος θα βοηθήσει τους υπεύθυνους του σχολείου να εκτελέσουν τον παραπάνω έλεγχο για τους 360 μαθητές της Β' και Γ' Λυκείου. α) Αρχικά, ο αλγόριθμος θα διαβάζει το γραπτό και τον προφορικό βαθμό του μαθητή. β) Σε περίπτωση που από τα παραπάνω στοιχεία προκύπτει ότι ο μαθητής έχει δικαίωμα να δώσει και συμπληρωματική προφορική εξέταση, ο αλγόριθμος θα εκτυπώνει μήνυμα "Δικαίωμα προφορικής βελτιωτικής εξέτασης". Αν η διαφορά βαθμολογιών δεν υπαγορεύει καμία δυνατότητα βελτίωσης, ο αλγόριθμος θα εκτυπώνει το μέσο όρο της γραπτής και προφορικής βαθμολογίας. γ) Όταν ολοκληρωθεί ο έλεγχος για όλους τους μαθητές, ο αλγόριθμος θα εκτυπώνει. μηνύματα: Αριθμός επανεξεταζόμενων μαθητών και τον αριθμό των επανεξεταζόμενων μαθητών. Ποσοστό επανεξέτασης και το ποσοστό επανεξέτασης Να γίνει πρόγραμμα που να υπολογίζει και εμφανίζει τις καθαρές αποδοχές 30 υπαλλήλων μιας εταιρείας καθώς και το μέσο μισθό τους. Κάθε υπάλληλος λαμβάνει σαν βασικό μισθό 150 αν εργάζεται στο τμήμα Πωλήσεων και 200 αν εργάζεται στο τμήμα των Αγορών. Για κάθε παιδί άνω των 2 παίρνει επίδομα 30 ενώ μέχρι και 2 παιδιά παίρνει συνολικό επίδομα 20. Για κάθε ώρα υπερωρίας αμείβεται με 5 μέχρι 8 ώρες και με 4 αν έχει εργαστεί περισσότερες από 8 ώρες. Αν έχει διδακτορικό δίπλωμα παίρνει επιστημονικό επίδομα 10% επί του βασικού μισθού. Οι κρατήσεις του είναι 5% επί του βασικού μισθού. Το πρόγραμμα να διαβάζει τον αριθμό παιδιών και τις υπερωρίες του κάθε υπαλλήλου καθώς και σε ποιο τμήμα δουλεύει. Επίσης να διαβάζει αν ο κάθε υπάλληλος έχει διδακτορικό δίπλωμα Σε ένα video club η κάθε κασέτα χρεώνεται ως εξής: 6 το τριήμερο και 1.5 για κάθε ημέρα καθυστέρησης. Να γίνει πρόγραμμα που διαβάζει τις ημέρες ενοικίασης, τον αριθμό των κασετών και υπολογίζει τη συνολική χρέωση για την ενοικίαση μιας κασέτας καθώς επίσης και τις συνολικές εισπράξεις του video club Σε ένα σχολείο της Ευρωπαϊκής Ένωσης θέλουν να βγάλουν στατιστικά σχετικά με τα ποσοστά επιτυχίας στις εξετάσεις. Να γράψετε αλγόριθμο ο οποίος θα διαβάζει το βαθμό πρόσβασης 130 μαθητών, ο οποίος πρέπει να ελέγχεται ώστε να βρίσκεται στη βαθμολογική κλίμακα [ ] και θα υπολογίζει και θα εκτυπώνει το πλήθος των μαθητών με βαθμό πρόσβασης πάνω από Να αναπτύξετε αλγόριθμο ο οποίος θα χρησιμοποιείται για τη γρήγορη διόρθωση κουίζ πολλαπλής επιλογής με Ν ερωτήσεις. Ο χρήστης θα εισάγει πόσες μονάδες κερδίζει ο μαθητής αν δώσει απάντηση Α, Β, Γ, ή Δ καθώς και το πλήθος των ερωτήσεων. Ο αλγόριθμος θα διαβάζει την απάντηση για κάθε ερώτηση και αφού ελέγξει την εγκυρότητα της απάντησης θα αποδίδει την ανάλογη βαθμολογία. Στο τέλος θα εκτυπώνει τη βαθμολογία του μαθητή. 112

43 5.203 Σε ένα τηλεοπτικό κανάλι το κόστος προβολής μίας διαφήμισης είναι ίσο με το κόστος διάρκειας μείον την έκπτωση. Πιο συγκεκριμένα, το κόστος διάρκειας υπολογίζεται κλιμακωτά ως εξής: από 1 μέχρι και 15 δευτερόλεπτα προς 280 ευρώ/δευτερόλεπτο. από 16 μέχρι και 30 δευτερόλεπτα προς 230 ευρώ/δευτερόλεπτο. από 31 μέχρι και 40 δευτερόλεπτα προς 200 ευρώ/δευτερόλεπτο. από 41 μέχρι και 90 δευτερόλεπτα προς 150 ευρώ/δευτερόλεπτο. Επιπλέον, η έκπτωση που παρέχει το κανάλι για μία διαφήμιση, υπολογίζεται ως εξής: από 2 μέχρι και 4 προβολές η έκπτωση είναι ίση με 5% του κόστους διάρκειας της. από 5 μέχρι και 8 προβολές η έκπτωση είναι ίση με 10% του κόστους διάρκειας της. από 9 μέχρι και 15 προβολές η έκπτωση είναι ίση με 15% του κόστους διάρκειας της. από 16 μέχρι και 20 προβολές η έκπτωση είναι ίση με 25% του κόστους διάρκειας της. Λαμβάνοντας υπόψη τις ανωτέρω πληροφορίες, να γράψετε αλγόριθμο ο οποίος: α) να διαβάζει τη διάρκεια 12 διαφημίσεων και να ελέγχει την ορθή καταχώρησή της. β) να διαβάζει των αριθμό προβολών 12 διαφημίσεων και να ελέγχει την ορθή καταχώρησή του. γ) να υπολογίζει και να τυπώνει το κόστος προβολής κάθε διαφήμισης. δ) να υπολογίζει και να τυπώνει τη συνολική διάρκεια προβολής όλων των διαφημίσεων Στο πλαίσιο προγράμματος προληπτικής ιατρικής για την αντιμετώπιση του νεανικού διαβήτη έγιναν αιματολογικές εξετάσεις στους 90 μαθητές (αγόρια και κορίτσια) ενός Γυμνασίου. Για κάθε παιδί καταχωρίστηκαν τα ακόλουθα στοιχεία: ονοματεπώνυμο μαθητή, κωδικός φύλλου ( Α για τα αγόρια και Κ για τα κορίτσια), περιεκτικότητα σακχάρου στο αίμα. Οι φυσιολογικές τιμές σακχάρου στο αίμα κυμαίνονται από 70 έως 100 ml/dl (συμπεριλαμβανομένων και των ακραίων τιμών). Να αναπτύξετε αλγόριθμο που: α) θα διαβάζει τα παραπάνω στοιχεία (ονοματεπώνυμο, κωδικός φύλλου, περιεκτικότητα σακχάρου στο αίμα) και θα ελέγχει την αξιόπιστη καταχώρισή τους (δηλαδή το φύλο να είναι μόνο Α ή Κ και η περιεκτικότητα σακχάρου στο αίμα να είναι θετικός αριθμός), β) θα εμφανίζει για κάθε παιδί του οποίου η περιεκτικότητα σακχάρου στο αίμα είναι εκτός των φυσιολογικών τιμών, το ονοματεπώνυμο, το φύλο και την περιεκτικότητα του σακχάρου, γ) θα εμφανίζει το συνολικό αριθμό των αγοριών των οποίων η περιεκτικότητα σακχάρου στο αίμα είναι εκτός των φυσιολογικών τιμών δ) θα εμφανίζει το συνολικό αριθμό των κοριτσιών των οποίων η περιεκτικότητα σακχάρου στο αίμα είναι εκτός των φυσιολογικών τιμών Σε έναν αγώνα μπάσκετ είχαν συμμετοχή Ν παίκτες μιας ομάδας. Να δοθεί αλγόριθμος που να διαβάζει τον αριθμό Ν (έλεγχος ώστε να μην είναι μεγαλύτερος από 10) και στη συνέχεια για κάθε παίκτη να ζητά τα στοιχεία: 1. Πόντους που πέτυχε, 2. Φάουλ που έκανε, 3. Τρίποντα εύστοχα και 4. Τρίποντα άστοχα. Στη συνέχεια ο αλγόριθμος θα πρέπει να εμφανίζει : 1. Σύνολο πόντων της ομάδας, 2. Συνολικό αριθμό φάουλ, 3. Μέσο όρο πόντων ανά παίκτη και 4. Ποσοστό ευστοχίας στα τρίποντα συνολικά για την ομάδα. 113

44 5.206 Για κάθε υπάλληλο δίνονται: ο μηνιαίος βασικός μισθός και ο αριθμός των παιδιών του. Δεχόμαστε ότι ο υπάλληλος μπορεί να έχει μέχρι και 20 παιδιά και ότι ο μηνιαίος βασικός μισθός του κυμαίνεται από 500 μέχρι και 1000 ευρώ. Οι συνολικές αποδοχές του υπολογίζονται ως το άθροισμα του μηνιαίου βασικού μισθού και του οικογενειακού επιδόματός του. Το οικογενειακό επίδομα υπολογίζεται ως εξής: 30 ευρώ για κάθε παιδί μέχρι και τρία παιδιά, και 40 ευρώ για κάθε παιδί πέραν των τριών. Να γράψετε πρόγραμμα, το οποίο: α) εισάγει τα κατάλληλα δεδομένα και ελέγχει την ορθή καταχώρισή τους, β) υπολογίζει και εμφανίζει το οικογενειακό επίδομα και γ) υπολογίζει και εμφανίζει τις συνολικές αποδοχές του υπαλλήλου Στο μηχάνημα ανάληψης μετρητών (ΑΤΜ) μιας τράπεζας κάθε πελάτης εισάγει την κάρτα του, πληκτρολογεί το κωδικό του και αν αυτός είναι σωστός μπορεί να προχωρήσει στην ανάληψη ενός ποσού, αρκεί το υπόλοιπο του λογαριασμού του να είναι μεγαλύτερο από το ποσό αυτό. Τα επιτρεπόμενα ποσά ανάληψης εμφανίζονται στον παρακάτω πίνακα: Αύξων αριθμός Ποσό ( ) Ο πελάτης επιλέγει το ποσό που θέλει, πληκτρολογώντας τον αύξοντα αριθμό που αντιστοιχεί σε αυτό. Το μηχάνημα μπορεί να δώσει μόνο χαρτονομίσματα των 50 και 10. Να γραφεί πρόγραμμα το οποίο: α) θα δέχεται στην είσοδο τον κωδικό αριθμό της κάρτας του πελάτη, β) θα δέχεται τον κωδικό αριθμό που πληκτρολογεί ο πελάτης, και εφόσον αυτός συμφωνεί με τον κωδικό αριθμό της κάρτας, θα προχωράει στα επόμενα ερωτήματα, γ) θα δέχεται το υπόλοιπο του λογαριασμού του πελάτη που βρίσκεται αποθηκευμένο στην κάρτα, δ) θα ζητάει από τον πελάτη να πληκτρολογήσει έναν αριθμό από το 1 μέχρι 6 για να επιλέξει το ποσό ανάληψης, ε) θα υπολογίζει πόσα χαρτονομίσματα των 50 και πόσα των 10 αντιστοιχούν στο παραπάνω ποσό, στ) θα εμφανίζει το ποσό που πήρε ο πελάτης, τον αριθμό των χαρτονομισμάτων των 50 και των 10 που αντιστοιχούν στο ποσό αυτό και το νέο υπόλοιπο του λογαριασμού. Τα παραπάνω να γίνουν για 100 πελάτες Να γίνει αλγόριθμος που να διαβάζει 100 θετικούς αριθμούς (να γίνεται έλεγχος) και να υπολογίζει και εμφανίζει το άθροισμα των αριθμών, πόσες λάθος τιμές δόθηκαν σε κάθε επανάληψη καθώς και τις συνολικά λάθος τιμές που πληκτρολογήθηκαν. 114

45 5.209 Σε μια στατιστική υπηρεσία ανατέθηκε να κάνει μια έρευνα σχετικά με το ύψος των Ελλήνων. Συγκεκριμένα, της ζητήθηκε να βρει το ποσοστό των ανδρών που έχουν ύψος άνω του 1.80 m και το ποσοστό των γυναικών που έχουν ύψος άνω του 1.70 m, εξετάζοντας ένα δείγμα ανθρώπων. Να αναπτύξετε αλγόριθμο που: α) να διαβάζει το φύλο ( Α ή Γ ) και το ύψος καθενός από τους ανθρώπους του δείγματος, και β) να υπολογίζει τα ζητούμενα ποσοστά. Σημείωση: Σε περίπτωση που δοθεί κάποια απαράδεκτη τιμή, ο αλγόριθμος θα πρέπει να εμφανίζει διαγνωστικό μήνυμα και να ξαναδιαβάζει τη συγκεκριμένη μεταβλητή. Αποδεκτές τιμές για το ύψος είναι από 0.45 μέχρι 2.50 m ενώ το φύλο μπορεί να πάρει μία από τις τιμές Α και Γ Να γραφεί αλγόριθμος ο οποίος: α) Να διαβάζει 25 ακέραιους αριθμούς μεγαλύτερους του μηδενός και να ελέγχει την αξιόπιστη καταχώρησή τους. β) Στην περίπτωση όπου κάποιος από αυτούς είναι πολλαπλάσιος του 8 και μεγαλύτερος του 30, θα πρέπει να εκχωρείται σε μια μεταβλητή Δ το πηλίκο της διαίρεσης του αριθμού με το 12 και στη συνέχεια να εμφανίζεται το μήνυμα Η τιμή της Δ είναι:, όπου στο κενό να εμφανίζεται η τιμή της Δ. γ) Στην περίπτωση όπου κάποιος από αυτούς είναι μεγαλύτερος του 60, θα πρέπει να εκχωρείται σε μια μεταβλητή Ρ η τετραγωνική ρίζα του αριθμού και στην συνέχεια να εμφανίζεται το μήνυμα: Η τετραγωνική ρίζα του αριθμού:,, είναι:, όπου στο πρώτο κενό να εμφανίζεται ο αριθμός και στο δεύτερο κενό η τετραγωνική ρίζα του αριθμού. δ) Σε οποιαδήποτε άλλη περίπτωση, θα πρέπει να εκχωρείται σε μια μεταβλητή Υ η διπλάσια τιμή του τετραγώνου του αριθμού. Αν αυτή είναι μεγαλύτερη του 125 να εμφανίζεται το μήνυμα Το διπλάσιο τετράγωνο του αριθμού είναι:, όπου στο κενό να εμφανίζεται η τιμή Υ, διαφορετικά να εκχωρείται στην μεταβλητή Υ η τιμή Πριν την έναρξη των εξετάσεων υπολογίζεται ο αριθμός των απουσιών κάθε μαθητή για να κριθεί αν έχει δικαίωμα να συμμετέχει στις εξετάσεις. Σχετικά με τις απουσίες ενός μαθητή στο Λύκειο, ισχύουν τα παρακάτω: Ο μαθητής έχει δικαίωμα να δώσει εξετάσεις τον Ιούνιο αν: α) έχει μέχρι 64 απουσίες ή β) έχει μέχρι 114 απουσίες από τις οποίες οι αδικαιολόγητες δεν ξεπερνούν τις 64 ή γ) έχει μέχρι 164 απουσίες από τις οποίες οι αδικαιολόγητες δεν ξεπερνούν τις 64 και ο μέσος όρος στα προφορικά του είναι πάνω από 15. Ο μαθητής παραπέμπεται για ολική εξέταση το Σεπτέμβριο αν: α) έχει πάνω από 64 και μέχρι 114 απουσίες και οι αδικαιολόγητες ξεπερνούν τις 64 ή, β) έχει πάνω από 114 και μέχρι 164 απουσίες από τις οποίες οι αδικαιολόγητες δεν ξεπερνούν τις 64 αλλά ο μέσος όρος δεν είναι πάνω από 15. Σε κάθε άλλη περίπτωση ο μαθητής επαναλαμβάνει τη χρονιά. Να γράψετε αλγόριθμο ο οποίος θα διαβάζει τον αριθμό των αδικαιολόγητων και δικαιολογημένων απουσιών 200 μαθητών, οι οποίοι πρέπει να ελέγχονται ώστε να είναι μη αρνητικοί, καθώς και το μέσο προφορικό βαθμό τους και θα εκτυπώνει την περίπτωση όπου ανήκει ο μαθητής. 115

46 5.212 Ένα πάρκινγκ διαθέτει 120 θέσεις και χρεώνει κλιμακωτά τη στάθμευση σε αυτές σύμφωνα με τον παρακάτω πίνακα: Ώρες στάθμευσης Κόστος ( ) Λιγότερες από Από 3 έως λιγότερες από Από 6 έως λιγότερες από 9 1 Για τις επιπλέον ώρες το κόστος είναι 10 για όλες τις ώρες Για παράδειγμα, αν ένα αυτοκίνητο έμεινε για 4 ώρες, θα πληρώσει 8 ευρώ, ενώ αν διέμεινε 7 ώρες, θα πληρώσει 11.5 ευρώ, ενώ, αν διέμεινε 11 ώρες, θα πληρώσει 22.5 ευρώ. Να κατασκευάσετε αλγόριθμο ο οποίος: α. για κάθε αυτοκίνητο που στάθμευσε στο πάρκινγκ θα διαβάζει τον αριθμό κυκλοφορίας του και τη διάρκεια στάθμευσης σε ώρες, την οποία θα δέχεται μόνο εφόσον είναι μεγαλύτερη από το 0. Επίσης θα υπολογίζει κάθε φορά πόσοι λάθος αριθμοί δόθηκαν. Θεωρούμε ότι το πάρκινγκ γέμισε και κάθε θέση καταλήφθηκε μόνο μία φορά από κάποιο αυτοκίνητο. β. θα υπολογίζει το ποσό που πρέπει να πληρώσει ο κάτοχός του. γ. θα εμφανίζει τον αριθμό κυκλοφορίας και το ποσό που αναλογεί. δ. Θα εμφανίζει τις συνολικές εισπράξεις του πάρκινγκ. ε. Θα εμφανίζει το ποσοστό των αυτοκινήτων που στάθμευσαν περισσότερες από 3 ώρες στο πάρκινγκ. στ. αν κάθε αυτοκίνητο στάθμευε στο πάρκινγκ για 3 ώρες, να εμφανίζεται μήνυμα σχετικά με το αν τα έσοδά του θα ήταν περισσότερα, λιγότερα ή ίσα με τις πραγματικές εισπράξεις που πραγματοποιήθηκαν Μια εταιρεία έχει 48 υπαλλήλους και τους πληρώνει κάθε εβδομάδα σύμφωνα με τον παρακάτω πίνακα: Ώρες εργασίας / ώρα από 0 έως και 40 5 από 40 έως και 50 7 πάνω από 50 9 Για παράδειγμα, ένας υπάλληλος που δούλεψε 45 ώρες σε μία εβδομάδα θα πληρωθεί 235. Να αναπτύξετε αλγόριθμο ο οποίος: α) Να διαβάζει το όνομα του κάθε υπαλλήλου. β) Να διαβάζει τον αριθμό των ωρών εργασίας κάθε υπαλλήλου σε μία εβδομάδα και να ελέγχει αν οι ώρες εργασίας είναι αριθμός μεγαλύτερος ή ίσος του μηδενός. γ) Να υπολογίζει και να εμφανίζει την εβδομαδιαία αμοιβή του κάθε υπαλλήλου. δ) Να υπολογίζει και να εμφανίζει το συνολικό κόστος για την εταιρεία. ε) Να υπολογίζει και να εμφανίζει το πλήθος των υπαλλήλων που δεν έχουν κάνει υπερωρίες. Ένας υπάλληλος θεωρείται ότι κάνει υπερωρία όταν εργάζεται πάνω από 40 ώρες την εβδομάδα. 116

47 5.214 Να αναπτυχθεί αλγόριθμος που θα διαβάζει την χωρητικότητα ενός πλοίου ελέγχοντας ώστε να είναι θετικός αριθμός και στη συνέχεια το πλήθος των containers που πρέπει να μεταφερθούν. Στη συνέχεια για κάθε container να διαβάζεται το βάρος του και στη συνέχεια και να εκτιμάται και να εκτυπώνεται πόσο δρομολόγια χρειάζεται το πλοίο για τη μεταφορά Στο πλαίσιο του πρωταθλήματος ποδοσφαίρου γίνονται κάθε Κυριακή κάποιοι αγώνες. Να γίνει πρόγραμμα που: α) διαβάζει το πλήθος των αγώνων που έγιναν β) διαβάζει το όνομα και τον αριθμό των τερμάτων της γηπεδούχου και τη φιλοξενούμενης ομάδας για κάθε αγώνα γ) εμφανίζει σε ποιο αγώνα σημειώθηκε η μεγαλύτερη διαφορά τερμάτων δ) εμφανίζει πόσες ισοπαλίες, πόσες νίκες γηπεδούχων ομάδων και πόσες νίκες φιλοξενούμενων ομάδων υπήρξαν Θέλετε να βγάλετε κάποια στατιστικά στοιχεία για τις 30 παραστάσεις που παρουσίασε ο θίασός σας στην καλοκαιρινή του περιοδεία. Να φτιάξετε αλγόριθμο ο οποίος: α) θα διαβάζει τα έσοδα της παράστασης και το κόστος της παράστασης, β) θα υπολογίζει και θα εκτυπώνει το καθαρό κέρδος από κάθε παράσταση. Αν το κέρδος είναι περισσότερο από 1450 θα εκτυπώνει το μήνυμα: "Να Ξαναπάμε!". Τέλος, ο αλγόριθμος θα εκτυπώνει το συνολικό κέρδος από όλες τις παραστάσεις και το ποσό της λιγότερο κερδοφόρας παράστασης Θέλετε να βγάλετε κάποια στατιστικά στοιχεία για τους 40 παίκτες του Basket που συμμετείχαν στο Euro. Να φτιάξετε αλγόριθμο ο οποίος: α) θα διαβάζει τους πόντους που πέτυχε ο παίκτης στο τελικό, β) θα διαβάζει τους πόντους που πέτυχε ο παίκτης σε όλους τους υπόλοιπους αγώνες, γ) θα εκτυπώνει για κάθε παίκτη το σύνολο των πόντων που πέτυχε. Αν ο παίκτης έχει πετύχει περισσότερους από 75 πόντους να εκτυπώνει ένα μήνυμα "Πολύ Καλός Παίκτης". Τέλος, ο αλγόριθμος θα εκτυπώνει τους πόντους που πέτυχαν όλοι οι παίκτες και τους πόντους που πέτυχε ο καλύτερος παίκτης Να γραφεί αλγόριθμος που θα διαβάζει τους χρόνους που έκαναν στα 100 μ. 10 αθλητές και θα εμφανίζει τον μικρότερο χρόνο καθώς και το ποιος ήταν ο αθλητής αυτός (δηλ. ο 1 ος, ο 3 ος, ο 10 ος, ) Δίνονται η έκταση, ο πληθυσμός και το όνομα καθεμιάς από τις 15 χώρες της Ε.Ε. Να αναπτύξετε αλγόριθμο που: α) θα διαβάζει τα παραπάνω δεδομένα, β) θα εμφανίζει τη χώρα με τη μεγαλύτερη έκταση, γ) θα εμφανίζει τη χώρα με το μικρότερο πληθυσμό και δ) θα εμφανίζει το μέσο όρο του πληθυσμού των 15 χωρών της Ε.Ε Να γραφεί αλγόριθμος ο οποίος θα διαβάζει τον αριθμό των σχολείων μίας Νομαρχίας και για κάθε σχολείο το όνομά του και τον αριθμό των μαθητών. Στη συνέχεια θα υπολογίζει και θα εμφανίζει το όνομα και τον αριθμό των μαθητών του πολυπληθέστερου σχολείου. 117

Παλλατίδειο ΓΕΛ Σιδηροκάστρου

Παλλατίδειο ΓΕΛ Σιδηροκάστρου Δομή Επανάληψης 2000 Θέμα 2 ο Έστω τμήμα αλγορίθμου με μεταβλητές A, B, C, D, X και Υ. D 2 Για Χ από 2 μέχρι 5 με_βήμα 2 Α 10 * Χ Β 5 * Χ + 10 C Α + Β (5 * Χ) D 3 * D - 5 Υ A + B C + D Να βρείτε τις τιμές

Διαβάστε περισσότερα

ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΣΚΗΣΕΙΣ

ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΣΚΗΣΕΙΣ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΣΚΗΣΕΙΣ 1. Η αμοιβή ενός τεχνίτη κατασκευής δαπέδων εξαρτάται από το πλήθος των τετραγωνικών μέτρων που καλύπτει σε μια οικοδομή. Η χρέωση γίνεται ανά τετραγωνικό μέτρο και κλιμακωτά σύμφωνα

Διαβάστε περισσότερα

Μεθοδολογία προβλημάτων με Δομή Επανάληψης

Μεθοδολογία προβλημάτων με Δομή Επανάληψης Μεθοδολογία προβλημάτων με Δομή Επανάληψης Ενότητες βιβλίου: - Ώρες διδασκαλίας: 3 Μετρητές Σε πολλές ασκήσεις ζητείται να καταμετρηθεί το πλήθος των τιμών που ικανοποιούν μια συνθήκη (π.χ. είναι θετικοί

Διαβάστε περισσότερα

Δομές Επανάληψης - πακέτο 3 (ΝΕΕΣ ασκήσεις)

Δομές Επανάληψης - πακέτο 3 (ΝΕΕΣ ασκήσεις) Δομές Επανάληψης - πακέτο 3 (ΝΕΕΣ ασκήσεις) Άσκηση 33. Α. Δίνεται το παρακάνω τμήμα αλγορίθμου: S 0 i 5 Όσο (i > 1) επανάλαβε S S + i i i 1 Εμφάνισε i Εμφάνισε S Μπορείτε δημιουργήσετε κωδικοποίηση σε

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός: Θέμα 1ο Α) Απαντήστε στις παρακάτω ερωτήσεις επιλέγοντας Σ (Σωστό) ή Λ (Λάθος). 1. Η ομάδα εντολών μέσα στην Αρχή_επανάληψης..μέχρις_ότου

Διαβάστε περισσότερα

Δίνονται η έκταση, ο πληθυσμός και το όνομα καθεμιάς από τις 15 χώρες της Ευρωπαϊκής Ενωσης. Να αναπτύξετε αλγόριθμο που

Δίνονται η έκταση, ο πληθυσμός και το όνομα καθεμιάς από τις 15 χώρες της Ευρωπαϊκής Ενωσης. Να αναπτύξετε αλγόριθμο που 1 ΘΕΜΑ 4ο Σε ένα πρόγραμμα περιβαλλοντικής εκπαίδευσης συμμετέχουν 0 σχολεία. Στα πλαίσια αυτού του προγράμματος, εθελοντές μαθητές των σχολείων, που συμμετέχουν στο πρόγραμμα, μαζεύουν ποσότητες τριών

Διαβάστε περισσότερα

Ασκήσεις στη ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ. Α. εντολές όσο επανάλαβε & αρχή_επανάληψης μέχρις_ότου

Ασκήσεις στη ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ. Α. εντολές όσο επανάλαβε & αρχή_επανάληψης μέχρις_ότου Ασκήσεις στη ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ Α. εντολές όσο επανάλαβε & αρχή_επανάληψης μέχρις_ότου 1. Πόσα * θα εμφανιστούν σε κάθε μια από τις παρακάτω περιπτώσεις Α έως Ε αν εκτελεστούν οι εντολές που βλέπετε; Να υλοποιήσετε

Διαβάστε περισσότερα

επιµέλεια Θοδωρής Πιερράτος

επιµέλεια Θοδωρής Πιερράτος Ερωτήσεις Σωστό Λάθος 1. Στη δοµή επανάληψης Όσο... επανάλαβε ο έλεγχος της συνθήκης γίνεται στην αρχή, δηλαδή πριν εκτελεστεί οποιαδήποτε εντολή που περιέχεται στη δοµή. 2. Ο µετρητής που ελέγχει τη συνθήκη

Διαβάστε περισσότερα

ΚΕΦΑΛΑΙΟ 4 ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ

ΚΕΦΑΛΑΙΟ 4 ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ ΚΕΦΑΛΑΙΟ 4 ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ ΕΡΩΤΗΣΕΙΣ ΘΕΩΡΙΑΣ ΚΕΦΑΛΑΙΟΥ 4 4. Πότε χρησιμοποιείται η δομή επανάληψης και ποιες είναι οι τρεις επαναληπτικές δομές; 4.2 Να γράψετε τη σύνταξη των εντολών επανάληψης που γνωρίζετε.

Διαβάστε περισσότερα

Ημερομηνία: Τρίτη 27 Δεκεμβρίου 2016 Διάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ

Ημερομηνία: Τρίτη 27 Δεκεμβρίου 2016 Διάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ ΤΑΞΗ: ΜΑΘΗΜΑ: Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΑΕΠΠ ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ Ημερομηνία: Τρίτη 27 Δεκεμβρίου 2016 Διάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας το γράμμα κάθε πρότασης και δίπλα σε

Διαβάστε περισσότερα

ΚΕΦΑΛΑΙΑ & 8.2 (ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ) ΘΕΩΡΙΑ

ΚΕΦΑΛΑΙΑ & 8.2 (ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ) ΘΕΩΡΙΑ ΚΕΦΑΛΑΙΑ 2.4.5 & 8.2 (ΔΟΜΕΣ ΕΠΑΝΑΛΗΨΗΣ) ΘΕΩΡΙΑ Ερωτήσεις Σωστό / Λάθος 1. Στη δομή Για... από... μέχρι η αρχική τιμή του μετρητή πρέπει να είναι πάντα μικρότερη από την τελική. 2. Η δομή Όσο... επανάλαβε

Διαβάστε περισσότερα

ΙΑΓΩΝΙΣΜΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ Γ ΛΥΚΕΙΟΥ

ΙΑΓΩΝΙΣΜΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ Γ ΛΥΚΕΙΟΥ ΙΑΓΩΝΙΣΜΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΥ Γ ΛΥΚΕΙΟΥ Επαναληπτικό: 1 2 κεφάλαιο ΗΜ/ΝΙΑ :.. ΟΝΟΜΑΤΕΠΩΝΥΜΟ :.. ΘΕΜΑ 1 ο Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-10 και δίπλα τη λέξη

Διαβάστε περισσότερα

Μιχάλης Αρταβάνης κλάδου Πληροφορικής ΠΕ19

Μιχάλης Αρταβάνης κλάδου Πληροφορικής ΠΕ19 Φυλλάδιο Ασκήσεων 1 - οµές Επανάληψης Ασκ1. Πόσες φορές θα εκτελεστούν οι επαναληπτικές δοµές στα παρακάτω τµήµατα αλγορίθµων; x 5 Όσο (x > 0) x x - 1 x 5 Όσο (x >= 0) x x - 1 x -5 Όσο (x >= 0) x x - 1

Διαβάστε περισσότερα

ΚΕΦΑΛΑΙΟ 2 Παράδειγμα 3 Παράδειγμα 5 Παράδειγμα 6 ΔΤ3 ΔΤ4 151

ΚΕΦΑΛΑΙΟ 2 Παράδειγμα 3 Παράδειγμα 5 Παράδειγμα 6  ΔΤ3 ΔΤ4  151 ΚΕΦΑΛΑΙΟ 2 Παράδειγμα 3 Σε ένα μετεωρολογικό κέντρο χρειάζεται να βρεθεί η μέγιστη και η ελάχιστη θερμοκρασία από τις μέσες ημερήσιες θερμοκρασίες ενός μήνα. Να γραφεί ένας αλγόριθμος που θα διαβάζει τη

Διαβάστε περισσότερα

Ασκήσεις στη οµή Επανάληψης

Ασκήσεις στη οµή Επανάληψης Άσκηση 1 Ασκήσεις στη οµή Επανάληψης Ένα τρένο ξεκινάει από Αθήνα για Θεσσαλονίκη έχοντας να κάνει στάση σε 12 ενδιάµεσους σταθµούς. Το τρένο έχει µέγιστη χωρητικότητα επιβατών 780 άτοµα. Να γραφεί αλγόριθµος

Διαβάστε περισσότερα

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΔΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 19/12/2008. Τμήμα ΓΤ1 Όνομα:...

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΔΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 19/12/2008. Τμήμα ΓΤ1 Όνομα:... ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΔΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 19/12/2008 Τμήμα ΓΤ1 Όνομα:... ΘΕΜΑ 1 ο. Α) Να γράψετε στο φύλλο απαντήσεών σας Σ εάν κρίνετε ότι η πρόταση είναι σωστή και

Διαβάστε περισσότερα

8. Η δημιουργία του εκτελέσιμου προγράμματος γίνεται μόνο όταν το πηγαίο πρόγραμμα δεν περιέχει συντακτικά λάθη.

8. Η δημιουργία του εκτελέσιμου προγράμματος γίνεται μόνο όταν το πηγαίο πρόγραμμα δεν περιέχει συντακτικά λάθη. 1ΗΣ ΣΕΛΙΔΑΣ ΤΕΛΙΚΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ 2015 Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ) ΣΥΝΟΛΟ

Διαβάστε περισσότερα

ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ ΚΕΦΑΛΑΙΟ 2 ο ΚΕΦΑΛΑΙΟ 7 ο - ΑΣΚΗΣΕΙΣ - ΠΡΟΒΛΗΜΑΤΑ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΔΟΜΕΣ

ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ ΚΕΦΑΛΑΙΟ 2 ο ΚΕΦΑΛΑΙΟ 7 ο - ΑΣΚΗΣΕΙΣ - ΠΡΟΒΛΗΜΑΤΑ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΔΟΜΕΣ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ ΚΕΦΑΛΑΙΟ 2 ο ΚΕΦΑΛΑΙΟ 7 ο - ΑΣΚΗΣΕΙΣ - ΠΡΟΒΛΗΜΑΤΑ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΔΟΜΕΣ 1. Να εκτελέσετε το παρακάτω τµήµα αλγορίθµου, για Κ = 24 και L = 40. Να γράψετε στο τετράδιό σας τις τιµές

Διαβάστε περισσότερα

Φάσμα. προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι.

Φάσμα. προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. σύγχρονο Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. μαθητικό φροντιστήριο 25ης Μαρτίου 111 - ΠΕΤΡΟΥΠΟΛΗ - 210 50 20 990-210 50 27 990 25ης Μαρτίου 74 - ΠΕΤΡΟΥΠΟΛΗ - 210 50 50 658-210 50 60 845 Γραβιάς 85 -

Διαβάστε περισσότερα

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων;

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων; ΦΡΟΝΤΙΣΤΗΡΙΑΚΟΣ ΟΡΓΑΝΙΣΜΟΣ ΘΕΜΑ Α ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ 01/03/2015 Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1.

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Θέμα Α

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Θέμα Α ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Θέμα Α Α1. Δίνονται οι παρακάτω εντολές από ένα τμήμα προγράμματος: ΔΙΑΒΑΣΕ α, β x α > β Να χαρακτηρίσετε αν κάθε μία από τις παρακάτω προτάσεις είναι

Διαβάστε περισσότερα

3. Ασκήσεις στη Δομή Επανάληψης

3. Ασκήσεις στη Δομή Επανάληψης 3. Ασκήσεις στη Δομή Επανάληψης 301 Να γραφεί αλγόριθμος που θα διαβάζει έναν ακέραιο αριθμό n και θα υπολογίζει την παράσταση: 1 + 2 + 3 +... + n Y = + n 1* 3* 5*...* (2n + 1) 302 Να γραφεί αλγόριθμος

Διαβάστε περισσότερα

ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ ΚΕΦΑΛΑΙΟ 2 ο ΚΕΦΑΛΑΙΟ 7 ο - ΑΣΚΗΣΕΙΣ - ΠΡΟΒΛΗΜΑΤΑ ΔΟΜΗ ΕΠΙΛΟΓΗΣ

ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ ΚΕΦΑΛΑΙΟ 2 ο ΚΕΦΑΛΑΙΟ 7 ο - ΑΣΚΗΣΕΙΣ - ΠΡΟΒΛΗΜΑΤΑ ΔΟΜΗ ΕΠΙΛΟΓΗΣ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ ΚΕΦΑΛΑΙΟ 2 ο ΚΕΦΑΛΑΙΟ 7 ο - ΑΣΚΗΣΕΙΣ - ΠΡΟΒΛΗΜΑΤΑ ΔΟΜΗ ΕΠΙΛΟΓΗΣ 1. Να γράψετε αλγόριθμο α) σε διάγραμμα ροής, β) σε ψευδογλώσσα και γ) σε πρόγραμμα ΓΛΩΣΣΑ, ο οποίος θα διαβάζει

Διαβάστε περισσότερα

ΑΡΧΗ 1ης ΣΕΛΙΔΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ

ΑΡΧΗ 1ης ΣΕΛΙΔΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΑΡΧΗ 1ης ΣΕΛΙΔΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΔΙΑΓΩΝΙΣΜΑ ΠΕΡΙΟΔΟΥ : ΟΚΤΩΒΡΙΟΥ 2015 ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ : 7 ΘΕΜΑ Α

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ 1ΗΣ ΣΕΛΙΔΑΣ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ Σ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΝΕΩΝ ΜΟΥΔΑΝΙΩΝ Δευτέρα, 12 Μαΐου 2014 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ:

Διαβάστε περισσότερα

ΟΜΟΣΠΟΝ ΙΑ ΕΚΠΑΙ ΕΥΤΙΚΩΝ ΦΡΟΝΤΙΣΤΩΝ ΕΛΛΑ ΟΣ (Ο.Ε.Φ.Ε.) ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2012 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΟΜΟΣΠΟΝ ΙΑ ΕΚΠΑΙ ΕΥΤΙΚΩΝ ΦΡΟΝΤΙΣΤΩΝ ΕΛΛΑ ΟΣ (Ο.Ε.Φ.Ε.) ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2012 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ: ΚΑΤΕΥΘΥΝΣΗ: ΜΑΘΗΜΑ: ΘΕΜΑ Α Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ (2ος Κύκλος) ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ηµεροµηνία: Κυριακή 22 Απριλίου 2012 ΕΚΦΩΝΗΣΕΙΣ Α1. Να γράψετε στο τετράδιό

Διαβάστε περισσότερα

Η Δομή Επανάληψης. Εισαγωγή στην δομή επανάληψης Χρονική διάρκεια: 3 διδακτικές ώρες

Η Δομή Επανάληψης. Εισαγωγή στην δομή επανάληψης Χρονική διάρκεια: 3 διδακτικές ώρες Η Δομή Επανάληψης Εισαγωγή στην δομή επανάληψης Χρονική διάρκεια: 3 διδακτικές ώρες Οι 2 πρώτες διδακτικές ώρες στην τάξη Η τρίτη διδακτική ώρα στο εργαστήριο Γενικός Διδακτικός Σκοπός Ενότητας Να εξοικειωθούν

Διαβάστε περισσότερα

Α2. Να γράψετε τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β που αντιστοιχεί σωστά.

Α2. Να γράψετε τους αριθμούς της Στήλης Α και δίπλα το γράμμα της Στήλης Β που αντιστοιχεί σωστά. ΔΙΑΓΩΝΙΣΜΑ ΕΚΠ. ΕΤΟΥΣ 2016-2017 ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / Γ ΟΙΚ & ΠΛΗΡ (ΘΕΡΙΝΑ) ΗΜΕΡΟΜΗΝΙΑ: 13-11-2016 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: ΓΙΑΝΝΗΣ ΜΙΧΑΛΕΑΚΟΣ- ΑΝΝΑ ΚΑΤΡΑΚΗ ΘΕΜΑ Α Α1. Να γράψετε τους αριθμούς για κάθε

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ 23/04/2012. Α. Να απαντήσετε με Σ ή Λ στις παρακάτω προτάσεις:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ 23/04/2012. Α. Να απαντήσετε με Σ ή Λ στις παρακάτω προτάσεις: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ 23/04/2012 ΘΕΜΑ Α Α. Να απαντήσετε με Σ ή Λ στις παρακάτω προτάσεις: 1. Κάθε βρόγχος που υλοποιείται με την εντολή Για μπορεί να

Διαβάστε περισσότερα

ΔΟΜΗΜΕΝΟΣ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ

ΔΟΜΗΜΕΝΟΣ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ ΕΡΩΤΗΣΕΙΣ 1. Τι καλείται ψευδοκώδικας; 2. Τι καλείται λογικό διάγραμμα; 3. Για ποιο λόγο είναι απαραίτητη η τυποποίηση του αλγόριθμου; 4. Ποιες είναι οι βασικές αλγοριθμικές δομές; 5. Να περιγράψετε τις

Διαβάστε περισσότερα

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΙΜΕΛΕΙΑ: ΜΑΡΙΑ Σ. ΖΙΩΓΑ ΚΑΘΗΓΗΤΡΙΑ ΠΛΗΡΟΦΟΡΙΚΗΣ ΘΕΩΡΙΑ 2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ 1) Πότε χρησιμοποιείται η δομή επανάληψης

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: ΘΕΜΑ Α

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: ΘΕΜΑ Α ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 03-11-2013 ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-4 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη

Διαβάστε περισσότερα

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΠΛΗΡΟΦΟΡΙΚΗ

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΠΛΗΡΟΦΟΡΙΚΗ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΠΛΗΡΟΦΟΡΙΚΗ Ον/μο:.. Γ Λυκείου Ύλη:1-2 Τεχν. Κατ. 03-11-13 ΘΕΜΑ 1 ο Α. 1)Ποιες κατηγορίες προβλημάτων γνωρίζετε; 2)Να αναπτύξετε τα κριτήρια που πρέπει να ικανοποιεί ένας αλγόριθμος. 3)Ποια

Διαβάστε περισσότερα

Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2. Α1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων πληροφορικής

Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2. Α1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων πληροφορικής Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2 Α1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων πληροφορικής Α2. Ο αλγόριθμος αποτελείται από ένα πεπερασμένο σύνολο εντολών Α3. Ο αλγόριθμος

Διαβάστε περισσότερα

Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές (Σ) η λανθασμένες (Λ).

Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές (Σ) η λανθασμένες (Λ). ΚΟΡΥΦΑΙΟ ΦΡΟΝΤΙΣΤΗΡΙΟ korifeo.gr ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: 6 ΘΕΜΑ 1 ο Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙ ΩΝ: 6

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙ ΩΝ: 6 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙ ΩΝ: 6 ΘΕΜΑ 1 ο Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές (Σ) η λανθασµένες

Διαβάστε περισσότερα

ΟΜΟΣΠΟΝ ΙΑ ΕΚΠΑΙ ΕΥΤΙΚΩΝ ΦΡΟΝΤΙΣΤΩΝ ΕΛΛΑ ΟΣ (Ο.Ε.Φ.Ε.) ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2012 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΟΜΟΣΠΟΝ ΙΑ ΕΚΠΑΙ ΕΥΤΙΚΩΝ ΦΡΟΝΤΙΣΤΩΝ ΕΛΛΑ ΟΣ (Ο.Ε.Φ.Ε.) ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2012 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ: ΚΑΤΕΥΘΥΝΣΗ: ΜΑΘΗΜΑ: ΘΕΜΑ Α Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ (2ος Κύκλος) ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ηµεροµηνία: Κυριακή 22 Απριλίου 2012 ΕΚΦΩΝΗΣΕΙΣ Α1. Να γράψετε στο τετράδιό

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 ο Γ ΛΥΚΕΙΟΥ-ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ 1ο ΔΙΑΓΩΝΙΣΜΑ Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές ή λάθος: 1. Ο δομημένος προγραμματισμός στηρίζεται

Διαβάστε περισσότερα

Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι.

Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. σύγχρονο Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. μαθητικό φροντιστήριο 25ης Μαρτίου 111 ΠΕΤΡΟΥΠΟΛΗ 210 50 20 990 210 50 27 990 25ης Μαρτίου 74 ΠΕΤΡΟΥΠΟΛΗ 210 50 50 658 210 50 60 845 Γραβιάς 85 ΚΗΠΟΥΠΟΛΗ

Διαβάστε περισσότερα

8.4. Δραστηριότητες - ασκήσεις

8.4. Δραστηριότητες - ασκήσεις 8.4. Δραστηριότητες - ασκήσεις ΣΤΗΝ ΤΑΞΗ ΔΤ1. ΔΤ2. ΔΤ3. ΔΤ4. Αν η μεταβλητή Α έχει την τιμή 10, η μεταβλητή Β έχει την τιμή 5 και η μεταβλητή Γ έχει την τιμή 3, ποιες από τις παρακάτω εκφράσεις είναι αληθείς

Διαβάστε περισσότερα

ΔΟΚΙΜΑΣΤΙΚΟ ΤΕΣΤ Γ' ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 26 ΑΠΡΙΛΙΟΥ 2017 ΑΕΠΠ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΤΕΣΣΕΡΕΙΣ (4)

ΔΟΚΙΜΑΣΤΙΚΟ ΤΕΣΤ Γ' ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 26 ΑΠΡΙΛΙΟΥ 2017 ΑΕΠΠ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΤΕΣΣΕΡΕΙΣ (4) ΘΕΜΑ 1ο ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΔΟΚΙΜΑΣΤΙΚΟ ΤΕΣΤ Γ' ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 26 ΑΠΡΙΛΙΟΥ 2017 ΑΕΠΠ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΤΕΣΣΕΡΕΙΣ (4) Α. Να γράψετε στο τετράδιο σας τον αριθμό καθεμιάς από τις παρακάτω

Διαβάστε περισσότερα

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΑΡΧΗ 1ης ΣΕΛΙ ΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΔΙΑΓΩΝΙΣΜΑ ΠΕΡΙΟΔΟΥ : ΝΟΕΜΒΡΙΟΥ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ : 7 ΘΕΜΑ Α : Α1

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Κανάρη 36, Δάφνη Τηλ. 210 9713934 & 210 9769376 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ο.Π. ΣΠΟΥΔΩΝ ΟΙΚΟΝΟΜΙΑΣ ΚΑΙ ΠΛΗΡΟΦΟΡΙΚΗΣ Θέμα Α A1. Να γράψετε τον αριθμό καθεμιάς από τις παρακάτω προτάσεις

Διαβάστε περισσότερα

1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες εντολές (μορφές) της;

1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες εντολές (μορφές) της; 1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες (μορφές) της; Η δομή επανάληψης χρησιμοποιείται όταν μια σειρά εντολών πρέπει να εκτελεστεί σε ένα σύνολο περιπτώσεων, που έχουν κάτι

Διαβάστε περισσότερα

8. Επιλογή και επανάληψη

8. Επιλογή και επανάληψη 8. Επιλογή και επανάληψη 8.1 Εντολές Επιλογής ΕΣΕΠ06-Θ1Β5 Η ιεραρχία των λογικών τελεστών είναι µικρότερη των αριθµητικών. ΕΣ07-Θ1Γ5 Η σύγκριση λογικών δεδοµένων έχει έννοια µόνο στην περίπτωση του ίσου

Διαβάστε περισσότερα

Δομή Επιλογής Απαντήσεις Ασκήσεων

Δομή Επιλογής Απαντήσεις Ασκήσεων Δομή Επιλογής Απαντήσεις Ασκήσεων Άσκηση 1. Ποια θα είναι η τιμή της μεταβλητής x μετά την εκτέλεση καθενός από τα παρακάτω τμήματα προγραμμάτων (1 ο τμήμα) (2 ο τμήμα) X 5 X 7 AN X>5 TOTE AN X>5 TOTE

Διαβάστε περισσότερα

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων;

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων; ΦΡΟΝΤΙΣΤΗΡΙΑΚΟΣ ΟΡΓΑΝΙΣΜΟΣ ΘΕΜΑ Α ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ 01/03/2015 Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1.

Διαβάστε περισσότερα

ΦάσµαGroup προπαρασκευή για

ΦάσµαGroup προπαρασκευή για Σύγχρονο ΦάσµαGroup προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι Μαθητικό Φροντιστήριο 25 ης Μαρτίου 74 ΠΛΑΤΕΙΑ ΠΕΤΡΟΥΠΟΛΗΣ 50.50.658 50.60.845 25 ης Μαρτίου 111 ΠΕΤΡΟΥΠΟΛΗ 50.20.990 50.27.990 Γραβιάς 85 ΚΗΠΟΥΠΟΛΗ

Διαβάστε περισσότερα

ΦΡΟΝΤΙΣΤΗΡΙΟ ΦΑΣΜΑ 12/10/2014

ΦΡΟΝΤΙΣΤΗΡΙΟ ΦΑΣΜΑ 12/10/2014 Γ ΤΑΞΗ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α [40 μόρια] ΔΙΑΓΩΝΙΣΜΑ α) Να επιλέξτε το γράμμα Σ, αν μια πρόταση είναι σωστή και

Διαβάστε περισσότερα

ΑΕΠΠ 4o Επαναληπτικό Διαγώνισμα

ΑΕΠΠ 4o Επαναληπτικό Διαγώνισμα ΑΕΠΠ 4o Επαναληπτικό Διαγώνισμα Ονοματεπώνυμο: ΘΕΜΑ 1 A. Να γράψετε τους κανόνες που πρέπει να ακολουθούνται στη χρήση των εμφωλευμένων βρόχων. B. Να χαρακτηρίσετε ως σωστή (Σ) ή λάθος (Λ) καθεμία από

Διαβάστε περισσότερα

ΑΕΠΠ 2o Επαναληπτικό Διαγώνισμα

ΑΕΠΠ 2o Επαναληπτικό Διαγώνισμα ΑΕΠΠ 2o Επαναληπτικό Διαγώνισμα Ονοματεπώνυμο: ΘΕΜΑ 1 A. Να γράψετε τους κανόνες που πρέπει να ακολουθούνται στη χρήση των εμφωλευμένων βρόχων. Β. Na γίνει ο πολλαπλασιασμός 15 * 45 αλά ρώσικα και να γραφεί

Διαβάστε περισσότερα

ΕΝΔΕΙΚΤΙΚΕΣ ΑΣΚΗΣΕΙΣ ΕΡΩΤΗΣΕΙΣ ΑΞΙΟΛΟΓΗΣΗΣ ΓΙΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ

ΕΝΔΕΙΚΤΙΚΕΣ ΑΣΚΗΣΕΙΣ ΕΡΩΤΗΣΕΙΣ ΑΞΙΟΛΟΓΗΣΗΣ ΓΙΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ ΕΝΔΕΙΚΤΙΚΕΣ ΑΣΚΗΣΕΙΣ ΕΡΩΤΗΣΕΙΣ ΑΞΙΟΛΟΓΗΣΗΣ ΓΙΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ Ερωτήσεις Ανάπτυξης 1. Να περιγράψετε τη δομή της λίστας και τη διαδικασία εισαγωγής και διαγραφής ενός κόμβου. 3.9.1 Σελ 71-72

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ _ ΦΥΛΛΟ2

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ _ ΦΥΛΛΟ2 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ _ ΦΥΛΛΟ2 ΑΣΚΗΣΕΙΣ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ 1. Δίνεται ο παρακάτω αλγόριθμος : Αλγόριθμος Παράδειγμα_1 Διάβασε α Αν α > 0 τότε α α mod 5 Τέλος_αν Εκτύπωσε α Τέλος

Διαβάστε περισσότερα

οµές Επανάληψης Π1. Να αναπτύξετε αλγόριθµο που θα εκτυπώνει τους αριθµούς από το 1 ως το 10.

οµές Επανάληψης Π1. Να αναπτύξετε αλγόριθµο που θα εκτυπώνει τους αριθµούς από το 1 ως το 10. Οι δοµές επανάληψης εφαρµόζονται στις περιπτώσεις, όπου µια οµάδα εντολών πρέπει να εκτελεστεί σε ένα σύνολο περιπτώσεων, που έχουν κάτι κοινό. Οι τρεις µορφές δοµών επανάληψης είναι: 1. Επαναληπτική οµή

Διαβάστε περισσότερα

β. Ποια είναι η «τιμή φρουρός» στο παρακάτω τμήμα αλγορίθμου γραμμένο σε «ψευδογλώσσα»; Διάβασε όνομα Όσο όνομα < > ΤΕΛΟΣ επανάλαβε Εμφάνισε όνομα

β. Ποια είναι η «τιμή φρουρός» στο παρακάτω τμήμα αλγορίθμου γραμμένο σε «ψευδογλώσσα»; Διάβασε όνομα Όσο όνομα < > ΤΕΛΟΣ επανάλαβε Εμφάνισε όνομα ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΘΕΜΑ Α. Α1. Δίνεται το παρακάτω τμήμα αλγορίθμου γραμμένο σε «ψευδογλώσσα» το οποίο παραβιάζει δύο(2) αλγοριθμικά κριτήρια: Κ 1 Λ 0 Αρχή_επανάληψης

Διαβάστε περισσότερα

Μάριος Αγγελίδης

Μάριος Αγγελίδης Δομή Επανάληψης Ενότητες βιβλίου: 2.4.5, 8.2, 8.2.1, 8.2.2, 8.2.3 Ώρες διδασκαλίας: 5 Η δομή επανάληψης χρησιμοποιείται όταν έχουμε μία ομάδα εντολών που θέλουμε να εκτελεστούν πολλές φορές. Υπάρχουν τρείς

Διαβάστε περισσότερα

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΙΜΕΛΕΙΑ: ΜΑΡΙΑ Σ. ΖΙΩΓΑ ΚΑΘΗΓΗΤΡΙΑ ΠΛΗΡΟΦΟΡΙΚΗΣ ΑΣΚΗΣΕΙΣ 2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΕΡΩΤΗΣΕΙΣ ΣΩΣΤΟ ΛΑΘΟΣ Σημειώστε αν είναι

Διαβάστε περισσότερα

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 16/12/2008. Τµήµα ΓΤ2 Όνοµα:...

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 16/12/2008. Τµήµα ΓΤ2 Όνοµα:... ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 16/12/2008 Τµήµα ΓΤ2 Όνοµα:... ΘΕΜΑ 1 ο. Α) Να γράψετε στο φύλλο απαντήσεών σας Σ εάν κρίνετε ότι η πρόταση είναι σωστή και

Διαβάστε περισσότερα

Β ΛΥΚΕΙΟΥ ΕΙΣΑΓΩΓΗ ΣΤΙΣ ΑΡΧΕΣ ΤΗΣ ΕΠΙΣΤΗΜΗΣ ΤΩΝ Η/Υ

Β ΛΥΚΕΙΟΥ ΕΙΣΑΓΩΓΗ ΣΤΙΣ ΑΡΧΕΣ ΤΗΣ ΕΠΙΣΤΗΜΗΣ ΤΩΝ Η/Υ ΕΡΩΤΗΣΕΙΣ Να γράψετε στο γραπτό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-4 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος, αν είναι λανθασμένη. 1. Ένας αλγόριθμος είναι μία πεπερασμένη

Διαβάστε περισσότερα

Α4. Δίδεται ο παρακάτω αλγόριθμος

Α4. Δίδεται ο παρακάτω αλγόριθμος Διαγώνισμα 2014-15 Ανάπτυξη Εφαρμογών σε Πραγματικό Περιβάλλον Επώνυμο Όνομα Εξεταζόμενο μάθημα Γ Λυκείου Κυριακή 02/11/2014 Τμήμα Ημερομηνία Τάξη Θέμα Α A1. Επιλέξτε Σωστό ή Λάθος για τις παρακάτω προτάσεις:

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Θέμα 1 ο Α. Δίνεται η παρακάτω ακολουθία εντολών αλγορίθμου: ΑΛΓΟΡΙΘΜΟΣ Θέμα1 ΔΕΔΟΜΕΝΑ // Ν // Σ 0 π 0 ΓΙΑ ι ΑΠΟ -10 ΜΕΧΡΙ Ν ΔΙΑΒΑΣΕ α, β Σ Σ + α+ β π

Διαβάστε περισσότερα

Φύλλο εργασίας 3 ο Δομή επιλογής Εισαγωγή στις Αρχές της Επιστήμης Η/Υ.

Φύλλο εργασίας 3 ο Δομή επιλογής Εισαγωγή στις Αρχές της Επιστήμης Η/Υ. Φύλλο εργασίας 3 ο Δομή επιλογής Εισαγωγή στις Αρχές της Επιστήμης Η/Υ. Στα προβλήματα που αντιμετωπίσατε μέχρι τώρα, εκτελούνταν όλες οι εντολές σειριακά (η μια εντολή μετά την άλλη). Στην πραγματικότητα

Διαβάστε περισσότερα

ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2013 ΕΚΦΩΝΗΣΕΙΣ

ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2013 ΕΚΦΩΝΗΣΕΙΣ ΤΑΞΗ: ΚΑΤΕΥΘΥΝΣΗ: ΜΑΘΗΜΑ: Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ (2ος Κύκλος) ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω

Διαβάστε περισσότερα

ΠΡΟΤΕΙΝΟΜΕΝΟ ΔΙΑΓΩΝΙΣΜΑ ΑΕΠΠ. (Α) Να απαντήσετε στη παρακάτω ερώτηση : Τι είναι ένα υποπρόγραμμα; Τι γνωρίζετε για τα χαρακτηριστικά του; (10 Μονάδες)

ΠΡΟΤΕΙΝΟΜΕΝΟ ΔΙΑΓΩΝΙΣΜΑ ΑΕΠΠ. (Α) Να απαντήσετε στη παρακάτω ερώτηση : Τι είναι ένα υποπρόγραμμα; Τι γνωρίζετε για τα χαρακτηριστικά του; (10 Μονάδες) ΠΡΟΤΕΙΝΟΜΕΝΟ ΔΙΑΓΩΝΙΣΜΑ ΑΕΠΠ ΘΕΜΑ 1 ο (Α) Να απαντήσετε στη παρακάτω ερώτηση : Τι είναι ένα υποπρόγραμμα; Τι γνωρίζετε για τα χαρακτηριστικά του; (10 Μονάδες) (Β) Να σημειώσετε με κατάλληλο τρόπο ανάλογα

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΣΧ... ΕΤΤΟΣΣ 22000099-22001100 Επιμέλεια : Ομάδα Διαγωνισμάτων από Το στέκι των πληροφορικών Θέμα 1 ο Α. Δίνεται η παρακάτω ακολουθία

Διαβάστε περισσότερα

Τ και τιµή του Β θετική µετατρέπεται ισοδύναµα στην εντολή Όσο ως εξής:

Τ και τιµή του Β θετική µετατρέπεται ισοδύναµα στην εντολή Όσο ως εξής: ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ ΕΞΕΤΑΣΕΙΣ ΠΡΟΣΟΜΟΙΩΣΗΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 12 ΙΑΝΟΥΑΡΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ: Θέμα 1ο I. Δίνεται το παρακάτω τμήμα αλγορίθμου. Να εξετάσετε αν ικανοποιεί τα αλγοριθμικά κριτήρια. Γράψε 'Δώσε

Διαβάστε περισσότερα

2. Στον παραπάνω πίνακα προσθέτουμε (εφόσον χρειάζεται) μια ακόμη στήλη που την ονομάζουμε έξοδο και στην οποία γράφουμε ότι εμφανίζεται.

2. Στον παραπάνω πίνακα προσθέτουμε (εφόσον χρειάζεται) μια ακόμη στήλη που την ονομάζουμε έξοδο και στην οποία γράφουμε ότι εμφανίζεται. Κατηγορία 1 η Πίνακες τιμών Τρόπος αντιμετώπισης: 1. Για να παρακολουθούμε τις τιμές των μεταβλητών δημιουργούμε ένα πίνακα τιμών ο οποίος έχει τόσες στήλες όσες και οι διαφορετικές μεταβλητές που υπάρχουν

Διαβάστε περισσότερα

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Επιμέλεια: Χρύσα Παπαγεωργίου 1. Δίνονται δύο αριθμοί. Να υπολογισθεί το άθροισμα και το γινόμενό τους. 2. Δίνονται τρεις αριθμοί. Να υπολογισθεί ο μέσος

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΘΕΜΑ Α ΑΠΑΝΤΗΣΕΙΣ Α1. α. Παραβιάζει τα κριτήρια της καθοριστικότητας και της περατότητας β. Αιτιολόγηση: ο αλγόριθμος παραβιάζει το κριτήριο

Διαβάστε περισσότερα

Α1. Να χαρακτηρίσετε καθεμία από τις παρακάτω προτάσεις με τη λέξη Σωστή ή με τη λέξη Λάθος.

Α1. Να χαρακτηρίσετε καθεμία από τις παρακάτω προτάσεις με τη λέξη Σωστή ή με τη λέξη Λάθος. ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / Γ- ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ (ΘΕΡΙΝΑ) ΗΜΕΡΟΜΗΝΙΑ: 08-11-2015 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι.ΜΙΧΑΛΕΑΚΟΣ- Α.ΚΑΤΡΑΚΗ - Π.ΣΙΟΤΡΟΠΟΣ ΘΕΜΑ Α Α1. Να χαρακτηρίσετε καθεμία από τις παρακάτω προτάσεις

Διαβάστε περισσότερα

ΑΣΚΗΣΕΙΣ Επανάληψης 1 1. Να γραφτεί αλγόριθμος που να δέχεται από το πληκτρολόγιο θετικούς ακέραιους μέχρι να δοθεί το 0 ή αρνητικός.

ΑΣΚΗΣΕΙΣ Επανάληψης 1 1. Να γραφτεί αλγόριθμος που να δέχεται από το πληκτρολόγιο θετικούς ακέραιους μέχρι να δοθεί το 0 ή αρνητικός. ΑΣΚΗΣΕΙΣ Επανάληψης 1 1. Να γραφτεί αλγόριθμος που να δέχεται από το πληκτρολόγιο θετικούς ακέραιους μέχρι να δοθεί το 0 ή αρνητικός. Να βρεθεί ποιος ήταν ο μεγαλύτερος αριθμός από αυτούς που δόθηκαν.

Διαβάστε περισσότερα

2. Να αντιστοιχίσετε κάθε εδομένο της Στήλης Α με το σωστό Τύπο εδομένου της Στήλης Β.

2. Να αντιστοιχίσετε κάθε εδομένο της Στήλης Α με το σωστό Τύπο εδομένου της Στήλης Β. 1. Δίνεται ο παρακάτω αλγόριθμος σε μορφή διαγράμματος ροής: α. Να κατασκευάσετε ισοδύναμο αλγόριθμο σε ψευδογλώσσα. β. Να εκτελέσετε τον αλγόριθμο για κάθε μία από τις παρακάτω τιμές της μεταβλητής Χ.

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 08 / 02 / 2015 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι. ΜΙΧΑΛΕΑΚΟΣ- Α.ΚΑΤΡΑΚΗ - Π.

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 08 / 02 / 2015 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι. ΜΙΧΑΛΕΑΚΟΣ- Α.ΚΑΤΡΑΚΗ - Π. ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 08 / 02 / 2015 ΕΠΙΜΕΛΕΙΑ ΔΙΑΓΩΝΙΣΜΑΤΟΣ: Ι. ΜΙΧΑΛΕΑΚΟΣ- Α.ΚΑΤΡΑΚΗ - Π.ΣΙΟΤΡΟΠΟΣ ΘΕΜΑ Α Α1. Να γράψετε στο γραπτό σας τον αριθμό καθεμιάς από τις παρακάτω

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ 2012

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ 2012 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ 2012 ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή,

Διαβάστε περισσότερα

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΘΕΜΑ Α Α1. Να χαρακτηρίσετε καθεμιά από τις προτάσεις που ακολουθούν γράφοντας στο τετράδιό σας, δίπλα από τον αριθμό κάθε πρότασης, το γράμμα Σ, αν αυτή

Διαβάστε περισσότερα

Δομή επιλογής - πακέτο 1. Άσκηση 1. Να συμπληρώσετε τον παρακάτω πίνακα με τις τιμές αληθής - ψευδής. (α <= β) και (β >= γ)

Δομή επιλογής - πακέτο 1. Άσκηση 1. Να συμπληρώσετε τον παρακάτω πίνακα με τις τιμές αληθής - ψευδής. (α <= β) και (β >= γ) Δομή επιλογής - πακέτο 1 Άσκηση 1. Να συμπληρώσετε τον παρακάτω πίνακα με τις τιμές αληθής - ψευδής α β γ (α mod 2 = 0) ή (β β) ή (γ >=2) (γ >= α) και (β div 2 = 1)

Διαβάστε περισσότερα

Δομές Ακολουθίας- Επιλογής - Επανάληψης. Δομημένος Προγραμματισμός

Δομές Ακολουθίας- Επιλογής - Επανάληψης. Δομημένος Προγραμματισμός Δομές Ακολουθίας- Επιλογής - Επανάληψης Δομημένος Προγραμματισμός 1 Βασικές Έννοιες αλγορίθμων Σταθερές Μεταβλητές Εκφράσεις Πράξεις Εντολές 2 Βασικές Έννοιες Αλγορίθμων Σταθερά: Μια ποσότητα που έχει

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΘΕΜΑ 1ο Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό, αν είναι σωστή,

Διαβάστε περισσότερα

1. Όλα τα προβλήματα μπορούν να λυθούν με τη βοήθεια HY. 2. Ο υπολογισμός του εμβαδού τετραγώνου είναι πρόβλημα άλυτο.

1. Όλα τα προβλήματα μπορούν να λυθούν με τη βοήθεια HY. 2. Ο υπολογισμός του εμβαδού τετραγώνου είναι πρόβλημα άλυτο. Κεφάλαιο 2.1. Πρόβλημα >ΕΝΟΤΗΤΑ 2/ΚΕΦ.2.1/ ΤΥΠΟΥ Β1: ΣΩΣΤΟ-ΛΑΘΟΣ GI_V_EIY_0_19376 Β1. Να γράψετε στο γραπτό σας τον αριθμό κάθε πρότασης και δίπλα τη λέξη Σωστό, αν η πρόταση είναι σωστή, ή τη λέξη Λάθος

Διαβάστε περισσότερα

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1 ΣΩΣΤΟ 2 ΛΑΘΟΣ 3 ΛΑΘΟΣ 4 ΛΑΘΟΣ 5 - ΣΩΣΤΟ Α5. Α3.

ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1 ΣΩΣΤΟ 2 ΛΑΘΟΣ 3 ΛΑΘΟΣ 4 ΛΑΘΟΣ 5 - ΣΩΣΤΟ Α5. Α3. ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΤΕΤΑΡΤΗ 08/04/2015 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΔΕΚΑ (10) ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. 1

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2013-2014

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2013-2014 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2013-2014 Επιμέλεια: Ομάδα Διαγωνισμάτων από το Στέκι των Πληροφορικών Θέμα Α A1. Να γράψετε στο τετράδιό σας τους

Διαβάστε περισσότερα

επιστρέφει αριθµό που προκύπτει µε αντιστροφή των στοιχείων του πρώτου

επιστρέφει αριθµό που προκύπτει µε αντιστροφή των στοιχείων του πρώτου ΑΕσΠΠ-Κεφ.10 Υποπρογράµµατα 1 1. Να γραφεί µία συνάρτηση για κάθε ένα από τα παρακάτω: i. Να δέχεται την ακτίνα ενός κύκλου και να επιστρέφει το εµβαδόν του. ii. Να δέχεται την ακτίνα ενός κύκλου και να

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΔΕΥΤΕΡΑ 12 ΙΟΥΝΙΟΥ 2017 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ ΣΥΝΟΛΟ

Διαβάστε περισσότερα

Κεφαλαιο 2.2 ΑΝΑΚΕΦΑΛΑΙΩΤΙΚΕΣ ΑΛΓΟΡΙΘΜΟΙ

Κεφαλαιο 2.2 ΑΝΑΚΕΦΑΛΑΙΩΤΙΚΕΣ ΑΛΓΟΡΙΘΜΟΙ Κεφαλαιο 2.2 ΑΝΑΚΕΦΑΛΑΙΩΤΙΚΕΣ ΑΛΓΟΡΙΘΜΟΙ 1.Σ, 2.Σ, 3. Λ, 4.Σ, 5.Σ Στο α) ανήκουν: 1,2,5,6,7 Στο β) ανήκουν: 3,4,8,9,10 1.-Λ, 2.-Λ, 3.-Σ, 4.-Σ, 5.-Σ 1. -Πραγματικός, 2. -Αρφαριθμητικός, 3.-Αλφαριθμητικός,

Διαβάστε περισσότερα

ΘΕΜΑΤΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 1/12/2013

ΘΕΜΑΤΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 1/12/2013 ΘΕΜΑΤΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 1/12/2013 ΘΕΜΑ 1 ο Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις και δίπλα τη λέξη Σωστό,

Διαβάστε περισσότερα

ΘΕΜΑ 1 ο. S <-- 0 ιάβασε Υ Όσο α <= Υ επανάλαβε S <-- S +α. Τέλος_επανάληψης

ΘΕΜΑ 1 ο. S <-- 0 ιάβασε Υ Όσο α <= Υ επανάλαβε S <-- S +α. Τέλος_επανάληψης ΑΡΧΗ 1 ΗΣ ΣΕΛΙ ΑΣ Γ ΛΥΚΕΙΟΥ ΦΡΟΝΤΙΣΤΗΡΙΑ ΘΕΩΡΙΑ ΚΑΙ ΠΡΑΞΗ ΙΑΓΩΝΙΣΜΑ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 ο Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από

Διαβάστε περισσότερα

Ασκήσεις στη δομή επιλογής

Ασκήσεις στη δομή επιλογής Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον 1 Ασκήσεις στη δομή επιλογής Εμφάνιση μηνυμάτων Έλεγχος περιπτώσεων 1. Να γραφεί αλγόριθμος ο οποίος να διαβάζει τρεις αριθμούς και να εμφανίζει το μεγαλύτερο

Διαβάστε περισσότερα

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΔΙΑΓΩΝΙΣΜΑ ΠΕΡΙΟΔΟΥ : ΜΑΪΟΥ

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΔΙΑΓΩΝΙΣΜΑ ΠΕΡΙΟΔΟΥ : ΜΑΪΟΥ ΑΡΧΗ 1ης ΣΕΛΙ ΑΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ : Γ ΛΥΚΕΙΟΥ ΣΠΟΥΔΕΣ ΟΙΚΟΝΟΜΙΑΣ & ΠΛΗΡΟΦΟΡΙΚΗΣ ΔΙΑΓΩΝΙΣΜΑ ΠΕΡΙΟΔΟΥ : ΜΑΪΟΥ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ : 7 ΘΕΜΑ Α : Α1. Να

Διαβάστε περισσότερα

ΔΙΑΓΩΝΙΣΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ: Β - Γ ΛΥΚΕΙΟΥ ΤΜΗΜΑΤΑ: Β(ΧΟΛΑΡΓΟΣ) HM/NIA: 15/1/2017

ΔΙΑΓΩΝΙΣΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ: Β - Γ ΛΥΚΕΙΟΥ ΤΜΗΜΑΤΑ: Β(ΧΟΛΑΡΓΟΣ) HM/NIA: 15/1/2017 ΔΙΑΓΩΝΙΣΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ: Β - Γ ΛΥΚΕΙΟΥ ΤΜΗΜΑΤΑ: Β(ΧΟΛΑΡΓΟΣ) HM/NIA: 15/1/2017 ΘΕΜΑ Α (Α1) Απαντήστε στις παρακάτω ερωτήσεις επιλέγοντας Σ (Σωστό) ή Λ (Λάθος).

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ Α3. α. (σελ. 183-184) Στοίβα: ώθηση, απώθηση Ουρά:

Διαβάστε περισσότερα

ΤΡΙΩΡΗ ΓΡΑΠΤΗ ΔΟΚΙΜΑΣΙΑ

ΤΡΙΩΡΗ ΓΡΑΠΤΗ ΔΟΚΙΜΑΣΙΑ ΤΡΙΩΡΗ ΓΡΑΠΤΗ ΔΟΚΙΜΑΣΙΑ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 ο Α. Δίνεται η εντολή εκχώρησης: τ κ < λ Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος. Να δικαιολογήσετε

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο Να περιγραφεί η δομή επανάληψης Αρχή_επανάληψης Μέχρις_ότου

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο Να περιγραφεί η δομή επανάληψης Αρχή_επανάληψης Μέχρις_ότου 2.87 Να περιγραφεί η δομή επανάληψης Μέχρις_ότου Ημορφή της δομής επανάληψης Μέχρις_ότου είναι: Μέχρις_ότου Συνθήκη Η ομάδα εντολών στο εσωτερικό της επανάληψης, εκτελείται μέχρις ότου ισχύει η συνθήκη

Διαβάστε περισσότερα

Να γράψετε τα αποτελέσματα αυτού του αλγόριθμου για Χ=13, Χ=9 και Χ=22. Και στις 3 περιπτώσεις το αποτέλεσμα του αλγορίθμου είναι 1

Να γράψετε τα αποτελέσματα αυτού του αλγόριθμου για Χ=13, Χ=9 και Χ=22. Και στις 3 περιπτώσεις το αποτέλεσμα του αλγορίθμου είναι 1 Άσκηση 1. Δίνεται ο παρακάτω αλγόριθμος: ΑΛΓΟΡΙΘΜΟΣ ΕΛΕΓΧΟΣ_ΑΝΑΘΕΣΗΣ ΔΙΑΒΑΣΕ X ΌΣΟ Χ > 1 ΕΠΑΝΑΛΑΒΕ ΑΝ Χ MOD 2 = 0 ΤΟΤΕ Χ Χ / 2 Χ 3 * Χ + 1 ΑΠΟΤΕΛΕΣΜΑΤΑ // Χ // ΤΕΛΟΣ ΕΛΕΓΧΟΣ_ΑΝΑΘΕΣΗΣ Να γράψετε τα αποτελέσματα

Διαβάστε περισσότερα

Α2. Να γράψετε στο τετράδιο σας τον αριθμό 1-4 κάθε πρότασης και δίπλα το γράμμα που δίνει τη σωστή επιλογή.

Α2. Να γράψετε στο τετράδιο σας τον αριθμό 1-4 κάθε πρότασης και δίπλα το γράμμα που δίνει τη σωστή επιλογή. ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΚΥΡΙΑΚΗ 23/04/2017 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΕΠΠ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: ΕΠΤΑ ( 7) ΘΕΜΑ Α Α1. Να χαρακτηρίσετε τις προτάσεις που ακολουθούν γράφοντας στο

Διαβάστε περισσότερα

Ένα περιοδικό για το ΑΕΠΠ Τεύχος Πανελλαδικών ΙΙ

Ένα περιοδικό για το ΑΕΠΠ Τεύχος Πανελλαδικών ΙΙ Ένα περιοδικό για το ΑΕΠΠ Τεύχος Πανελλαδικών ΙΙ Περιλαμβάνει τα δεύτερα θέματα των πανελληνίων εξετάσεων από το 2000 μέχρι και σήμερα ΑΠΟΛΥΤΗΡΙΕΣ ΓΕΝΙΚΟΥ 2000 Έστω τμήμα αλγορίθμου με μεταβλητές Α, Β,

Διαβάστε περισσότερα

Φύλλο εργασίας 4 ο Δομή επανάληψης Εισαγωγή στις Αρχές της Επιστήμης Η/Υ.

Φύλλο εργασίας 4 ο Δομή επανάληψης Εισαγωγή στις Αρχές της Επιστήμης Η/Υ. Φύλλο εργασίας 4 ο Δομή επανάληψης Εισαγωγή στις Αρχές της Επιστήμης Η/Υ. Λίγοι αλγόριθμοι χρησιμοποιούν μόνο τις δομές ακολουθίας και επιλογής. Στα ρεαλιστικά προβλήματα χρειάζεται συνήθως μια σειρά εντολών

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ 1) Χ 0 ΟΣΟ Χ<10 ΕΠΑΝΑΛΑΒΕ X X+3 ΓΡΑΨΕ Χ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 2) Χ 0 ΟΣΟ Χ<14 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ Χ X X+3 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ 1) Χ 0 ΟΣΟ Χ<10 ΕΠΑΝΑΛΑΒΕ X X+3 ΓΡΑΨΕ Χ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 2) Χ 0 ΟΣΟ Χ<14 ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ Χ X X+3 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ 1ο ΓΕΛ ΠΕΥΚΗΣ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ Α' ΤΕΤΡΑΜΗΝΟΥ ΤΕΤΑΡΤΗ 11 ΙΑΝΟΥΑΡΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α Α1. Δίνεται η παρακάτω εντολή

Διαβάστε περισσότερα

Σελίδα 1 από 7 ΔΙΑΓΩΝΙΣΜΑ ΕΚΠ. ΕΤΟΥΣ ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ:

Σελίδα 1 από 7 ΔΙΑΓΩΝΙΣΜΑ ΕΚΠ. ΕΤΟΥΣ ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 08-09-2013 ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-8 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη

Διαβάστε περισσότερα

Ονοματεπώνυμο: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον. Δομή Ακολουθίας και Επιλογής Κεφ: 2.1, 2.3, , 6.3, , 8.1, 8.1.

Ονοματεπώνυμο: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον. Δομή Ακολουθίας και Επιλογής Κεφ: 2.1, 2.3, , 6.3, , 8.1, 8.1. Ονοματεπώνυμο: Μάθημα: Υλη: Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Δομή Ακολουθίας και Επιλογής Κεφ: 2.1, 2.3, 2.4.1-2.4.4, 6.3, 7.1-7.10, 8.1, 8.1.1 Επιμέλεια διαγωνίσματος: Ρομπογιαννάκη Ι.Αικατερίνη

Διαβάστε περισσότερα