Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές αλγοριθμικές δομές

Μέγεθος: px
Εμφάνιση ξεκινά από τη σελίδα:

Download "Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές αλγοριθμικές δομές"

Transcript

1 Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές αλγοριθμικές δομές

2 Βασικές Αλγοριθμικές Δομές 2

3 Εισαγωγή Οι αλγοριθμικές δομές εκφράζουν διαφορετικούς τρόπους γραφής ενός αλγορίθμου. Οι αλγοριθμικές δομές είναι τρεις: Δομή ακολουθίας Δομή επιλογής Δομή επανάληψης 3

4 Στοιχεία Ψευδογλώσσας Σταθερές Μεταβλητές Εκφράσεις Τελεστές Σχήματα Λογικών Υποθέσεων Επαναληπτικές Διαδικασίες Εντολές Εκχώρησης Ρήματα σε Προστακτική Ουσιαστικά Σχόλια Πρώτη & Τελευταία Γραμμή Δεδομένα & Αποτελέσματα 4

5 Σταθερές (Constants) Αναφερόμαστε σε προκαθορισμένες τιμές που παραμένουν αμετάβλητες σε όλη τη διάρκεια εκτέλεσης ενός αλγορίθμου: Αριθμητικές: αριθμητικοί χαρακτήρες, συν, πλην, κόμμα Αλφαριθμητικές: Οποιοσδήποτε χαρακτήρας εντός εισαγωγικών Λογικές: Αληθής ή Ψευδής 5

6 Μεταβλητές (Variables) Είναι ένα γλωσσικό στοιχείο που χρησιμοποιείται για να παραστήσει ένα στοιχείο δεδομένου. Στη μεταβλητή γίνεται εκχώρηση μίας τιμής, η οποία μπορεί να αλλάζει κατά τη διάρκεια εκτέλεσης του αλγορίθμου: Αριθμητικές Αλφαριθμητικές Λογικές Για τη σύνθεση του ονόματος μίας μεταβλητής χρησιμοποιούνται αριθμητικοί χαρακτήρες, αλφαριθμητικοί χαρακτήρες (πεζοί και κεφαλαίοι) και ο χαρακτήρας της κάτω παύλας. 6

7 Εκφράσεις (Expressions) Οι εκφράσεις διαμορφώνονται από τους τελεστέους (operands), σταθερές & μεταβλητές, και από τους τελεστές. Η διεργασία αποτίμησης μιας έκφρασης συνιστάται στην απόδοση τιμών στις μεταβλητές και στην εκτέλεση των πράξεων. Η τελική τιμή μιας έκφρασης εξαρτάται από την ιεραρχία των πράξεων και τη χρήση παρενθέσεων. Μια έκφραση μπορεί να αποτελείται από μία μόνο μεταβλητή ή σταθερά έως και πολύπλοκες μαθηματικές εκφράσεις. 7

8 Τελεστές (Operators) Πρόκειται για τα γνωστά σύμβολα που χρησιμοποιούνται στις διάφορες πράξεις Αριθμητικοί: +, -, *, /, ^ Συγκριτικοί: <=, <, =, <>, >, >= Λογικοί: και (σύζευξη), ή (διάζευξη), όχι (άρνηση) 8

9 Σχήματα Λογικών Υποθέσεων (1/3) αν συνθήκη τότε εντολή1 (εντολές1) αλλιώς εντολή2 (εντολές2) τέλος_αν 9

10 Σχήματα Λογικών Υποθέσεων (2/3) αν συνθήκη1 τότε εντολή1 (εντολές1) αλλιώς_αν συνθήκη2 τότε εντολή2 (εντολές2) αλλιώς_αν συνθήκη3 τότε εντολή3 (εντολές3) αλλιώς τέλος_αν 10

11 Σχήματα Λογικών Υποθέσεων (3/3) επίλεξε μεταβλητή περίπτωση λίστα_τιμών1 εντολή1 (εντολές1) περίπτωση λίστα_τιμών2 εντολή2 (εντολές2) περίπτωση αλλιώς εντολήν (εντολέςν) τέλος_επιλογών 11

12 Επαναληπτικές Διαδικασίες (1/3) όσο συνθήκη επανέλαβε εντολή (εντολές) τέλος_επανάληψης 12

13 Επαναληπτικές Διαδικασίες (2/3) αρχή_επανάληψης εντολή (εντολές) μέχρις_ότου συνθήκη 13

14 Επαναληπτικές Διαδικασίες (3/3) για μεταβλητή από αρχική_τιμή μέχρι τελική_τιμή με βήμα βήμα εντολή (εντολές) τέλος_επανάληψης 14

15 Εντολές Εκχώρησης Σταθερά τιμή Μεταβλητή τιμή Μεταβλητή σταθερά Μεταβλητή μεταβλητή Μεταβλητή έκφραση 15

16 Ρήματα σε Προστακτική Γράψε Διάβασε Τύπωσε 16

17 Ουσιαστικά Σε ορισμένες περιπτώσεις όταν οι ζητούμενες ενέργειες είναι πολλές ή προφανείς, καθορίζονται με τη χρήση ουσιαστικών αντί ρημάτων: Εισαγωγή δεδομένων Εκτύπωση αποτελεσμάτων 17

18 Σχόλια Προκειμένου να διαχωρίζονται οι επεξηγηματικές φράσεις από τις βασικές λέξεις ή φράσεις του αλγορίθμου, προτάσσεται στις πρώτες το σύμβολο του θαυμαστικού (!) 18

19 Πρώτη & Τελευταία Γραμμή πρόγραμμα όνομα_προγράμματος τέλος_προγράμματος όνομα_προγράμματος 19

20 Δομή Ακολουθίας 20

21 Ακολουθιακή Δομή Η ακολουθιακή δομή είναι η πιο απλή αλγοριθμική δομή στην οποία όλες οι εντολές του αλγορίθμου εκτελούνται: η μία μετά την άλλη (ακολουθιακά) μόνο μία φορά η κάθε μία υποχρεωτικά (δηλαδή δεν αγνοείται κάποια εντολή όπως συμβαίνει σε άλλες αλγοριθμικές δομές) Η ακολουθιακή δομή υλοποιείται με τις εντολές: διάβασε γράψε καταχώρισε ( ) 21

22 Δομή Ακολουθίας (1/4) Η ακολουθιακή δομή εντολών (σειριακών βημάτων) χρησιμοποιείται πρακτικά για την αντιμετώπιση απλών προβλημάτων, όπου είναι δεδομένη η σειρά εκτέλεσης ενός συνόλου ενεργειών. Ένας αλγόριθμος διατυπωμένος σε ψευδογλώσσα αρχίζει πάντα με τη λέξη πρόγραμμα συνοδευόμενη με το όνομα του αλγορίθμου και τελειώνει με τη λέξη τέλος_προγράμματος συνοδευόμενη επίσης με το όνομα. 22

23 Δομή Ακολουθίας (2/4) Η πρώτη ενέργεια που γίνεται είναι η εισαγωγή δεδομένων με τη χρήση του ρήματος διάβασε Η λέξη διάβασε συνοδεύεται με το όνομα μίας ή περισσοτέρων μεταβλητών, και εννοείται ότι μετά την ολοκλήρωση της ενέργειας αυτής, η μεταβλητή θα έχει λάβει κάποια αριθμητική τιμή ως περιεχόμενο. Κάθε μία λέξη της χρησιμοποιούμενης ψευδογλώσσας, που προσδιορίζει μια σαφή ενέργεια θα αποκαλείται στο εξής εντολή. Όλες οι εντολές σε ένα αλγόριθμο αποτυπώνονται με διαφορετικό χρώμα από το όνομα του αλγορίθμου και τις διάφορες σταθερές και μεταβλητές. 23

24 Δομή Ακολουθίας (3/4) Στη συνέχεια ακολουθεί η εντολή εκχώρησης τιμής. Η γενική μορφή της είναι: Μεταβλητή Έκφραση Η λειτουργία της είναι να γίνονται οι πράξεις στην έκφραση και το αποτέλεσμα να αποδίδεται, μεταβιβάζεται, εκχωρείται στη μεταβλητή. Στην εντολή αυτή χρησιμοποιείται το αριστερό βέλος, προκειμένου να δείχνει τη φορά της εκχώρησης. 24

25 Δομή Ακολουθίας (4/4) Ο αλγόριθμος ολοκληρώνεται με την εντολή εκτύπωσε που αποτυπώνει το τελικό αποτέλεσμα στον εκτυπωτή. Η σύνταξη της είναι ανάλογη με αυτή της εντολής διάβασε. Εναλλακτικά μπορεί να χρησιμοποιηθεί και η εντολή γράψε που αποτυπώνει ένα αποτέλεσμα στην οθόνη. 25

26 Παράδειγμα(1) Να δοθεί αλγόριθμος για τον υπολογισμό εμβαδού τριγώνου. Ε=(β*υ)/2 26

27 Λύση(1) Α τρόπος: ΑΛΓΟΡΙΘΜΟΣ ΕΜΒΑΔΟΝ_ΤΡΙΓΩΝΟΥ ΑΡΧΗ ΔΙΑΒΑΣΕ ΒΑΣΗ, ΥΨΟΣ ΕΜΒΑΔΟΝ ΒΑΣΗ * ΥΨΟΣ/2 ΕΜΦΑΝΙΣΕ ΤΟ ΕΜΒΑΔΟΝ ΕΙΝΑΙ:, ΕΜΒΑΔΟΝ ΤΕΛΟΣ ΕΜΒΑΔΟΝ_ΤΡΙΓΩΝΟΥ 27

28 Λύση(2) Β τρόπος: ΠΡΟΓΡΑΜΜΑ ΕΜΒΑΔΟΝ_ΤΡΙΓΩΝΟΥ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ:ΒΑΣΗ, ΥΨΟΣ, ΕΜΒΑΔΟΝ ΑΡΧΗ ΔΙΑΒΑΣΕ ΒΑΣΗ, ΥΨΟΣ ΕΜΒΑΔΟΝ ΒΑΣΗ * ΥΨΟΣ/2 ΓΡΑΨΕ ΤΟ ΕΜΒΑΔΟΝ ΕΙΝΑΙ:,ΕΜΒΑΔΟΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΕΜΒΑΔΟΝ_ΤΡΙΓΩΝΟΥ 28

29 Άσκηση 1 Να δοθεί αλγόριθμος για τον υπολογισμό της περιμέτρου ενός κύκλου. περ=2πρ π=3,14 29

30 Λύση Άσκησης 1 ΠΡΟΓΡΑΜΜΑ ΠΕΡΙΜΕΤΡΟΣ_ΚΥΚΛΟΥ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: ΑΚΤΙΝΑ, ΠΕΡΙΜΕΤΡΟΣ, Π ΑΡΧΗ ΔΙΑΒΑΣΕ ΑΚΤΙΝΑ Π 3.14 ΠΕΡΙΜΕΤΡΟΣ 2*ΑΚΤΙΝΑ*Π ΓΡΑΨΕ Η ΠΕΡΙΜΕΤΡΟΣ ΕΙΝΑΙ, ΠΕΡΙΜΕΤΡΟΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΠΕΡΙΜΕΤΡΟΣ_ΚΥΚΛΟΥ 30

31 Άσκηση 2 Να δοθεί αλγόριθμος ο οποίος θα μετατρέπει μια θερμοκρασία από βαθμούς Φαρενάιτ σε βαθμούς Κελσίου. Ο παρακάτω τύπος εκφράζει τη σχέση που υπάρχει μεταξύ βαθμών Φαρενάιτ και Κελσίου: (F-32)/9=C/5 Οπότε C=5/9*(F-32) 31

32 Λύση Άσκησης 2 ΠΡΟΓΡΑΜΜΑ ΦΑΡΕΝΑΪΤ_ΚΕΛΣΙΟΥ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ:F, C ΑΡΧΗ ΔΙΑΒΑΣΕ F C 5/9*(F-32) ΓΡΑΨΕ ΟΙ ΒΑΘΜΟΙ ΚΕΛΣΙΟΥ ΕΙΝΑΙ:,C ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΦΑΡΕΝΑΪΤ_ ΚΕΛΣΙΟΥ 32

33 Άσκηση 3 Αν έχετε τις παρακάτω πληροφορίες: ΝΟΜΙΣΜΑ ΤΙΜΗ ΠΩΛΗΣΗΣ Λίρα Αγγλίας 1,25 Δολάριο Αμερικής 0,85 Γιεν Ιαπωνίας 0,0075 Να δώσετε αλγόριθμο που να υπολογίζει σε το σύνολο από 1025 λίρες Αγγλίας, 2234 δολάρια Αμερικής και Γιεν Ιαπωνίας. 33

34 Λύση Άσκησης 3 ΠΡΟΓΡΑΜΜΑ ΣΥΝΑΛΛΑΓΜΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ:ΛΙΡΑ, ΔΟΛΑΡΙΟ, ΓΙΕΝ, ΕΥΡΩ ΑΡΧΗ ΛΙΡΑ 1,25 ΔΟΛΑΡΙΟ 0,85 ΓΙΕΝ 0,0075 ΕΥΡΩ 1025*ΛΙΡΑ+2234*ΔΟΛΑΡΙΟ * ΓΙΕΝ ΓΡΑΨΕ Το σύνολο σε ΕΥΡΩ είναι, ΕΥΡΩ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΣΥΝΑΛΛΑΓΜΑ 34

35 Δομή Επιλογής 35

36 Δομή Επιλογής- Γενικά Δομή Επιλογής Η δομή επιλογής χρησιμοποιείται όταν θέλουμε να ελέγξουμε μια συνθήκη και να εκτελέσουμε κάποιες ενέργειες ανάλογα με την τιμή αυτής της συνθήκης. Συγκεκριμένα αν η συνθήκη είναι αληθής, τότε θέλουμε να εκτελούνται κάποιες εντολές ενώ αν είναι ψευδής θέλουμε να εκτελούνται κάποιες άλλες εντολές (διαφορετικές) ή να μην εκτελείται καμία εντολή. Η δομή της επιλογής υλοποιείται με τις εντολές: αν επίλεξε 36

37 Δομή Επιλογής (1/3) Στην πραγματικότητα πολύ λίγα προβλήματα μπορούν να επιλυθούν με τον προηγούμενο τρόπο της σειριακής/ακολουθιακής δομής ενεργειών. Συνήθως τα προβλήματα έχουν κάποιες ιδιαιτερότητες και δεν ισχύουν τα ίδια βήματα για κάθε περίπτωση. Η πλέον συνηθισμένη περίπτωση είναι να λαμβάνονται κάποιες αποφάσεις με βάση κάποια δεδομένα κριτήρια, που μπορεί να είναι διαφορετικά για κάθε διαφορετικό στιγμιότυπο ενός προβλήματος. 37

38 Δομή Επιλογής (2/3) Η διαδικασία της επιλογής περιλαμβάνει τον έλεγχο κάποιας συνθήκης που μπορεί να έχει δύο τιμές (Αληθής ή Ψευδής) και ακολουθεί η απόφαση εκτέλεσης κάποιας ενέργειας με βάση την τιμή της λογικής αυτής συνθήκης. Στην παράσταση αλγορίθμων με ψευδογλώσσα η επιλογή υλοποιείται με την εντολή αν...τότε 38

39 Δομή Επιλογής (3/3) Σύνταξη αν συνθήκη τότε εντολή Λειτουργία Αν ισχύει η συνθήκη (δηλαδή αν είναι αληθής), τότε μόνο εκτελείται η εντολή που ακολουθεί 39

40 Εντολή Αν 40

41 Περιορισμένη Επιλογή ΣΥΝΤΑΞΗ αν συνθήκη τότε εντολή (εντολές) τέλος_αν ΛΕΙΤΟΥΡΓΙΑ Αν η συνθήκη είναι αληθής τότε εκτελείται η εντολή (ή οι εντολές) ανάμεσα στο αν και στο τέλος_αν και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_αν. Αν η συνθήκη είναι ψευδής τότε η εντολή (ή οι εντολές) ανάμεσα στο αν και στο τέλος_αν δεν εκτελείται (δεν εκτελούνται) και ο αλγόριθμος συνεχίζει κατευθείαν στην επόμενη εντολή μετά το τέλος_αν. ΝΑΙ συνθήκη ΟΧΙ εντολή (εντολές) 41

42 Απλή Επιλογή ΣΥΝΤΑΞΗ αν συνθήκη τότε εντολή1 (εντολές1) αλλιώς εντολή2 (εντολές2) τέλος_αν ΛΕΙΤΟΥΡΓΙΑ Αν η συνθήκη είναι αληθής τότε εκτελείται μόνο η εντολή1 (ή οι εντολές1) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_αν. Αν η συνθήκη είναι ψευδής τότε εκτελείται μόνο η εντολή2 (ή οι εντολές2) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_αν. ΝΑΙ συνθήκη ΟΧΙ εντολή1 (εντολές1) εντολή2 (εντολές2) 42

43 Εμφωλευμένη Επιλογή (Α τρόπος) ΣΥΝΤΑΞΗ αν συνθήκη1 τότε εντολή1 (εντολές1) αλλιώς αν συνθήκη2 τότε εντολή2 (εντολές2) αλλιώς αν συνθήκη3 τότε (εντολές3) εντολή3 αλλιώς τέλος_αν τέλος_αν τέλος_αν ΛΕΙΤΟΥΡΓΙΑ Αν η συνθήκη1 είναι αληθής τότε εκτελείται μόνο η εντολή1 (ή οι εντολές1) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά την τελευταία εντολή τέλος_αν. Αν η συνθήκη1 είναι ψευδής τότε ελέγχεται η συνθήκη2. Αν η συνθήκη2 είναι αληθής τότε εκτελείται μόνο η εντολή2 (ή οι εντολές2) και ο αλγόριθμος συνεχίζει στην εντολή μετά την τελευταία εντολή τέλος_αν. Αν η συνθήκη2 είναι ψευδής τότε ελέγχεται η συνθήκη3 κ.ο.κ. Παρατηρούμε ότι για την κάθε εντολή αν υπάρχει μια αντίστοιχη εντολή τέλος_αν που την τερματίζει. Στο τέλος μπορούμε προαιρετικά να προσθέσουμε και μια ακόμα εντολή αλλιώς ώστε να εκτελείται μία ή περισσότερες εντολές όταν όλες οι προηγούμενες συνθήκες είναι ψευδείς. 43

44 Εμφωλευμένη Επιλογή (Β τρόπος) ΣΥΝΤΑΞΗ αν συνθήκη1 τότε εντολή1 (εντολές1) αλλιώς_αν συνθήκη2 τότε εντολή2 (εντολές2) αλλιώς_αν συνθήκη3 τότε εντολή3 (εντολές3) αλλιώς τέλος_αν ΛΕΙΤΟΥΡΓΙΑ Λειτουργεί ακριβώς όπως και η προηγούμενη εντολή. Το μόνο που αλλάζει είναι ο τρόπος γραφής της καθώς χρησιμοποιούμε μόνο μια τέλος_αν για τον τερματισμό όλων των ελέγχων. Επίσης και εδώ μπορούμε προαιρετικά να προσθέσουμε στο τέλος και μια ακόμα εντολή αλλιώς ώστε να εκτελείται μία ή περισσότερες εντολές όταν όλες οι προηγούμενες συνθήκες είναι ψευδείς. 44

45 Εντολή Επίλεξε 45

46 Η εντολή επίλεξε είναι μια ειδική περίπτωση της εντολής αν η οποία χρησιμοποιείται όταν θέλουμε να κάνουμε πολλαπλούς ελέγχους εξετάζοντας την τιμή μιας μεταβλητής και όχι μιας συνθήκης. ΣΥΝΤΑΞΗ Εντολή πολλαπλής επιλογής επίλεξε μεταβλητή περίπτωση λίστα_τιμών1 εντολή1 (εντολές1) περίπτωση λίστα_τιμών2 εντολή2 (εντολές2) περίπτωση αλλιώς εντολήν (εντολέςν) τέλος_επιλογών επίλεξε 46

47 ΛΕΙΤΟΥΡΓΙΑ ΕΝΤΟΛΗΣ ΕΠΙΛΕΞΕ ΛΕΙΤΟΥΡΓΙΑ Ελέγχεται η τιμή της μεταβλητής. Αν η τιμή της μεταβλητής ανήκει στη λίστα_τιμών1 (δηλαδή αν είναι ίση με κάποια από τις τιμές της λίστας_τιμών1) τότε εκτελείται μόνο η εντολή1 (ή οι εντολές1) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_επιλογών. Αν η τιμή της μεταβλητής ανήκει στη λίστα_τιμών2 (δηλαδή αν είναι ίση με κάποια από τις τιμές της λίστας_τιμών2) τότε εκτελείται μόνο η εντολή2 (ή οι εντολές2) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_επιλογών κ.ο.κ. Αν η μεταβλητή δεν ανήκει σε κανένα από τα προηγούμενα σύνολα τιμών τότε εκτελείται η εντολήν (ή οι εντολέςν). Η εντολή επίλεξε ελέγχει συνεπώς μόνο ισότητες όσον αφορά την τιμή της μεταβλητής. 47

48 ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ ΕΝΤΟΛΗΣ ΕΠΙΛΕΞΕ μεταβλητή λίστα_τιμών1 λίστα_τιμών2 περίπτωση αλλιώς εντολή1 (εντολές1) εντολή2 (εντολές2) εντολήν (εντολέςν) 48

49 Ασκήσεις Αλγόριθμοι Περιορισμένης Επιλογής 49

50 Αλγόριθμος 1 Το πρόγραμμα να συγκρίνει δύο αριθμούς και να εμφανίζει τον μεγαλύτερο και τον μικρότερο αριθμό ή το μήνυμα ότι οι αριθμοί είναι ίσοι. 50

51 Λύση Αλγόριθμου 1 πρόγραμμα σύγκριση μεταβλητές πραγματικές: α1, α2 αρχή γράψε Δώσε 2 αριθμούς: διάβασε α1, α2 αν α1 > α2 τότε γράψε Μεγαλύτερος =, α1 γράψε Μικρότερος =, α2 τέλος_αν αν α1 < α2 τότε γράψε Μεγαλύτερος =, α2 γράψε Μικρότερος =, α1 τέλος_αν αν α1 = α2 τότε γράψε Οι αριθμοί είναι ίσοι. τέλος_αν τέλος_προγράμματος σύγκριση 51

52 Αλγόριθμος 2 Να δοθεί ο αλγόριθμος που θα χαρακτηρίζει έναν αριθμό ως θετικό, αρνητικό ή μηδέν. 52

53 Λύση Αλγόριθμου 2 πρόγραμμα χαρακτηρισμός μεταβλητές πραγματικές: χ αρχή γράψε Δώσε έναν αριθμό: διάβασε χ αν χ > 0 τότε γράψε θετικός τέλος_αν αν χ < 0 τότε γράψε αρνητικός τέλος_αν αν χ=0 τότε γράψε μηδέν τέλος_αν τέλος_προγράμματος χαρακτηρισμός 53

54 Αλγόριθμος 3 Να δοθεί ο αλγόριθμος που θα συγκρίνει δύο αριθμούς α και β και θα υπολογίζει ένα από τα ακόλουθα αποτελέσματα: αν α > β α + β αν α < β α β αν α = β α / β 54

55 Λύση Αλγόριθμου 3 πρόγραμμα σύγκριση μεταβλητές πραγματικές: α, β, π αρχή γράψε Δώσε 2 αριθμούς διάβασε α, β αν α > β τότε π α + β γράψε Άθροισμα =, π τέλος_αν αν α < β τότε π α - β γράψε Διαφορά =, π τέλος_αν αν α = β τότε αν β <> 0 τότε π α / β γράψε Πηλίκο =, π τέλος_αν αν β = 0 τότε γράψε Δεν υπολογίζεται το πηλίκο τέλος_αν τέλος_αν τέλος_προγράμματος σύγκριση 55

56 Αλγόριθμος 4 Να δοθεί ο αλγόριθμος που λύνει την εξίσωση y = 1 / x. 56

57 Λύση Αλγόριθμου 4 πρόγραμμα εξίσωση μεταβλητές πραγματικές: x, y αρχή γράψε Δώσε την τιμή του x: διάβασε x αν x = 0 τότε γράψε Αδύνατη Εξίσωση τέλος_αν αν x<>0 τότε y 1 / x γράψε Η λύση είναι:, y τέλος_αν τέλος_προγράμματος εξίσωση 57

58 Δομή Επανάληψης 58

59 Δομή Επανάληψης Η δομή επανάληψης χρησιμοποιείται όταν θέλουμε να εκτελέσουμε μία ή περισσότερες εντολές πολλές φορές. Η επανάληψη αυτή μπορεί να γίνει: είτε για όσο χρόνο αληθεύει μια συνθήκη (όσο) είτε μέχρι να γίνει αληθής μια συνθήκη (αρχή_επανάληψης) είτε για ένα συγκεκριμένο αριθμό φορών (για) 59

60 Εντολή όσο ΣΥΝΤΑΞΗ όσο συνθήκη επανέλαβε εντολή (εντολές) τέλος_επανάληψης ΛΕΙΤΟΥΡΓΙΑ Όσο η συνθήκη είναι αληθής επαναλαμβάνεται η εκτέλεση της εντολής (ή της ομάδας εντολών) που περικλείεται (περικλείονται) ανάμεσα στην εντολή όσο και στην εντολή τέλος_επανάληψης. Όταν η συνθήκη γίνει ψευδής η επανάληψη τερματίζεται και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_επανάληψης. Επίσης πρέπει να τονίσουμε ότι αν υ συνθήκη είναι από την αρχή ψευδής τότε η εντολή όσο δεν θα εκτελεστεί καμία φορά. 60

61 ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ Εντολής όσο 61

62 Εφαρμογή Εντολής όσο Η εντολή όσο μπορεί να χρησιμοποιηθεί τόσο σε προβλήματα με γνωστό αριθμό επαναλήψεων όσο και σε προβλήματα με άγνωστο αριθμό επαναλήψεων. Στην 1 η περίπτωση χρησιμοποιείται συνήθως ένας μετρητής επαναλήψεων, ενώ στη 2 η περίπτωση ελέγχεται μια συνθήκη σε σχέση με την τιμή που τερματίζει την επανάληψη. 62

63 Εντολή αρχή_επανάληψης ΣΥΝΤΑΞΗ αρχή_επανάληψης εντολή (εντολές) μέχρις_ότου συνθήκη ΛΕΙΤΟΥΡΓΙΑ Όσο η συνθήκη που ελέγχεται είναι ψευδής επαναλαμβάνεται η εκτέλεση της εντολής (ή της ομάδας εντολών) που περικλείεται (περικλείονται) ανάμεσα στη αρχή_επανάληψης και στο μέχρις_ότου. Όταν η συνθήκη γίνει αληθής η επανάληψη τερματίζεται και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά την εντολή μέχρις_ότου. Επίσης πρέπει να τονίσουμε ότι ακόμα και αν η συνθήκη είναι από την αρχή αληθής τότε η εντολή αρχή_επανάληψης θα εκτελεστεί τουλάχιστον μία φορά. Ουσιαστικά η εντολή αυτή έχει ακριβώς την αντίθετη λογική από την εντολή όσο. 63

64 ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ Εντολής αρχή_επανάληψης 64

65 Εφαρμογή Εντολής αρχή_επανάληψης Η εντολή αρχή_επανάληψης μπορεί να χρησιμοποιηθεί όπως και η εντολή όσο τόσο σε προβλήματα με γνωστό αριθμό επαναλήψεων όσο και σε προβλήματα με άγνωστο αριθμό επαναλήψεων. Στην πρώτη περίπτωση χρησιμοποιείται ένας μετρητής επαναλήψεων, ενώ στη δεύτερη περίπτωση ελέγχεται μια συνθήκη σε σχέση με την τιμή που τερματίζει την επανάληψη. 65

66 Εντολή για ΣΥΝΤΑΞΗ (βήμα > 0) για μεταβλητή από αρχική_τιμή μέχρι τελική_τιμή με βήμα βήμα εντολή (εντολές) τέλος_επανάληψης ΣΥΝΤΑΞΗ (βήμα < 0) για μεταβλητή από τελική_τιμή μέχρι αρχική_τιμή με βήμα αρνητικό εντολή (εντολές) τέλος_επανάληψης 66

67 ΛΕΙΤΟΥΡΓΙΑ Εντολής για Η μεταβλητή λειτουργεί σαν μετρητής επαναλήψεων. Αρχικά ξεκινάει από την τιμή που καθορίζουμε, ελέγχει αν η τιμή της είναι μικρότερη ή ίση από την τελική τιμή που πρέπει να φτάσει και εφόσον αυτό ισχύει εκτελούνται όλες οι εντολές που περιλαμβάνονται ανάμεσα στην εντολή για και στην εντολή τέλος_επανάληψης. Στη συνέχεια η μεταβλητή αυτή αυξάνεται σύμφωνα με την τιμή του βήματος που έχουμε καθορίσει. Όταν η μεταβλητή ξεπεράσει την τελική της τιμή τότε η επανάληψη ολοκληρώνεται και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_επανάληψης. 67

68 ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ Εντολής για 68

69 Κριτήριο Επιλογής Εντολής Επανάληψης Αριθμός Επαναλήψεων Εντολή Επανάληψης γνωστός εντολή για εντολή όσο εντολή αρχή_επανάληψης άγνωστος εντολή όσο εντολή αρχή_επανάληψης 69

70 Γενικές Παρατηρήσεις για τις Εντολές Επανάληψης Περίπτωση Λύση Όταν το πρόγραμμα ζητάει υπολογισμό αθροίσματος τότε χρησιμοποιούμε πάντα αθροιστή δηλαδή μια μεταβλητή που αυξάνεται σε κάθε επανάληψη κατά μια συγκεκριμένη ή τυχαία τιμή και αρχικοποιείται με το 0. Όταν το πρόγραμμα ζητάει υπολογισμό πλήθους τότε χρησιμοποιούμε πάντα μετρητή δηλαδή μια μεταβλητή που αυξάνεται σε κάθε επανάληψη κατά 1 και αρχικοποιείται με 0. Όταν το πρόγραμμα ζητάει υπολογισμό γινομένου Όταν ο αριθμός των επαναλήψεων είναι γνωστός τότε χρησιμοποιούμε πάντα πολλαπλασιαστή δηλαδή μια μεταβλητή που πολλαπλασιάζεται σε κάθε επανάληψη με μια συγκεκριμένη ή τυχαία τιμή και αρχικοποιείται με το 1. τότε χρησιμοποιούμε μετρητή επαναλήψεων δηλαδή μια μεταβλητή που αυξάνεται σε κάθε επανάληψη κατά μια συγκεκριμένη τιμή (συνήθως κατά 1) και αρχικοποιείται με μια συγκεκριμένη τιμή (συνήθως με το 1). Όταν ο αριθμός των επαναλήψεων είναι άγνωστος τότε δεν μπορούμε να χρησιμοποιήσουμε μετρητή επαναλήψεων. Η συνθήκη που ελέγχουμε στην περίπτωση αυτή έχει να κάνει με μια τιμή που τερματίζει την επανάληψη. 70

71 Διαφορές της εντολής όσο από την εντολή αρχή_επανάληψης Στην εντολή όσο η συνθήκη ελέγχεται στην αρχή της επανάληψης ενώ στην εντολή αρχή_επανάληψης η συνθήκη ελέγχεται στο τέλος της επανάληψης. Στην εντολή όσο η ομάδα εντολών μπορεί να μην εκτελεστεί καμία φορά όταν η συνθήκη είναι εξ αρχής ψευδής, ενώ στην εντολή αρχή_επανάληψης η ομάδα εντολών εκτελείται τουλάχιστον μια φορά ανεξάρτητα από την συνθήκη. Στην εντολή όσο η επανάληψη εκτελείται όσο η συνθήκη είναι αληθής, ενώ στην εντολή αρχή_επανάληψης η επανάληψη εκτελείται όσο η συνθήκη είναι ψευδής και τερματίζει μόλις η συνθήκη γίνει αληθής. 71

72 Πλεονεκτήματα της εντολής για σε σχέση με τις εντολές όσο και αρχή_επανάληψης στην εντολή για δεν απαιτείται να υπάρχουν (μέσα στο σώμα των εντολών της) ξεχωριστές εντολές τροποποίησης της τιμής του μετρητή των επαναλήψεων γιατί αυτός μεταβάλλεται αυτόματα από την ίδια την εντολή για σε κάθε επανάληψη κατά βήμα (αυξάνεται ή μειώνεται). Αντίθετα στις εντολές όσο και αρχή_επανάληψης όταν ο αριθμός των επαναλήψεων είναι γνωστός είναι υποχρεωτική η ύπαρξη εντολής αλλαγής της τιμής του μετρητή των επαναλήψεων. στην εντολή για δεν απαιτείται να υπάρχει ξεχωριστή εντολή αρχικοποίησης της τιμής του μετρητή των επαναλήψεων γιατί αυτή γίνεται αυτομάτως από την ίδια την εντολή για. Αντίθετα στις εντολές όσο και αρχή_επανάληψης όταν ο αριθμός των επαναλήψεων είναι γνωστός είναι υποχρεωτική η αρχικοποίηση του μετρητή των επαναλήψεων σε ξεχωριστή εντολή. 72

73 Μειονεκτήματα της εντολής για σε σχέση με τις εντολές όσο και αρχή_επανάληψης Η εντολή για εφαρμόζεται μόνο όταν ο αριθμός των επαναλήψεων είναι γνωστός. Αντίθετα οι εντολές όσο και αρχή_επανάληψης μπορούν να χρησιμοποιηθούν σε κάθε περίπτωση δηλαδή και για γνωστό και για άγνωστο αριθμό επαναλήψεων. 73

74 Παραδείγματα 74

75 Παράδειγμα 1 Να γραφεί ο αλγόριθμος υπολογισμού του αθροίσματος των αριθμών από το 1 μέχρι το 100 ( ) χρησιμοποιώντας και τις τρεις δομές επανάληψης. 75

76 Λύση Παραδείγματος 1-α τρόπος ΠΡΟΓΡΑΜΜΑ ΑΘΡΟΙΣΜΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι, SUM ΑΡΧΗ I 1 SUM 0 ΟΣΟ I<=100 ΕΠΑΝΑΛΑΒΕ SUM SUM+I I I+1 ΤΕΛΟΣ_ ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ SUM ΤΕΛΟΣ_ ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΘΡΟΙΣΜΑ 76

77 Λύση Παραδείγματος 1-β τρόπος ΠΡΟΓΡΑΜΜΑ ΑΘΡΟΙΣΜΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι, SUM ΑΡΧΗ I 1 SUM 0 ΑΡΧΗ_ ΕΠΑΝΑΛΗΨΗΣ SUM SUM+I I I+1 ΜΕΧΡΙΣ_ ΟΤΟΥ I>100 ΓΡΑΨΕ SUM ΤΕΛΟΣ_ ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΘΡΟΙΣΜΑ 77

78 Λύση Παραδείγματος 1-γ τρόπος ΠΡΟΓΡΑΜΜΑ ΑΘΡΟΙΣΜΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι, SUM ΑΡΧΗ SUM 0 ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 100 SUM SUM+I ΤΕΛΟΣ_ ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ SUM ΤΕΛΟΣ_ ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΘΡΟΙΣΜΑ 78

79 Παράδειγμα 2 Να γραφεί αλγόριθμος που να εμφανίζει την πρόταση «ΙΕΚ ΛΑΓΚΑΔΑ» 100 φορές. ΛΥΣΗ: ΠΡΟΓΡΑΜΜΑ ΙΕΚ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι ΑΡΧΗ ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100 ΓΡΑΨΕ ΙΕΚ ΛΑΓΚΑΔΑ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΙΕΚ 79

80 Παράδειγμα 3 Να γραφεί αλγόριθμος που να εμφανίζει τη λέξη «ΘΕΣΣΑΛΟΝΙΚΗ» στην οθόνη του υπολογιστή κάθε φορά που ο χρήστης πατάει το πλήκτρο «Θ». Η διαδικασία να επαναλαμβάνεται έως ότου ο χρήστης πατήσει το πλήκτρο «Q». Τότε ο αλγόριθμος να εμφανίζει πόσες φορές πατήθηκε το πλήκτρο «Θ». 80

81 Λύση Παραδείγματος 3 ΠΡΟΓΡΑΜΜΑ ΘΕΣΣΑΛΟΝΙΚΗ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ:ΠΛΗΘΟΣ ΑΛΦΑΡΙΘΜΗΤΙΚΕΣ(ΧΑΡΑΚΤΗΡΕΣ):Χ ΑΡΧΗ ΠΛΗΘΟΣ 0 ΑΡΧΗ ΕΠΑΝΑΛΗΨΗΣ ΔΙΑΒΑΣΕ Χ ΑΝ Χ= Θ ΤΟΤΕ ΓΡΑΨΕ ΘΕΣΣΑΛΟΝΙΚΗ ΠΛΗΘΟΣ ΠΛΗΘΟΣ+1 ΤΕΛΟΣ_ΑΝ ΜΕΧΡΙΣ_ΟΤΟΥ Χ= Q ΓΡΑΨΕ ΠΛΗΘΟΣ ΤΕΛΟΣ_ ΠΡΟΓΡΑΜΜΑΤΟΣ ΘΕΣΣΑΛΟΝΙΚΗ 81

82 Παράδειγμα 4 Ένας καταναλωτής διαθέτει 150 για αγορά ρυζιού, προκειμένου να το δωρίσει σε ένα φιλανθρωπικό ίδρυμα. Σε ένα πολυκατάστημα διατίθενται πακέτα ρυζιού σε τέσσερις διαφορετικές συσκευασίες από διαφορετικές εταιρείες. Να γράψετε αλγόριθμο ο οποίος: α. Διαβάζει το όνομα της εταιρείας, την αξία και την ποσότητα σε γραμμάρια για κάθε μία από τις τέσσερις συσκευασίες ρυζιού. β. Υπολογίζει και εμφανίζει το όνομα της εταιρείας που προσφέρει το ρύζι στην πλέον συμφέρουσα για τον καταναλωτή συσκευασία (να θεωρήσετε ότι υπάρχει μόνο μία τέτοια εταιρεία). γ. Υπολογίζει και εμφανίζει τον αριθμό των πακέτων που μπορεί να αγοράσει από την πλέον συμφέρουσα για τον καταναλωτή συσκευασία (σύμφωνα με το ερώτημα β). Παρατήρηση: η κάθε εταιρεία διαθέτει το ρύζι σε μία και μόνη συσκευασία, π.χ. η Α εταιρεία διαθέτει ρύζι μόνο σε συσκευασία των 200gr, η Β σε συσκευασία των 250, η Γ σε συσκευασία των 300 gr, η Δ σε συσκευασία των 350 gr. 82

83 Λύση Παραδείγματος 4 ΑΛΓΟΡΙΘΜΟΣ ΑΓΟΡΑ_ΡΥΖΙΟΥ ΔΙΑΒΑΣΕ ΟΝΟΜΑ, ΑΞΙΑ, ΠΟΣΟΤΗΤΑ ΚΟΣΤΟΣ ΑΞΙΑ/ΠΟΣΟΤΗΤΑ ΜΙΝ ΚΟΣΤΟΣ ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 4 ΔΙΑΒΑΣΕ ΟΝΟΜΑ, ΑΞΙΑ, ΠΟΣΟΤΗΤΑ ΚΟΣΤΟΣ ΑΞΙΑ/ΠΟΣΟΤΗΤΑ ΑΝ ΚΟΣΤΟΣ<ΜΙΝ ΤΟΤΕ ΜΙΝ ΚΟΣΤΟΣ ΕΤΑΙΡΕΙΑ ΟΝΟΜΑ ΚΑΛΥΤΕΡΗ_ΤΙΜΗ ΑΞΙΑ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΕΜΦΑΝΙΣΕ ΕΤΑΙΡΕΙΑ ΠΛΗΘΟΣ_ΠΑΚΕΤΩΝ 150 DIV ΚΑΛΥΤΕΡΗ ΤΙΜΗ ΕΜΦΑΝΙΣΕ ΠΛΗΘΟΣ_ΠΑΚΕΤΩΝ ΤΕΛΟΣ ΑΓΟΡΑ_ΡΥΖΙΟΥ 83

84 Παράδειγμα 5 Σε κάποια εξεταστική δοκιμασία ένα γραπτό αξιολογείται από δυο βαθμολογητές στη βαθμολογική κλίμακα[0,100]. Αν η διαφορά μεταξύ των βαθμολογιών του α και του β βαθμολογητή είναι μικρότερη ή ίση των 20 μονάδων της παραπάνω κλίμακας, ο τελικός βαθμός είναι ο μέσος όρος των δυο βαθμολογιών. Αν η διαφορά μεταξύ των βαθμολογιών του α και του β βαθμολογητή είναι μεγαλύτερη από 20 μονάδες, το γραπτό δίνεται για αναβαθμολόγηση σε τρίτο βαθμολογητή. Ο τελικός βαθμός του γραπτού προκύπτει τότε από το μέσο όρο των τριών βαθμολογιών. Να αναπτύξετε αλγόριθμο ο οποίος, αφού ελέγξει την εγκυρότητα των βαθμών στη βαθμολογική κλίμακα [0,100], να υλοποιεί την παραπάνω διαδικασία εξαγωγής τελικού βαθμού και να εμφανίζει τον τελικό βαθμό του γραπτού στην εικοσαβάθμια κλίμακα. Παρατήρηση: Να θεωρήσετε ότι όλες οι ποσότητες εκφράζονται ως πραγματικοί αριθμοί. 84

85 Λύση Παραδείγματος 5 ΠΡΟΓΡΑΜΜΑ ΒΑΘΜΟΛΟΓΙΑ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ:Β1,Β2,Β3,ΤΒ ΑΡΧΗ ΔΙΑΒΑΣΕ Β1 ΟΣΟ (Β1>100) Η (Β1<0) ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ ΛΑΘΟΣ ΒΑΘΜΟΣ ΞΑΝΑΔΩΣΕ ΔΙΑΒΑΣΕ Β1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΔΙΑΒΑΣΕ Β2 ΟΣΟ (Β2>100) Η (Β2<0) ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ ΛΑΘΟΣ ΒΑΘΜΟΣ ΞΑΝΑΔΩΣΕ ΔΙΑΒΑΣΕ Β2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ Α_Τ(Β1-Β2)<=20 ΤΟΤΕ ΤΒ (Β1+Β2)/2 ΑΛΛΙΩΣ ΔΙΑΒΑΣΕ Β3 ΟΣΟ (Β3>100) Η (Β3<0) ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ ΛΑΘΟΣ ΒΑΘΜΟΣ ΞΑΝΑΔΩΣΕ ΔΙΑΒΑΣΕ Β3 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΒ (Β1+Β2+Β3)/3 ΤΕΛΟΣ_ΑΝ ΓΡΑΨΕ Ο ΤΕΛΙΚΟΣ ΒΑΘΜΟΣ ΣΤΗΝ ΕΙΚΟΣ/ΙΑ ΚΛΙΜ ΕΙΝΑΙ,ΤΒ/5 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΒΑΘΜΟΛΟΓΙΑ 85

86 Παράδειγμα 6 (1) Το κλασικό παιχνίδι «Πέτρα-Ψαλίδι-Χαρτί» παίζεται με δύο παίκτες. Σε κάθε γύρο του παιχνιδιού, ο κάθε παίκτης επιλέγει ένα από τα ΠΕΤΡΑ, ΨΑΛΙΔΙ, ΧΑΡΤΙ, και παρουσιάζει την επιλογή του ταυτόχρονα με τον αντίπαλό του. Η ΠΕΤΡΑ κερδίζει το ΨΑΛΙΔΙ, το ΨΑΛΙΔΙ το ΧΑΡΤΙ και το ΧΑΡΤΙ την ΠΕΤΡΑ. Σε περίπτωση που οι δύο παίκτες έχουν την ίδια επιλογή, ο γύρος λήγει ισόπαλος. Τα ο παιχνίδι προχωράει με συνεχόμενους γύρους μέχρι ένας τουλάχιστον από τους παίκτες να αποχωρήσει. Νικητής αναδεικνύεται ο παίκτης με τις περισσότερες νίκες. Αν οι δύο παίκτες έχουν τον ίδιο αριθμό νικών, το παιχνίδι λήγει ισόπαλο. 86

87 Παράδειγμα 6 (2) Να αναπτύξετε αλγόριθμο ο οποίος διαβάζει τα ονόματα των δύο παικτών και υλοποιεί το παραπάνω παιχνίδι ως εξής: Α. Για κάθε γύρο του παιχνιδιού: διαβάζει την επιλογή κάθε παίκτη, η οποία μπορεί να είναι μία από τις εξής: ΠΕΤΡΑ, ΨΑΛΙΔΙ, ΧΑΡΤΙ, ΤΕΛΟΣ. (Δεν απαιτείται έλεγχος εγκυρότητας τιμών.) συγκρίνει τις επιλογές των παικτών και διαπιστώνει το νικητή του γύρου ή την ισοπαλία. Β. Τερματίζει το παιχνίδι όταν ένας τουλάχιστον από τους δύο παίκτες επιλέξει ΤΕΛΟΣ. Γ. Εμφανίζει το όνομα του νικητή ή, αν δεν υπάρχει νικητής, το μήνυμα «ΤΟ ΠΑΙΧΝΙΔΙ ΕΛΗΞΕ ΙΣΟΠΑΛΟ». 87

88 Λύση Παραδείγματος 6 ΠΡΟΓΡΑΜΜΑ ΠΑΙΧΝΙΔΙ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ν1,Ν2 ΧΑΡΑΚΤΗΡΕΣ: ΟΝ1,ΟΝ2,ΕΠ1,ΕΠ2 ΑΡΧΗ ΔΙΑΒΑΣΕ ΟΝ1,ΟΝ2 Ν1 0 Ν2 0 ΔΙΑΒΑΣΕ ΕΠ1,ΕΠ2 ΟΣΟ ΕΠ1<>'ΤΕΛΟΣ' ΚΑΙ ΕΠ2<>'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ ΑΝ ΕΠ1=ΕΠ2 ΤΟΤΕ ΓΡΑΨΕ ΙΣΟΠΑΛΙΑ ΑΛΛΙΩΣ ΑΝ ΕΠ1='ΠΕΤΡΑ' ΤΟΤΕ ΑΝ ΕΠ2='ΨΑΛΙΔΙ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ1 Ν1 Ν1+1 ΑΛΛΙΩΣ _ΑΝ ΕΠ2='ΧΑΡΤΙ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ2 Ν2 Ν2+1 ΤΕΛΟΣ_ΑΝ ΑΛΛΙΩΣ_ΑΝ ΕΠ1='ΨΑΛΙΔΙ' ΤΟΤΕ ΑΝ ΕΠ2='ΠΕΤΡΑ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ2 Ν2 Ν2+1 ΑΛΛΙΩΣ_ΑΝ ΕΠ2='ΧΑΡΤΙ' ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ1 Ν1 Ν1+1 ΤΕΛΟΣ_ΑΝ ΑΛΛΙΩΣ!δηλαδή ΕΠ1='ΧΑΡΤΙ' ΑΝ ΕΠ2='ΠΕΤΡΑ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ1 Ν1 Ν1+1 ΤΕΛΟΣ_ΑΝ ΑΛΛΙΩΣ_ΑΝ ΕΠ2='ΨΑΛΙΔΙ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ2 Ν2 Ν2+1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΠΑΙΧΝΙΔΙ ΔΙΑΒΑΣΕ ΕΠ1,ΕΠ2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ Ν1>Ν2 ΤΟΤΕ ΓΡΑΨΕ 'ΝΙΚΗΤΗΣ Ο',ΟΝ1 ΑΛΛΙΩΣ_ΑΝ Ν2>Ν1 ΤΟΤΕ ΓΡΑΨΕ 'ΝΙΚΗΤΗΣ Ο',ΟΝ2 ΑΛΛΙΩΣ ΓΡΑΨΕ 'ΤΟ ΠΑΙΧΝΙΔΙ ΕΛΗΞΕ ΙΣΟΠΑΛΟ' ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΠΑΙΧΝΙΔΙ 88

89 Τέλος Κεφαλαίου

1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες εντολές (μορφές) της;

1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες εντολές (μορφές) της; 1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες (μορφές) της; Η δομή επανάληψης χρησιμοποιείται όταν μια σειρά εντολών πρέπει να εκτελεστεί σε ένα σύνολο περιπτώσεων, που έχουν κάτι

Διαβάστε περισσότερα

2 ΟΥ και 7 ΟΥ ΚΕΦΑΛΑΙΟΥ

2 ΟΥ και 7 ΟΥ ΚΕΦΑΛΑΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΙΜΕΛΕΙΑ: ΜΑΡΙΑ Σ. ΖΙΩΓΑ ΚΑΘΗΓΗΤΡΙΑ ΠΛΗΡΟΦΟΡΙΚΗΣ ΘΕΩΡΙΑ 2 ΟΥ και 7 ΟΥ ΚΕΦΑΛΑΙΟΥ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ και ΔΟΜΗ ΑΚΟΛΟΥΘΙΑΣ 2.1 Να δοθεί ο ορισμός

Διαβάστε περισσότερα

ΔΟΜΗΜΕΝΟΣ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ

ΔΟΜΗΜΕΝΟΣ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ ΕΡΩΤΗΣΕΙΣ 1. Τι καλείται ψευδοκώδικας; 2. Τι καλείται λογικό διάγραμμα; 3. Για ποιο λόγο είναι απαραίτητη η τυποποίηση του αλγόριθμου; 4. Ποιες είναι οι βασικές αλγοριθμικές δομές; 5. Να περιγράψετε τις

Διαβάστε περισσότερα

8. Επιλογή και επανάληψη

8. Επιλογή και επανάληψη 8. Επιλογή και επανάληψη 8.1 Εντολές Επιλογής ΕΣΕΠ06-Θ1Β5 Η ιεραρχία των λογικών τελεστών είναι µικρότερη των αριθµητικών. ΕΣ07-Θ1Γ5 Η σύγκριση λογικών δεδοµένων έχει έννοια µόνο στην περίπτωση του ίσου

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ Α3. α. (σελ. 183-184) Στοίβα: ώθηση, απώθηση Ουρά:

Διαβάστε περισσότερα

Φροντιστήρια Επίγνωση Προτεινόμενα Θέματα Πανελλαδικών ΑΕΠΠ 2015

Φροντιστήρια Επίγνωση Προτεινόμενα Θέματα Πανελλαδικών ΑΕΠΠ 2015 Φροντιστήρια Επίγνωση Προτεινόμενα Θέματα Πανελλαδικών ΑΕΠΠ 2015 Βάλβης Δημήτριος Μηχανικός Πληροφορικής ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα

Διαβάστε περισσότερα

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 Ο

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 Ο ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 Ο Α. Να αναπτύξετε τις παρακάτω ερωτήσεις: 1. Τι καλείται βρόγχος; 2. Σε ποιες κατηγορίες διακρίνονται τα προβλήματα ανάλογα με

Διαβάστε περισσότερα

ΕΝΙΑΙΟ ΛΥΚΕΙΟ ΚΑΛΑΜΠΑΚΑΣ ΣΧΟΛ. ΕΤΟΣ 2012-2013

ΕΝΙΑΙΟ ΛΥΚΕΙΟ ΚΑΛΑΜΠΑΚΑΣ ΣΧΟΛ. ΕΤΟΣ 2012-2013 ΕΝΙΑΙΟ ΛΥΚΕΙΟ ΚΑΛΑΜΠΑΚΑΣ ΣΧΟΛ. ΕΤΟΣ 2012-2013 ΕΚΠΑΙΔΕΥΤΙΚΉ ΠΡΟΣΟΜΟΙΩΣΗ ΕΞΕΤΑΣΕΩΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α Α1. Να γράψετε

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ & ΥΠΗΡΕΣΙΩΝ) 2007 ΕΚΦΩΝΗΣΕΙΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ & ΥΠΗΡΕΣΙΩΝ) 2007 ΕΚΦΩΝΗΣΕΙΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ & ΥΠΗΡΕΣΙΩΝ) 2007 ΘΕΜΑ 1ο ΕΚΦΩΝΗΣΕΙΣ Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΤΕΧΝ/ΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ - Γ ΛΥΚΕΙΟΥ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΤΕΧΝ/ΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ - Γ ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΤΕΧΝ/ΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ - Γ ΛΥΚΕΙΟΥ ΘΕΜΑΤΑ ΘΕΜΑ A Α1. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή, ή τη λέξη ΛΑΘΟΣ,

Διαβάστε περισσότερα

2015 1-5 1. 5 5 4. 10 2. . 3. 6 3. . 6

2015 1-5 1. 5 5 4. 10 2. . 3. 6 3. . 6 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθµό καθεµίας από τις παρακάτω προτάσεις 1-5 και, δίπλα, τη λέξη ΣΩΣΤΟ, αν

Διαβάστε περισσότερα

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη

Διαβάστε περισσότερα

1 η εξεταστική περίοδος από 20/10/2013 έως 17/11/2013. γραπτή εξέταση στο μάθημα Α ΝΑΠΤΥΞΗ ΕΦΑΡΜ Ο ΓΩ Ν ΣΕ ΠΡΟΓΡ ΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ

1 η εξεταστική περίοδος από 20/10/2013 έως 17/11/2013. γραπτή εξέταση στο μάθημα Α ΝΑΠΤΥΞΗ ΕΦΑΡΜ Ο ΓΩ Ν ΣΕ ΠΡΟΓΡ ΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ γραπτή εξέταση στο μάθημα Α ΝΑΠΤΥΞΗ ΕΦΑΡΜ Ο ΓΩ Ν ΣΕ ΠΡΟΓΡ ΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ Τάξη: Τμήμα: Βαθμός: Ονοματεπώνυμο: Καθηγητές: ΒΛΙΣΙΔΗΣ ΓΙΩΡΓΟΣ ΘΕΜΑ Α Α1. Να αναφέρετε τους λόγους για τους οποίους

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ 29 ΜΑΪΟΥ 2013 ΕΚΦΩΝΗΣΕΙΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ 29 ΜΑΪΟΥ 2013 ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ Α ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ 29 ΜΑΪΟΥ 2013 ΕΚΦΩΝΗΣΕΙΣ Α1. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-6 και

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1Ο Α1. Να χαρακτηρίσετε τις παρακάτω προτάσεις σαν Σωστό ή Λάθος. 1. Ο υπολογιστής είναι ο ταχύτερος μηχανισμός επεξεργασίας δεδομένων. 2. Οι εντολές

Διαβάστε περισσότερα

ΘΕΜΑΤΑ ΚΑΙ ΑΠΑΝΤΗΣΕΙΣ ΠΑΝΕΛΛΑΔΙΚΩΝ ΕΞΕΤΑΣΕΩΝ 2013 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΘΕΜΑΤΑ ΚΑΙ ΑΠΑΝΤΗΣΕΙΣ ΠΑΝΕΛΛΑΔΙΚΩΝ ΕΞΕΤΑΣΕΩΝ 2013 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη ΣΩΣΤΟ, αν η πρόταση

Διαβάστε περισσότερα

www.lazarinis.gr ΑΕΠΠ - ΗΜΕΡΗΣΙΑ ΛΥΚΕΙΑ 2011 - ΘΕΜΑΤΑ ΚΑΙ ΛΥΣΕΙΣ

www.lazarinis.gr ΑΕΠΠ - ΗΜΕΡΗΣΙΑ ΛΥΚΕΙΑ 2011 - ΘΕΜΑΤΑ ΚΑΙ ΛΥΣΕΙΣ Σελίδα 1 από 12 www.lazarinis.gr ΑΕΠΠ - ΗΜΕΡΗΣΙΑ ΛΥΚΕΙΑ 2011 - ΘΕΜΑΤΑ ΚΑΙ ΛΥΣΕΙΣ Σε συνεργασία µε τις εκδόσεις ΕΛΛΗΝΟΕΚ ΟΤΙΚΗ κυκλοφορούν τα βοηθήµατα «Ανάπτυξη Εφαρµογών σε Προγραµµατιστικό Περιβάλλον:

Διαβάστε περισσότερα

ΘΕΜΑΤΑ ΚΑΙ ΕΠΑΝΤΗΣΕΙΣ ΠΑΝΕΛΛΑΔΙΚΩΝ ΕΞΕΤΑΣΕΩΝ 2010 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΘΕΜΑΤΑ ΚΑΙ ΕΠΑΝΤΗΣΕΙΣ ΠΑΝΕΛΛΑΔΙΚΩΝ ΕΞΕΤΑΣΕΩΝ 2010 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α Α1. ίνονται τα παρακάτω τμήματα αλγορίθμου σε φυσική γλώσσα. 1 Αν η βαθμολογία (ΒΑΘΜΟΣ) είναι μεγαλύτερη από τον Μέσο Ορο (ΜΟ), τότε να τυπώνει «Πολύ

Διαβάστε περισσότερα

Α4. Δίδεται ο παρακάτω αλγόριθμος

Α4. Δίδεται ο παρακάτω αλγόριθμος Διαγώνισμα 2014-15 Ανάπτυξη Εφαρμογών σε Πραγματικό Περιβάλλον Επώνυμο Όνομα Εξεταζόμενο μάθημα Γ Λυκείου Κυριακή 02/11/2014 Τμήμα Ημερομηνία Τάξη Θέμα Α A1. Επιλέξτε Σωστό ή Λάθος για τις παρακάτω προτάσεις:

Διαβάστε περισσότερα

10 Α2. 5 Α3. (ΟΧΙ = 20-4*2^2)) H (X>Ψ ΚΑΙ X > Ψ

10 Α2. 5 Α3. (ΟΧΙ = 20-4*2^2)) H (X>Ψ ΚΑΙ X > Ψ Α Π Α Ν Τ Η Σ Ε Ι Σ Θ Ε Μ Α Τ Ω Ν Π Α Ν Ε Λ Λ Α Δ Ι Κ Ω Ν Ε Ξ Ε Τ Α Σ Ε Ω Ν 2 0 1 4 Α Ν Α Π Τ Υ Ξ Η Ε Φ Α Ρ Μ Ο Γ Ω Ν Σ Ε Π Ρ Ο Γ Ρ Α Μ Μ Α Τ Ι Σ Τ Ι Κ Ο Π Ε Ρ Ι Β Α Λ Λ Ο Ν Τ Ε Χ Ν Ο Λ Ο Γ Ι Κ Η Σ Κ Α

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ & ΥΠΗΡΕΣΙΩΝ) 2010 ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ Α Α1. ίνονται τα παρακάτω τµήµατα αλγορίθµου σε φυσική γλώσσα. 1. Αν η

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο Αν χ και y μεταβλητές με τιμές 5 και 10 αντίστοιχα να εξηγηθούν οι ακόλουθες εντολές εξόδου.

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο Αν χ και y μεταβλητές με τιμές 5 και 10 αντίστοιχα να εξηγηθούν οι ακόλουθες εντολές εξόδου. 2.1 Αν χ και y μεταβλητές με τιμές 5 και 10 αντίστοιχα να εξηγηθούν οι ακόλουθες εντολές εξόδου. 1) Η τιμή του χ είναι,χ Ητιμή του χ είναι 5 Ηεντολή εμφανίζει ότι υπάρχει στα διπλά εισαγωγικά ως έχει.

Διαβάστε περισσότερα

ÏÅÖÅ. Β. Να αναφέρετε τις κυριότερες τυποποιηµένες τεχνικές σχεδίασης αλγορίθµων. ΜΟΝΑ ΕΣ 3

ÏÅÖÅ. Β. Να αναφέρετε τις κυριότερες τυποποιηµένες τεχνικές σχεδίασης αλγορίθµων. ΜΟΝΑ ΕΣ 3 1 Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΘΕΜΑ 1 Ο ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό

Διαβάστε περισσότερα

Αν τότε. αλλιώς. Τέλος_αν. Τέλος_αν

Αν τότε. αλλιώς. Τέλος_αν. Τέλος_αν Α Π Α Ν Τ Η Σ Ε Ι Σ Θ Ε Μ Α Τ Ω Ν Π Α Ν Ε Λ Λ Α Δ Ι Κ Ω Ν Ε Ξ Ε Τ Α Σ Ε Ω Ν 2 0 1 5 Α Ν Α Π Τ Υ Ξ Η Ε Φ Α Ρ Μ Ο Γ Ω Ν Σ Ε Π Ρ Ο Γ Ρ Α Μ Μ Α Τ Ι Σ Τ Ι Κ Ο Π Ε Ρ Ι Β Α Λ Λ Ο Ν Τ Ε Χ Ν Ο Λ Ο Γ Ι Κ Η Σ Κ Α

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ ΤΕΧΝ/ΚΗΣ ΚΑΤ/ΝΣΗΣ (Πλ. & Υπ.) 2006 ΕΚΦΩΝΗΣΕΙΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ ΤΕΧΝ/ΚΗΣ ΚΑΤ/ΝΣΗΣ (Πλ. & Υπ.) 2006 ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ 1 ο ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ' ΛΥΚΕΙΟΥ ΤΕΧΝ/ΚΗΣ ΚΑΤ/ΝΣΗΣ (Πλ. & Υπ.) 2006 ΕΚΦΩΝΗΣΕΙΣ Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και

Διαβάστε περισσότερα

Μιχάλης Αρταβάνης κλάδου Πληροφορικής ΠΕ19

Μιχάλης Αρταβάνης κλάδου Πληροφορικής ΠΕ19 Φυλλάδιο Ασκήσεων 1 - οµές Επανάληψης Ασκ1. Πόσες φορές θα εκτελεστούν οι επαναληπτικές δοµές στα παρακάτω τµήµατα αλγορίθµων; x 5 Όσο (x > 0) x x - 1 x 5 Όσο (x >= 0) x x - 1 x -5 Όσο (x >= 0) x x - 1

Διαβάστε περισσότερα

Αναδρομή. Τι γνωρίζετε για τη δυνατότητα «κλήσης» αλγορίθμων; Τι νόημα έχει;

Αναδρομή. Τι γνωρίζετε για τη δυνατότητα «κλήσης» αλγορίθμων; Τι νόημα έχει; ΜΑΘΗΜΑ 7 Κλήση αλγορίθμου από αλγόριθμο Αναδρομή Σ χ ο λ ι κ ο Β ι β λ ι ο ΥΠΟΚΕΦΑΛΑΙΟ 2.2.7: ΕΝΤΟΛΕΣ ΚΑΙ ΔΟΜΕΣ ΑΛΓΟΡΙΘΜΟΥ ΠΑΡΑΓΡΑΦΟI 2.2.7.5: Κλήση αλγορίθμου από αλγόριθμο 2.2.7.6: Αναδρομή εισαγωγη

Διαβάστε περισσότερα

Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ. Óõíåéñìüò ΕΚΦΩΝΗΣΕΙΣ

Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ. Óõíåéñìüò ΕΚΦΩΝΗΣΕΙΣ 1 ΘΕΜΑ 1 o Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ Α. Να γράψετε στην κόλλα σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1 5 και δίπλα τη λέξη

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΗΜΕΡΗΣΙΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 6 ΙΟΥΝΙΟΥ 2014 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

Κεφάλαιο 4 ο. Δομή επιλογής. Περιεχόμενα

Κεφάλαιο 4 ο. Δομή επιλογής. Περιεχόμενα Δομή επιλογής Κεφάλαιο 4 ο Περιεχόμενα 4.1. Δομή επιλογής 4.2. Δομή απλής επιλογής 4.3. Παραδείγματα δομή απλής επιλογής 4.4. Δομή σύνθετης επιλογής 4.5. Παραδείγματα δομή σύνθετης επιλογής 4.6. Δομή πολλαπλής

Διαβάστε περισσότερα

ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 (Α) Σημειώστε δίπλα σε κάθε πρόταση «Σ» ή «Λ» εφόσον είναι σωστή ή λανθασμένη αντίστοιχα. 1. Τα συντακτικά λάθη ενός προγράμματος

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 04/03/2012 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. Α2. 2. ΣΩΣΤΟ 2 δ 3. ΣΩΣΤΟ 3 ε 5. ΛΑΘΟΣ 5 α. 1.

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 04/03/2012 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. Α2. 2. ΣΩΣΤΟ 2 δ 3. ΣΩΣΤΟ 3 ε 5. ΛΑΘΟΣ 5 α. 1. ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 04/03/2012 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. Α2. 1. ΛΑΘΟΣ 1 στ 2. ΣΩΣΤΟ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΛΑΘΟΣ 5 α Α3. α. (σελ. 193-194) Υπολογισμός αθροίσματος

Διαβάστε περισσότερα

ÑÏÕËÁ ÌÁÊÑÇ. Β. Να αναφέρετε τις κυριότερες τυποποιηµένες τεχνικές σχεδίασης αλγορίθµων. ΜΟΝΑ ΕΣ 3

ÑÏÕËÁ ÌÁÊÑÇ. Β. Να αναφέρετε τις κυριότερες τυποποιηµένες τεχνικές σχεδίασης αλγορίθµων. ΜΟΝΑ ΕΣ 3 1 Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΘΕΜΑ 1 Ο ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός: Θέμα 1ο Α) Απαντήστε στις παρακάτω ερωτήσεις επιλέγοντας Σ (Σωστό) ή Λ (Λάθος). 1) Ο έλεγχος μιας συνθήκης έχει μόνο δυο τιμές,

Διαβάστε περισσότερα

ΚΕΦΑΛΑΙΟ ΙI ΚΕΦΑΛΑΙΟ 2

ΚΕΦΑΛΑΙΟ ΙI ΚΕΦΑΛΑΙΟ 2 ΚΕΦΑΛΑΙΟ ΙI Βασικές Έννοιες Αλγορίθμων Αλγόριθμος, είναι μια πεπερασμένη σειρά ενεργειών, αυστηρά καθορισμένων και εκτελέσιμων σε πεπερασμένο χρόνο, που στοχεύουν στην επίλυση ενός προβλήματος. Κάθε αλγόριθμος

Διαβάστε περισσότερα

Α2. ίνεται το παρακάτω τμήμα αλγορίθμου: Για i από 3 μέχρι Α με_βήμα Β Εμφάνισε i Τέλος_επανάληψης ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΤΕΛΟΣ 1ΗΣ ΑΠΟ 6 ΣΕΛΙ ΕΣ

Α2. ίνεται το παρακάτω τμήμα αλγορίθμου: Για i από 3 μέχρι Α με_βήμα Β Εμφάνισε i Τέλος_επανάληψης ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΤΕΛΟΣ 1ΗΣ ΑΠΟ 6 ΣΕΛΙ ΕΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΠΑΝΕΛΛΑ ΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΕΣΠΕΡΙΝΟΥ ΕΠΑΛ (ΟΜΑ ΑΣ Β ) ΣΑΒΒΑΤΟ 22 ΜΑΪΟΥ 2010 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ

Διαβάστε περισσότερα

ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ ΤΗΣ Γ' ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ ΤΗΣ Γ' ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ ΤΗΣ Γ' ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΘΕΜΑ Α Α1. 1. ΣΩΣΤΟ 2. ΣΩΣΤΟ 3. ΛΑΘΟΣ 4. ΣΩΣΤΟ 5. ΛΑΘΟΣ ΟΙ ΛΥΣΕΙΣ ΤΩΝ ΘΕΜΑΤΩΝ ΑΠΟ ΤΟΝ ΚΑΘΗΓΗΤΗ

Διαβάστε περισσότερα

ΣΧΕΔΙΟ ΜΑΘΗΜΑΤΟΣ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ : Γ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ : ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ

ΣΧΕΔΙΟ ΜΑΘΗΜΑΤΟΣ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ : Γ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ : ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ ΣΧΕΔΙΟ ΜΑΘΗΜΑΤΟΣ ΜΑΘΗΜΑ ΤΑΞΗ ΚΕΦΑΛΑΙΟ 2 ο ΕΙΣΗΓΗΤΗΣ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ : Γ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ : ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ : ΚΑΖΑΝΤΖΗΣ ΧΡΗΣΤΟΣ 1. Γενικός

Διαβάστε περισσότερα

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον. Προτεινόμενα θέματα 2013 - Λύσεις

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον. Προτεινόμενα θέματα 2013 - Λύσεις Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Προτεινόμενα θέματα 2013 - Λύσεις ΘΕΜΑ 1 ο Α1. Να γράψετε την λέξη Σωστό αν είναι σωστή, ή την λέξη Λάθος αν είναι λανθασμένη η πρόταση : 1. Μια συνάρτηση

Διαβάστε περισσότερα

ΘΕΜΑ 1ο Α. Να αναφερθούν οι βασικές αλγοριθµικές δοµές (συνιστώσες / εντολές ενός αλγορίθµου). Μονάδες 10

ΘΕΜΑ 1ο Α. Να αναφερθούν οι βασικές αλγοριθµικές δοµές (συνιστώσες / εντολές ενός αλγορίθµου). Μονάδες 10 ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ ʹ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 1 ΙΟΥΝΙΟΥ 2001 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ

Διαβάστε περισσότερα

ΔΙΔΑΚΤΙΚΗ της ΠΛΗΡΟΦΟΡΙΚΗΣ

ΔΙΔΑΚΤΙΚΗ της ΠΛΗΡΟΦΟΡΙΚΗΣ ΕΘΝΙΚΟ ΚΑΙ ΚΑΠΟΔΙΣΤΡΙΑΚΟ ΠΑΝΕΠΙΣΤΗΜΙΟ ΑΘΗΝΩΝ ΤΜΗΜΑ ΠΛΗΡΟΦΟΡΙΚΗΣ & ΤΗΛΕΠΙΚΟΙΝΩΝΙΩΝ ΔΙΔΑΚΤΙΚΗ της ΠΛΗΡΟΦΟΡΙΚΗΣ Μ. Γρηγοριάδου Ρ. Γόγουλου Ενότητα: Η Διδασκαλία του Προγραμματισμού Περιεχόμενα Παρουσίασης

Διαβάστε περισσότερα

ΘΕΜΑ Α Α1. Να γράψετε τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή ή τη λέξη ΛΑΘΟΣ, αν είναι λανθασμένη.

ΘΕΜΑ Α Α1. Να γράψετε τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή ή τη λέξη ΛΑΘΟΣ, αν είναι λανθασμένη. ΜΑΘΗΜΑ / ΤΑΞΗ : Ανάπτυξη Εφαρμογών ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: ΘΕΜΑ Α Α1. Να γράψετε τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή ή τη λέξη ΛΑΘΟΣ, αν είναι λανθασμένη.

Διαβάστε περισσότερα

7. Βασικά στοιχεία προγραµµατισµού.

7. Βασικά στοιχεία προγραµµατισµού. 7. Βασικά στοιχεία προγραµµατισµού. ΗΜ01-Θ1Γ Δίνονται οι παρακάτω έννοιες: 1. Λογικός τύπος δεδοµένων 2. Επιλύσιµο 3. Ακέραιος τύπος δεδοµένων 4. Περατότητα 5. Μεταβλητή 6. Ηµιδοµηµένο 7. Πραγµατικός τύπος

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Δ ΕΣΠΕΡΙΝΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Δ ΕΣΠΕΡΙΝΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Δ ΕΣΠΕΡΙΝΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 27 ΜΑΪΟΥ 2015 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2015 Β ΦΑΣΗ ÁÈÇÍÁ ΑΠΑΝΤΗΣΕΙΣ

ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2015 Β ΦΑΣΗ ÁÈÇÍÁ ΑΠΑΝΤΗΣΕΙΣ ΤΑΞΗ: ΚΑΤΕΥΘΥΝΣΗ: ΜΑΘΗΜΑ: ΘΕΜΑ Α Α1. 1. Λάθος 2. Λάθος 3. Σωστό 4. Λάθος 5. Σωστό Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ (2ος Κύκλος) ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ηµεροµηνία: Κυριακή 19 Απριλίου

Διαβάστε περισσότερα

ΦΡΟΝΤΙΣΤΗΡΙΟ «ΕΝΑ» ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ

ΦΡΟΝΤΙΣΤΗΡΙΟ «ΕΝΑ» ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ ΦΡΟΝΤΙΣΤΗΡΙΟ «ΕΝΑ» ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ ΘΕΜΑ 1 ο Α. Να γράψετε στο τετράδιο σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις και δίπλα

Διαβάστε περισσότερα

Μονάδες 12 ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ

Μονάδες 12 ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΗΜΕΡΗΣΙΩΝ ΚΑΙ ΕΣΠΕΡΙΝΩΝ ΕΠΑΓΓΕΛΜΑΤΙΚΩΝ ΛΥΚΕΙΩΝ (ΟΜΑΔΑ A ) ΚΑΙ ΜΑΘΗΜΑΤΩΝ ΕΙΔΙΚΟΤΗΤΑΣ ΕΠΑΓΓΕΛΜΑΤΙΚΩΝ ΛΥΚΕΙΩΝ (ΟΜΑΔΑ Β ) ΠΑΡΑΣΚΕΥΗ 5 ΙΟΥΝΙΟΥ 2015 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ:

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΣΠΕΡΙΝΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΣΠΕΡΙΝΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΣΠΕΡΙΝΩΝ ΠΑΝΕΛΛΑΔΙΚΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 6 ΙΟΥΝΙΟΥ 2014 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΔΟΜΗΜΕΝΟΣ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ / Γ ΕΠΑΛ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 27/01/2013

ΜΑΘΗΜΑ / ΤΑΞΗ : ΔΟΜΗΜΕΝΟΣ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ / Γ ΕΠΑΛ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 27/01/2013 ΜΑΘΗΜΑ / ΤΑΞΗ : ΔΟΜΗΜΕΝΟΣ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ / Γ ΕΠΑΛ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 27/01/2013 ΘΕΜΑ Α Α1. Να χαρακτηρίσετε τις προτάσεις που ακολουθούν, γράφοντας δίπλα στο γράμμα που αντιστοιχεί σε κάθε πρόταση τη

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Θέµα 1: Α. Η «σύγκριση» λειτουργιών ανθρώπου και υπολογιστή επιφέρει βέβαια µια τεράστια ποιοτική διαφορά υπέρ του ανθρώπου. I. Ποια είναι η διαφορά

Διαβάστε περισσότερα

Μαθησιακές δυσκολίες ΙΙ. Παλαιγεωργίου Γιώργος Τμήμα Μηχανικών Ηλεκτρονικών Υπολογιστών Τηλεπικοινωνιών και Δικτύων, Πανεπιστήμιο Θεσσαλίας

Μαθησιακές δυσκολίες ΙΙ. Παλαιγεωργίου Γιώργος Τμήμα Μηχανικών Ηλεκτρονικών Υπολογιστών Τηλεπικοινωνιών και Δικτύων, Πανεπιστήμιο Θεσσαλίας Μαθησιακές δυσκολίες ΙΙ Παλαιγεωργίου Γιώργος Τμήμα Μηχανικών Ηλεκτρονικών Υπολογιστών Τηλεπικοινωνιών και Δικτύων, Πανεπιστήμιο Θεσσαλίας Μάρτιος 2010 Προηγούμενη διάλεξη Μαθησιακές δυσκολίες Σε όλες

Διαβάστε περισσότερα

Α Β (ΟΧΙ Α) Η Β Α ΚΑΙ Β Α Η Β ΨΕΥ ΗΣ ΑΛΗΘΗΣ

Α Β (ΟΧΙ Α) Η Β Α ΚΑΙ Β Α Η Β ΨΕΥ ΗΣ ΑΛΗΘΗΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΕΣΠΕΡΙΝΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 2 ΙΟΥΝΙΟΥ 2006 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ

Διαβάστε περισσότερα

7. Βασικά στοιχεία προγραμματισμού

7. Βασικά στοιχεία προγραμματισμού 7. Βασικά στοιχεία προγραμματισμού 146 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Εισαγωγή Κάθε γλώσσα προγραμματισμού, όπως αναφέρθηκε, έχει το δικό της λεξιλόγιο και τα προγράμματα της ακολουθούν

Διαβάστε περισσότερα

ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΘΕΜΑ 1 Α.

ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΘΕΜΑ 1 Α. ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΘΕΜΑ 1 Α. 1. Αν το Α έχει την τιµή 10 και το Β την τιµή 20 τότε η έκφραση (Α > 8 ΚΑΙ Β < 20) Ή (Α > 10 Ή Β = 10) είναι αληθής 2. Σε περίπτωση εµφωλευµένων βρόχων, ο εσωτερικός

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ Γ ΛΥΚΕΙΟΥ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ Γ ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ Γ ΛΥΚΕΙΟΥ ΙΑΓΩΝΙΣΜΑ ΘΕΜΑ 1 Ο Α. Να χαρακτηρίσετε µε σωστό ή λάθος τις παρακάτω προτάσεις: 1. Ανοικτά είναι τα προβλήµατα που δεν

Διαβάστε περισσότερα

! "!# $ % & & ' "& '# & +

! !# $ % & & ' & '# & + !! "!# $ % & & ' "& '# "()#*! & +, &! *! *! ) -.!-/ /)-0*- -0*-/*. 1! '!* %2 1' "# 32 * 1!! ( 4. 1'! )! 1! 5 6 &! *( '.., 1! (. 7., 7(8 34+ % -*- 3 9 4:+/3 *!" # *!"/!# 0! 5 % ;* ?@A =>?@A ?@1

Διαβάστε περισσότερα

B Γυμνασίου. Ενότητα 9

B Γυμνασίου. Ενότητα 9 B Γυμνασίου Ενότητα 9 Γραμμικές εξισώσεις με μία μεταβλητή Διερεύνηση (1) Να λύσετε τις πιο κάτω εξισώσεις και ακολούθως να σχολιάσετε το πλήθος των λύσεων που βρήκατε σε καθεμιά. α) ( ) ( ) ( ) Διερεύνηση

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ Ανάπτυξη Εφαρµογών ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Γ ΛΥΚΕΙΟΥ ΙΑΓΩΝΙΣΜΑ Α κ Θέµα 1 ο Α. Να γράψετε στο τετράδιο σας τον αριθµό κάθε µιάς από τις παρακάτω προτάσεις και δίπλα τη λέξη: Σωστό, αν είναι σωστή, ή τη λέξη

Διαβάστε περισσότερα

Περι-γράφοντας... κλωνάρια

Περι-γράφοντας... κλωνάρια Όνομα(τα): Όνομα Η/Υ: Σ Τμήμα: Ημερομηνία: Περι-γράφοντας... κλωνάρια Ξεκινήστε το Χώρο ραστηριοτήτων, επιλέξτε τη θεματική ενότητα: ΘΕ03: Απλή επιλογή και επιλέξτε την πρώτη δραστηριότητα (Περι-γράφοντας...

Διαβάστε περισσότερα

ΚΕΦΑΛΑΙΟ 1ο 3ο. ΚΕΦΑΛΑΙΟ 5ο 6ο. ΚΕΦΑΛΑΙΟ 7ο. Δομημένος Προγραμματισμός - Γενικές Ασκήσεις Επανάληψης

ΚΕΦΑΛΑΙΟ 1ο 3ο. ΚΕΦΑΛΑΙΟ 5ο 6ο. ΚΕΦΑΛΑΙΟ 7ο. Δομημένος Προγραμματισμός - Γενικές Ασκήσεις Επανάληψης ΚΕΦΑΛΑΙΟ 1ο 3ο 1. Συμπληρώστε τα κενά με τη λέξη που λείπει. α. Ένα πρόβλημα το χωρίζουμε σε άλλα απλούστερα, όταν είναι ή όταν έχει τρόπο επίλυσης. β. Η επίλυση ενός προβλήματος προϋποθέτει την του. γ.

Διαβάστε περισσότερα

III. Πως μετατρέπεται το πηγαίο πρόγραμμα σε εκτελέσιμο πρόγραμμα;

III. Πως μετατρέπεται το πηγαίο πρόγραμμα σε εκτελέσιμο πρόγραμμα; ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ: Θέμα 1ο I. Τι πρέπει να ικανοποιεί ένα κομμάτι κώδικα ώστε να χαρακτηριστεί ως υποπρόγραμμα; Τα υποπρογράμματα πρέπει

Διαβάστε περισσότερα

ΕΡΩΤΗΣΕΙΣ ΑΞΙΟΛΟΓΗΣΗΣ ΤΕΤΡΑΔΙΟΥ ΜΑΘΗΤΗ

ΕΡΩΤΗΣΕΙΣ ΑΞΙΟΛΟΓΗΣΗΣ ΤΕΤΡΑΔΙΟΥ ΜΑΘΗΤΗ ΕΡΩΤΗΣΕΙΣ ΑΞΙΟΛΟΓΗΣΗΣ ΤΕΤΡΑΔΙΟΥ ΜΑΘΗΤΗ ΤΕΣΤ1 ΑΠΑΝΤΗΣΕΙΣ 1. Κατανόηση, Ανάλυση, Επίλυση 2. Είσοδος, Επεξεργασία, Έξοδος, Έλεγχος 3. Κατανόηση 4. Πληροφορία 5. Διατύπωση 6. Δομή 7. Απαιτήσεων 8. Λ, 9. Σ,

Διαβάστε περισσότερα

Λύσεις Θεμάτων Πανελλαδικών Εξετάσεων στο μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον

Λύσεις Θεμάτων Πανελλαδικών Εξετάσεων στο μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Λύσεις Θεμάτων Πανελλαδικών Εξετάσεων στο μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον 31 Μάη 2007 Ζήτημα Α Θέμα 1 1. Σωστό, 2. Λάθος, 3. Σωστό, 4. Λάθος, 5. Λάθος Ζήτημα Β1, i) Μεταφερσιμότητα

Διαβάστε περισσότερα

Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ

Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΚΦΩΝΗΣΕΙΣ 1 Γ' ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 ο ΕΚΦΩΝΗΣΕΙΣ Α. Να γράψετε στο τετράδιό σας τον αριθµό καθεµιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη

Διαβάστε περισσότερα

Μεταβλητές. Για περισσότερες λεπτομέρειες πάνω στις μεταβλητές θα ήταν χρήσιμο να διαβάσεις το

Μεταβλητές. Για περισσότερες λεπτομέρειες πάνω στις μεταβλητές θα ήταν χρήσιμο να διαβάσεις το Τάξη : Α Λυκείου Λογισμικό : Scratch Ενδεικτική Διάρκεια : 45 λεπτά Μεταβλητές Όλα όσα έμαθες στα προηγούμενα φυλλάδια είναι απαραίτητα για να υλοποιήσεις απλές εφαρμογές. Ωστόσο αν θέλεις να δημιουργήσεις

Διαβάστε περισσότερα

Δυναμικές Ιστοσελίδες Εισαγωγή στην Javascript για προγραμματισμό στην πλευρά του client

Δυναμικές Ιστοσελίδες Εισαγωγή στην Javascript για προγραμματισμό στην πλευρά του client ΕΣΔ 516 Τεχνολογίες Διαδικτύου Δυναμικές Ιστοσελίδες Εισαγωγή στην Javascript για προγραμματισμό στην πλευρά του client Περιεχόμενα Περιεχόμενα Javascript και HTML Βασική σύνταξη Μεταβλητές Τελεστές Συναρτήσεις

Διαβάστε περισσότερα

ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ

ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ ΒΑΙΚΕ ΕΝΝΟΙΕ ΑΓΟΡΙΘΜΩΝ ΕΡΩΤΗΕΙ ΑΞΙΟΟΓΗΗ ΕΡΩΤΗΕΙ ΩΤΟΥ ΑΘΟΥ 1. ηµειώστε το γράµµα αν η πρόταση είναι σωστή και το γράµµα αν είναι λάθος. 1. Ο αλγόριθµος πρέπει να τερµατίζεται µετά από εκτέλεση πεπερασµένου

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ) Γ ΤΑΞΗΣ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ 2002

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ) Γ ΤΑΞΗΣ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ 2002 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ) Γ ΤΑΞΗΣ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ 2002 ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ 1ο Α. Να αναφέρετε ονομαστικά τις βασικές λειτουργίες

Διαβάστε περισσότερα

ΘΕΜΑ 1 ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ

ΘΕΜΑ 1 ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ 1 ο ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 27 MAΪΟΥ 2009 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ανάπτυξη Εφαρµογών σε Προγραµµατιστικό Περιβάλλον ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ κ ΙΑΓΩΝΙΣΜΑ Α ΘΕΜΑ 1 Α. Να γράψετε τους αριθµούς της στήλης Α και δίπλα το γράµµα της Στήλης Β που αντιστοιχεί

Διαβάστε περισσότερα

Α Λυκείου Άλγεβρα Τράπεζα Θεμάτων Το Δεύτερο Θέμα

Α Λυκείου Άλγεβρα Τράπεζα Θεμάτων Το Δεύτερο Θέμα Α Λυκείου Άλγεβρα Τράπεζα Θεμάτων Το Δεύτερο Θέμα Θεωρούμε την ακολουθία (α ν ) των θετικών περιττών αριθμών: 1, 3, 5, 7, α) Να αιτιολογήσετε γιατί η (α ν ) είναι αριθμητική πρόοδος και να βρείτε τον εκατοστό

Διαβάστε περισσότερα

ΑΡΧΙΤΕΚΤΟΝΙΚΗ ΥΠΟΛΟΓΙΣΤΩΝ. Κεφάλαιο 3

ΑΡΧΙΤΕΚΤΟΝΙΚΗ ΥΠΟΛΟΓΙΣΤΩΝ. Κεφάλαιο 3 ΑΡΧΙΤΕΚΤΟΝΙΚΗ ΥΠΟΛΟΓΙΣΤΩΝ Κεφάλαιο 3 Κεντρική Μονάδα Επεξεργασίας Κεντρική Μονάδα Επεξεργασίας Μονάδα επεξεργασίας δεδομένων Μονάδα ελέγχου Μονάδα επεξεργασίας δεδομένων Δομή Αριθμητικής Λογικής Μονάδας

Διαβάστε περισσότερα

Πώς μπορούμε να δημιουργούμε γεωμετρικά σχέδια με τη Logo;

Πώς μπορούμε να δημιουργούμε γεωμετρικά σχέδια με τη Logo; Κεφάλαιο 2 Εισαγωγή Πώς μπορούμε να δημιουργούμε γεωμετρικά σχέδια με τη Logo; Η Logo είναι μία από τις πολλές γλώσσες προγραμματισμού. Κάθε γλώσσα προγραμματισμού έχει σκοπό τη δημιουργία προγραμμάτων

Διαβάστε περισσότερα

10. Με πόσους και ποιους τρόπους μπορεί να αναπαρασταθεί ένα πρόβλημα; 11. Περιγράψτε τα τρία στάδια αντιμετώπισης ενός προβλήματος.

10. Με πόσους και ποιους τρόπους μπορεί να αναπαρασταθεί ένα πρόβλημα; 11. Περιγράψτε τα τρία στάδια αντιμετώπισης ενός προβλήματος. 1. Δώστε τον ορισμό του προβλήματος. 2. Σι εννοούμε με τον όρο επίλυση ενός προβλήματος; 3. Σο πρόβλημα του 2000. 4. Σι εννοούμε με τον όρο κατανόηση προβλήματος; 5. Σι ονομάζουμε χώρο προβλήματος; 6.

Διαβάστε περισσότερα

Ανάπτυξη και Σχεδίαση Λογισμικού

Ανάπτυξη και Σχεδίαση Λογισμικού Ανάπτυξη και Σχεδίαση Λογισμικού Η γλώσσα προγραμματισμού C Γεώργιος Δημητρίου Εκφράσεις και Λίγες Εντολές Οι εκφράσεις της C Τελεστές Απλές και σύνθετες εντολές Εντολές ελέγχου (επιλογής) Εισαγωγή σε

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ: Θέμα 1ο Ι. Να αντιστοιχίσετε τους παρακάτω όρους. Στη στήλη Β περισσεύει μια επιλογή. (6 Μονάδες) 1 - Β 2 - Α 3

Διαβάστε περισσότερα

ΜΕΤΑΠΤΥΧΙΑΚΟ ΠΡΟΓΡΑΜΜΑ:

ΜΕΤΑΠΤΥΧΙΑΚΟ ΠΡΟΓΡΑΜΜΑ: ΠΑΝΕΠΙΣΤΗΜΙΟ ΠΑΤΡΩΝ ΤΜΗΜΑ ΜΑΘΗΜΑΤΙΚΩΝ ΜΕΤΑΠΤΥΧΙΑΚΟ ΠΡΟΓΡΑΜΜΑ: «Υπολογιστικά Μαθηματικά Και Πληροφορική» Κατεύθυνση: «Τεχνολογίες Πληροφορικής Και Επικοινωνιών Στην Εκπαίδευση» ΔΙΠΛΩΜΑΤΙΚΗ ΕΡΓΑΣΙΑ ΘΕΜΑ:

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Θέµα 1 ο Α. Να απαντήσετε τις παρακάτω ερωτήσεις τύπου Σωστό Λάθος (Σ Λ) 1. Σκοπός της συγχώνευσης 2 ή περισσοτέρων ταξινοµηµένων πινάκων είναι η δηµιουργία

Διαβάστε περισσότερα

www.costaschatzinikolas.gr

www.costaschatzinikolas.gr ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ σε ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ (ΑΕΠΠ) ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ σε ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ (ΑΕΠΠ) Δημιουργία - Συγγραφή Costas Chatzinikolas www.costachatzinikolas.gr info@costaschatzinikolas.gr

Διαβάστε περισσότερα

Ενημέρωση αλλαγών στην αξιολόγηση ΟΠΣ_ΕΣΠΑ Εγκατάσταση στην Παραγωγή: 13/9/2010

Ενημέρωση αλλαγών στην αξιολόγηση ΟΠΣ_ΕΣΠΑ Εγκατάσταση στην Παραγωγή: 13/9/2010 Ενημέρωση αλλαγών στην αξιολόγηση ΟΠΣ_ΕΣΠΑ ΠΕΡΙΕΧΟΜΕΝΑ Ι. Αλλαγές στο ΣΤΑΔΙΟ Α στην αξιολόγηση (εξέταση πληρότητας) I.1. Προσδιορισμός ερωτημάτων λίστας εξέτασης Λ1 στο ΕΠ I.2. Προσδιορισμός της λίστας

Διαβάστε περισσότερα

ΕΙΣΑΓΩΓΗ ΣΤΟΥΣ ΑΛΓΟΡΙΘΜΟΥΣ ΚΑΙ ΣΤΟΝ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟ ΠΑΝΕΠΙΣΤΗΜΙΟ ΑΙΓΑΙΟΥ ΤΜΗΜΑ ΠΟΛΙΤΙΣΜΙΚΗΣ ΤΕΧΝΟΛΟΓΙΑΣ ΚΑΙ ΕΠΙΚΟΙΝΩΝΙΑΣ. Διδάσκουσα Δρ Β.

ΕΙΣΑΓΩΓΗ ΣΤΟΥΣ ΑΛΓΟΡΙΘΜΟΥΣ ΚΑΙ ΣΤΟΝ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟ ΠΑΝΕΠΙΣΤΗΜΙΟ ΑΙΓΑΙΟΥ ΤΜΗΜΑ ΠΟΛΙΤΙΣΜΙΚΗΣ ΤΕΧΝΟΛΟΓΙΑΣ ΚΑΙ ΕΠΙΚΟΙΝΩΝΙΑΣ. Διδάσκουσα Δρ Β. ΕΙΣΑΓΩΓΗ ΣΤΟΥΣ ΑΛΓΟΡΙΘΜΟΥΣ ΚΑΙ ΣΤΟΝ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟ ΠΑΝΕΠΙΣΤΗΜΙΟ ΑΙΓΑΙΟΥ ΤΜΗΜΑ ΠΟΛΙΤΙΣΜΙΚΗΣ ΤΕΧΝΟΛΟΓΙΑΣ ΚΑΙ ΕΠΙΚΟΙΝΩΝΙΑΣ Διδάσκουσα Δρ Β. Καβακλή Χειμερινό Εξάμηνο 2001 1 Σύνολο χαρακτήρων της Pascal Για

Διαβάστε περισσότερα

Δυαδικό Σύστημα Αρίθμησης

Δυαδικό Σύστημα Αρίθμησης Δυαδικό Σύστημα Αρίθμησης Το δυαδικό σύστημα αρίθμησης χρησιμοποιεί δύο ψηφία. Το 0 και το 1. Τα ψηφία ενός αριθμού στο δυαδικό σύστημα αρίθμησης αντιστοιχίζονται σε δυνάμεις του 2. Μονάδες, δυάδες, τετράδες,

Διαβάστε περισσότερα

Εργαστήριο Δομημένος Προγραμματισμός (C#) Τμήμα Μηχανολογίας Νικόλαος Ζ. Ζάχαρης Καθηγητής Εφαρμογών

Εργαστήριο Δομημένος Προγραμματισμός (C#) Τμήμα Μηχανολογίας Νικόλαος Ζ. Ζάχαρης Καθηγητής Εφαρμογών Εργαστήριο Δομημένος Προγραμματισμός (C#) Τμήμα Μηχανολογίας Νικόλαος Ζ. Ζάχαρης Καθηγητής Εφαρμογών Σκοπός Να αναπτύξουν ένα πρόγραμμα όπου θα επαναλάβουν τα βήματα ανάπτυξης μιας παραθυρικής εφαρμογής.

Διαβάστε περισσότερα

ΣΠΗΛΙΩΤΗΣ ΣΤΑΜΟΥΛΗΣ. ΚΑΘΗΓΗΤΗΣ ΠΛΗΡΟΦΟΡΙΚΗΣ 12ου ΓΕΛ ΛΑΡΙΣΑΣ

ΣΠΗΛΙΩΤΗΣ ΣΤΑΜΟΥΛΗΣ. ΚΑΘΗΓΗΤΗΣ ΠΛΗΡΟΦΟΡΙΚΗΣ 12ου ΓΕΛ ΛΑΡΙΣΑΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΕΥΤΕΡΑ 12 ΙΟΥΝΙΟΥ 2000 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Θέµα

Διαβάστε περισσότερα

Βήματα: μνήμη 2. Αλγόριθμος βήματα που περιγράφουν την επεξεργασία των δεδομένων. Δομές Δεδομένων + Αλγόριθμοι = Προγράμματα

Βήματα: μνήμη 2. Αλγόριθμος βήματα που περιγράφουν την επεξεργασία των δεδομένων. Δομές Δεδομένων + Αλγόριθμοι = Προγράμματα Απλά Προγράμματα Βήματα: 1. Καθορισμός παράστασης δεδομένων στη μνήμη 2. Αλγόριθμος βήματα που περιγράφουν την επεξεργασία των δεδομένων Δομές Δεδομένων + Αλγόριθμοι = Προγράμματα Οι Βασικοί κανόνες Κατανόηση

Διαβάστε περισσότερα

Κεφάλαιο 5ο: Εντολές Επανάληψης

Κεφάλαιο 5ο: Εντολές Επανάληψης Χρήστος Τσαγγάρης ΕΕ ΙΠ Τµήµατος Μαθηµατικών, Πανεπιστηµίου Αιγαίου Κεφάλαιο 5ο: Εντολές Επανάληψης Η διαδικασία της επανάληψης είναι ιδιαίτερη συχνή, αφού πλήθος προβληµάτων µπορούν να επιλυθούν µε κατάλληλες

Διαβάστε περισσότερα

Τα δεδομένα στη C++ χωρίζονται σε 3 κατηγορίες: τους αριθμούς (numbers), τους χαρακτήρες (characters) και τις συμβολοσειρές (strings).

Τα δεδομένα στη C++ χωρίζονται σε 3 κατηγορίες: τους αριθμούς (numbers), τους χαρακτήρες (characters) και τις συμβολοσειρές (strings). Για να λύσουμε ένα πρόβλημα στη C++ χρειαζόμαστε δυο βασικές έννοιες. Η μια είναι οι οδηγίες εντολές, ο αλγόριθμος δηλαδή, που πρέπει να ακολουθήσουμε για να λύσουμε το πρόβλημά μας και η άλλη είναι τα

Διαβάστε περισσότερα

Περιληπτικά, τα βήματα που ακολουθούμε γενικά είναι τα εξής:

Περιληπτικά, τα βήματα που ακολουθούμε γενικά είναι τα εξής: Αυτό που πρέπει να θυμόμαστε, για να μη στεναχωριόμαστε, είναι πως τόσο στις εξισώσεις, όσο και στις ανισώσεις 1ου βαθμού, που θέλουμε να λύσουμε, ακολουθούμε ακριβώς τα ίδια βήματα! Εκεί που πρεπει να

Διαβάστε περισσότερα

ΓΡΑΠΤΕΣ ΠΡΟΑΓΩΓΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΜΑΪΟΥ-ΙΟΥΝΙΟΥ 2015

ΓΡΑΠΤΕΣ ΠΡΟΑΓΩΓΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΜΑΪΟΥ-ΙΟΥΝΙΟΥ 2015 ΛΥΚΕΙΟ ΑΡΧ. ΜΑΚΑΡΙΟΥ Γ - ΔΑΣΟΥΠΟΛΗ ΣΧΟΛΙΚΟ ΕΤΟΣ 2014-2015 ΓΡΑΠΤΕΣ ΠΡΟΑΓΩΓΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΜΑΪΟΥ-ΙΟΥΝΙΟΥ 2015 ΜΑΘΗΜΑ: ΠΛΗΡΟΦΟΡΙΚΗ ΗΜΕΡΟΜΗΝΙΑ: 10 /6 / 2015 ΒΑΘΜΟΣ:... ΤΑΞΗ: Β ΧΡΟΝΟΣ: 2 ώρες ΥΠ. ΚΑΘΗΓΗΤΗ:...

Διαβάστε περισσότερα

Τύποι, Σταθερές και Μεταβλητές

Τύποι, Σταθερές και Μεταβλητές ΚΕΦΑΛΑΙΟ 3 Τύποι, Σταθερές και Μεταβλητές Η έννοια της μεταβλητής Γενικά μπορούμε να πούμε ότι η έννοια της μεταβλητής στον προγραμματισμό είναι άμεσα συνδεδεμένη με την έννοια που αυτή έχει σε μαθηματικό

Διαβάστε περισσότερα

1. Να αναφέρετε ονοµαστικά τις λειτουργίες µε τις οποίες ο υπολογιστής µπορεί να επιτελέσει µε επιτυχία οποιαδήποτε επεξεργασία. Ï.Å.Ö.Å.

1. Να αναφέρετε ονοµαστικά τις λειτουργίες µε τις οποίες ο υπολογιστής µπορεί να επιτελέσει µε επιτυχία οποιαδήποτε επεξεργασία. Ï.Å.Ö.Å. 1 Γ' ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗ ΘΕΜΑ 1: Α. 1. Να αναφέρετε ονοµαστικά τις λειτουργίες µε τις οποίες ο υπολογιστής µπορεί να επιτελέσει µε επιτυχία

Διαβάστε περισσότερα

Κατασκευή Προγράμματος για επίλυση Φυσικομαθηματικών συναρτήσεων

Κατασκευή Προγράμματος για επίλυση Φυσικομαθηματικών συναρτήσεων Κατασκευή Προγράμματος για επίλυση Φυσικομαθηματικών συναρτήσεων Λιακόπουλος Ιωάννης1 και Λυπηρίδης Χαράλαμπος2 1liakopoulosjohn@gmail.com, 2xarislip@hotmail.com Επιβλέπων Καθηγητής: Λάζαρος Τζήμκας tzimkaslazaros@gmail.com

Διαβάστε περισσότερα

Είδη εντολών. Απλές εντολές. Εντολές ελέγχου. Εκτελούν κάποια ενέργεια. Ορίζουν τον τρόπο με τον οποίο εκτελούνται άλλες εντολές

Είδη εντολών. Απλές εντολές. Εντολές ελέγχου. Εκτελούν κάποια ενέργεια. Ορίζουν τον τρόπο με τον οποίο εκτελούνται άλλες εντολές Μορφές Εντολών Είδη εντολών Απλές εντολές Εκτελούν κάποια ενέργεια Εντολές ελέγχου Ορίζουν τον τρόπο με τον οποίο εκτελούνται άλλες εντολές Εντολές και παραστάσεις Μιαεντολήείναιμιαπαράστασηπου ακολουθείται

Διαβάστε περισσότερα

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΣΠΕΡΙΝΩΝ

ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΣΠΕΡΙΝΩΝ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΣΠΕΡΙΝΩΝ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΡΙΤΗ 19 ΙΟΥΝΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

3. Σηµειώσεις Access. # Εισαγωγή ψηφίου ή κενού διαστήµατος. Επιτρέπονται τα ση-

3. Σηµειώσεις Access. # Εισαγωγή ψηφίου ή κενού διαστήµατος. Επιτρέπονται τα ση- Μάθηµα 3 Προχωρηµένες ιδιότητες πεδίων Μάσκες εισαγωγής Οι ιδιότητες Μορφή και Μάσκα εισαγωγής περιγράφονται µαζί γιατί έχουν κοινά χαρακτηριστικά που αφορούν την εµφάνιση. Με την ιδιότητα Μορφή καθορίζουµε

Διαβάστε περισσότερα

Ανακτήθηκε από την ΕΚΠΑΙΔΕΥΤΙΚΗ ΚΛΙΜΑΚΑ http://edu.klimaka.gr ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ

Ανακτήθηκε από την ΕΚΠΑΙΔΕΥΤΙΚΗ ΚΛΙΜΑΚΑ http://edu.klimaka.gr ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΠΑΝΕΛΛΗΝΙΕΣ ΕΞΕΤΑΣΕΙΣ ΗΜΕΡΗΣΙΩΝ ΚΑΙ ΕΣΠΕΡΙΝΩΝ ΕΠΑΓΓΕΛΜΑΤΙΚΩΝ ΛΥΚΕΙΩΝ (ΟΜΑ Α A ) ΚΑΙ ΜΑΘΗΜΑΤΩΝ ΕΙ ΙΚΟΤΗΤΑΣ ΕΠΑΓΓΕΛΜΑΤΙΚΩΝ ΛΥΚΕΙΩΝ (ΟΜΑ Α Β ) ΠΕΜΠΤΗ 7 ΙΟΥΝΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΟΜΗΜΕΝΟΣ

Διαβάστε περισσότερα

2 Ορισμός Κλάσεων. Παράδειγμα: Μηχανή για Εισιτήρια. Δομή μιας Κλάσης. Ο Σκελετός της Κλάσης για τη Μηχανή. Ορισμός Πεδίων 4/3/2008

2 Ορισμός Κλάσεων. Παράδειγμα: Μηχανή για Εισιτήρια. Δομή μιας Κλάσης. Ο Σκελετός της Κλάσης για τη Μηχανή. Ορισμός Πεδίων 4/3/2008 Παράδειγμα: Μηχανή για Εισιτήρια 2 Ορισμός Κλάσεων Σύνταξη κλάσης: πεδία, κατασκευαστές, μέθοδοι Ένας αυτόματος εκδότης εισιτηρίων είναι μια μηχανή που δέχεται χρήματα και εκδίδει ένα εισιτήριο. Εκδίδει

Διαβάστε περισσότερα

Πληρουορική Γ Γσμμασίοσ

Πληρουορική Γ Γσμμασίοσ Πληρουορική Γ Γσμμασίοσ Προγραμματισμός και Αλγόριθμοι Από το και τημ Χελώμα στημ Ευριπίδης Βραχνός http://evripides.mysch.gr/ 2014 2015 1 Προγραμματισμός Ζάννειο Πρότυπο Πειραματικό Γυμνάσιο Πειραιά Ενότητα:

Διαβάστε περισσότερα

Γενικά Στοιχεία Ηλεκτρονικού Υπολογιστή

Γενικά Στοιχεία Ηλεκτρονικού Υπολογιστή Γενικά Στοιχεία Ηλεκτρονικού Υπολογιστή 1. Ηλεκτρονικός Υπολογιστής Ο Ηλεκτρονικός Υπολογιστής είναι μια συσκευή, μεγάλη ή μικρή, που επεξεργάζεται δεδομένα και εκτελεί την εργασία του σύμφωνα με τα παρακάτω

Διαβάστε περισσότερα

Ένα περιοδικό για το ΑΕΠΠ. Φυλλάδια Ασκήσεων Περιλαμβάνει τα φυλλάδια ασήσεων του μαθήματος ΑΕΠΠ της Γ Λυκείου

Ένα περιοδικό για το ΑΕΠΠ. Φυλλάδια Ασκήσεων Περιλαμβάνει τα φυλλάδια ασήσεων του μαθήματος ΑΕΠΠ της Γ Λυκείου Ένα περιοδικό για το ΑΕΠΠ Φυλλάδια Ασκήσεων Περιλαμβάνει τα φυλλάδια ασήσεων του μαθήματος ΑΕΠΠ της Γ Λυκείου 1 ο Φυλλάδιο Ασκήσεων Α. Να απαντήσετε στις παρακάτω προτάσεις με σωστό (Σ) ή λάθος (Λ) 1)

Διαβάστε περισσότερα