Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές αλγοριθμικές δομές

Μέγεθος: px
Εμφάνιση ξεκινά από τη σελίδα:

Download "Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές αλγοριθμικές δομές"

Transcript

1 Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές αλγοριθμικές δομές

2 Βασικές Αλγοριθμικές Δομές 2

3 Εισαγωγή Οι αλγοριθμικές δομές εκφράζουν διαφορετικούς τρόπους γραφής ενός αλγορίθμου. Οι αλγοριθμικές δομές είναι τρεις: Δομή ακολουθίας Δομή επιλογής Δομή επανάληψης 3

4 Στοιχεία Ψευδογλώσσας Σταθερές Μεταβλητές Εκφράσεις Τελεστές Σχήματα Λογικών Υποθέσεων Επαναληπτικές Διαδικασίες Εντολές Εκχώρησης Ρήματα σε Προστακτική Ουσιαστικά Σχόλια Πρώτη & Τελευταία Γραμμή Δεδομένα & Αποτελέσματα 4

5 Σταθερές (Constants) Αναφερόμαστε σε προκαθορισμένες τιμές που παραμένουν αμετάβλητες σε όλη τη διάρκεια εκτέλεσης ενός αλγορίθμου: Αριθμητικές: αριθμητικοί χαρακτήρες, συν, πλην, κόμμα Αλφαριθμητικές: Οποιοσδήποτε χαρακτήρας εντός εισαγωγικών Λογικές: Αληθής ή Ψευδής 5

6 Μεταβλητές (Variables) Είναι ένα γλωσσικό στοιχείο που χρησιμοποιείται για να παραστήσει ένα στοιχείο δεδομένου. Στη μεταβλητή γίνεται εκχώρηση μίας τιμής, η οποία μπορεί να αλλάζει κατά τη διάρκεια εκτέλεσης του αλγορίθμου: Αριθμητικές Αλφαριθμητικές Λογικές Για τη σύνθεση του ονόματος μίας μεταβλητής χρησιμοποιούνται αριθμητικοί χαρακτήρες, αλφαριθμητικοί χαρακτήρες (πεζοί και κεφαλαίοι) και ο χαρακτήρας της κάτω παύλας. 6

7 Εκφράσεις (Expressions) Οι εκφράσεις διαμορφώνονται από τους τελεστέους (operands), σταθερές & μεταβλητές, και από τους τελεστές. Η διεργασία αποτίμησης μιας έκφρασης συνιστάται στην απόδοση τιμών στις μεταβλητές και στην εκτέλεση των πράξεων. Η τελική τιμή μιας έκφρασης εξαρτάται από την ιεραρχία των πράξεων και τη χρήση παρενθέσεων. Μια έκφραση μπορεί να αποτελείται από μία μόνο μεταβλητή ή σταθερά έως και πολύπλοκες μαθηματικές εκφράσεις. 7

8 Τελεστές (Operators) Πρόκειται για τα γνωστά σύμβολα που χρησιμοποιούνται στις διάφορες πράξεις Αριθμητικοί: +, -, *, /, ^ Συγκριτικοί: <=, <, =, <>, >, >= Λογικοί: και (σύζευξη), ή (διάζευξη), όχι (άρνηση) 8

9 Σχήματα Λογικών Υποθέσεων (1/3) αν συνθήκη τότε εντολή1 (εντολές1) αλλιώς εντολή2 (εντολές2) τέλος_αν 9

10 Σχήματα Λογικών Υποθέσεων (2/3) αν συνθήκη1 τότε εντολή1 (εντολές1) αλλιώς_αν συνθήκη2 τότε εντολή2 (εντολές2) αλλιώς_αν συνθήκη3 τότε εντολή3 (εντολές3) αλλιώς τέλος_αν 10

11 Σχήματα Λογικών Υποθέσεων (3/3) επίλεξε μεταβλητή περίπτωση λίστα_τιμών1 εντολή1 (εντολές1) περίπτωση λίστα_τιμών2 εντολή2 (εντολές2) περίπτωση αλλιώς εντολήν (εντολέςν) τέλος_επιλογών 11

12 Επαναληπτικές Διαδικασίες (1/3) όσο συνθήκη επανέλαβε εντολή (εντολές) τέλος_επανάληψης 12

13 Επαναληπτικές Διαδικασίες (2/3) αρχή_επανάληψης εντολή (εντολές) μέχρις_ότου συνθήκη 13

14 Επαναληπτικές Διαδικασίες (3/3) για μεταβλητή από αρχική_τιμή μέχρι τελική_τιμή με βήμα βήμα εντολή (εντολές) τέλος_επανάληψης 14

15 Εντολές Εκχώρησης Σταθερά τιμή Μεταβλητή τιμή Μεταβλητή σταθερά Μεταβλητή μεταβλητή Μεταβλητή έκφραση 15

16 Ρήματα σε Προστακτική Γράψε Διάβασε Τύπωσε 16

17 Ουσιαστικά Σε ορισμένες περιπτώσεις όταν οι ζητούμενες ενέργειες είναι πολλές ή προφανείς, καθορίζονται με τη χρήση ουσιαστικών αντί ρημάτων: Εισαγωγή δεδομένων Εκτύπωση αποτελεσμάτων 17

18 Σχόλια Προκειμένου να διαχωρίζονται οι επεξηγηματικές φράσεις από τις βασικές λέξεις ή φράσεις του αλγορίθμου, προτάσσεται στις πρώτες το σύμβολο του θαυμαστικού (!) 18

19 Πρώτη & Τελευταία Γραμμή πρόγραμμα όνομα_προγράμματος τέλος_προγράμματος όνομα_προγράμματος 19

20 Δομή Ακολουθίας 20

21 Ακολουθιακή Δομή Η ακολουθιακή δομή είναι η πιο απλή αλγοριθμική δομή στην οποία όλες οι εντολές του αλγορίθμου εκτελούνται: η μία μετά την άλλη (ακολουθιακά) μόνο μία φορά η κάθε μία υποχρεωτικά (δηλαδή δεν αγνοείται κάποια εντολή όπως συμβαίνει σε άλλες αλγοριθμικές δομές) Η ακολουθιακή δομή υλοποιείται με τις εντολές: διάβασε γράψε καταχώρισε ( ) 21

22 Δομή Ακολουθίας (1/4) Η ακολουθιακή δομή εντολών (σειριακών βημάτων) χρησιμοποιείται πρακτικά για την αντιμετώπιση απλών προβλημάτων, όπου είναι δεδομένη η σειρά εκτέλεσης ενός συνόλου ενεργειών. Ένας αλγόριθμος διατυπωμένος σε ψευδογλώσσα αρχίζει πάντα με τη λέξη πρόγραμμα συνοδευόμενη με το όνομα του αλγορίθμου και τελειώνει με τη λέξη τέλος_προγράμματος συνοδευόμενη επίσης με το όνομα. 22

23 Δομή Ακολουθίας (2/4) Η πρώτη ενέργεια που γίνεται είναι η εισαγωγή δεδομένων με τη χρήση του ρήματος διάβασε Η λέξη διάβασε συνοδεύεται με το όνομα μίας ή περισσοτέρων μεταβλητών, και εννοείται ότι μετά την ολοκλήρωση της ενέργειας αυτής, η μεταβλητή θα έχει λάβει κάποια αριθμητική τιμή ως περιεχόμενο. Κάθε μία λέξη της χρησιμοποιούμενης ψευδογλώσσας, που προσδιορίζει μια σαφή ενέργεια θα αποκαλείται στο εξής εντολή. Όλες οι εντολές σε ένα αλγόριθμο αποτυπώνονται με διαφορετικό χρώμα από το όνομα του αλγορίθμου και τις διάφορες σταθερές και μεταβλητές. 23

24 Δομή Ακολουθίας (3/4) Στη συνέχεια ακολουθεί η εντολή εκχώρησης τιμής. Η γενική μορφή της είναι: Μεταβλητή Έκφραση Η λειτουργία της είναι να γίνονται οι πράξεις στην έκφραση και το αποτέλεσμα να αποδίδεται, μεταβιβάζεται, εκχωρείται στη μεταβλητή. Στην εντολή αυτή χρησιμοποιείται το αριστερό βέλος, προκειμένου να δείχνει τη φορά της εκχώρησης. 24

25 Δομή Ακολουθίας (4/4) Ο αλγόριθμος ολοκληρώνεται με την εντολή εκτύπωσε που αποτυπώνει το τελικό αποτέλεσμα στον εκτυπωτή. Η σύνταξη της είναι ανάλογη με αυτή της εντολής διάβασε. Εναλλακτικά μπορεί να χρησιμοποιηθεί και η εντολή γράψε που αποτυπώνει ένα αποτέλεσμα στην οθόνη. 25

26 Παράδειγμα(1) Να δοθεί αλγόριθμος για τον υπολογισμό εμβαδού τριγώνου. Ε=(β*υ)/2 26

27 Λύση(1) Α τρόπος: ΑΛΓΟΡΙΘΜΟΣ ΕΜΒΑΔΟΝ_ΤΡΙΓΩΝΟΥ ΑΡΧΗ ΔΙΑΒΑΣΕ ΒΑΣΗ, ΥΨΟΣ ΕΜΒΑΔΟΝ ΒΑΣΗ * ΥΨΟΣ/2 ΕΜΦΑΝΙΣΕ ΤΟ ΕΜΒΑΔΟΝ ΕΙΝΑΙ:, ΕΜΒΑΔΟΝ ΤΕΛΟΣ ΕΜΒΑΔΟΝ_ΤΡΙΓΩΝΟΥ 27

28 Λύση(2) Β τρόπος: ΠΡΟΓΡΑΜΜΑ ΕΜΒΑΔΟΝ_ΤΡΙΓΩΝΟΥ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ:ΒΑΣΗ, ΥΨΟΣ, ΕΜΒΑΔΟΝ ΑΡΧΗ ΔΙΑΒΑΣΕ ΒΑΣΗ, ΥΨΟΣ ΕΜΒΑΔΟΝ ΒΑΣΗ * ΥΨΟΣ/2 ΓΡΑΨΕ ΤΟ ΕΜΒΑΔΟΝ ΕΙΝΑΙ:,ΕΜΒΑΔΟΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΕΜΒΑΔΟΝ_ΤΡΙΓΩΝΟΥ 28

29 Άσκηση 1 Να δοθεί αλγόριθμος για τον υπολογισμό της περιμέτρου ενός κύκλου. περ=2πρ π=3,14 29

30 Λύση Άσκησης 1 ΠΡΟΓΡΑΜΜΑ ΠΕΡΙΜΕΤΡΟΣ_ΚΥΚΛΟΥ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ: ΑΚΤΙΝΑ, ΠΕΡΙΜΕΤΡΟΣ, Π ΑΡΧΗ ΔΙΑΒΑΣΕ ΑΚΤΙΝΑ Π 3.14 ΠΕΡΙΜΕΤΡΟΣ 2*ΑΚΤΙΝΑ*Π ΓΡΑΨΕ Η ΠΕΡΙΜΕΤΡΟΣ ΕΙΝΑΙ, ΠΕΡΙΜΕΤΡΟΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΠΕΡΙΜΕΤΡΟΣ_ΚΥΚΛΟΥ 30

31 Άσκηση 2 Να δοθεί αλγόριθμος ο οποίος θα μετατρέπει μια θερμοκρασία από βαθμούς Φαρενάιτ σε βαθμούς Κελσίου. Ο παρακάτω τύπος εκφράζει τη σχέση που υπάρχει μεταξύ βαθμών Φαρενάιτ και Κελσίου: (F-32)/9=C/5 Οπότε C=5/9*(F-32) 31

32 Λύση Άσκησης 2 ΠΡΟΓΡΑΜΜΑ ΦΑΡΕΝΑΪΤ_ΚΕΛΣΙΟΥ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ:F, C ΑΡΧΗ ΔΙΑΒΑΣΕ F C 5/9*(F-32) ΓΡΑΨΕ ΟΙ ΒΑΘΜΟΙ ΚΕΛΣΙΟΥ ΕΙΝΑΙ:,C ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΦΑΡΕΝΑΪΤ_ ΚΕΛΣΙΟΥ 32

33 Άσκηση 3 Αν έχετε τις παρακάτω πληροφορίες: ΝΟΜΙΣΜΑ ΤΙΜΗ ΠΩΛΗΣΗΣ Λίρα Αγγλίας 1,25 Δολάριο Αμερικής 0,85 Γιεν Ιαπωνίας 0,0075 Να δώσετε αλγόριθμο που να υπολογίζει σε το σύνολο από 1025 λίρες Αγγλίας, 2234 δολάρια Αμερικής και Γιεν Ιαπωνίας. 33

34 Λύση Άσκησης 3 ΠΡΟΓΡΑΜΜΑ ΣΥΝΑΛΛΑΓΜΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ:ΛΙΡΑ, ΔΟΛΑΡΙΟ, ΓΙΕΝ, ΕΥΡΩ ΑΡΧΗ ΛΙΡΑ 1,25 ΔΟΛΑΡΙΟ 0,85 ΓΙΕΝ 0,0075 ΕΥΡΩ 1025*ΛΙΡΑ+2234*ΔΟΛΑΡΙΟ * ΓΙΕΝ ΓΡΑΨΕ Το σύνολο σε ΕΥΡΩ είναι, ΕΥΡΩ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΣΥΝΑΛΛΑΓΜΑ 34

35 Δομή Επιλογής 35

36 Δομή Επιλογής- Γενικά Δομή Επιλογής Η δομή επιλογής χρησιμοποιείται όταν θέλουμε να ελέγξουμε μια συνθήκη και να εκτελέσουμε κάποιες ενέργειες ανάλογα με την τιμή αυτής της συνθήκης. Συγκεκριμένα αν η συνθήκη είναι αληθής, τότε θέλουμε να εκτελούνται κάποιες εντολές ενώ αν είναι ψευδής θέλουμε να εκτελούνται κάποιες άλλες εντολές (διαφορετικές) ή να μην εκτελείται καμία εντολή. Η δομή της επιλογής υλοποιείται με τις εντολές: αν επίλεξε 36

37 Δομή Επιλογής (1/3) Στην πραγματικότητα πολύ λίγα προβλήματα μπορούν να επιλυθούν με τον προηγούμενο τρόπο της σειριακής/ακολουθιακής δομής ενεργειών. Συνήθως τα προβλήματα έχουν κάποιες ιδιαιτερότητες και δεν ισχύουν τα ίδια βήματα για κάθε περίπτωση. Η πλέον συνηθισμένη περίπτωση είναι να λαμβάνονται κάποιες αποφάσεις με βάση κάποια δεδομένα κριτήρια, που μπορεί να είναι διαφορετικά για κάθε διαφορετικό στιγμιότυπο ενός προβλήματος. 37

38 Δομή Επιλογής (2/3) Η διαδικασία της επιλογής περιλαμβάνει τον έλεγχο κάποιας συνθήκης που μπορεί να έχει δύο τιμές (Αληθής ή Ψευδής) και ακολουθεί η απόφαση εκτέλεσης κάποιας ενέργειας με βάση την τιμή της λογικής αυτής συνθήκης. Στην παράσταση αλγορίθμων με ψευδογλώσσα η επιλογή υλοποιείται με την εντολή αν...τότε 38

39 Δομή Επιλογής (3/3) Σύνταξη αν συνθήκη τότε εντολή Λειτουργία Αν ισχύει η συνθήκη (δηλαδή αν είναι αληθής), τότε μόνο εκτελείται η εντολή που ακολουθεί 39

40 Εντολή Αν 40

41 Περιορισμένη Επιλογή ΣΥΝΤΑΞΗ αν συνθήκη τότε εντολή (εντολές) τέλος_αν ΛΕΙΤΟΥΡΓΙΑ Αν η συνθήκη είναι αληθής τότε εκτελείται η εντολή (ή οι εντολές) ανάμεσα στο αν και στο τέλος_αν και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_αν. Αν η συνθήκη είναι ψευδής τότε η εντολή (ή οι εντολές) ανάμεσα στο αν και στο τέλος_αν δεν εκτελείται (δεν εκτελούνται) και ο αλγόριθμος συνεχίζει κατευθείαν στην επόμενη εντολή μετά το τέλος_αν. ΝΑΙ συνθήκη ΟΧΙ εντολή (εντολές) 41

42 Απλή Επιλογή ΣΥΝΤΑΞΗ αν συνθήκη τότε εντολή1 (εντολές1) αλλιώς εντολή2 (εντολές2) τέλος_αν ΛΕΙΤΟΥΡΓΙΑ Αν η συνθήκη είναι αληθής τότε εκτελείται μόνο η εντολή1 (ή οι εντολές1) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_αν. Αν η συνθήκη είναι ψευδής τότε εκτελείται μόνο η εντολή2 (ή οι εντολές2) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_αν. ΝΑΙ συνθήκη ΟΧΙ εντολή1 (εντολές1) εντολή2 (εντολές2) 42

43 Εμφωλευμένη Επιλογή (Α τρόπος) ΣΥΝΤΑΞΗ αν συνθήκη1 τότε εντολή1 (εντολές1) αλλιώς αν συνθήκη2 τότε εντολή2 (εντολές2) αλλιώς αν συνθήκη3 τότε (εντολές3) εντολή3 αλλιώς τέλος_αν τέλος_αν τέλος_αν ΛΕΙΤΟΥΡΓΙΑ Αν η συνθήκη1 είναι αληθής τότε εκτελείται μόνο η εντολή1 (ή οι εντολές1) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά την τελευταία εντολή τέλος_αν. Αν η συνθήκη1 είναι ψευδής τότε ελέγχεται η συνθήκη2. Αν η συνθήκη2 είναι αληθής τότε εκτελείται μόνο η εντολή2 (ή οι εντολές2) και ο αλγόριθμος συνεχίζει στην εντολή μετά την τελευταία εντολή τέλος_αν. Αν η συνθήκη2 είναι ψευδής τότε ελέγχεται η συνθήκη3 κ.ο.κ. Παρατηρούμε ότι για την κάθε εντολή αν υπάρχει μια αντίστοιχη εντολή τέλος_αν που την τερματίζει. Στο τέλος μπορούμε προαιρετικά να προσθέσουμε και μια ακόμα εντολή αλλιώς ώστε να εκτελείται μία ή περισσότερες εντολές όταν όλες οι προηγούμενες συνθήκες είναι ψευδείς. 43

44 Εμφωλευμένη Επιλογή (Β τρόπος) ΣΥΝΤΑΞΗ αν συνθήκη1 τότε εντολή1 (εντολές1) αλλιώς_αν συνθήκη2 τότε εντολή2 (εντολές2) αλλιώς_αν συνθήκη3 τότε εντολή3 (εντολές3) αλλιώς τέλος_αν ΛΕΙΤΟΥΡΓΙΑ Λειτουργεί ακριβώς όπως και η προηγούμενη εντολή. Το μόνο που αλλάζει είναι ο τρόπος γραφής της καθώς χρησιμοποιούμε μόνο μια τέλος_αν για τον τερματισμό όλων των ελέγχων. Επίσης και εδώ μπορούμε προαιρετικά να προσθέσουμε στο τέλος και μια ακόμα εντολή αλλιώς ώστε να εκτελείται μία ή περισσότερες εντολές όταν όλες οι προηγούμενες συνθήκες είναι ψευδείς. 44

45 Εντολή Επίλεξε 45

46 Η εντολή επίλεξε είναι μια ειδική περίπτωση της εντολής αν η οποία χρησιμοποιείται όταν θέλουμε να κάνουμε πολλαπλούς ελέγχους εξετάζοντας την τιμή μιας μεταβλητής και όχι μιας συνθήκης. ΣΥΝΤΑΞΗ Εντολή πολλαπλής επιλογής επίλεξε μεταβλητή περίπτωση λίστα_τιμών1 εντολή1 (εντολές1) περίπτωση λίστα_τιμών2 εντολή2 (εντολές2) περίπτωση αλλιώς εντολήν (εντολέςν) τέλος_επιλογών επίλεξε 46

47 ΛΕΙΤΟΥΡΓΙΑ ΕΝΤΟΛΗΣ ΕΠΙΛΕΞΕ ΛΕΙΤΟΥΡΓΙΑ Ελέγχεται η τιμή της μεταβλητής. Αν η τιμή της μεταβλητής ανήκει στη λίστα_τιμών1 (δηλαδή αν είναι ίση με κάποια από τις τιμές της λίστας_τιμών1) τότε εκτελείται μόνο η εντολή1 (ή οι εντολές1) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_επιλογών. Αν η τιμή της μεταβλητής ανήκει στη λίστα_τιμών2 (δηλαδή αν είναι ίση με κάποια από τις τιμές της λίστας_τιμών2) τότε εκτελείται μόνο η εντολή2 (ή οι εντολές2) και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_επιλογών κ.ο.κ. Αν η μεταβλητή δεν ανήκει σε κανένα από τα προηγούμενα σύνολα τιμών τότε εκτελείται η εντολήν (ή οι εντολέςν). Η εντολή επίλεξε ελέγχει συνεπώς μόνο ισότητες όσον αφορά την τιμή της μεταβλητής. 47

48 ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ ΕΝΤΟΛΗΣ ΕΠΙΛΕΞΕ μεταβλητή λίστα_τιμών1 λίστα_τιμών2 περίπτωση αλλιώς εντολή1 (εντολές1) εντολή2 (εντολές2) εντολήν (εντολέςν) 48

49 Ασκήσεις Αλγόριθμοι Περιορισμένης Επιλογής 49

50 Αλγόριθμος 1 Το πρόγραμμα να συγκρίνει δύο αριθμούς και να εμφανίζει τον μεγαλύτερο και τον μικρότερο αριθμό ή το μήνυμα ότι οι αριθμοί είναι ίσοι. 50

51 Λύση Αλγόριθμου 1 πρόγραμμα σύγκριση μεταβλητές πραγματικές: α1, α2 αρχή γράψε Δώσε 2 αριθμούς: διάβασε α1, α2 αν α1 > α2 τότε γράψε Μεγαλύτερος =, α1 γράψε Μικρότερος =, α2 τέλος_αν αν α1 < α2 τότε γράψε Μεγαλύτερος =, α2 γράψε Μικρότερος =, α1 τέλος_αν αν α1 = α2 τότε γράψε Οι αριθμοί είναι ίσοι. τέλος_αν τέλος_προγράμματος σύγκριση 51

52 Αλγόριθμος 2 Να δοθεί ο αλγόριθμος που θα χαρακτηρίζει έναν αριθμό ως θετικό, αρνητικό ή μηδέν. 52

53 Λύση Αλγόριθμου 2 πρόγραμμα χαρακτηρισμός μεταβλητές πραγματικές: χ αρχή γράψε Δώσε έναν αριθμό: διάβασε χ αν χ > 0 τότε γράψε θετικός τέλος_αν αν χ < 0 τότε γράψε αρνητικός τέλος_αν αν χ=0 τότε γράψε μηδέν τέλος_αν τέλος_προγράμματος χαρακτηρισμός 53

54 Αλγόριθμος 3 Να δοθεί ο αλγόριθμος που θα συγκρίνει δύο αριθμούς α και β και θα υπολογίζει ένα από τα ακόλουθα αποτελέσματα: αν α > β α + β αν α < β α β αν α = β α / β 54

55 Λύση Αλγόριθμου 3 πρόγραμμα σύγκριση μεταβλητές πραγματικές: α, β, π αρχή γράψε Δώσε 2 αριθμούς διάβασε α, β αν α > β τότε π α + β γράψε Άθροισμα =, π τέλος_αν αν α < β τότε π α - β γράψε Διαφορά =, π τέλος_αν αν α = β τότε αν β <> 0 τότε π α / β γράψε Πηλίκο =, π τέλος_αν αν β = 0 τότε γράψε Δεν υπολογίζεται το πηλίκο τέλος_αν τέλος_αν τέλος_προγράμματος σύγκριση 55

56 Αλγόριθμος 4 Να δοθεί ο αλγόριθμος που λύνει την εξίσωση y = 1 / x. 56

57 Λύση Αλγόριθμου 4 πρόγραμμα εξίσωση μεταβλητές πραγματικές: x, y αρχή γράψε Δώσε την τιμή του x: διάβασε x αν x = 0 τότε γράψε Αδύνατη Εξίσωση τέλος_αν αν x<>0 τότε y 1 / x γράψε Η λύση είναι:, y τέλος_αν τέλος_προγράμματος εξίσωση 57

58 Δομή Επανάληψης 58

59 Δομή Επανάληψης Η δομή επανάληψης χρησιμοποιείται όταν θέλουμε να εκτελέσουμε μία ή περισσότερες εντολές πολλές φορές. Η επανάληψη αυτή μπορεί να γίνει: είτε για όσο χρόνο αληθεύει μια συνθήκη (όσο) είτε μέχρι να γίνει αληθής μια συνθήκη (αρχή_επανάληψης) είτε για ένα συγκεκριμένο αριθμό φορών (για) 59

60 Εντολή όσο ΣΥΝΤΑΞΗ όσο συνθήκη επανέλαβε εντολή (εντολές) τέλος_επανάληψης ΛΕΙΤΟΥΡΓΙΑ Όσο η συνθήκη είναι αληθής επαναλαμβάνεται η εκτέλεση της εντολής (ή της ομάδας εντολών) που περικλείεται (περικλείονται) ανάμεσα στην εντολή όσο και στην εντολή τέλος_επανάληψης. Όταν η συνθήκη γίνει ψευδής η επανάληψη τερματίζεται και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_επανάληψης. Επίσης πρέπει να τονίσουμε ότι αν υ συνθήκη είναι από την αρχή ψευδής τότε η εντολή όσο δεν θα εκτελεστεί καμία φορά. 60

61 ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ Εντολής όσο 61

62 Εφαρμογή Εντολής όσο Η εντολή όσο μπορεί να χρησιμοποιηθεί τόσο σε προβλήματα με γνωστό αριθμό επαναλήψεων όσο και σε προβλήματα με άγνωστο αριθμό επαναλήψεων. Στην 1 η περίπτωση χρησιμοποιείται συνήθως ένας μετρητής επαναλήψεων, ενώ στη 2 η περίπτωση ελέγχεται μια συνθήκη σε σχέση με την τιμή που τερματίζει την επανάληψη. 62

63 Εντολή αρχή_επανάληψης ΣΥΝΤΑΞΗ αρχή_επανάληψης εντολή (εντολές) μέχρις_ότου συνθήκη ΛΕΙΤΟΥΡΓΙΑ Όσο η συνθήκη που ελέγχεται είναι ψευδής επαναλαμβάνεται η εκτέλεση της εντολής (ή της ομάδας εντολών) που περικλείεται (περικλείονται) ανάμεσα στη αρχή_επανάληψης και στο μέχρις_ότου. Όταν η συνθήκη γίνει αληθής η επανάληψη τερματίζεται και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά την εντολή μέχρις_ότου. Επίσης πρέπει να τονίσουμε ότι ακόμα και αν η συνθήκη είναι από την αρχή αληθής τότε η εντολή αρχή_επανάληψης θα εκτελεστεί τουλάχιστον μία φορά. Ουσιαστικά η εντολή αυτή έχει ακριβώς την αντίθετη λογική από την εντολή όσο. 63

64 ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ Εντολής αρχή_επανάληψης 64

65 Εφαρμογή Εντολής αρχή_επανάληψης Η εντολή αρχή_επανάληψης μπορεί να χρησιμοποιηθεί όπως και η εντολή όσο τόσο σε προβλήματα με γνωστό αριθμό επαναλήψεων όσο και σε προβλήματα με άγνωστο αριθμό επαναλήψεων. Στην πρώτη περίπτωση χρησιμοποιείται ένας μετρητής επαναλήψεων, ενώ στη δεύτερη περίπτωση ελέγχεται μια συνθήκη σε σχέση με την τιμή που τερματίζει την επανάληψη. 65

66 Εντολή για ΣΥΝΤΑΞΗ (βήμα > 0) για μεταβλητή από αρχική_τιμή μέχρι τελική_τιμή με βήμα βήμα εντολή (εντολές) τέλος_επανάληψης ΣΥΝΤΑΞΗ (βήμα < 0) για μεταβλητή από τελική_τιμή μέχρι αρχική_τιμή με βήμα αρνητικό εντολή (εντολές) τέλος_επανάληψης 66

67 ΛΕΙΤΟΥΡΓΙΑ Εντολής για Η μεταβλητή λειτουργεί σαν μετρητής επαναλήψεων. Αρχικά ξεκινάει από την τιμή που καθορίζουμε, ελέγχει αν η τιμή της είναι μικρότερη ή ίση από την τελική τιμή που πρέπει να φτάσει και εφόσον αυτό ισχύει εκτελούνται όλες οι εντολές που περιλαμβάνονται ανάμεσα στην εντολή για και στην εντολή τέλος_επανάληψης. Στη συνέχεια η μεταβλητή αυτή αυξάνεται σύμφωνα με την τιμή του βήματος που έχουμε καθορίσει. Όταν η μεταβλητή ξεπεράσει την τελική της τιμή τότε η επανάληψη ολοκληρώνεται και ο αλγόριθμος συνεχίζει στην επόμενη εντολή μετά το τέλος_επανάληψης. 67

68 ΔΙΑΓΡΑΜΜΑ ΡΟΗΣ Εντολής για 68

69 Κριτήριο Επιλογής Εντολής Επανάληψης Αριθμός Επαναλήψεων Εντολή Επανάληψης γνωστός εντολή για εντολή όσο εντολή αρχή_επανάληψης άγνωστος εντολή όσο εντολή αρχή_επανάληψης 69

70 Γενικές Παρατηρήσεις για τις Εντολές Επανάληψης Περίπτωση Λύση Όταν το πρόγραμμα ζητάει υπολογισμό αθροίσματος τότε χρησιμοποιούμε πάντα αθροιστή δηλαδή μια μεταβλητή που αυξάνεται σε κάθε επανάληψη κατά μια συγκεκριμένη ή τυχαία τιμή και αρχικοποιείται με το 0. Όταν το πρόγραμμα ζητάει υπολογισμό πλήθους τότε χρησιμοποιούμε πάντα μετρητή δηλαδή μια μεταβλητή που αυξάνεται σε κάθε επανάληψη κατά 1 και αρχικοποιείται με 0. Όταν το πρόγραμμα ζητάει υπολογισμό γινομένου Όταν ο αριθμός των επαναλήψεων είναι γνωστός τότε χρησιμοποιούμε πάντα πολλαπλασιαστή δηλαδή μια μεταβλητή που πολλαπλασιάζεται σε κάθε επανάληψη με μια συγκεκριμένη ή τυχαία τιμή και αρχικοποιείται με το 1. τότε χρησιμοποιούμε μετρητή επαναλήψεων δηλαδή μια μεταβλητή που αυξάνεται σε κάθε επανάληψη κατά μια συγκεκριμένη τιμή (συνήθως κατά 1) και αρχικοποιείται με μια συγκεκριμένη τιμή (συνήθως με το 1). Όταν ο αριθμός των επαναλήψεων είναι άγνωστος τότε δεν μπορούμε να χρησιμοποιήσουμε μετρητή επαναλήψεων. Η συνθήκη που ελέγχουμε στην περίπτωση αυτή έχει να κάνει με μια τιμή που τερματίζει την επανάληψη. 70

71 Διαφορές της εντολής όσο από την εντολή αρχή_επανάληψης Στην εντολή όσο η συνθήκη ελέγχεται στην αρχή της επανάληψης ενώ στην εντολή αρχή_επανάληψης η συνθήκη ελέγχεται στο τέλος της επανάληψης. Στην εντολή όσο η ομάδα εντολών μπορεί να μην εκτελεστεί καμία φορά όταν η συνθήκη είναι εξ αρχής ψευδής, ενώ στην εντολή αρχή_επανάληψης η ομάδα εντολών εκτελείται τουλάχιστον μια φορά ανεξάρτητα από την συνθήκη. Στην εντολή όσο η επανάληψη εκτελείται όσο η συνθήκη είναι αληθής, ενώ στην εντολή αρχή_επανάληψης η επανάληψη εκτελείται όσο η συνθήκη είναι ψευδής και τερματίζει μόλις η συνθήκη γίνει αληθής. 71

72 Πλεονεκτήματα της εντολής για σε σχέση με τις εντολές όσο και αρχή_επανάληψης στην εντολή για δεν απαιτείται να υπάρχουν (μέσα στο σώμα των εντολών της) ξεχωριστές εντολές τροποποίησης της τιμής του μετρητή των επαναλήψεων γιατί αυτός μεταβάλλεται αυτόματα από την ίδια την εντολή για σε κάθε επανάληψη κατά βήμα (αυξάνεται ή μειώνεται). Αντίθετα στις εντολές όσο και αρχή_επανάληψης όταν ο αριθμός των επαναλήψεων είναι γνωστός είναι υποχρεωτική η ύπαρξη εντολής αλλαγής της τιμής του μετρητή των επαναλήψεων. στην εντολή για δεν απαιτείται να υπάρχει ξεχωριστή εντολή αρχικοποίησης της τιμής του μετρητή των επαναλήψεων γιατί αυτή γίνεται αυτομάτως από την ίδια την εντολή για. Αντίθετα στις εντολές όσο και αρχή_επανάληψης όταν ο αριθμός των επαναλήψεων είναι γνωστός είναι υποχρεωτική η αρχικοποίηση του μετρητή των επαναλήψεων σε ξεχωριστή εντολή. 72

73 Μειονεκτήματα της εντολής για σε σχέση με τις εντολές όσο και αρχή_επανάληψης Η εντολή για εφαρμόζεται μόνο όταν ο αριθμός των επαναλήψεων είναι γνωστός. Αντίθετα οι εντολές όσο και αρχή_επανάληψης μπορούν να χρησιμοποιηθούν σε κάθε περίπτωση δηλαδή και για γνωστό και για άγνωστο αριθμό επαναλήψεων. 73

74 Παραδείγματα 74

75 Παράδειγμα 1 Να γραφεί ο αλγόριθμος υπολογισμού του αθροίσματος των αριθμών από το 1 μέχρι το 100 ( ) χρησιμοποιώντας και τις τρεις δομές επανάληψης. 75

76 Λύση Παραδείγματος 1-α τρόπος ΠΡΟΓΡΑΜΜΑ ΑΘΡΟΙΣΜΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι, SUM ΑΡΧΗ I 1 SUM 0 ΟΣΟ I<=100 ΕΠΑΝΑΛΑΒΕ SUM SUM+I I I+1 ΤΕΛΟΣ_ ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ SUM ΤΕΛΟΣ_ ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΘΡΟΙΣΜΑ 76

77 Λύση Παραδείγματος 1-β τρόπος ΠΡΟΓΡΑΜΜΑ ΑΘΡΟΙΣΜΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι, SUM ΑΡΧΗ I 1 SUM 0 ΑΡΧΗ_ ΕΠΑΝΑΛΗΨΗΣ SUM SUM+I I I+1 ΜΕΧΡΙΣ_ ΟΤΟΥ I>100 ΓΡΑΨΕ SUM ΤΕΛΟΣ_ ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΘΡΟΙΣΜΑ 77

78 Λύση Παραδείγματος 1-γ τρόπος ΠΡΟΓΡΑΜΜΑ ΑΘΡΟΙΣΜΑ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι, SUM ΑΡΧΗ SUM 0 ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 100 SUM SUM+I ΤΕΛΟΣ_ ΕΠΑΝΑΛΗΨΗΣ ΓΡΑΨΕ SUM ΤΕΛΟΣ_ ΠΡΟΓΡΑΜΜΑΤΟΣ ΑΘΡΟΙΣΜΑ 78

79 Παράδειγμα 2 Να γραφεί αλγόριθμος που να εμφανίζει την πρόταση «ΙΕΚ ΛΑΓΚΑΔΑ» 100 φορές. ΛΥΣΗ: ΠΡΟΓΡΑΜΜΑ ΙΕΚ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ι ΑΡΧΗ ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 100 ΓΡΑΨΕ ΙΕΚ ΛΑΓΚΑΔΑ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΙΕΚ 79

80 Παράδειγμα 3 Να γραφεί αλγόριθμος που να εμφανίζει τη λέξη «ΘΕΣΣΑΛΟΝΙΚΗ» στην οθόνη του υπολογιστή κάθε φορά που ο χρήστης πατάει το πλήκτρο «Θ». Η διαδικασία να επαναλαμβάνεται έως ότου ο χρήστης πατήσει το πλήκτρο «Q». Τότε ο αλγόριθμος να εμφανίζει πόσες φορές πατήθηκε το πλήκτρο «Θ». 80

81 Λύση Παραδείγματος 3 ΠΡΟΓΡΑΜΜΑ ΘΕΣΣΑΛΟΝΙΚΗ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ:ΠΛΗΘΟΣ ΑΛΦΑΡΙΘΜΗΤΙΚΕΣ(ΧΑΡΑΚΤΗΡΕΣ):Χ ΑΡΧΗ ΠΛΗΘΟΣ 0 ΑΡΧΗ ΕΠΑΝΑΛΗΨΗΣ ΔΙΑΒΑΣΕ Χ ΑΝ Χ= Θ ΤΟΤΕ ΓΡΑΨΕ ΘΕΣΣΑΛΟΝΙΚΗ ΠΛΗΘΟΣ ΠΛΗΘΟΣ+1 ΤΕΛΟΣ_ΑΝ ΜΕΧΡΙΣ_ΟΤΟΥ Χ= Q ΓΡΑΨΕ ΠΛΗΘΟΣ ΤΕΛΟΣ_ ΠΡΟΓΡΑΜΜΑΤΟΣ ΘΕΣΣΑΛΟΝΙΚΗ 81

82 Παράδειγμα 4 Ένας καταναλωτής διαθέτει 150 για αγορά ρυζιού, προκειμένου να το δωρίσει σε ένα φιλανθρωπικό ίδρυμα. Σε ένα πολυκατάστημα διατίθενται πακέτα ρυζιού σε τέσσερις διαφορετικές συσκευασίες από διαφορετικές εταιρείες. Να γράψετε αλγόριθμο ο οποίος: α. Διαβάζει το όνομα της εταιρείας, την αξία και την ποσότητα σε γραμμάρια για κάθε μία από τις τέσσερις συσκευασίες ρυζιού. β. Υπολογίζει και εμφανίζει το όνομα της εταιρείας που προσφέρει το ρύζι στην πλέον συμφέρουσα για τον καταναλωτή συσκευασία (να θεωρήσετε ότι υπάρχει μόνο μία τέτοια εταιρεία). γ. Υπολογίζει και εμφανίζει τον αριθμό των πακέτων που μπορεί να αγοράσει από την πλέον συμφέρουσα για τον καταναλωτή συσκευασία (σύμφωνα με το ερώτημα β). Παρατήρηση: η κάθε εταιρεία διαθέτει το ρύζι σε μία και μόνη συσκευασία, π.χ. η Α εταιρεία διαθέτει ρύζι μόνο σε συσκευασία των 200gr, η Β σε συσκευασία των 250, η Γ σε συσκευασία των 300 gr, η Δ σε συσκευασία των 350 gr. 82

83 Λύση Παραδείγματος 4 ΑΛΓΟΡΙΘΜΟΣ ΑΓΟΡΑ_ΡΥΖΙΟΥ ΔΙΑΒΑΣΕ ΟΝΟΜΑ, ΑΞΙΑ, ΠΟΣΟΤΗΤΑ ΚΟΣΤΟΣ ΑΞΙΑ/ΠΟΣΟΤΗΤΑ ΜΙΝ ΚΟΣΤΟΣ ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 4 ΔΙΑΒΑΣΕ ΟΝΟΜΑ, ΑΞΙΑ, ΠΟΣΟΤΗΤΑ ΚΟΣΤΟΣ ΑΞΙΑ/ΠΟΣΟΤΗΤΑ ΑΝ ΚΟΣΤΟΣ<ΜΙΝ ΤΟΤΕ ΜΙΝ ΚΟΣΤΟΣ ΕΤΑΙΡΕΙΑ ΟΝΟΜΑ ΚΑΛΥΤΕΡΗ_ΤΙΜΗ ΑΞΙΑ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΕΜΦΑΝΙΣΕ ΕΤΑΙΡΕΙΑ ΠΛΗΘΟΣ_ΠΑΚΕΤΩΝ 150 DIV ΚΑΛΥΤΕΡΗ ΤΙΜΗ ΕΜΦΑΝΙΣΕ ΠΛΗΘΟΣ_ΠΑΚΕΤΩΝ ΤΕΛΟΣ ΑΓΟΡΑ_ΡΥΖΙΟΥ 83

84 Παράδειγμα 5 Σε κάποια εξεταστική δοκιμασία ένα γραπτό αξιολογείται από δυο βαθμολογητές στη βαθμολογική κλίμακα[0,100]. Αν η διαφορά μεταξύ των βαθμολογιών του α και του β βαθμολογητή είναι μικρότερη ή ίση των 20 μονάδων της παραπάνω κλίμακας, ο τελικός βαθμός είναι ο μέσος όρος των δυο βαθμολογιών. Αν η διαφορά μεταξύ των βαθμολογιών του α και του β βαθμολογητή είναι μεγαλύτερη από 20 μονάδες, το γραπτό δίνεται για αναβαθμολόγηση σε τρίτο βαθμολογητή. Ο τελικός βαθμός του γραπτού προκύπτει τότε από το μέσο όρο των τριών βαθμολογιών. Να αναπτύξετε αλγόριθμο ο οποίος, αφού ελέγξει την εγκυρότητα των βαθμών στη βαθμολογική κλίμακα [0,100], να υλοποιεί την παραπάνω διαδικασία εξαγωγής τελικού βαθμού και να εμφανίζει τον τελικό βαθμό του γραπτού στην εικοσαβάθμια κλίμακα. Παρατήρηση: Να θεωρήσετε ότι όλες οι ποσότητες εκφράζονται ως πραγματικοί αριθμοί. 84

85 Λύση Παραδείγματος 5 ΠΡΟΓΡΑΜΜΑ ΒΑΘΜΟΛΟΓΙΑ ΜΕΤΑΒΛΗΤΕΣ ΠΡΑΓΜΑΤΙΚΕΣ:Β1,Β2,Β3,ΤΒ ΑΡΧΗ ΔΙΑΒΑΣΕ Β1 ΟΣΟ (Β1>100) Η (Β1<0) ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ ΛΑΘΟΣ ΒΑΘΜΟΣ ΞΑΝΑΔΩΣΕ ΔΙΑΒΑΣΕ Β1 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΔΙΑΒΑΣΕ Β2 ΟΣΟ (Β2>100) Η (Β2<0) ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ ΛΑΘΟΣ ΒΑΘΜΟΣ ΞΑΝΑΔΩΣΕ ΔΙΑΒΑΣΕ Β2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ Α_Τ(Β1-Β2)<=20 ΤΟΤΕ ΤΒ (Β1+Β2)/2 ΑΛΛΙΩΣ ΔΙΑΒΑΣΕ Β3 ΟΣΟ (Β3>100) Η (Β3<0) ΕΠΑΝΑΛΑΒΕ ΓΡΑΨΕ ΛΑΘΟΣ ΒΑΘΜΟΣ ΞΑΝΑΔΩΣΕ ΔΙΑΒΑΣΕ Β3 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΒ (Β1+Β2+Β3)/3 ΤΕΛΟΣ_ΑΝ ΓΡΑΨΕ Ο ΤΕΛΙΚΟΣ ΒΑΘΜΟΣ ΣΤΗΝ ΕΙΚΟΣ/ΙΑ ΚΛΙΜ ΕΙΝΑΙ,ΤΒ/5 ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΒΑΘΜΟΛΟΓΙΑ 85

86 Παράδειγμα 6 (1) Το κλασικό παιχνίδι «Πέτρα-Ψαλίδι-Χαρτί» παίζεται με δύο παίκτες. Σε κάθε γύρο του παιχνιδιού, ο κάθε παίκτης επιλέγει ένα από τα ΠΕΤΡΑ, ΨΑΛΙΔΙ, ΧΑΡΤΙ, και παρουσιάζει την επιλογή του ταυτόχρονα με τον αντίπαλό του. Η ΠΕΤΡΑ κερδίζει το ΨΑΛΙΔΙ, το ΨΑΛΙΔΙ το ΧΑΡΤΙ και το ΧΑΡΤΙ την ΠΕΤΡΑ. Σε περίπτωση που οι δύο παίκτες έχουν την ίδια επιλογή, ο γύρος λήγει ισόπαλος. Τα ο παιχνίδι προχωράει με συνεχόμενους γύρους μέχρι ένας τουλάχιστον από τους παίκτες να αποχωρήσει. Νικητής αναδεικνύεται ο παίκτης με τις περισσότερες νίκες. Αν οι δύο παίκτες έχουν τον ίδιο αριθμό νικών, το παιχνίδι λήγει ισόπαλο. 86

87 Παράδειγμα 6 (2) Να αναπτύξετε αλγόριθμο ο οποίος διαβάζει τα ονόματα των δύο παικτών και υλοποιεί το παραπάνω παιχνίδι ως εξής: Α. Για κάθε γύρο του παιχνιδιού: διαβάζει την επιλογή κάθε παίκτη, η οποία μπορεί να είναι μία από τις εξής: ΠΕΤΡΑ, ΨΑΛΙΔΙ, ΧΑΡΤΙ, ΤΕΛΟΣ. (Δεν απαιτείται έλεγχος εγκυρότητας τιμών.) συγκρίνει τις επιλογές των παικτών και διαπιστώνει το νικητή του γύρου ή την ισοπαλία. Β. Τερματίζει το παιχνίδι όταν ένας τουλάχιστον από τους δύο παίκτες επιλέξει ΤΕΛΟΣ. Γ. Εμφανίζει το όνομα του νικητή ή, αν δεν υπάρχει νικητής, το μήνυμα «ΤΟ ΠΑΙΧΝΙΔΙ ΕΛΗΞΕ ΙΣΟΠΑΛΟ». 87

88 Λύση Παραδείγματος 6 ΠΡΟΓΡΑΜΜΑ ΠΑΙΧΝΙΔΙ ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Ν1,Ν2 ΧΑΡΑΚΤΗΡΕΣ: ΟΝ1,ΟΝ2,ΕΠ1,ΕΠ2 ΑΡΧΗ ΔΙΑΒΑΣΕ ΟΝ1,ΟΝ2 Ν1 0 Ν2 0 ΔΙΑΒΑΣΕ ΕΠ1,ΕΠ2 ΟΣΟ ΕΠ1<>'ΤΕΛΟΣ' ΚΑΙ ΕΠ2<>'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ ΑΝ ΕΠ1=ΕΠ2 ΤΟΤΕ ΓΡΑΨΕ ΙΣΟΠΑΛΙΑ ΑΛΛΙΩΣ ΑΝ ΕΠ1='ΠΕΤΡΑ' ΤΟΤΕ ΑΝ ΕΠ2='ΨΑΛΙΔΙ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ1 Ν1 Ν1+1 ΑΛΛΙΩΣ _ΑΝ ΕΠ2='ΧΑΡΤΙ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ2 Ν2 Ν2+1 ΤΕΛΟΣ_ΑΝ ΑΛΛΙΩΣ_ΑΝ ΕΠ1='ΨΑΛΙΔΙ' ΤΟΤΕ ΑΝ ΕΠ2='ΠΕΤΡΑ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ2 Ν2 Ν2+1 ΑΛΛΙΩΣ_ΑΝ ΕΠ2='ΧΑΡΤΙ' ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ1 Ν1 Ν1+1 ΤΕΛΟΣ_ΑΝ ΑΛΛΙΩΣ!δηλαδή ΕΠ1='ΧΑΡΤΙ' ΑΝ ΕΠ2='ΠΕΤΡΑ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ1 Ν1 Ν1+1 ΤΕΛΟΣ_ΑΝ ΑΛΛΙΩΣ_ΑΝ ΕΠ2='ΨΑΛΙΔΙ' ΤΟΤΕ ΓΡΑΨΕ 'ΚΕΡΔΙΖΕΙ Ο',ΟΝ2 Ν2 Ν2+1 ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΠΑΙΧΝΙΔΙ ΔΙΑΒΑΣΕ ΕΠ1,ΕΠ2 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΑΝ Ν1>Ν2 ΤΟΤΕ ΓΡΑΨΕ 'ΝΙΚΗΤΗΣ Ο',ΟΝ1 ΑΛΛΙΩΣ_ΑΝ Ν2>Ν1 ΤΟΤΕ ΓΡΑΨΕ 'ΝΙΚΗΤΗΣ Ο',ΟΝ2 ΑΛΛΙΩΣ ΓΡΑΨΕ 'ΤΟ ΠΑΙΧΝΙΔΙ ΕΛΗΞΕ ΙΣΟΠΑΛΟ' ΤΕΛΟΣ_ΑΝ ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΠΑΙΧΝΙΔΙ 88

89 Τέλος Κεφαλαίου

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον ΚΕΦΑΛΑΙΟ 2 2.4 Βασικές συνιστώσες/εντολές ενός αλγορίθμου 2.4.1 Δομή ακολουθίας ΚΕΦΑΛΑΙΟ 7 7.1 7.9 Σταθερές (constants): Προκαθορισμένες τιμές που παραμένουν

Διαβάστε περισσότερα

Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2. Α1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων πληροφορικής

Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2. Α1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων πληροφορικής Ερωτήσεις πολλαπλής επιλογής - Κεφάλαιο 2 Α1. Ο αλγόριθμος είναι απαραίτητος μόνο για την επίλυση προβλημάτων πληροφορικής Α2. Ο αλγόριθμος αποτελείται από ένα πεπερασμένο σύνολο εντολών Α3. Ο αλγόριθμος

Διαβάστε περισσότερα

Επαναληπτικές Διαδικασίες

Επαναληπτικές Διαδικασίες Επαναληπτικές Διαδικασίες Οι επαναληπτικές δομές ( εντολές επανάληψης επαναληπτικά σχήματα ) χρησιμοποιούνται, όταν μια ομάδα εντολών πρέπει να εκτελείται αρκετές- πολλές φορές ανάλογα με την τιμή μιας

Διαβάστε περισσότερα

Επιλογή και επανάληψη. Λογική έκφραση ή συνθήκη

Επιλογή και επανάληψη. Λογική έκφραση ή συνθήκη Επιλογή και επανάληψη Η ύλη που αναπτύσσεται σε αυτό το κεφάλαιο είναι συναφής µε την ύλη που αναπτύσσεται στο 2 ο κεφάλαιο. Όπου υπάρχουν διαφορές αναφέρονται ρητά. Προσέξτε ιδιαίτερα, πάντως, ότι στο

Διαβάστε περισσότερα

Αλγόριθμοι Αναπαράσταση αλγορίθμων Η αναπαράσταση των αλγορίθμων μπορεί να πραγματοποιηθεί με:

Αλγόριθμοι Αναπαράσταση αλγορίθμων Η αναπαράσταση των αλγορίθμων μπορεί να πραγματοποιηθεί με: Αλγόριθμοι 2.2.1. Ορισμός: Αλγόριθμος είναι μια πεπερασμένη σειρά εντολών, αυστηρά καθορισμένων και εκτελέσιμων σε πεπερασμένο χρόνο, που στοχεύουν στην επίλυση ενός προβλήματος. Τα κυριότερα χρησιμοποιούμενα

Διαβάστε περισσότερα

1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες εντολές (μορφές) της;

1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες εντολές (μορφές) της; 1. Πότε χρησιμοποιούμε την δομή επανάληψης; Ποιες είναι οι διάφορες (μορφές) της; Η δομή επανάληψης χρησιμοποιείται όταν μια σειρά εντολών πρέπει να εκτελεστεί σε ένα σύνολο περιπτώσεων, που έχουν κάτι

Διαβάστε περισσότερα

Αρχές Προγραμματισμού Η/Υ Μέθοδοι παρουσίασης του αλγόριθμου και Βασικές έννοιες

Αρχές Προγραμματισμού Η/Υ Μέθοδοι παρουσίασης του αλγόριθμου και Βασικές έννοιες Αρχές Προγραμματισμού Η/Υ Μέθοδοι παρουσίασης του αλγόριθμου και Βασικές έννοιες Βελώνης Γεώργιος Καθηγητής Πληροφορικής ΠΕ20 Περιεχόμενα Μέθοδοι Παρουσίασης του αλγόριθμου Εισαγωγή Φραστική μέθοδος Ψευδοκώδικας

Διαβάστε περισσότερα

2 ΟΥ και 7 ΟΥ ΚΕΦΑΛΑΙΟΥ

2 ΟΥ και 7 ΟΥ ΚΕΦΑΛΑΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΙΜΕΛΕΙΑ: ΜΑΡΙΑ Σ. ΖΙΩΓΑ ΚΑΘΗΓΗΤΡΙΑ ΠΛΗΡΟΦΟΡΙΚΗΣ ΘΕΩΡΙΑ 2 ΟΥ και 7 ΟΥ ΚΕΦΑΛΑΙΟΥ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΑΛΓΟΡΙΘΜΩΝ και ΔΟΜΗ ΑΚΟΛΟΥΘΙΑΣ 2.1 Να δοθεί ο ορισμός

Διαβάστε περισσότερα

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΙΜΕΛΕΙΑ: ΜΑΡΙΑ Σ. ΖΙΩΓΑ ΚΑΘΗΓΗΤΡΙΑ ΠΛΗΡΟΦΟΡΙΚΗΣ ΘΕΩΡΙΑ 2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ 1) Πότε χρησιμοποιείται η δομή επανάληψης

Διαβάστε περισσότερα

ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 5 ΙΟΥΛΙΟΥ ΑΕΠΠ

ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 5 ΙΟΥΛΙΟΥ ΑΕΠΠ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΕΞΕΤΑΣΕΙΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 5 ΙΟΥΛΙΟΥ 2007 - ΑΕΠΠ ΘΕΜΑ 1ο Α. Να χαρακτηρίσετε καθεμιά από τις προτάσεις που ακολουθούν γράφοντας στο τετράδιό σας, δίπλα από τον αριθμό κάθε

Διαβάστε περισσότερα

ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ ΣΕ ΓΛΩΣΣΟΜΑΘΕΙΑ

ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ ΣΕ ΓΛΩΣΣΟΜΑΘΕΙΑ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ ΣΕ ΓΛΩΣΣΟΜΑΘΕΙΑ Καλλιόπη Μαγδαληνού ΕΠΙΚΕΦΑΛΙΔΑ ΠΡΟΓΡΑΜΜΑΤΟΣ ΔΗΛΩΣΕΙΣ ΣΤΑΘΕΡΩΝ ΔΗΛΩΣΕΙΣ ΜΕΤΑΒΛΗΤΩΝ ΕΝΤΟΛΕΣ πρόγραμμα τεστ σταθερές π = 3.14 μεταβλητές πραγματικές : εμβαδό, ακτίνα αρχή

Διαβάστε περισσότερα

Μάριος Αγγελίδης

Μάριος Αγγελίδης Δομή Επανάληψης Ενότητες βιβλίου: 2.4.5, 8.2, 8.2.1, 8.2.2, 8.2.3 Ώρες διδασκαλίας: 5 Η δομή επανάληψης χρησιμοποιείται όταν έχουμε μία ομάδα εντολών που θέλουμε να εκτελεστούν πολλές φορές. Υπάρχουν τρείς

Διαβάστε περισσότερα

ΠΕΡΙΕΧΟΜΕΝΑ. Εντολές επιλογής Εντολές επανάληψης

ΠΕΡΙΕΧΟΜΕΝΑ. Εντολές επιλογής Εντολές επανάληψης ΠΕΡΙΕΧΟΜΕΝΑ Εντολές επιλογής Εντολές επανάληψης Εισαγωγή Στο προηγούμενο κεφάλαιο αναπτύξαμε προγράμματα, τα οποία ήταν πολύ απλά και οι εντολές των οποίων εκτελούνται η μία μετά την άλλη. Αυτή η σειριακή

Διαβάστε περισσότερα

Ορισµοί κεφαλαίου. Σηµαντικά σηµεία κεφαλαίου

Ορισµοί κεφαλαίου. Σηµαντικά σηµεία κεφαλαίου Ορισµοί κεφαλαίου Αλγόριθµος είναι µια πεπερασµένη σειρά ενεργειών, αυστηρά καθορισµένων και εκτελέσιµων σε πεπερασµένο χρόνο, που στοχεύουν στην επίλυση ενός προβλήµατος. Σηµαντικά σηµεία κεφαλαίου Κριτήρια

Διαβάστε περισσότερα

Κεφάλαιο 2 ο Βασικές Έννοιες Αλγορίθμων (σελ )

Κεφάλαιο 2 ο Βασικές Έννοιες Αλγορίθμων (σελ ) Κεφάλαιο 2 ο Βασικές Έννοιες Αλγορίθμων (σελ. 25 48) Τι είναι αλγόριθμος; Γ ΛΥΚΕΙΟΥ Αλγόριθμος είναι μία πεπερασμένη σειρά ενεργειών, αυστηρά καθορισμένων και εκτελέσιμων σε πεπερασμένο χρονικό διάστημα,

Διαβάστε περισσότερα

ΓΛΩΣΣΑ ΑΛΦΑΒΗΤΟ ΤΥΠΟΙ ΔΕΔΟΜΕΝΩΝ ΣΤΑΘΕΡΕΣ ΜΕΤΑΒΛΗΤΕΣ

ΓΛΩΣΣΑ ΑΛΦΑΒΗΤΟ ΤΥΠΟΙ ΔΕΔΟΜΕΝΩΝ ΣΤΑΘΕΡΕΣ ΜΕΤΑΒΛΗΤΕΣ ΓΛΩΣΣΑ ΑΛΦΑΒΗΤΟ Κεφαλαία και μικρά γράμματα ελληνικού αλφαβήτου: Α Ω και α ω Κεφαλαία και μικρά γράμματα λατινικού αλφαβήτου: A Z και a z Αριθμητικά ψηφία: 0 9 Ειδικοί χαρακτήρες: + - * / =. ( ),! & κενός

Διαβάστε περισσότερα

ΔΟΜΗΜΕΝΟΣ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ

ΔΟΜΗΜΕΝΟΣ ΠΡΟΓΡΑΜΜΑΤΙΣΜΟΣ ΕΡΩΤΗΣΕΙΣ 1. Τι καλείται ψευδοκώδικας; 2. Τι καλείται λογικό διάγραμμα; 3. Για ποιο λόγο είναι απαραίτητη η τυποποίηση του αλγόριθμου; 4. Ποιες είναι οι βασικές αλγοριθμικές δομές; 5. Να περιγράψετε τις

Διαβάστε περισσότερα

2ο ΓΕΛ ΑΓ.ΔΗΜΗΤΡΙΟΥ ΑΕΠΠ ΘΕΟΔΟΣΙΟΥ ΔΙΟΝ ΠΡΟΣΟΧΗ ΣΤΑ ΠΑΡΑΚΑΤΩ

2ο ΓΕΛ ΑΓ.ΔΗΜΗΤΡΙΟΥ ΑΕΠΠ ΘΕΟΔΟΣΙΟΥ ΔΙΟΝ ΠΡΟΣΟΧΗ ΣΤΑ ΠΑΡΑΚΑΤΩ ΠΡΟΣΟΧΗ ΣΤΑ ΠΑΡΑΚΑΤΩ ΣΤΑΘΕΡΕΣ είναι τα μεγέθη που δεν μεταβάλλονται κατά την εκτέλεση ενός αλγόριθμου. Εκτός από τις αριθμητικές σταθερές (7, 4, 3.5, 100 κλπ), τις λογικές σταθερές (αληθής και ψευδής)

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 18/02/2013 ΘΕΜΑ Α ΑΠΑΝΤΗΣΕΙΣ Α1. α. Παραβιάζει τα κριτήρια της καθοριστικότητας και της περατότητας β. Αιτιολόγηση: ο αλγόριθμος παραβιάζει το κριτήριο

Διαβάστε περισσότερα

ΘΕΜΑ 1ο. Μονάδες 10. Β. ίνεται το παρακάτω τμήμα αλγορίθμου: Όσο Ι < 10 επανάλαβε Εμφάνισε Ι Ι Ι + 3 Τέλος_επανάληψης ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ

ΘΕΜΑ 1ο. Μονάδες 10. Β. ίνεται το παρακάτω τμήμα αλγορίθμου: Όσο Ι < 10 επανάλαβε Εμφάνισε Ι Ι Ι + 3 Τέλος_επανάληψης ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ 1ο ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΤΑΡΤΗ 4 ΙΟΥΛΙΟΥ 2007 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΔΟΜΗ ΕΠΙΛΟΓΗΣ. Οι διάφορες εκδοχές της

ΔΟΜΗ ΕΠΙΛΟΓΗΣ. Οι διάφορες εκδοχές της ΔΟΜΗ ΕΠΙΛΟΓΗΣ Οι διάφορες εκδοχές της Απλή επιλογή Ναι Ομάδα Εντολών Α Ισχύει η Συνθήκη; Χ Χ Χ Όχι Αν (Συνθήκη =Αληθινή) Τότε Ομάδα εντολών Τέλος_αν Λειτουργία: 1. Αν ισχύει η συνθήκη εκτελείται ΠΡΩΤΑ

Διαβάστε περισσότερα

Πληροφορική ΙΙ. Τ.Ε.Ι. Ιονίων Νήσων Σχολή Διοίκησης και Οικονομίας - Λευκάδα

Πληροφορική ΙΙ. Τ.Ε.Ι. Ιονίων Νήσων Σχολή Διοίκησης και Οικονομίας - Λευκάδα Πληροφορική ΙΙ Τ.Ε.Ι. Ιονίων Νήσων Σχολή Διοίκησης και Οικονομίας - Λευκάδα Στέργιος Παλαμάς, Υλικό Μαθήματος «Πληροφορική ΙΙ», 2015-2016 Μάθημα 1: Εισαγωγή στους Αλγόριθμους Αλγόριθμος είναι μια πεπερασμένη

Διαβάστε περισσότερα

ΤΡΙΩΡΗ ΓΡΑΠΤΗ ΔΟΚΙΜΑΣΙΑ

ΤΡΙΩΡΗ ΓΡΑΠΤΗ ΔΟΚΙΜΑΣΙΑ ΤΡΙΩΡΗ ΓΡΑΠΤΗ ΔΟΚΙΜΑΣΙΑ ΜΑΘΗΜΑ : ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 ο Α. Δίνεται η εντολή εκχώρησης: τ κ < λ Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος. Να δικαιολογήσετε

Διαβάστε περισσότερα

Γ τάξη Τεχνολογικής Κατεύθυνσης Ενιαίου Λυκείου ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ. ΔΟΜΗ ΕΠΙΛΟΓΗΣ Διδάσκων: ΔΟΥΡΒΑΣ ΙΩΑΝΝΗΣ

Γ τάξη Τεχνολογικής Κατεύθυνσης Ενιαίου Λυκείου ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ. ΔΟΜΗ ΕΠΙΛΟΓΗΣ Διδάσκων: ΔΟΥΡΒΑΣ ΙΩΑΝΝΗΣ Γ τάξη Τεχνολογικής Κατεύθυνσης Ενιαίου Λυκείου ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΟΜΗ ΕΠΙΛΟΓΗΣ Διδάσκων: ΔΟΥΡΒΑΣ ΙΩΑΝΝΗΣ Κεφάλαιο 2 : Δομή Επιλογής Εντολές επιλογής Εντολή ΑΝ. Εντολές

Διαβάστε περισσότερα

Κεφάλαια Εντολές επανάληψης. Τρεις εντολές επανάληψης. Επιλογή εντολής επανάληψης ΟΣΟ...ΕΠΑΝΑΛΑΒΕ. Σύνταξη στη ΓΛΩΣΣΑ

Κεφάλαια Εντολές επανάληψης. Τρεις εντολές επανάληψης. Επιλογή εντολής επανάληψης ΟΣΟ...ΕΠΑΝΑΛΑΒΕ. Σύνταξη στη ΓΛΩΣΣΑ Εντολές επανάληψης Κεφάλαια 02-08 οµές Επανάληψης Επιτρέπουν την εκτέλεση εντολών περισσότερες από µία φορά Οι επαναλήψεις ελέγχονται πάντοτε από κάποια συνθήκη η οποία καθορίζει την έξοδο από το βρόχο

Διαβάστε περισσότερα

Δομές Επανάληψης. Όσο μέχρις ότου για. 22/11/08 Ανάπτυξη εφαρμογών 1

Δομές Επανάληψης. Όσο μέχρις ότου για. 22/11/08 Ανάπτυξη εφαρμογών 1 Δομές Επανάληψης Όσο μέχρις ότου για 22/11/08 Ανάπτυξη εφαρμογών 1 Όσο. επανάλαβε Όσο Συνθήκη επανάλαβε Εντολή1 Εντολή2.. Ομάδα εντολών Συνθήκη Αληθής Ομάδα εντολών Εντολή Ν Τέλος_Επανάληψης Ψευδής 1.

Διαβάστε περισσότερα

8. Επιλογή και επανάληψη

8. Επιλογή και επανάληψη 8. Επιλογή και επανάληψη 8.1 Εντολές Επιλογής ΕΣΕΠ06-Θ1Β5 Η ιεραρχία των λογικών τελεστών είναι µικρότερη των αριθµητικών. ΕΣ07-Θ1Γ5 Η σύγκριση λογικών δεδοµένων έχει έννοια µόνο στην περίπτωση του ίσου

Διαβάστε περισσότερα

3. Αλγόριθμοι + ομές εδομένων = Προγράμματα.

3. Αλγόριθμοι + ομές εδομένων = Προγράμματα. ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ EΠΑΝΑΛΗΠΤΙΚΕΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Σ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 5 ΙΟΥΛΙΟΥ 2007 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΣ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ): ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο Να περιγραφεί η δομή επανάληψης Αρχή_επανάληψης Μέχρις_ότου

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο Να περιγραφεί η δομή επανάληψης Αρχή_επανάληψης Μέχρις_ότου 2.87 Να περιγραφεί η δομή επανάληψης Μέχρις_ότου Ημορφή της δομής επανάληψης Μέχρις_ότου είναι: Μέχρις_ότου Συνθήκη Η ομάδα εντολών στο εσωτερικό της επανάληψης, εκτελείται μέχρις ότου ισχύει η συνθήκη

Διαβάστε περισσότερα

Ψευδοκώδικας. November 7, 2011

Ψευδοκώδικας. November 7, 2011 Ψευδοκώδικας November 7, 2011 Οι γλώσσες τύπου ψευδοκώδικα είναι ένας τρόπος περιγραφής αλγορίθμων. Δεν υπάρχει κανένας τυπικός ορισμός της έννοιας του ψευδοκώδικα όμως είναι κοινός τόπος ότι οποιαδήποτε

Διαβάστε περισσότερα

Εισαγωγή στην Επιστήμη των Η/Υ Β ΓΕΛ Σημειώσεις στην Ψευδογλώσσα

Εισαγωγή στην Επιστήμη των Η/Υ Β ΓΕΛ Σημειώσεις στην Ψευδογλώσσα Εισαγωγή στην Επιστήμη των Η/Υ Β ΓΕΛ Σημειώσεις στην Ψευδογλώσσα 1. Εισαγωγή Η Ψευδογλώσσα, σύμφωνα με το σχολικό βιβλίο, είναι μια υποθετική γλώσσα αναπαράστασης αλγορίθμων με στοιχεία από κάποιες γλώσσες

Διαβάστε περισσότερα

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ

2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΙΜΕΛΕΙΑ: ΜΑΡΙΑ Σ. ΖΙΩΓΑ ΚΑΘΗΓΗΤΡΙΑ ΠΛΗΡΟΦΟΡΙΚΗΣ ΘΕΩΡΙΑ 2 ΟΥ και 8 ΟΥ ΚΕΦΑΛΑΙΟΥ ΒΑΣΙΚΕΣ ΕΝΝΟΙΕΣ ΔΟΜΗ ΕΠΙΛΟΓΗΣ 1) Ποιοι είναι οι τελεστές σύγκρισης και

Διαβάστε περισσότερα

Κεφάλαιο 7 ο Βασικές Έννοιες Προγραμματισμού (σελ )

Κεφάλαιο 7 ο Βασικές Έννοιες Προγραμματισμού (σελ ) Κεφάλαιο 7 ο Βασικές Έννοιες Προγραμματισμού (σελ. 147 159) Για τις γλώσσες προγραμματισμού πρέπει να έχουμε υπόψη ότι: Κάθε γλώσσα προγραμματισμού σχεδιάζεται για συγκεκριμένο σκοπό, δίνοντας ιδιαίτερη

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ 23/04/2012. Α. Να απαντήσετε με Σ ή Λ στις παρακάτω προτάσεις:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ 23/04/2012. Α. Να απαντήσετε με Σ ή Λ στις παρακάτω προτάσεις: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ 23/04/2012 ΘΕΜΑ Α Α. Να απαντήσετε με Σ ή Λ στις παρακάτω προτάσεις: 1. Κάθε βρόγχος που υλοποιείται με την εντολή Για μπορεί να

Διαβάστε περισσότερα

ΚΕΦΑΛΑΙΟ 2 ο. αποτέλεσµα προς το χρήστη ή προς έναν άλλο αλγόριθµο. 7 ο ΓΕΛ Καλλιθέας Οδηγός Α.Ε.Π.Π.

ΚΕΦΑΛΑΙΟ 2 ο. αποτέλεσµα προς το χρήστη ή προς έναν άλλο αλγόριθµο. 7 ο ΓΕΛ Καλλιθέας Οδηγός Α.Ε.Π.Π. ΚΕΦΑΛΑΙΟ 2 ο 1. Τι είναι αλγόριθµος; Η θεωρία των αλγορίθµων έχει µεγάλη παράδοση και η ηλικία ορισµένων από αυτών είναι µερικών χιλιάδων χρόνων, όπως του Ευκλείδη για τον υπολογισµό του ΜΚ δύο αριθµών

Διαβάστε περισσότερα

Β. ίνεται το παρακάτω τμήμα δηλώσεων ενός προγράμματος σε «ΓΛΩΣΣΑ»: ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Ζ[15] ΠΡΑΓΜΑΤΙΚΕΣ: Ω

Β. ίνεται το παρακάτω τμήμα δηλώσεων ενός προγράμματος σε «ΓΛΩΣΣΑ»: ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Χ, Ζ[15] ΠΡΑΓΜΑΤΙΚΕΣ: Ω ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ ΘΕΜΑ 1ο ΕΠΑΝΑΛΗΠΤΙΚΕΣ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 10 ΙΟΥΛΙΟΥ 2009 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ

Διαβάστε περισσότερα

Αριθμητικές Λογικές - Σύνθετες εκφράσεις, εντολή εκχώρησης, εντολές εισόδου εξόδου, Δομές ακολουθίας/ επιλογής/ επανάληψης

Αριθμητικές Λογικές - Σύνθετες εκφράσεις, εντολή εκχώρησης, εντολές εισόδου εξόδου, Δομές ακολουθίας/ επιλογής/ επανάληψης Αριθμητικές Λογικές - Σύνθετες εκφράσεις, εντολή εκχώρησης, εισόδου εξόδου, Δομές ακολουθίας/ επιλογής/ επανάληψης Ενότητες βιβλίου: 7.7-7.9, 2.4.1 Ώρες διδασκαλίας: 2 Αριθμητικές Λογικές - Σύνθετες εκφράσεις

Διαβάστε περισσότερα

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον. Διάρκεια 3 ώρες. Όνομα... Επώνυμο... Βαθμός...

Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον. Διάρκεια 3 ώρες. Όνομα... Επώνυμο... Βαθμός... 1 Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον Διάρκεια 3 ώρες Στοιχεία Μαθητή: Όνομα... Επώνυμο... Βαθμός... 2 Θεμα Α (30%) Α1 ΣΩΣΤΟ - ΛΑΘΟΣ 1. Ένα υποπρόγραμμα δεν μπορεί να κληθεί περισσότερες

Διαβάστε περισσότερα

Γ ΤΑΞΗ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

Γ ΤΑΞΗ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΤΑΞΗ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α [40 μόρια] α) Να επιλέξτε το γράμμα Σ, αν μια πρόταση είναι σωστή και το γράμμα

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ονοματεπώνυμο: Βαθμός: Θέμα 1ο Α) Απαντήστε στις παρακάτω ερωτήσεις επιλέγοντας Σ (Σωστό) ή Λ (Λάθος). 1. Η ομάδα εντολών μέσα στην Αρχή_επανάληψης..μέχρις_ότου

Διαβάστε περισσότερα

1. Τι ονομάζουμε αλγόριθμο; Δώστε παράδειγμα.

1. Τι ονομάζουμε αλγόριθμο; Δώστε παράδειγμα. 1. Τι ονομάζουμε αλγόριθμο; Δώστε παράδειγμα. ΑΠΑΝΤΗΣΗ Ορισμός: Αλγόριθμος είναι μια πεπερασμένη σειρά ενεργειών, αυστηρά καθορισμένων και εκτελέσιμων σε πεπερασμένο χρόνο, που στοχεύουν στην επίλυση ενός

Διαβάστε περισσότερα

Παράδειγμα 2. Λύση & Επεξηγήσεις. Τέλος_επανάληψης Εμφάνισε "Ναι" Τέλος Α2

Παράδειγμα 2. Λύση & Επεξηγήσεις. Τέλος_επανάληψης Εμφάνισε Ναι Τέλος Α2 Διδακτική πρόταση ΕΝΟΤΗΤΑ 2η, Θέματα Θεωρητικής Επιστήμης των Υπολογιστών Κεφάλαιο 2.2. Παράγραφος 2.2.7.4 Εντολές Όσο επανάλαβε και Μέχρις_ότου Η διαπραγμάτευση των εντολών επανάληψης είναι σημαντικό

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2015-2016 Θέμα Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις προτάσεις 1-4 και δίπλα τη λέξη ΣΩΣΤΟ,

Διαβάστε περισσότερα

επιµέλεια Θοδωρής Πιερράτος

επιµέλεια Θοδωρής Πιερράτος Βασικές έννοιες προγραµµατισµού Η ύλη που αναπτύσσεται σε αυτό το κεφάλαιο είναι συναφής µε την ύλη που αναπτύσσεται στο 2 ο κεφάλαιο. Όπου υπάρχουν διαφορές αναφέρονται ρητά. Προσέξτε ιδιαίτερα, πάντως,

Διαβάστε περισσότερα

ΑΕΠΠ 4o Επαναληπτικό Διαγώνισμα

ΑΕΠΠ 4o Επαναληπτικό Διαγώνισμα ΑΕΠΠ 4o Επαναληπτικό Διαγώνισμα Ονοματεπώνυμο: ΘΕΜΑ 1 A. Να γράψετε τους κανόνες που πρέπει να ακολουθούνται στη χρήση των εμφωλευμένων βρόχων. B. Να χαρακτηρίσετε ως σωστή (Σ) ή λάθος (Λ) καθεμία από

Διαβάστε περισσότερα

Ημερομηνία: Τρίτη 27 Δεκεμβρίου 2016 Διάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ

Ημερομηνία: Τρίτη 27 Δεκεμβρίου 2016 Διάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ ΤΑΞΗ: ΜΑΘΗΜΑ: Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΑΕΠΠ ΠΡΟΣΑΝΑΤΟΛΙΣΜΟΥ Ημερομηνία: Τρίτη 27 Δεκεμβρίου 2016 Διάρκεια Εξέτασης: 3 ώρες ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας το γράμμα κάθε πρότασης και δίπλα σε

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΣΧΧ.. ΕΕΤΤΟΟΣΣ 22001100-22001111 Επιμέλεια : Ομάδα Διαγωνισμάτων από Το στέκι των πληροφορικών Θέμα Α Α1. Δίνονται οι παρακάτω

Διαβάστε περισσότερα

ΘΕΜΑΤΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 1/12/2013

ΘΕΜΑΤΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 1/12/2013 ΘΕΜΑΤΑ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΗΜΕΡΟΜΗΝΙΑ: 1/12/2013 ΘΕΜΑ 1 ο Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις και δίπλα τη λέξη Σωστό,

Διαβάστε περισσότερα

Κεφαλαιο 2.2 ΑΝΑΚΕΦΑΛΑΙΩΤΙΚΕΣ ΑΛΓΟΡΙΘΜΟΙ

Κεφαλαιο 2.2 ΑΝΑΚΕΦΑΛΑΙΩΤΙΚΕΣ ΑΛΓΟΡΙΘΜΟΙ Κεφαλαιο 2.2 ΑΝΑΚΕΦΑΛΑΙΩΤΙΚΕΣ ΑΛΓΟΡΙΘΜΟΙ 1.Σ, 2.Σ, 3. Λ, 4.Σ, 5.Σ Στο α) ανήκουν: 1,2,5,6,7 Στο β) ανήκουν: 3,4,8,9,10 1.-Λ, 2.-Λ, 3.-Σ, 4.-Σ, 5.-Σ 1. -Πραγματικός, 2. -Αρφαριθμητικός, 3.-Αλφαριθμητικός,

Διαβάστε περισσότερα

Ασκήσεις Πανελληνίων Εξετάσεων Δομή Επανάληψης

Ασκήσεις Πανελληνίων Εξετάσεων Δομή Επανάληψης ΘΕΜΑ Α Ασκήσεις Πανελληνίων Εξετάσεων 2000-2012 Δομή Επανάληψης Θέμα 1 (Μονάδες 5 2005) Ποιο κριτήριο δεν ικανοποιεί ο παρακάτω αλγόριθμος και γιατί; S 0 Για Ι από 2 μέχρι 10 με_βήμα 0 S S+I Εμφάνισε S

Διαβάστε περισσότερα

Τ και τιµή του Β θετική µετατρέπεται ισοδύναµα στην εντολή Όσο ως εξής:

Τ και τιµή του Β θετική µετατρέπεται ισοδύναµα στην εντολή Όσο ως εξής: ΑΡΧΗ 1ΗΣ ΣΕΛΙ ΑΣ Γ ΤΑΞΗ ΕΞΕΤΑΣΕΙΣ ΠΡΟΣΟΜΟΙΩΣΗΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΠΕΜΠΤΗ 12 ΙΑΝΟΥΑΡΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙ ΩΝ: 6

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙ ΩΝ: 6 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙ ΩΝ: 6 ΘΕΜΑ 1 ο Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές (Σ) η λανθασµένες

Διαβάστε περισσότερα

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ

ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ. ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΑΠΟΦΟΙΤΟΙ ΣΕΙΡΑ: ΗΜΕΡΟΜΗΝΙΑ: 05/03/2012 ΑΠΑΝΤΗΣΕΙΣ ΘΕΜΑ Α Α1. Α2. 1. ΣΩΣΤΟ 1 στ 2. ΛΑΘΟΣ 2 δ 3. ΣΩΣΤΟ 3 ε 4. ΛΑΘΟΣ 4 β 5. ΣΩΣΤΟ 5 γ Α3. α. (σελ. 183-184) Στοίβα: ώθηση, απώθηση Ουρά:

Διαβάστε περισσότερα

Σε καθεμιά από τις παρακάτω περιπτώσεις, να μετατρέψετε τη δομή επανάληψης ΟΣΟ στην δομή ΑΠΑΝΤΗΣΗ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΜΕΧΡΙΣ_ΟΤΟΥ Α<-54

Σε καθεμιά από τις παρακάτω περιπτώσεις, να μετατρέψετε τη δομή επανάληψης ΟΣΟ στην δομή ΑΠΑΝΤΗΣΗ ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ ΜΕΧΡΙΣ_ΟΤΟΥ Α<-54 Άσκηση_1 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Σε καθεμιά από τις παρακάτω περιπτώσεις, να μετατρέψετε τη δομή επανάληψης ΟΣΟ στην δομή επανάληψης ΜΕΧΡΙΣ_ΟΤΟΥ. 1 η Περίπτωση Κ 0 ΌΣΟ Λ > 5 ΕΠΑΝΑΛΑΒΕ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ Γ ΛΥΚΕΙΟΥ ΘΕΜΑ 1 ο Α. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα τη λέξη Σωστό,

Διαβάστε περισσότερα

Γενικές εξετάσεις 2014 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Τεχνολογική Κατεύθυνση

Γενικές εξετάσεις 2014 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Τεχνολογική Κατεύθυνση Φροντιστήρια δυαδικό 1 ΦΡΟΝΤΙΣΤΗΡΙΑ δυαδικό Γενικές εξετάσεις 2014 Ανάπτυξη εφαρμογών σε προγραμματιστικό περιβάλλον Τεχνολογική Κατεύθυνση Τα θέματα επεξεργάστηκαν οι καθηγητές των Φροντιστηρίων «δυαδικό»

Διαβάστε περισσότερα

Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές (Σ) η λανθασμένες (Λ).

Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές (Σ) η λανθασμένες (Λ). ΚΟΡΥΦΑΙΟ ΦΡΟΝΤΙΣΤΗΡΙΟ korifeo.gr ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΔΟΜΗ ΕΠΑΝΑΛΗΨΗΣ ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ: 6 ΘΕΜΑ 1 ο Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις

Διαβάστε περισσότερα

Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι.

Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. σύγχρονο Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. μαθητικό φροντιστήριο 25ης Μαρτίου 111 ΠΕΤΡΟΥΠΟΛΗ 210 50 20 990 210 50 27 990 25ης Μαρτίου 74 ΠΕΤΡΟΥΠΟΛΗ 210 50 50 658 210 50 60 845 Γραβιάς 85 ΚΗΠΟΥΠΟΛΗ

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ (ΚΕΦΑΛΑΙΟ 1-2β)

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ (ΚΕΦΑΛΑΙΟ 1-2β) ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ (ΚΕΦΑΛΑΙΟ 1-2β) ΘΕΜΑ 1 ο (Μονάδες 40) A. Γράψτε τον αριθµό καθεµιάς από τις παρακάτω προτάσεις και διπλά τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη Λάθος,

Διαβάστε περισσότερα

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων;

Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1. Τι είναι δυναµική δοµή δεδοµένων; Μονάδες 3 2. Τι είναι στατική δοµή δεδοµένων; ΦΡΟΝΤΙΣΤΗΡΙΑΚΟΣ ΟΡΓΑΝΙΣΜΟΣ ΘΕΜΑ Α ΔΙΑΓΩΝΙΣΜΑ ΠΡΟΣΟΜΟΙΩΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ 01/03/2015 Α1. Στον προγραµµατισµό χρησιµοποιούνται δοµές δεδοµένων. 1.

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2013-2014

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2013-2014 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΧΟΛΙΚΟΥ ΕΤΟΥΣ 2013-2014 Επιμέλεια: Ομάδα Διαγωνισμάτων από το Στέκι των Πληροφορικών Θέμα Α A1. Να γράψετε στο τετράδιό σας τους

Διαβάστε περισσότερα

Ψευδογλώσσας και Διαγράμματα Ροής

Ψευδογλώσσας και Διαγράμματα Ροής Βασικοί κανόνες Αρχή και Τέλος Η ψευδογλώσσα ξεκινάει με την εντολή Αλγόριθμος , το διάγραμμα ροής με το οβάλ Η ψευδογλώσσα καταλήγει με την εντολή Τέλος , το διάγραμμα ροής με το οβάλ Εντολές

Διαβάστε περισσότερα

ΑΕΠΠ Ερωτήσεις θεωρίας

ΑΕΠΠ Ερωτήσεις θεωρίας ΑΕΠΠ Ερωτήσεις θεωρίας Κεφάλαιο 1 1. Τα δεδομένα μπορούν να παρέχουν πληροφορίες όταν υποβάλλονται σε 2. Το πρόβλημα μεγιστοποίησης των κερδών μιας επιχείρησης είναι πρόβλημα 3. Για την επίλυση ενός προβλήματος

Διαβάστε περισσότερα

επιµέλεια Θοδωρής Πιερράτος

επιµέλεια Θοδωρής Πιερράτος Ερωτήσεις Σωστό Λάθος 1. Στη δοµή επανάληψης Όσο... επανάλαβε ο έλεγχος της συνθήκης γίνεται στην αρχή, δηλαδή πριν εκτελεστεί οποιαδήποτε εντολή που περιέχεται στη δοµή. 2. Ο µετρητής που ελέγχει τη συνθήκη

Διαβάστε περισσότερα

ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ

ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΔΙΑΓΩΝΙΣΜΑ ΕΝΔΟΦΡΟΝΤΙΣΤΗΡΙΑΚΗΣ ΠΡΟΣΟΜΟΙΩΣΗΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΥΡΙΑΚΗ 18 ΝΟΕΜΒΡΙΟΥ 2012 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ

Διαβάστε περισσότερα

καθώς και το παρακάτω τμήμα αλγορίθμου γραμμένο σε «ΓΛΩΣΣΑ»:

καθώς και το παρακάτω τμήμα αλγορίθμου γραμμένο σε «ΓΛΩΣΣΑ»: ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ Γ ΤΑΞΗ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΚΑΙ ΕΠΑΛ (ΟΜΑΔΑ Β ) ΠΑΡΑΣΚΕΥΗ 25/04/2014 - ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ 2 ΣΥΝΟΛΟ ΣΕΛΙΔΩΝ:

Διαβάστε περισσότερα

Ας δούμε λίγο την θεωρία με την οποία ασχοληθήκαμε μέχρι τώρα.

Ας δούμε λίγο την θεωρία με την οποία ασχοληθήκαμε μέχρι τώρα. Ας δούμε λίγο την θεωρία με την οποία ασχοληθήκαμε μέχρι τώρα. Είδαμε τι είναι πρόβλημα, τι είναι αλγόριθμος και τέλος τι είναι πρόγραμμα. Πρέπει να μπορείτε να ξεχωρίζετε αυτές τις έννοιες και να αντιλαμβάνεστε

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ομή Επανάληψης

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ομή Επανάληψης ΕΠ.1 Να αναπτυχθεί αλγόριθμος που θα εκτυπώνει τους διψήφιους άρτιους ακέραιους. Η άσκηση στην ουσία θα πρέπει να εκτυπώσει του αριθμούς 10, 12, 14,.,96, 98. Μεμιαπρώτηματιάθαμπορούσαμενατηνλύσουμεμετοναπροσπελάσουμετιςτιμές

Διαβάστε περισσότερα

ΑΡΧΗ 2ΗΣ ΣΕΛΙΔΑΣ Γ Α... Β

ΑΡΧΗ 2ΗΣ ΣΕΛΙΔΑΣ Γ Α... Β ΘΕΜΑ Α ΑΡΧΗ 1ΗΣ ΣΕΛΙΔΑΣ ΠΡΟΣΟΜΟΙΩΣΗ ΑΠΟΛΥΤΗΡΙΩΝ ΕΞΕΤΑΣΕΩΝ Γ' ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΔΕΥΤΕΡΑ 11 ΑΠΡΙΛΙΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ

Διαβάστε περισσότερα

Φυσικές και τεχνητές γλώσσες. Το αλφάβητο της ΓΛΩΣΣΑΣ, Τύποι Δεδομένων. Σταθερές, Μεταβλητές, Τελεστές, Συναρτήσεις, Δομή Προγράμματος

Φυσικές και τεχνητές γλώσσες. Το αλφάβητο της ΓΛΩΣΣΑΣ, Τύποι Δεδομένων. Σταθερές, Μεταβλητές, Τελεστές, Συναρτήσεις, Δομή Προγράμματος Φυσικές και τεχνητές γλώσσες. Το αλφάβητο της ΓΛΩΣΣΑΣ, Τύποι Δεδομένων. Σταθερές, Μεταβλητές, Τελεστές, Συναρτήσεις, Δομή Προγράμματος Ενότητες βιβλίου: 6.3, 7.1-7.6, 7.10, 8.1 Ώρες διδασκαλίας: 2 Φυσικές

Διαβάστε περισσότερα

Φροντιστήρια Επίγνωση Προτεινόμενα Θέματα Πανελλαδικών ΑΕΠΠ 2015

Φροντιστήρια Επίγνωση Προτεινόμενα Θέματα Πανελλαδικών ΑΕΠΠ 2015 Φροντιστήρια Επίγνωση Προτεινόμενα Θέματα Πανελλαδικών ΑΕΠΠ 2015 Βάλβης Δημήτριος Μηχανικός Πληροφορικής ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-5 και δίπλα

Διαβάστε περισσότερα

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΔΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 19/12/2008. Τμήμα ΓΤ1 Όνομα:...

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΔΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 19/12/2008. Τμήμα ΓΤ1 Όνομα:... ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΔΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 19/12/2008 Τμήμα ΓΤ1 Όνομα:... ΘΕΜΑ 1 ο. Α) Να γράψετε στο φύλλο απαντήσεών σας Σ εάν κρίνετε ότι η πρόταση είναι σωστή και

Διαβάστε περισσότερα

Γκύζη 14-Αθήνα Τηλ :

Γκύζη 14-Αθήνα Τηλ : ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Γ ΤΑΞΗΣ ΗΜΕΡΗΣΙΟΥ ΕΝΙΑΙΟΥ ΛΥΚΕΙΟΥ ΔΕΥΤΕΡΑ 23 ΜΑΪΟΥ 2011 ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ (ΚΥΚΛΟΥ ΠΛΗΡΟΦΟΡΙΚΗΣ ΚΑΙ ΥΠΗΡΕΣΙΩΝ)

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο 43 2.55 Ποιες είναι οι δύο μορφές της δομής πολλαπλής επιλογής και ποτέ χρησιμοποιείται; 1 η Μορφή:Η πολλαπλή επιλογή εφαρμόζεται στα προβλήματα όπου μπορούν να ληφθούν διαφορετικές αποφάσεις ανάλογα με

Διαβάστε περισσότερα

Πληροφορική 2. Αλγόριθμοι

Πληροφορική 2. Αλγόριθμοι Πληροφορική 2 Αλγόριθμοι 1 2 Τι είναι αλγόριθμος; Αλγόριθμος είναι ένα διατεταγμένο σύνολο από σαφή βήματα το οποίο παράγει κάποιο αποτέλεσμα και τερματίζεται σε πεπερασμένο χρόνο. Ο αλγόριθμος δέχεται

Διαβάστε περισσότερα

ΦΡΟΝΤΙΣΤΗΡΙΑ ΜΕΣΗΣ ΕΚΠΑΙΔΕΥΣΗΣ ΠΡΟΟΔΟΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΟΚΤΩΒΡΙΟΥ 2015

ΦΡΟΝΤΙΣΤΗΡΙΑ ΜΕΣΗΣ ΕΚΠΑΙΔΕΥΣΗΣ ΠΡΟΟΔΟΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΟΚΤΩΒΡΙΟΥ 2015 ΦΡΟΝΤΙΣΤΗΡΙΑ ΜΕΣΗΣ ΕΚΠΑΙΔΕΥΣΗΣ ΠΡΟΟΔΟΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΔΙΑΓΩΝΙΣΜΑ ΟΚΤΩΒΡΙΟΥ 2015 Θέμα 1 (Α) Να απαντήσετε στις παρακάτω προτάσεις χαρακτηρίζοντάς τες με το γράμμα Σ αν

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΘΕΜΑΤΑ ΘΕΜΑ A Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-6 και δίπλα τη λέξη ΣΩΣΤΟ, αν είναι σωστή, ή τη λέξη ΛΑΘΟΣ, αν

Διαβάστε περισσότερα

Κεφ 2. Βασικές Έννοιες Αλγορίθμων

Κεφ 2. Βασικές Έννοιες Αλγορίθμων Κεφ 2. Βασικές Έννοιες Αλγορίθμων 2.7 Τι είναι οι μεταβλητές και τι οι σταθερές; ΑΠΑΝΤΗΣΗ Μεταβλητές: Μια μεταβλητή είναι μια θέση μνήμης του υπολογιστή με συγκεκριμένο όνομα, που χρησιμοποιείται για να

Διαβάστε περισσότερα

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: ΘΕΜΑ Α

ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: ΘΕΜΑ Α ΜΑΘΗΜΑ / ΤΑΞΗ : ΑΕΠΠ / ΘΕΡΙΝΑ ΣΕΙΡΑ: 1 η ΗΜΕΡΟΜΗΝΙΑ: 03-11-2013 ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις 1-4 και δίπλα τη λέξη Σωστό, αν είναι σωστή, ή τη λέξη

Διαβάστε περισσότερα

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 16/12/2008. Τµήµα ΓΤ2 Όνοµα:...

ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 16/12/2008. Τµήµα ΓΤ2 Όνοµα:... ΓΕΝΙΚΟ ΛΥΚΕΙΟ ΚΑΡΠΕΝΗΣΙΟΥ ΙΩΡΟ ΕΠΑΝΑΛΗΠΤΙΚΟ ΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ 16/12/2008 Τµήµα ΓΤ2 Όνοµα:... ΘΕΜΑ 1 ο. Α) Να γράψετε στο φύλλο απαντήσεών σας Σ εάν κρίνετε ότι η πρόταση είναι σωστή και

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΕΠΑΝΑΛΗΠΤΙΚΟ ΔΙΑΓΩΝΙΣΜΑ ΟΝΟΜΑΤΕΠΩΝΥΜΟ: Θέμα 1ο I. Δίνεται το παρακάτω τμήμα αλγορίθμου. Να εξετάσετε αν ικανοποιεί τα αλγοριθμικά κριτήρια. Γράψε 'Δώσε

Διαβάστε περισσότερα

ΠΕΝΤΕΛΗ. Κτίριο 1 : Πλ. ΗρώωνΠολυτεχνείου 13, Τηλ / Κτίριο 2 : Πλ. Ηρώων Πολυτεχνείου 29, Τηλ ΒΡΙΛΗΣΣΙΑ

ΠΕΝΤΕΛΗ. Κτίριο 1 : Πλ. ΗρώωνΠολυτεχνείου 13, Τηλ / Κτίριο 2 : Πλ. Ηρώων Πολυτεχνείου 29, Τηλ ΒΡΙΛΗΣΣΙΑ Τάξη Μάθημα Εξεταστέα ύλη Γ Λυκείου Α.Ε.Π.Π. ΠΕΝΤΕΛΗ Κτίριο 1 : Πλ. ΗρώωνΠολυτεχνείου 13, Τηλ. 210 8048919 / 210 6137110 Κτίριο 2 : Πλ. Ηρώων Πολυτεχνείου 29, Τηλ. 210 8100606 ΒΡΙΛΗΣΣΙΑ Καθηγητής Ημερομηνία

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Θέμα Α

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Θέμα Α ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Θέμα Α Α1. Δίνονται οι παρακάτω εντολές από ένα τμήμα προγράμματος: ΔΙΑΒΑΣΕ α, β x α > β Να χαρακτηρίσετε αν κάθε μία από τις παρακάτω προτάσεις είναι

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗΣ ΚΑΤΕΥΘΥΝΣΗΣ ΕΚΦΩΝΗΣΕΙΣ ΘΕΜΑ 1 ο Α. Να γράψετε στο τετράδιο σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις και δίπλα τη λέξη

Διαβάστε περισσότερα

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 Ο

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 Ο ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ 1 Ο Α. Να αναπτύξετε τις παρακάτω ερωτήσεις: 1. Τι καλείται βρόγχος; 2. Σε ποιες κατηγορίες διακρίνονται τα προβλήματα ανάλογα με

Διαβάστε περισσότερα

ΟΜΟΣΠΟΝ ΙΑ ΕΚΠΑΙ ΕΥΤΙΚΩΝ ΦΡΟΝΤΙΣΤΩΝ ΕΛΛΑ ΟΣ (Ο.Ε.Φ.Ε.) ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2012 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΟΜΟΣΠΟΝ ΙΑ ΕΚΠΑΙ ΕΥΤΙΚΩΝ ΦΡΟΝΤΙΣΤΩΝ ΕΛΛΑ ΟΣ (Ο.Ε.Φ.Ε.) ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ ΕΠΑΝΑΛΗΠΤΙΚΑ ΘΕΜΑΤΑ 2012 ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΤΑΞΗ: ΚΑΤΕΥΘΥΝΣΗ: ΜΑΘΗΜΑ: ΘΕΜΑ Α Γ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ (2ος Κύκλος) ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ Ηµεροµηνία: Κυριακή 22 Απριλίου 2012 ΕΚΦΩΝΗΣΕΙΣ Α1. Να γράψετε στο τετράδιό

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο Ποια είναι η μορφή ενός αλγόριθμου με ψευδοκώδικα; Αρχίζει πάντα με τη λέξη Αλγόριθμος Αλγόριθμος Στη συνέχεια παρεμβάλλονται οι Εντολές Και τελειώνει με τη λέξη Τέλος Τέλος Εντολές Ποιες είναι οι αλγοριθμικές

Διαβάστε περισσότερα

ΑΕΠΠ 2o Επαναληπτικό Διαγώνισμα

ΑΕΠΠ 2o Επαναληπτικό Διαγώνισμα ΑΕΠΠ 2o Επαναληπτικό Διαγώνισμα Ονοματεπώνυμο: ΘΕΜΑ 1 A. Να γράψετε τους κανόνες που πρέπει να ακολουθούνται στη χρήση των εμφωλευμένων βρόχων. Β. Na γίνει ο πολλαπλασιασμός 15 * 45 αλά ρώσικα και να γραφεί

Διαβάστε περισσότερα

53 Χρόνια ΦΡΟΝΤΙΣΤΗΡΙΑ ΜΕΣΗΣ ΕΚΠΑΙΔΕΥΣΗΣ Σ Α Β Β Α Ϊ Δ Η Μ Α Ν Ω Λ Α Ρ Α Κ Η

53 Χρόνια ΦΡΟΝΤΙΣΤΗΡΙΑ ΜΕΣΗΣ ΕΚΠΑΙΔΕΥΣΗΣ Σ Α Β Β Α Ϊ Δ Η Μ Α Ν Ω Λ Α Ρ Α Κ Η 53 Χρόνια ΦΡΟΝΤΙΣΤΗΡΙΑ ΜΕΣΗΣ ΕΚΠΑΙΔΕΥΣΗΣ Σ Α Β Β Α Ϊ Δ Η Μ Α Ν Ω Λ Α Ρ Α Κ Η ΠΑΓΚΡΑΤΙ: Φιλολάου & Εκφαντίδου 26 : 210/76.01.470 210/76.00.179 ΘΕΜΑ Α Α1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς

Διαβάστε περισσότερα

ΠΡΟΣ: Τηλέφωνο: 210-3443422 Ινστιτούτο Εκπαιδευτικής Πολιτικής ΚΟΙΝ.:

ΠΡΟΣ: Τηλέφωνο: 210-3443422 Ινστιτούτο Εκπαιδευτικής Πολιτικής ΚΟΙΝ.: ΕΛΛΗΝΙΚΗ ΔΗΜΟΚΡΑΤΙΑ ΥΠΟΥΡΓΕΙΟ ΠΑΙΔΕΙΑΣ, ΕΡΕΥΝΑΣ ΚΑΙ ΘΡΗΣΚΕΥΜΑΤΩΝ ----- Βαθμός Ασφαλείας: Να διατηρηθεί μέχρι: Βαθ. Προτεραιότητας: ΓΕΝΙΚΗ ΔΙΕΥΘΥΝΣΗ ΣΠΟΥΔΩΝ Π/ΘΜΙΑΣ ΚΑΙ Δ/ΘΜΙΑΣ ΕΚΠΑΙΔΕΥΣΗΣ ΔΙΕΥΘΥΝΣΗ ΣΠΟΥΔΩΝ,

Διαβάστε περισσότερα

Θέματα Πανελληνίων Εξετάσεων που προέρχονται από την ενότητα «Δομή επιλογής» ( )

Θέματα Πανελληνίων Εξετάσεων που προέρχονται από την ενότητα «Δομή επιλογής» ( ) Θέματα Πανελληνίων Εξετάσεων που προέρχονται από την ενότητα «Δομή επιλογής» (2000-2012) 1. Να γράψετε στο τετράδιό σας τον αριθμό καθεμιάς από τις παρακάτω προτάσεις και δίπλα τη λέξη Σωστό, αν είναι

Διαβάστε περισσότερα

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο. Επικοινωνία:

ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ Κεφάλαιο 2 ο. Επικοινωνία: Επικοινωνία: spzygouris@gmail.com Να δοθεί ο ορισμός του Αλγορίθμου. Αλγόριθμος, σύμφωνα με το βιβλίο, είναι μια πεπερασμένη σειρά ενεργειών (όχι άπειρες), αυστηρά καθορισμένων και εκτελέσιμων σε πεπερασμένο

Διαβάστε περισσότερα

Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL)

Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Αλγοριθμική & Δομές Δεδομένων- Γλώσσα Προγραμματισμού Ι (PASCAL) Βασικές έννοιες αλγορίθμων Εισαγωγή Αρχικά εξηγείται ο όρος αλγόριθμος και παραθέτονται τα σπουδαιότερα κριτήρια που πρέπει να πληροί κάθε

Διαβάστε περισσότερα

ΑΣΚΗΣΕΙΣ ΠΑΝΕΛΛΗΝΙΩΝ

ΑΣΚΗΣΕΙΣ ΠΑΝΕΛΛΗΝΙΩΝ ΑΣΚΗΣΕΙΣ ΠΑΝΕΛΛΗΝΙΩΝ ΑΠΟ ΤΙΣ ΟΜΕΣ ΤΗΣ ΕΠΙΛΟΓΗΣ ΚΑΙ ΕΠΑΝΑΛΗΨΗΣ ΣΧΟΛΙΚΟ ΕΤΟΣ:2012-2013 Κορέλης Αντώνης Msc in High Performance Algorithms Καθηγητής Πληροφορικής Κορέλης Αντώνης 1 ΘΕΜΑΤΑ ΑΠΟ ΗΜΕΡΗΣΙΑ ΑΠΟΛΥΤΗΡΙΕΣ

Διαβάστε περισσότερα

ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 30 MAΪΟΥ ΑΕΠΠ

ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 30 MAΪΟΥ ΑΕΠΠ ΑΠΟΛΥΤΗΡΙΕΣ ΕΞΕΤΑΣΕΙΣ Δ ΤΑΞΗΣ ΕΣΠΕΡΙΝΟΥ ΓΕΝΙΚΟΥ ΛΥΚΕΙΟΥ ΠΑΡΑΣΚΕΥΗ 30 MAΪΟΥ 2008 - ΑΕΠΠ ΘΕΜΑ 1ο Α. 1. Ποια είναι τα κυριότερα χρησιμοποιούμενα γεωμετρικά σχήματα σε ένα διάγραμμα ροής και τι ενέργεια ή

Διαβάστε περισσότερα

ΠΕΝΤΕΛΗ ΒΡΙΛΗΣΣΙΑ. Α1. Δίνονται τα παρακάτω τμήματα αλγορίθμου σε φυσική γλώσσα, τα οποία πρέπει να γράψετε σε μορφή προγράμματος.

ΠΕΝΤΕΛΗ ΒΡΙΛΗΣΣΙΑ. Α1. Δίνονται τα παρακάτω τμήματα αλγορίθμου σε φυσική γλώσσα, τα οποία πρέπει να γράψετε σε μορφή προγράμματος. Τάξη Μάθημα Εξεταστέα ύλη Γ Λυκείου ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΠΕΝΤΕΛΗ Κτίριο 1 : Πλ. Ηρώων Πολυτεχνείου 13, Τηλ. 210 8048919 / 210 6137110 Κτίριο 2 : Πλ. Ηρώων Πολυτεχνείου 29, Τηλ. 210 8100606 ΒΡΙΛΗΣΣΙΑ Καθηγητές

Διαβάστε περισσότερα

Φάσμα. προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι.

Φάσμα. προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. σύγχρονο Φάσμα προπαρασκευή για Α.Ε.Ι. & Τ.Ε.Ι. μαθητικό φροντιστήριο 25ης Μαρτίου 111 - ΠΕΤΡΟΥΠΟΛΗ - 210 50 20 990-210 50 27 990 25ης Μαρτίου 74 - ΠΕΤΡΟΥΠΟΛΗ - 210 50 50 658-210 50 60 845 Γραβιάς 85 -

Διαβάστε περισσότερα

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΠΛΗΡΟΦΟΡΙΚΗ

ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΠΛΗΡΟΦΟΡΙΚΗ ΔΙΑΓΩΝΙΣΜΑ ΣΤΗΝ ΠΛΗΡΟΦΟΡΙΚΗ Ον/μο:.. Γ Λυκείου Ύλη:1-2 Τεχν. Κατ. 03-11-13 ΘΕΜΑ 1 ο Α. 1)Ποιες κατηγορίες προβλημάτων γνωρίζετε; 2)Να αναπτύξετε τα κριτήρια που πρέπει να ικανοποιεί ένας αλγόριθμος. 3)Ποια

Διαβάστε περισσότερα

ΕΝΙΑΙΟ ΛΥΚΕΙΟ ΚΑΛΑΜΠΑΚΑΣ ΣΧΟΛ. ΕΤΟΣ 2012-2013

ΕΝΙΑΙΟ ΛΥΚΕΙΟ ΚΑΛΑΜΠΑΚΑΣ ΣΧΟΛ. ΕΤΟΣ 2012-2013 ΕΝΙΑΙΟ ΛΥΚΕΙΟ ΚΑΛΑΜΠΑΚΑΣ ΣΧΟΛ. ΕΤΟΣ 2012-2013 ΕΚΠΑΙΔΕΥΤΙΚΉ ΠΡΟΣΟΜΟΙΩΣΗ ΕΞΕΤΑΣΕΩΝ Γ ΛΥΚΕΙΟΥ ΤΕΧΝΟΛΟΓΙΚΗ ΚΑΤΕΥΘΥΝΣΗ ΕΞΕΤΑΖΟΜΕΝΟ ΜΑΘΗΜΑ: ΑΝΑΠΤΥΞΗ ΕΦΑΡΜΟΓΩΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ ΘΕΜΑ Α Α1. Να γράψετε

Διαβάστε περισσότερα

ΚΟΡΥΦΑΙΟ ΦΡΟΝΤΙΣΤΗΡΙΟ korifeo.gr Μάθημα :Προγραμματισμός Εξεταζόμενη ύλη : 2o, 3o,4o,5o κεφάλαιο ΘΕΜΑ 1 ο

ΚΟΡΥΦΑΙΟ ΦΡΟΝΤΙΣΤΗΡΙΟ korifeo.gr Μάθημα :Προγραμματισμός Εξεταζόμενη ύλη : 2o, 3o,4o,5o κεφάλαιο ΘΕΜΑ 1 ο ΚΟΡΥΦΑΙΟ ΦΡΟΝΤΙΣΤΗΡΙΟ korifeo.gr Μάθημα :Προγραμματισμός Εξεταζόμενη ύλη : 2o, 3o,4o,5o κεφάλαιο ΘΕΜΑ 1 ο Α. Να χαρακτηρίσετε τις παρακάτω προτάσεις ως σωστές ή λανθασμένες. 1. Μια μεταβλητή μπορεί να

Διαβάστε περισσότερα